Skip to main content
Jump to: navigation, search

Difference between revisions of "Efxclipse/Tutorials/AddingE(fx)clipse to eclipse"

(New Preferences)
(Configure eclipse to use a JDK not a JRE)
 
(15 intermediate revisions by the same user not shown)
Line 1: Line 1:
[[File:Under_Construction_Go_somewhere_else.jpg]]
 
 
= Installing e(fx)clipse IDE.=
 
= Installing e(fx)clipse IDE.=
How to install e(fx)clipse on a Mars 4.5.0 version of eclipse
+
How to install e(fx)clipse on a Mars 4.5.0 version of eclipse.
 
These instructions were written and the screen captures taken with a clean install of the Eclipse for RCP and RAP Developers 64 bit package available here (http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/marsr).  The Operating system used was Windows 7 SP1.  These steps do not include the install of eclipse 4.5.0 (Mars).
 
These instructions were written and the screen captures taken with a clean install of the Eclipse for RCP and RAP Developers 64 bit package available here (http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/marsr).  The Operating system used was Windows 7 SP1.  These steps do not include the install of eclipse 4.5.0 (Mars).
 
[[File:Help_Install_New_Software.png|none|900px]]
 
[[File:Help_Install_New_Software.png|none|900px]]
Line 29: Line 28:
 
# Press the '''<u>N</u>ext >''' button.
 
# Press the '''<u>N</u>ext >''' button.
 
[[File:New_Target_Definition_Name_e(fx)eclipse_Add.png|none|900px]]
 
[[File:New_Target_Definition_Name_e(fx)eclipse_Add.png|none|900px]]
# Enter '''e(fx)clipse''' as the target platform name.
+
# Enter '''e(fx)clipse''' as the target platform '''Name:'''.
 
# Press the '''Add...''' button.   
 
# Press the '''Add...''' button.   
 
[[File:Add_Content_Add_Software_Site_Next.png|none|900px]]
 
[[File:Add_Content_Add_Software_Site_Next.png|none|900px]]
Line 44: Line 43:
 
# Press the '''Apply''' button.
 
# Press the '''Apply''' button.
 
# Press the '''OK''' button.
 
# Press the '''OK''' button.
 +
 +
= Configure eclipse to use a JDK not a JRE =
 +
When doing a '''ant build and run''' from the '''FX Build Configuration''' (file: build.fxbuild) the JRE Library must really be a JDK.  The following step show how to configure a JRE as a JDK so the '''ant build and run''' will work.
 +
[[File:FX_Build_Config.png|none|900px]]
 +
# Window -> Preferences
 +
[[File:Window_Preferences.png|none]]
 +
# Java -> Installed JREs
 +
# Press the '''Add...''' button.
 +
[[File:Java_Installed_JREs.png|none|900px]]
 +
# Select '''Standard VM'''
 +
# Press the '''Next >''' button.
 +
[[File:StandardVM.png]]
 +
# Don't press the '''Directory...''' button.  The '''Directory...''' button will filter out JDKs and only show JREs. 
 +
[[File:JRE_Home.png|none|900px]] 
 +
# Use the Operating System's file system browser get the full path of the target JDK.
 +
# In this example
 +
# '''C:\Program Files\Java\jdk1.8.0_25'''
 +
# Copy and paste the full path into the '''JRE home:''' text box.
 +
# Press the '''Finish''' button.
 +
[[File:JRE_Definition.png|none|900px]]
 +
# Make the new JDK the default JRE by checking the check box.
 +
# Press the '''OK''' button.
 +
[[File:Installed_JREs.png|none|900px]]
 +
# Navigate to the '''Execution Environments''' dialog.
 +
# Java -> Installed JREs -> Execution Environments.
 +
# Check the check box next the JDK, not the JRE.
 +
# Press the '''OK''' button.
 +
[[File:Execution_Environments.png|none|900px]]
 +
# The steps are now complete. All future new projects will point to a JDK, not a JRE.  If you have any existing projects they will still point to the JRE, not the JDK.
  
 
= A quick peak at what is now installed =
 
= A quick peak at what is now installed =
Line 102: Line 130:
 
<br />
 
<br />
 
<br />
 
<br />
[[File:New_FX-OSGi_application.png|none|900px]]
+
[[File:New_e4_FX_application.png|none|900px]]
 
JavaFX -> New e4 FX application
 
JavaFX -> New e4 FX application
 
<br />
 
<br />
Line 108: Line 136:
 
<br />
 
<br />
 
[[File:New_FX-OSGi_Bundle.png|none|900px]]
 
[[File:New_FX-OSGi_Bundle.png|none|900px]]
JavaFX -> New FX-OSGi application
 
<br />
 
<br />
 
<br />
 
[[File:New_e4_FX_application.png|none|900px]]
 
 
JavaFX -> New FX-OSGi Bundle
 
JavaFX -> New FX-OSGi Bundle
 
<br />
 
<br />
Line 144: Line 167:
 
<br />
 
<br />
 
<br />
 
<br />
[[File:Preferences_JavaFX_CSSExtDsl_Syntax_Coloring.png|none|900px]]
+
[[File:Preferences_JavaFX_CSSExtDsl_Compiler.png|none|900px]]
Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Coloring
+
Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Compiler
 
<br />
 
<br />
 
<br />
 
<br />
 
<br />
 
<br />
[[File:Preferences_JavaFX_CSSExtDsl_Compiler.png|none|900px]]
+
[[File:Preferences_JavaFX_CSSExtDsl_Syntax_Coloring.png|none|900px]]
 
Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Coloring
 
Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Coloring
 
<br />
 
<br />
 
<br />
 
<br />
 
<br />
 
<br />
[[File:Preferences_CSSExtDsl_Template.png|none|900px]]
+
[[File:Preferences_JavaFX_CSSExtDsl_Template.png|none|900px]]
 
Window -> Preferences -> JavaFX -> CSSEXTDSL -> Templates
 
Window -> Preferences -> JavaFX -> CSSEXTDSL -> Templates
 
<br />
 
<br />
Line 174: Line 197:
 
<br />
 
<br />
 
<br />
 
<br />
[[File:Preferences_Templates.png|none|900px]]
+
[[File:Preferences_JavaFX_FXGraph_Templates.png|none|900px]]
 
Window -> Preferences -> JavaFX -> FXGraph-> Templates
 
Window -> Preferences -> JavaFX -> FXGraph-> Templates
 
<br />
 
<br />

Latest revision as of 11:16, 10 September 2015

Installing e(fx)clipse IDE.

How to install e(fx)clipse on a Mars 4.5.0 version of eclipse. These instructions were written and the screen captures taken with a clean install of the Eclipse for RCP and RAP Developers 64 bit package available here (http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/marsr). The Operating system used was Windows 7 SP1. These steps do not include the install of eclipse 4.5.0 (Mars).

Error creating thumbnail: Unable to save thumbnail to destination
  1. Select the Help menu.
  2. Select the Install New Software... option.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select the --All Available Sites -- option from the Work with: drop down list.
  2. Uncheck the Group items by category check box in the bottom details section.
  3. Check only the e(fx)clipse - IDE Name option. All the other options starting with e(fx)clipse - IDE are subsets of the full e(fx)clipse IDE. The e(fx)clipse - Minimal JavaFX OSGi integration bundles option is out of scope for these instructions.
  4. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Press the I accept the terms of the license agreement radio button.
  2. Press the Finish button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Wait about 2 minutes for the install to complete.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Press the Yes button.

Setup a target platform for your application development

Error creating thumbnail: Unable to save thumbnail to destination
  1. Open Window > Preferences > Plugin-in Development > Target Platform
  2. Click Add ... on the right.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select Nothing: Start with an empty target definition.
  2. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Enter e(fx)clipse as the target platform Name:.
  2. Press the Add... button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select Software Site. Then press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Enter http://download.eclipse.org/efxclipse/runtime-released/2.0.0/site as the site. Press the enter key while in the Work with: text box.
  2. Expand FX Target and check Target Platform for Eclipse
  3. Uncheck Include required software check box.
  4. Press the Finish button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. The resolving will take less then one minute on most systems.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Check the e(fx)clipse check box to make the new target platform the (Active) platform.
  2. Press the Apply button.
  3. Press the OK button.

Configure eclipse to use a JDK not a JRE

When doing a ant build and run from the FX Build Configuration (file: build.fxbuild) the JRE Library must really be a JDK. The following step show how to configure a JRE as a JDK so the ant build and run will work.

Error creating thumbnail: Unable to save thumbnail to destination
  1. Window -> Preferences
Error creating thumbnail: Unable to save thumbnail to destination
  1. Java -> Installed JREs
  2. Press the Add... button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Select Standard VM
  2. Press the Next > button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Don't press the Directory... button. The Directory... button will filter out JDKs and only show JREs.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Use the Operating System's file system browser get the full path of the target JDK.
  2. In this example
  3. C:\Program Files\Java\jdk1.8.0_25
  4. Copy and paste the full path into the JRE home: text box.
  5. Press the Finish button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Make the new JDK the default JRE by checking the check box.
  2. Press the OK button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. Navigate to the Execution Environments dialog.
  2. Java -> Installed JREs -> Execution Environments.
  3. Check the check box next the JDK, not the JRE.
  4. Press the OK button.
Error creating thumbnail: Unable to save thumbnail to destination
  1. The steps are now complete. All future new projects will point to a JDK, not a JRE. If you have any existing projects they will still point to the JRE, not the JDK.

A quick peak at what is now installed

New Wizards

Error creating thumbnail: Unable to save thumbnail to destination

Package Explorer -> (right mouse click) -> New -> Project...


Error creating thumbnail: Unable to save thumbnail to destination

New, Wizard, JavaFX


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX HTML Template


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Library Project


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Product Configuration


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Create a Java Project


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFXGraph File


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> FXML File


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX 3.x ViewPart


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Main Class


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> JavaFX Preloader Class


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> New e4 FX application


Error creating thumbnail: Unable to save thumbnail to destination

JavaFX -> New FX-OSGi Bundle


New Preferences

Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSS


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSS -> Syntax Coloring


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSS -> Templates


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Compiler


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Coloring


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Templates


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph-> Compiler


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph-> Syntax Coloring


Error creating thumbnail: Unable to save thumbnail to destination

Window -> Preferences -> JavaFX -> FXGraph-> Templates


New View

Error creating thumbnail: Unable to save thumbnail to destination
Error creating thumbnail: Unable to save thumbnail to destination

Back to the top