Skip to main content
Jump to: navigation, search

Difference between revisions of "Eclipse WG Unconference France 2014 OSLC"

(Pre-requisites)
(Skills)
Line 3: Line 3:
  
 
Experience with JAX-RS web services a plus.
 
Experience with JAX-RS web services a plus.
 
  
 
=Pre-requisites=
 
=Pre-requisites=

Revision as of 20:08, 11 June 2014

Skills

Some Java programming experience with Eclipse IDE.

Experience with JAX-RS web services a plus.

Pre-requisites

Eclipse 4.2 (Mandatory): https://eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/keplersr2

  • It includes Maven plugin: m2eclipse, and Git plugin: Egit

Java JDK 1.6 + (Mandatory)

  • Setup the JAVA_HOME or JAVA_JRE environment variable

Stable version of Lyo: http://www.eclipse.org/downloads/download.php?file=/lyo/releases/2.1.0/org.eclipse.lyo.oslc4j-2.1.0.zip

  • Mandatory for the hands-on workshop
  • Stable version 2.1.0

Follow the instruction at http://wiki.eclipse.org/Lyo/BuildOSLC4JBugzilla

  • Clone the Lyo Docs repository
  • Build the OSLC4JBugzilla service provider application

Clone OSLC Lyo Core repository

Recommended:

Notes:

  • We provide the code of the labs
  • We provide a war file to deploy in Tomcat as alternative of running the OSLC4JBugzilla in Eclipse

Back to the top