Skip to main content
Jump to: navigation, search

Difference between revisions of "EMF DiffMerge/Download"

Line 30: Line 30:
  
 
Warning 1: Using the tool in a new modeling environment is likely to require a new customization.
 
Warning 1: Using the tool in a new modeling environment is likely to require a new customization.
 +
 
Warning 2: The tool is compatible with Sirius 1.x and Sirius 3.x but not Sirius 2.x.
 
Warning 2: The tool is compatible with Sirius 1.x and Sirius 3.x but not Sirius 2.x.
 
*Update site location: http://download.eclipse.org/diffmerge/releases/0.4.0/edm-patterns-site
 
*Update site location: http://download.eclipse.org/diffmerge/releases/0.4.0/edm-patterns-site

Revision as of 07:53, 25 September 2015

 Releases

The tool is tested in Eclipse Modeling 3.6 (Helios), 3.7 (Indigo), 3.8/4.2 (Juno) and 4.3 (Kepler).

0.1.0 - 11/2012

0.2.0 - Kepler 06/2013

0.3.0 - Luna 06/2014

The API changes between versions 0.2.0 and 0.3.0 can be found here.

0.4.0 - 12/2014

The API changes between versions 0.3.0 and 0.4.0 can be found here.

Patterns

A new major application of the diff/merge engine is available with this release: a tool for handling modeling patterns in modeling tools based on Sirius technology. The tool requires EMF Diff/Merge 0.4.x.

Warning 1: Using the tool in a new modeling environment is likely to require a new customization.

Warning 2: The tool is compatible with Sirius 1.x and Sirius 3.x but not Sirius 2.x.

0.4.1 - 03/2015

Fixes bugs 461377, 461935, 461936. Compatible with Patterns (see above).

0.5.0 - Mars 06/2015

Last build

Egg-incubation.png

Copyright © Eclipse Foundation, Inc. All Rights Reserved.