Skip to main content
Jump to: navigation, search

Difference between revisions of "CVS FAQ"

m (CVSFAQ moved to CVS FAQ)
Line 1: Line 1:
Content to come
+
== Getting Started ==
 +
 
 +
=== How do I get a project into my workspace from CVS? ===
 +
 
 +
<ol>
 +
      <li>Window-&gt;Show View-&gt;Other. Select CVS-&gt;CVS
 +
Repositories.</li>
 +
      <li>Context Menu-&gt;New-&gt;Repository Location...</li>
 +
      <li>Fill in the location information identifying your repository
 +
and click Finish.</li>
 +
      <li>Expand the newly-created repository location.</li>
 +
      <li>Expand HEAD.</li>
 +
      <li>Find the module you are interested in.</li>
 +
      <li>Context Menu-&gt;Check Out As Project.</li>
 +
</ol>
 +
The project now exists in your workspace.
 +
 
 +
=== How do I put a project into CVS from my workspace? ===
 +
<ol>
 +
      <li>Select the project in the Navigator or other view.</li>
 +
      <li>Context Menu-&gt;Team-&gt;Share Project...</li>
 +
      <li>Fill in the location information identifying your repository
 +
and click Next.</li>
 +
      <li>Click Finish and the Sharing wizard closes and the Commit wizard opens.</li>
 +
      <li>Supply a release comment and click Finish to commit the project contents to the repository.</li>
 +
</ol>
 +
The project now exists in the repository.
 +
 
 +
=== I already have a project checked out from CVS with the command-line tool. How do I use it in Eclipse without having to check out the whole project again? ===
 +
 
 +
<ol>
 +
      <li>Create a project in the workspace.</li>
 +
      <li>File-&gt;Import, select File System, locate your files, click
 +
Finish.</li>
 +
      <li>Select the project in the Navigator or other view.</li>
 +
      <li>Context Menu-&gt;Team-&gt;Share Project...</li>
 +
      <li>The wizard should tell you that it found all the necessary
 +
information. Click Finish.</li>
 +
</ol>
 +
 
 +
Eclipse has now shared the project with the CVS repository.

Revision as of 14:59, 1 June 2006

Getting Started

How do I get a project into my workspace from CVS?

  1. Window->Show View->Other. Select CVS->CVS Repositories.
  2. Context Menu->New->Repository Location...
  3. Fill in the location information identifying your repository and click Finish.
  4. Expand the newly-created repository location.
  5. Expand HEAD.
  6. Find the module you are interested in.
  7. Context Menu->Check Out As Project.

The project now exists in your workspace.

How do I put a project into CVS from my workspace?

  1. Select the project in the Navigator or other view.
  2. Context Menu->Team->Share Project...
  3. Fill in the location information identifying your repository and click Next.
  4. Click Finish and the Sharing wizard closes and the Commit wizard opens.
  5. Supply a release comment and click Finish to commit the project contents to the repository.

The project now exists in the repository.

I already have a project checked out from CVS with the command-line tool. How do I use it in Eclipse without having to check out the whole project again?

  1. Create a project in the workspace.
  2. File->Import, select File System, locate your files, click Finish.
  3. Select the project in the Navigator or other view.
  4. Context Menu->Team->Share Project...
  5. The wizard should tell you that it found all the necessary information. Click Finish.

Eclipse has now shared the project with the CVS repository.

Back to the top