Skip to main content
Jump to: navigation, search

CDO/Hibernate Store/Download and Install

< CDO‎ | Hibernate Store
Revision as of 17:57, 20 January 2010 by Mtaal.elver.org (Talk | contribs) (New page: == Required plugins/versions == The CDO Hibernate data store requires the following software: * Eclipse 3.6 (Helios) * EMF 2.6 * CDO 3.0 * Hibernate 3.3.2 or later (not earlier) * Teneo ...)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Required plugins/versions

The CDO Hibernate data store requires the following software:

  • Eclipse 3.6 (Helios)
  • EMF 2.6
  • CDO 3.0
  • Hibernate 3.3.2 or later (not earlier)
  • Teneo 1.2.0
  • JDBC drivers for relevant databases

All the software should be installed as plugins.

Download locations

To download Eclipse 3.6 (Helios). At this time (January 2010) Eclipse 3.6 is still under development so to download it go to this page and then the Development Builds tab: http://www.eclipse.org/downloads/

To follow the tutorials the Eclipse IDE for Java EE Developers or Eclipse IDE for Java Developers can be used (no need to pick the full modeling tools).

EMF is probably included in the Eclipse IDE. But if it isn't then it can be downloaded here: http://www.eclipse.org/modeling/emf/downloads/?project=emf (see the maintenance builds a bit lower on the page):

To download the CDO plugins visit this page: https://build.eclipse.org/hudson/job/cbi-emf-net4j-cdo-3.0/lastSuccessfulBuild/artifact/build and then click on Nxyz (where xyz is a date) to open the nightly build location. The easiest is to download the all features and plugins zip: emf-cdo-AllFeaturesAndPlugins-N201001181004.zip (with a different date in your case ofcourse)

Then download Teneo Hibernate 1.2.0: http://www.eclipse.org/modeling/emf/downloads/?project=teneo

Then download hibernate and database drivers from here: http://net4j.sourceforge.net/update/downloads/ then select a recent ThirdPartyyDrivers zip file (I used ThirdPartyDrivers_v6.zip). NOTE: you need to use the Hibernate 3.3.1 version *not* the Hibernate 3.3.2 version! This is an update site and I noticed that in Chrome this link does not open, in Firefox it does. Anyway you can always download and install these plugins through an update manager also. For the tutorials below I downloaded: org.hsqldb - 1.8.0.200912171633 org.hibernate - 3.3.2.200912171633 com.mysql.jdbc - 5.1.7.200912171633

Back to the top