Skip to main content
Jump to: navigation, search

Difference between revisions of "CBI/Feb7 2012"

< CBI
(New page: =Meeting= * February 7, 2012, 10am EST * Eclipse Conference facility ==Attendees== Andrew R., Igor F., Markus K., Kim M., Paul W. Regrets: David W., Wayne B. ==Not on agenda, still be...)
 
 
(5 intermediate revisions by one other user not shown)
Line 12: Line 12:
  
 
==Not on agenda, still being tracked as work left to do==
 
==Not on agenda, still being tracked as work left to do==
   a) Platform specific code swt & launchers
+
 
   b) Which execution environments will CBI build & test against
+
   a) Platform specific code swt & launchers ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=370704 Bug 370704])
  c) maven.eclipse.org and isolate CBI build from uncontrolled sources ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=369002 Bug 369002])
+
   b) Do not generate new version qualifier unless there are actual code changes ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=367581 Bug 367581])
 +
  c) Isolate CBI platform build from uncontrolled software sources ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=369002 Bug 369002])
 +
  d) unexpected contents in org.eclipse.osgi.services sources bundles([https://bugs.eclipse.org/bugs/show_bug.cgi?id=370124 Bug 370124])
 +
  e) reproducible build version qualifiers ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=370707 Bug 370707])
 +
  f) Provide orbit bundles via. maven.eclipse.org
 
   d) API Analysis  
 
   d) API Analysis  
 
   e) Junit tests
 
   e) Junit tests
 
+
  f) Which execution environments will CBI build & test against
  
 
==Minutes==
 
==Minutes==
  
# Step through LTS-ready definition as captured here http://wiki.eclipse.org/LTS
+
===Step through LTS-ready definition as captured here http://wiki.eclipse.org/LTS===
  
 
* Details added to define suitably configured system as follows: git >= 1.7, java >= 1.6, maven 3.03. Agreement that an Eclipse SDK install is not needed for the CBI build.
 
* Details added to define suitably configured system as follows: git >= 1.7, java >= 1.6, maven 3.03. Agreement that an Eclipse SDK install is not needed for the CBI build.
 
* Brief discussion of deterministic given the same code and dependencies (aka. third party libraries). Agreement that so long as dependencies are pulled from a controlled source (as per item listed as number 9 currently), this should be so.
 
* Brief discussion of deterministic given the same code and dependencies (aka. third party libraries). Agreement that so long as dependencies are pulled from a controlled source (as per item listed as number 9 currently), this should be so.
* Added test section. We could use a little input on it to make sure it is sufficient.
+
* Added test section based on Markus' request. We could use a little input on it to make sure it is sufficient.
 +
 
 +
===Signing===
  
 +
Briefly discussed signing as per [https://bugs.eclipse.org/bugs/show_bug.cgi?id=369798 Bug 369798]. More discussion and work is needed here. We'll revisit this.
  
# Signing
 
  
As per [https://bugs.eclipse.org/bugs/show_bug.cgi?id=369798 Bug 369798]
+
[[Category:CBI| ]]

Latest revision as of 09:14, 10 May 2017

Meeting

  • February 7, 2012, 10am EST
  • Eclipse Conference facility

Attendees

Andrew R., Igor F., Markus K., Kim M., Paul W.

Regrets: David W., Wayne B.

Not on agenda, still being tracked as work left to do

 a) Platform specific code swt & launchers (Bug 370704)
 b) Do not generate new version qualifier unless there are actual code changes (Bug 367581)
 c) Isolate CBI platform build from uncontrolled software sources (Bug 369002)
 d) unexpected contents in org.eclipse.osgi.services sources bundles(Bug 370124)
 e) reproducible build version qualifiers (Bug 370707)
 f) Provide orbit bundles via. maven.eclipse.org
 d) API Analysis 
 e) Junit tests
 f) Which execution environments will CBI build & test against

Minutes

Step through LTS-ready definition as captured here http://wiki.eclipse.org/LTS

  • Details added to define suitably configured system as follows: git >= 1.7, java >= 1.6, maven 3.03. Agreement that an Eclipse SDK install is not needed for the CBI build.
  • Brief discussion of deterministic given the same code and dependencies (aka. third party libraries). Agreement that so long as dependencies are pulled from a controlled source (as per item listed as number 9 currently), this should be so.
  • Added test section based on Markus' request. We could use a little input on it to make sure it is sufficient.

Signing

Briefly discussed signing as per Bug 369798. More discussion and work is needed here. We'll revisit this.

Back to the top