Skip to main content
Jump to: navigation, search

Difference between revisions of "Android Selector 1.1"

(Building)
(Building)
Line 31: Line 31:
  
 
In order to build the Android I-Card Selector, you need the following:
 
In order to build the Android I-Card Selector, you need the following:
* The last version of Android SDK ([http://developer.android.com/ http://developer.android.com/])
+
* The last version of ([http://developer.android.com/ Android SDK])
 
* The last version of [http://source.android.com/ Android source code].
 
* The last version of [http://source.android.com/ Android source code].
* The Apache Ant ([http://ant.apache.org/ http://ant.apache.org/]) or Eclipse with [http://developer.android.com/ ADT] (Android Development Tools)
+
* The ([http://ant.apache.org/ Apache Ant]) or Eclipse with [http://developer.android.com/ ADT] (Android Development Tools)
  
 
== Developer Perspective==
 
== Developer Perspective==

Revision as of 10:15, 26 August 2009

{{#eclipseproject:technology.higgins|eclipse_custom_style.css}}

Higgins logo 76Wx100H.jpg

The Android Selector 1.1 allows users to login to websites by auto-filling un/pw fields from their Android mobile device.

Although we call this solution a selector it does NOT currently support the IMI protocol, only un/pw form filling. The Username/password data is persisted on (non-IMI-compliant) cards on a hosted I-Card Service.

Version

This page describes the Android solution being developed for Higgins 1.1

End User Perspective

<to be written>

Deployer Perspective

Building

The projects are:

  • app/org.eclipse.higgins.android.icard.npapi
  • app/org.eclipse.higgins.android.icard.selector
  • app/org.eclipse.higgins.android.icard.service

These projects can be checked out from the Eclipse repository at the following SVN URIs:

https://dev.eclipse.org/svnroot/technology/org.eclipse.higgins/trunk/app/org.eclipse.higgins.android.icard.npapi
https://dev.eclipse.org/svnroot/technology/org.eclipse.higgins/trunk/app/org.eclipse.higgins.android.icard.selector
https://dev.eclipse.org/svnroot/technology/org.eclipse.higgins/trunk/app/org.eclipse.higgins.android.icard.service

In order to build the Android I-Card Selector, you need the following:

Developer Perspective

Architecture

Android selector 1.1.101.png
(Diagram Key)

Components, Packages & Services

Components:

Services:


Back to the top