
Module 3: Working with C/C++
Objectivej

 Learn basic Eclipse concepts: Perspectives, Views, …
 Learn how to use Eclipse to manage a remote project
 Learn how to use Eclipse to develop C programs Learn how to use Eclipse to develop C programs
 Learn how to launch and run a remote C program

 Contents
 Brief introduction to the C/C++ Development Tools 

(CDT)
 Create a simple remote applicationp pp
 Learn to launch a remote C application
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Login InformationLogin Information

 The hands on portion of this module will be 
done on a remote system at SDSC, thank you 
to SDSC!
 trestles sdsc edu trestles.sdsc.edu

 See the following URL for more information on the 
system
 http://www sdsc edu/us/resources/trestles/ http://www.sdsc.edu/us/resources/trestles/

 Each student will be assigned an ID and password 
at the start of the tutorial

 Please use only this ID Please use only this ID
We are also working to make this work with Ranger 

and Kraken, this work is not complete… 
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Eclipse Basicsp
 A workbench contains the menus, toolbars, editors and 

views that make up the main Eclipse window
 Th  kb h t   The workbench represents 

the desktop development 
environment
 Contains a set of tools 

view
view

 Contains a set of tools 
for resource mgmt

 Provides a common way 
of navigating through view

editor

of navigating through 
the resources

 Multiple workbenches 
can be opened at the 

view

p
same time

 Only one workbench can 
be open on a workspace

perspectiveModule 3

p p
at a time
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PerspectivesPerspectives

 Perspectives define the layout of views and 
di  i  h  kb heditors in the workbench

 They are task oriented, i.e. they contain 
specific views for doing certain tasks:specific views for doing certain tasks:
 There is a Resource Perspective for manipulating 

resources
 C/C++ Perspective for manipulating compiled code  C/C++ Perspective for manipulating compiled code 
Debug Perspective for debugging applications

 You can easily switch between perspectives

 If you are on the Welcome screen now, select 
“Go to Workbench” now Go to Workbench  now 
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Switching PerspectivesSwitching Perspectives

 Three ways of changing  Three ways of changing 
perspectives

 Choose the Window>Open 
P ti  tiPerspective menu option

 Then choose Other…

 Click on the Open 
Perspective button in the 
upper right corner of screen

 Click on a perspective 
shortcut button

 Switch perspective 
on ne t slideon next slide…
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Switch to Remote C/C++ Perspective/ p
 Select Window>Open 

Perspective
 Th  h  O h Then choose Other…
 Only needed if you’re not 

already in the perspective

 What Perspective am in in?
See title BarSee title Bar
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ViewsViews

 The workbench window is 

view

view viewdivided up into Views
 The main purpose of a view is:

 To provide alternative ways of presenting information

view view

 To provide alternative ways of presenting information
 For navigation
 For editing and modifying information 

 Views can have their own menus and toolbars
 Items available in menus and toolbars are 

available only in that viewavailable only in that view
Menu actions only 

apply to the view
 Views can be resized Views can be resized
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Stacked Views

 Stacked views appear as tabs
S l b b h h Selecting a tab brings that view to the 
foreground
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Helpp

 To access help
 H l >H l  C t t Help>Help Contents
 Help>Search
 Help>Dynamic Help

 Help Contents provides p p
detailed help on different 
Eclipse features in a 
browser

 Search allows you to  Search allows you to 
search for help locally, or 
using Google or the Eclipse 
web site

 Dynamic Help shows help  Dynamic Help shows help 
related to the current 
context (perspective, view, 
etc.)
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PreferencesPreferences
 Eclipse Preferences allow 

customization of almost everything
 T    To open use

 Mac: Eclipse>Preferences…
 Others: Windows>Preferences…

The C/C++ preferences The C/C++ preferences 
allow many options to 
be altered

In this example the p
Code Style preferences 
are shown
 These allow code to be 

automatically  automatically  
formatted in different 
ways
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T  f C/C++ P j tTypes of C/C++ Projects
 C/C++ Projects can be

 Local – source is located on local machine, builds happen locally
 Remote – source is either located on remote machine, or 

synchronized with remote machine, builds take place on remote 
machine

 Makefile-based – project contains its own makefile (or makefiles) 
for building the application

 Managed– Eclipse manages the build process, no makefile 
requiredrequired

 Parallel programs can be run on the local machine or on a remote 
system
 MPI needs to be installed
 An application built locally probably can’t be run on a remote 

machine unless their architectures are the same
 We will show you how to create, build and run the program on a 

remote machine
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Remote ProjectsRemote Projects
 “Traditional” Remote Projects
 Source is located on remote machine

 Synchronized Projects
 Source is located on both the local system  Source is located on remote machine

 Eclipse is installed on the local machine 
and can be used for:
 Editing
 Building

 Source is located on both the local system 
and on a remote target system.  The two 
copies are kept in sync by Eclipse.

 Eclipse is installed on the local machine 
and can be used for:
 Editing Running

 Debugging
 Source indexing is performed on remote 

machine
 Enables call hierarchy, type 

 Editing
 Building
 Running
 Debugging
 Development can continue “off-line”ab es ca e a c y, type

hierarchy, include browser, search, 
outline view, and more…

 Builds are performed on remote machine
 Supports both managed and 

makefile projects

 Source indexing is performed on local
machine
 Enables call hierarchy, type 

hierarchy, include browser, search, 
outline view, and more…makefile projects

 Application is run and debugged remotely 
using the PTP resource managers

 Builds are performed on one or more 
remote machines
 Supports both managed and 

makefile projects
 Application is run and debugged remotely  Application is run and debugged remotely 

using the PTP resource managers
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Traditional Remote Projects

7/13/2011Module 
4
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Creating a Remote C/C++ Project

 Use File>New>Remote C/C++ Project to open the 
 j  i d

Creating a Remote C/C++ Project

new project wizard
 The wizard will take you through the steps for creating 

the project

Don’t see the “Remote C/C++ Project” choice?
Make sure you are in the Remote C/C++ Perspective
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New Remote Project WizardNew Remote Project Wizard
 Enter project name, e.g. “hello”
 Select a Remote Provider

 Remote providers supply different 
ways of accessing remote (or local) 
systemssystems

 Choose Remote Tools

 A Connection specifies how to 
connect to the remote host
 Click on the New… button to create a 

new connection
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Remote Host ConfigurationRemote Host Configuration
 Enter a connection name (can be 

anything) for the Target nameanything) for the Target name
 Use “abe.ncsa.uiuc.edu”

 The host is remote, so the Remote 
host option should be checkedp

 Enter the host name or IP address of 
the remote host for the Host
 Use “abe.ncsa.uiuc.edu”

 Enter the user name and
password supplied at the beginning of 
the tutorial for the User and 
PasswordPassword

 Note: if your remote machine uses OTP 
for authentication, leave the password 
field blank

 Click Finish
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Project LocationProject Location

 The Location is the directory on  The Location is the directory on 
the remote host containing the 
source and executable files

 Click on the browse button to  Click on the browse button to 
browse for folders on the remote 
machine
 You should see the folders in your  You should see the folders in your 

home directory
 Choose the “hello” directory

 Click OK
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Project TypeProject Type
 The Project type determines 

information about the project
 If the project is managed or 

unmanaged (described later)
 The tool chain (compiler, linker, etc.) 

to use when buildingto use when building
 If the project creates an executable, 

static, or shared library
 Options available depend on whether 

h  j  i  l l  the project is local or remote

 Under Remote Makefile 
Project, select Empty Project 

l h i l h For Toolchains, select Other 
Toolchain

 Click on Finish to complete the 
dwizard
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Changing Remote Connection Information
 If you need to change remote connection 

information (such as username or 
password)  use the Remote 

Changing Remote Connection Information

password), use the Remote 
Environments view 

 Stop the remote 
connection first

 Right-click and  Right click and 
select Edit

 Note: running server is shown in lower right
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Project Explorer Viewj p
 Shows the user’s projects
 Each project contains

 Source files
 Executable files
 Folders
 Metadata (not visible)

 Can have any number of projects
 We only have a single project so  We only have a single project so 

far
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Synchronized Remote Projects

7/13/2011Module 
4

4-20



GoalsGoals

 Check out code from CVS
 Set up synchronized project with code from 

CVS
M  b ild   ith t diti l t  Manage builds as with traditional remote 

projects
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Creating the Project

 Configuring version control

Creating the Project

 Checking out the source code
 Team support
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Connecting to a Repository
 Select WindowOpen 

PerspectiveOther…
 Select CVS Repository  Select CVS Repository 

Exploring then OK
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Specify Repository Location
 Right-click in the CVS

Repositories view, then Repositories view, then 
select NewRepository 
Location…

 S t H t t  th   Set Host to the 
hostname of remote 
machine

 Set Repository path to 
the CVS repository path

 Fill i  U d  Fill in Username and 
Password

 Set Connection type to 

4-24

 Set Connection type to 
extssh to use an ssh 
connection

F   
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CVS Repository Exploring
 Open the repository in 

the CVS Repository 
viewview

 Open HEAD to view 
files and folders in the 
CVS head

 O  B h    Open Branches or 
Versions to view CVS 
branches or versions 
respectively

 Right-click on the 
repository and select 
Refresh Branches… 
to see all branches and 
versions

4-25Module 4 4-25



Checking out code in Eclipseg p
 If the project exists in the repository 

as an Eclipse Project, then one can 
simply “Check Out” the codesimply Check Out  the code

 In CVS Repositories view, right-click 
on project and select 
ProjectCheck Out

 Our example doesn’t have Eclipse 
Project information – this code was 
checked in with command line tools.

l d h h dd Our next slide shows how to add 
Eclipse Project information 
automatically as you check out the 
code.code.
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Check out as an Eclipse Projectp j
 In CVS Repositories view, right-click 

on project and select 
ProjectCheck Out As…ProjectCheck Out As…

 Make sure Check out as a project 
configured using the New Project 
Wizard is selected

 Leave Checkout subfolders 
checked

 Select Finish

The wizard that runs next
will add Eclipse information 
to the project.to the project.
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New Project Wizard:
Create a C ProjectCreate a C Project

 The New Project Wizard is used j
to create a C project

j Enter Project name
 Under Project Types, select 

Makefile projectEmpty 
ProjectProject
 Ensures that CDT will use existing 

makefiles
 Select Finish
 When prompted to switch to the 

C/C++ Perspective, select Yes
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Editor and Outline ViewEditor and Outline View
 Double-click on 

source file to open source file to open 
editor

 Outline view is  Outline view is 
shown for file in 
editor

 You should see  You should see 
warnings on the 
include files:
we will fix this
later

 Console shows
results of build
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EditorsEditors
 An editor for a resource (e.g. a file) 

opens when you double click on 

editor

opens when you double-click on 
a resource

 The type of editor depends on the type of the resource
 c files are opened with the C/C++ editor .c files are opened with the C/C++ editor
 Some editors do not just edit raw text

 When an editor opens on a resource, it stays open across 
different perspectivesp p

 An active editor contains menus and toolbars specific to that 
editor

 When you change a resource, an asterisk on the editor’s title y g
bar indicates unsaved changes

 Save the changes by using 
Command/Ctrl-S or File>Save
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Source Code Editors & MarkersSource Code Editors & Markers

 A source code editor is a 
special type of editor for 
manipulating source 
code

f Language features are 
highlighted

 Marker bars for showing
 Breakpoints
 Errors/warnings
 Task Tags, Bookmarks

 Location bar for 
navigating to interesting 
features in the entire file Icons:Icons:
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Line NumbersLine Numbers

 Text editors can show line numbers in the 
l ft lleft column

 To turn on line  To turn on line 
numbering:
 Right-mouse click in 

the editor marker barthe editor marker bar
 Click on Show Line 

Numbers
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Include File LocationsInclude File Locations

 Content assist and navigation 
i  k l d  f i l d  fil  requires knowledge of include file 

location on the remote system
 The editor will indicate warnings 

 li  th t h  th  blon lines that have the problem
 Problems View will display a 

warning
 The project properties must be 

changed to resolve the problem Indexer: Unresolved inclusion: <stdio.h> in 
file: /u/ac/etrain1/hello/hello.c:11.  Please re-
configure project's remote include paths or 
symbolssymbols.
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Changing the Project Properties
 Open the project properties by 

right-clicking on project and 

Changing the Project Properties

g g p j
select Properties

 Expand Remote 
Developmentp

 Select Remote Paths and 
Symbols

 Select GNU C to change  Select GNU C to change 
C paths and symbols

 Click Add
 Enter “/usr/include” Enter /usr/include
 Click OK
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Saving  the Project Properties 
 Click OK to save the Project 

Properties

Saving  the Project Properties 

 You will be prompted to
rebuild the index
 Select Yes

 Red warnings should be  Red warnings should be 
gone from editor, since 
Eclipse knows the location 
of the include files now
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Navigating to Other Files
 On demand hyperlink

 Hold down Command/Ctrl key

Navigating to Other Files

 Click on element to navigate to 
its definition in the header file
(Exact key combination 
depends on your OS)p y )

 E.g. Command/Ctrl and click on 
EXIT_SUCCESS

 Open declaration
 Right-click and select Open 

Declaration will also open the 
file in which the element is 
declared

 E.g. right-click on stdio.h and 
select Open Declarationse ect Ope ec a at o

Module 3 3-36



Content Assist & TemplatesContent Assist & Templates
 Type an incomplete function name e.g. “get” into the editor, 

and hit ctrl-space 
 Select desired completion value with cursor or mouse Select desired completion value with cursor or mouse

Hit ctrl-space again 
for code templates  Code Templates: type

‘f ’ d Ct l
p

‘for’ and Ctrl-space
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Building the ProjectBuilding the Project

 The project should build automatically when created 

 To manually build, select
the project and press the

 If there is no makefile, then the build will fail

p j p
the “build” button
 Alternatively, select Project>Build 

Project

h bl h ld The executable should appear in 
the project

 The Console view shows 
b ldbuild output
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Build ProblemsBuild Problems

 If there are problems, they 
ill b  h  i   i  will be shown in a variety 

of ways
 Marker on editor line
 Marker on overview ruler Marker on overview ruler
 Listed in the Problems view 

 Double-click on line in 
Problems view to go toProblems view to go to
location of error

Module 3 3-39



Fix Build ProblemsFix Build Problems

 Fix errors by giving getenv an argument and fixing 
d l i   h

 Save the file
 Rebuild by pressing build 

declarations as shown

button
 Problems view is now 

empty
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Create a Resource ManagerCreate a Resource Manager

 A Resource Manager specifies how/where 
 ill b  l h dprograms will be launched

 Switch to the Parallel Runtime perspective
 Window>Open Perspective…

 In the Resource Managers view, 
right-click and select Add Resource 
Manager…

 Select Remote Launch and Next >
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Configure the Resource ManagerConfigure the Resource Manager

 Choose Remote Tools for 
R i  idRemote service provider

 Choose “abe.ncsa.uiuc.edu” 
for Connection name
 This was the connection used 

when the project was created

 Click Finish
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Start the Resource Manager

 Right-click on the new 
  d l  

Start the Resource Manager

resource manager and select 
Start Resource Manager
from the menu

 If th     If the resource manager 
starts successfully, the icon 
should turn green

 A  i  l  f d i di t   An icon color of red indicates 
a problem occurred

NOTE: On some Linux systems, starting a resource 
manager may appear to hang. Open the window 
you launched Eclipse from and check if there is a 
prompt for a kerberos username. Hit “enter” twice 
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Create a Run Configuration
To run the application, create a 

Run Configuration

g

 Open the run configurations 
dialog
 Click on the arrow next to the run button
 Or use Run>Run Configurations Or use Run>Run Configurations…

 Select Parallel Application
 Select the New button 

Depending on which flavor of Depending on which flavor of 
Eclipse you installed, you might 
have more choices of application 
types
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Complete the Resources TabComplete the Resources Tab

 Select your Resource Manager Select your Resource Manager
 Should be selected automatically if it has been started

 The Remote Launch doesn’t require additional attributes
 Other resource managers may have additional attributes, such as a  Other resource managers may have additional attributes, such as a 

queue name, etc.

Module 3 3-45



Complete the Application TabComplete the Application Tab

 Make sure “hello” is selected  Make sure “hello” is selected 
for the Parallel Project

 Browse to find the
executable file for the executable file for the 
Application program

 Launch the application by 
clicking the Run button
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Viewing Program OutputViewing Program Output

 When the program runs, the Console view should 
t ti ll  b  tiautomatically become active

 Any output will be displayed in this view
 Stdout is shown in black
 Stderr is shown in red Stderr is shown in red
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Other CDT featuresOther CDT features

 Searching
Mark Occurrences
Open Declaration / hyperlinking between files 

i  th  ditin the editor

First, return to the “Remote C/C++ 
Perspective”
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Language-Based SearchingLanguage Based Searching

 “Knows” what things can 
be declared in each 
language (functions, 
variables, classes, 
modules, etc.)

 For example, search for 
every call to a function y
whose name starts with 
“get”

 Search can be project- or 
workspace-wideworkspace wide
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Mark OccurrencesMark Occurrences

 Double-click on a variable in the CDT editor
 All occurrences in the source file are 

highlighted to make locating the variable 
easiereasier

 Alt-shift-O to turn off
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Open DeclarationOpen Declaration

 Jumps to the declaration of 
 i bl  f ti  t  a variable, function, etc., 

even if it’s in a different file

 Right-click on an identifier Right click on an identifier
 Click Open Declaration

 Can also Ctrl-click (Mac: (
Cmd-click) on an identifier 
to “hyperlink” to its 
declaration
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Remote Projects - LocationRemote Projects Location

 How to tell where a project 
id ?resides?

 Right-click Project
 Select Properties…

 In Properties dialog,
select Resource
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Remote Projects - ReopeningRemote Projects Reopening

 When re-opening Eclipse 
workbench, remote projects 
will be closed

 To re-open a closed project, 
Right-click on closed project 
and select Open Project

 Open project shows folder 
icon, and can be expanded to 
show contents of projectshow contents of project
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