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Tutorial Outline
Time (Tentative!) Module Topics Presenter

8:00-8:30 1. Eclipse Installation

2. Introduction/Overview

 Installation of Eclipse and PTP

 Eclipse architecture & organization overview

Beth

Greg

 8:30-10:00 3. Eclipse basics (1.5 hr))  Eclipse basics; Creating a new project from CVS; 

Local, remote, and synchronized projects

 Creating a synchronized project from CVS

 Editor features; MPI Features

Beth

9:45-10:00 BREAK Marina Foyer

10:30-12:00

 

4. Build/run (1.5 hr)  Building w/Makefile

 Target configurations and launching a parallel app

 Including Modules (Build Environment Mgmt)

Jay 

12:00 – 1:00 Lunch Marina Ballroom D&E

1:00-3:00 4. Debugging (1 hr)

5. Fortran (30 min)

6. Adv/Misc (30 min)

 Debugging an MPI program

 Fortran

 Adv features -  including XSEDE feature

Greg

Jeff

Jeff

2:15-2:30 BREAK Marina Foyer

3:15-4:45

5. Performance Tuning & 

Analysis Tools

 TAU, External Tools FrameWork  (:40)

 Gprof/Gcov (:40) 

Wyatt 

Galen

4:45-5:00 6. Other Tools, Wrapup  PTP Future plans,  Other Tools, website, mailing 

lists, getting involved, Tutorial feedback

Beth



Final Slides, Installation 
Instructions

Please go to 
http://wiki.eclipse.org/PTP/tutorial
s/XSEDE13 for slides and 
installation instructions



Installation

Objective
To learn how to install Eclipse and PTP

Contents
System Prerequisites

Eclipse Download and Installation of “Eclipse for 
Parallel Application Developers”

Installation Confirmation

Updating the PTP within your Eclipse to the latest 
release

Installation Install-1



System Prerequisites

Local system (running Eclipse)
Linux (just about any version)

MacOSX (10.5 Leopard or higher)

Windows (XP on)

Java: Eclipse requires Sun or IBM Java
Only need Java runtime environment (JRE)

Java 1.6 or higher 

Java 1.6 is the same as JRE 6.0

The GNU Java Compiler (GCJ), which comes 
standard on Linux, will not work!

OpenJDK, distributed with some Linux distributions, 
comes closer to working, but should not be used.

See http://wiki.eclipse.org/PTP/installjava

Install-2Installation



Eclipse Packages

The current version of Eclipse (4.3) is also 
known as “Kepler”

Eclipse is available in a number of different 
packages for different kinds of development
http://eclipse.org/downloads

For PTP, we recommend the all-in-one 
download:
Eclipse for Parallel Application Developers

We often call this the “Parallel Package”

Install-3Installation

New! See 
next slide
for update



New! Parallel Package updated

 The public Parallel Package on eclipse.org/downloads is 
only updated three times yearly

 We are now building updated all-in-one packages with 
new releases of PTP already installed.

 Go to http://eclipse.org/ptp/downloads.php

 Under File Downloads:

 Click on the link, and on the file downloads page, see 
Parallel Application Developers Package and 
download the appropriate file for your platform

 Mac OS X

 Linux X86 and X86_64

 Windows x86 and x86_64

 Unzip or untar it

Install-4Installation



Exercise

1. Download the “Eclipse for Parallel Application 
Developers” package to your laptop
 Your tutorial instructions will provide the location of 

the package

 Make sure you match the architecture with that of 
your laptop

2. If your machine is Linux or Mac OS X, untar 
the file
 On Mac OS X you can just double-click in the Finder

3. If your machine is Windows, unzip the file

4. This creates an eclipse folder containing the 
executable as well as other support files and 
folders

Install-5Installation



Starting Eclipse
 Linux

 From a terminal window, enter
“<eclipse_installation_path>/eclipse/eclipse &”

 Mac OS X

 From finder, open the eclipse folder where you installed

 Double-click on the Eclipse application

 Or from a terminal window

 Windows

 Open the eclipse folder

 Double-click on the eclipse executable

Install-6Installation



Eclipse prompts for a workspace location at 
startup time

The workspace contains all user-defined data
Projects and resources such as folders and files

The default workspace location is fine for this tutorial

Specifying A Workspace

The prompt can be 
turned off

Install-7Installation



Eclipse Welcome Page

Displayed when Eclipse is run for the first time

Select “Go to the workbench”

Install-8
Installation



Checking for PTP Updates

From time-to-time there may be newer PTP 
releases than the Kepler release
Kepler and “Parallel package” updates are released 

only in September and February

PTP maintains its own update site with the 
most recent release
Bug fix releases can be more frequent than base 

Eclipse (e.g. Kepler), and what is within the parallel 
package

You must enable (and install from) the PTP-
specific update site before the updates will be 
found

Install-9Installation



Updating PTP
 Now select Help>Install New Software…

 In the Work With: dropdown box, select this update site, 
or enter it:
http://download.eclipse.org/tools/ptp/updates/kepler

Install-10Installation



Updating PTP (2)

 Easiest option is to check everything - which updates 
existing features and adds a few more

Note: for this tutorial, this installs extra features we’ll 
refer to later anyway (GEM, TAU)

 Select Next  to continue updating PTP

 Select Next  to confirm features to install

Install-11Installation



Updating PTP (3)

 Accept the License agreement and select Finish 

Install-12Installation



Updating PTP - restart

 Select Yes when prompted to restart Eclipse

Install-13Installation



Updating Individual Features

 It’s also possible (but a bit tedious) to update features 
without adding any new features
 Open each feature and check the ones you want to update

 Icons indicate: Grey plug: already installed
                      Double arrow: can be updated

                           Color plug: Not installed yet

 Note: if network is slow, consider unchecking:

Install-14Installation



Restart after Install

 If any new top-level features 
are installed, they will be 
shown on the welcome screen

 We only updated PTP, so we 
land back at C/C++ 
Perspective 

Install-15Installation

 Help>About or Eclipse > About Eclipse … 
will indicate the release of PTP installed

 Further Help>Check for Updates will find future updates on 
the PTP Update site



Exercise

1. Launch Eclipse and select the default 
workspace

2. Configure Eclipse to check for PTP updates

3. Update all PTP features to the latest level

4. Install the optional features of PTP, including 
TAU and GEM
– Selecting all features accomplishes 3. and 4.

5. Restart Eclipse once the installation is 
completed

Install-16Installation



Intro-1Introduction

Introduction

Objective
To introduce the Eclipse platform and PTP

Contents
New and Improved Features

What is Eclipse? 

What is PTP?



Intro-2

What is Eclipse?

A vendor-neutral open-source workbench for 
multi-language development

A extensible platform for tool integration

Plug-in based framework to create, integrate 
and utilize software tools

Introduction
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Eclipse Features

Full development lifecycle support

Revision control integration (CVS, SVN, Git)

Project dependency management

Incremental building

Content assistance

Context sensitive help

Language sensitive searching

Multi-language support

Debugging

Introduction
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Parallel Tools Platform (PTP)

 The Parallel Tools Platform aims to provide a highly 
integrated environment specifically designed for parallel 
application development

 Features include:
 An integrated development environment (IDE) that 

supports a wide range of parallel architectures and 
runtime systems

 A scalable parallel debugger

 Parallel programming tools 
(MPI, OpenMP, UPC, etc.)

 Support for the integration 
of parallel tools

 An environment that simplifies the 
end-user interaction with parallel systems

 http://www.eclipse.org/ptp

Introduction



Eclipse PTP Family of Tools
Coding & Analysis

(C, C++, Fortran)

Parallel Debugging

Launching & 
Monitoring

Performance Tuning
(TAU, PPW, …) Intro-5Introduction



How Eclipse is Used

Intro-6

Remote 
Source 
Code

Introduction

Local 
Source 
Code

Edit/Build

Launch/Monitor

Debugging

Performance Tuning



Eclipse Basics
Objective

Learn about basic Eclipse workbench concepts: 
projects, 

Learn about projects: local, synchronized, remote

Contents
Workbench components: Perspectives, Views, Editors

Local, remote, and synchronized projects

Learn how to create and manage a C project

Learn about Eclipse editing features

Eclipse Basics Basic-1



Eclipse Basics
 A workbench contains the menus, toolbars, editors and 

views that make up the main Eclipse window

perspective
Eclipse Basics

view
view

view

editor

 The workbench represents 
the desktop development 
environment

 Contains a set of tools 
for resource mgmt

 Provides a common way 
of navigating through 
the resources

 Multiple workbenches 
can be opened at the 
same time

 Only one workbench can 
be open on a workspace 
at a time

Basic-2



Perspectives

Perspectives define the layout of views and 
editors in the workbench

They are task oriented, i.e. they contain 
specific views for doing certain tasks:
C/C++ Perspective for manipulating compiled 

code 

Debug Perspective for debugging applications

System Monitoring Perspective for monitoring 
jobs

  You can easily switch between perspectives

If you are on the Welcome screen now, select 
“Go to Workbench” now 

Eclipse Basics Basic-3



Switching Perspectives

 Three ways of changing 
perspectives

1. Choose the Window>Open 
Perspective menu option
Then choose Other…

2. Click on the Open Perspective button in the 
upper right corner of 
screen (hover over it to
see names)

3. Click on a 
perspective 
shortcut button

Eclipse Basics Basic-4



Which Perspective?

Eclipse Basics Basic-5

The current perspective is displayed in the title 
bar



Views

The workbench window is 
divided up into Views

The main purpose of a view is:
To provide alternative ways of presenting information

For navigation

For editing and modifying information 

Views can have their own menus and toolbars
Items available in menus and toolbars are 

available only in that view

Menu actions only 
apply to the view

Views can be resized

view

view view

Eclipse Basics Basic-6



Stacked Views

Stacked views appear as tabs

Selecting a tab brings that view to the 
foreground

Eclipse Basics Basic-7



Expand a View

Double-click on a view/editor’s tab to fill the 
workbench with its content; 

Repeat to return to original size

Window > Reset Perspective
returns everything to original positions

Basic-8Eclipse Basics

Double
click

Double
click



Help

 To access help
 Help>Help Contents

 Help>Search

 Help>Dynamic Help

 Help Contents provides 
detailed help on different 
Eclipse features in a 
browser

 Search allows you to 
search for help locally, or 
using Google or the Eclipse 
web site

 Dynamic Help shows help 
related to the current 
context (perspective, view, 
etc.)

Eclipse Basics Basic-9



Eclipse Preferences

 Eclipse Preferences allow 
customization of almost 
everything

 To open use
 Mac: 

Eclipse>Preferences…

 Others: 
Window>Preferences…

 The C/C++ preferences 
allow many options to be 
altered

 In this example you can 
adjust what happens in 
the editor as you type.

Eclipse Basics Basic-10



Preferences Example

More C/C++ preferences:
In this example the 

Code Style preferences 
are shown

These allow code to be 
automatically  
formatted in different 
ways

Eclipse Basics Basic-11



Exercise
1. Change to a different perspective

2. Experiment with moving and resizing views
 Move a view from a stack to beside another view

 Expand a view to maximize it; return to original size

1. Save the perspective

2. Reset the perspective

3. Open Eclipse preferences

4. Search for “Launching”

5. Make sure the “Build (if required) before 
launching” setting is disabled

Eclipse Basics Basic-12



Optional Exercise
Best performed after learning about projects, CVS, and editors

1. Use source code formatting to format a source file, or a region 
of a source file

 Use Source>Format menu

1. In Eclipse Preferences, change the C/C++ source code style 
formatter, e.g. 

 Change the indentation from 4 to 6

 Make line wrapping not take effect until a line has a 
maximum line width of 120, instead of the default 80

 Save a (new) profile with these settings

 Format a source file with these settings

1. Revert the file back to the original – experiment with

 Replace with HEAD, replace with previous from local history, 
or reformat using original style

Eclipse Basics Basic-13



Creating a Synchronized Project
Objective

Learn how to create and use synchronized projects

Learn how to create a sync project 

From a source code repository in CVS, or

Import from source on a remote machine

Contents
Eclipse project types

Creating a synchronized project from CVS or remote dir

Using synchronize filters

Remote Terminal view

Converting an existing project to synchronized

Synchronized Projects Sync-1



Project Location

Local
Source is located on local machine, builds happen locally

This is the default Eclipse model

Synchronized
Source is located on both local and remote machine(s), 

then kept in synchronization by Eclipse

Building and launching happens remotely
(can also happen locally)

Used mainly for scientific and supercomputing 
applications

There are also remote-only projects, but these 
have limitations and are not covered here

Synchronized Projects Sync-2
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Synchronized Projects
 Projects types can be:

-3

File Service Index Service

Launch Service

Build Service

Debug Service

Local 
source 
code

Source 
code

copy
Local Remote

Build

Run

Debug

Compute

Edit Search/Index
Navigation

Synchronize

Executabl
e

Synchronized Projects



Revision Control Systems (RCS)

Eclipse supports a range of RCS, such as CVS, 
Git, and Subversion (and others)

These are distinct from synchronized projects

RCS can be used in conjunction with synchronized 
projects

Synchronized projects are typically not used for 
revision control

Synchronized Projects Sync-4
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Synchronized Project Creation

Local -> Remote
Projects start out local then are synchronized to a 

remote machine

Three options
Created from scratch

Imported from local filesystem

Imported from source code repository

Remote -> Local
Projects start out on remote machine then are 

synchronized to the local system

Two options
Already on remote system

Checked out from source code repository

-5Synchronized Projects

A

B

slides

slides



Sync-6

C, C++, and Fortran Projects
Build types

Makefile-based
Project contains its own makefile (or makefiles) for 

building the application – or other build command

Managed
Eclipse manages the build process, no makefile 

required

-6Synchronized Projects



SCENARIO A: 
Check out source 
code from CVS 

repository

Basic-7Synchronized 
Projects

A



 Switch to CVS Repository 

Exploring perspective
 Window > Open Perspective > Other…

 Select CVS Repository Exploring

 Select OK

 Right click in CVS Repositories 

view and select New>Repository 

Location…

Importing a Project from CVS

CVS Source Code 
Repository

CVS-8

A



 Enter Host: cvs.ncsa.uiuc.edu

 Repository path:
/CVS/ptp-samples

 For anonymous access:
 User: anonymous

 No password is required

 Connection type: pserver (default)

 For authorized access:
 User: your userid

 Password: your password

 Connection type: change to extssh

 Select Finish

Add CVS Repository

CVS Source Code 
Repository

CVS-9

A



 Expand the repository location

 Expand HEAD

 Expand samples

 Right click on shallow and select 

Check Out As…

 On Check Out As dialog, select 

Finish

Checking out the Project

CVS Source Code 
Repository

CVS-10

The default of 
“Check out as a 
project configured 
using the New 
Project Wizard” is 
what we want

A



Next: New Project Wizard

Basic-11Synchronized 
Projects

Expand Remote

Select
Synchronized 
C/C++ Project

Select Next>

If asked to select a
tag, select HEAD
and hit FINISH

A



SCENARIO B: 
Source code on 
remote machine

Basic-12Synchronized 
Projects

B



Source Code for project

Source code exists on remote target 

Sync-13Synchronized Projects

B



Create Synchronized Project

 In the Project Explorer, right click then choose
 New>Synchronized C/C++ Project if your project is C/C++ only

 New>Synchronized Fortran Project if your project contains Fortran 
files

 This adds a Fortran nature so you can access Fortran properties, etc.

Sync-14Synchronized Projects

Or via menus: 
File>New>Other…
And under Remote, choose 
Synchronized C/C++ 
Project

B



Synchronized Projects Sync-15

 Enter the Project Name

 E.g. “shallow”

 The Local Directory specifies 
where the local files are located

 Leave as default

 The Remote Directory specifies 
where the remote files are located
 Select a connection to the remote 

machine, or click on New… to create 
a new one
  (See next slide)

 Use Modify File Filtering… if required 
(see later slide)

New Synchronized Project Wizard
B

A



Creating a Connection

In the Target Environment Configuration 
dialog
Enter a Target name 

for the remote host

Enter host name, user name, 
and user password or 
other credentials

Select Finish

Sync-16Synchronized Projects

If your machine access requires 
ssh access through a 
frontend/intermediate node, use 
localhost and port – see 
alternate instructions for 
ssh tunnel



Remote Directory for Project

 After the connection has been specified,
Browse for the directory on the remote machine

 Select directory if it exists, or enter a new directory name

 Hit OK

Basic-17Synchronized 
Projects
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 Choose the Project Type
 This tutorial’s code has its own makefile, 

so use 
Makefile Project>Empty Project

 Otherwise, choose the type of project 
you want to create

 Choose the toolchain for the 
remote build
 Use a toolchain that most closely 

matches the remote system

 Choose a toolchain for the local 
build
 This is optional if you don’t plan to build 

on the local machine

 This is used for advanced 
editing/searching

 Use Modify File Filtering… if 
required (see later slide)

 Click Finish to create the project

Project Type & Toolchain

Synchronized Projects



 If prompted, switch to the C/C++ 
Perspective after creating the files

 You should now see the “shallow” project in your 
workspace

 Project is
synchronized
with remote
host

Project successfully created

Synchronized 
Projects

Sync-19

Expand the 
project root 
to see the 
project’s 
contents



Synchronized Project

 Back in the Project 
Explorer, decorator on 
project icon indicates 
synchronized project

 Double-+  icon

 C Project w/o Sync

 Synchronized Project

Sync-20Synchronized Projects



Synchronized Project Menu

 Synchronized projects are indicated 
with a “synchronized” icon

 Right click on project to access 
Synchronize menu
 Sync Active Now will manually 

synchronize the active configuration

 Set Active can be used to select the 
active configuration

 Manage… is used to create new 
configurations to synchronize to 
different target systems

 Sync All Now will manually 
synchronizes all configurations

Sync-21Synchronized Projects

 Auto-Sync (Global) will enable or 
disable automatic synchronization

 Auto-Sync Settings can be used to 
select which configurations will be 
synchronized

 Filter… is used to change the filter 
settings for the project



Manage Configurations

 Used to manage synchronize 
configurations

 Use Set Active to change the active 
configuration (shown in bold in the 
list of configurations)

 Use Add to add a new configuration 
in order to synchronize to a different 
target system

 Other configuration information, such 
as the default build configuration, can 
also be changed

Sync-22Synchronized Projects

By default, there will be a configuration for the 
target system (active) and a Local configuration. 
The Local configuration can be used to build a 
local copy of the project if desired.



Synchronize Filters

If not all files in the remote project should be 
synchronized, a filter can be set up
For example, it may not be desirable to synchronize 

binary files, or large data files

Filters can be created at the same time as the 
project is created
Click on the Modify File Filtering… button in the 

New Project wizard

Filters can be added later
Right click on the project and select 

Synchronization>Filter…

Sync-23Synchronized Projects



Synchronize Filter Dialog

 Files can be filtered individually 
by selecting/unselecting them in 
the File View at the top

 Include or exclude files based on 
paths and expressions

Sync-24Synchronized Projects



Synchronized Project Properties

 Synchronized configurations 
can also be managed 
through the project 
properties

 Open the project properties 
by right-clicking on the 
project and selecting 
Properties

 Select Synchronize

 This is the same as using the 
Synchronize>Manage… 
menu

Sync-25Synchronized Projects



Forcing a Resync

 If Auto-sync is set, the project 
should automatically resync with 
remote system when things 
change

 Sometimes you may need to 
do it explicitly

 Right click on project and select 
Synchronization>Sync Active 
Now

 Status area in lower right shows
when Synchronization occurs

Sync-26Synchronized Projects



Remote Terminal

 There is a remote terminal that 
can be used to provide a shell 
from within Eclipse

 Select Window>Show 
View>Other…

 Choose Terminal from the 
Terminal folder

 In the Terminal view, click on the 
New Terminal Connection 
button

 Choose a previously configured 
connection from the dropdown, or 
create a new one

Sync-27Synchronized Projects



 If you need to change remote connection 

information (such as username or 

password), use the Remote 

Environments view 

Changing Remote Connection Information

Sync-28

 Stop the remote 
connection first

 Right-click and 
select Edit Note: Remote Host may be stopped

 Any remote interaction starts it

 No need to restart it explicitly

Synchronized Projects



Converting a Local
C/C++/Fortran Project

 to a
Synchronized Project

The following slides are for reference. 
Our project is already a Synchronized Project.

Sync-29Synchronized Projects



Converting To Synchronized

If source files exist on the local machine and you wish to 
convert it to a Synchronized Project on a remote 
system…

 Select File>New>Other…

 Open the Remote folder

 Select Convert to 
Synchronized Project

 Click Next>

Sync-30Synchronized Projects



Convert Projects Wizard

 For Project to convert
 Choose your local project

 For Connection name: click on 
New…
 Unless you already have a connection

 Enter information for:
 Target name

 Host name of remote system

 User ID

 Password

 Click Finish to close it

 The connection name will 
appear in the Connection
list

Sync-31Synchronized Projects



Convert Projects Wizard (2)
Back in the conversion wizard dialog,

we specify where the remote files
will be stored

 Enter a directory name in the 
Remote Directory field: 
select Browse…
 Sample: /u/ac/trainXX/shallow 

Typing a new directory name creates it

 This should normally be an empty directory 
– since local files will be copied there

 Project files will be copied under this 
directory

 Click Finish

 The project should synchronize
automatically

Sync-32Synchronized Projects



Exercise
1. Create a synchronized project

 Your login information and source directory will be 
provided by the tutorial instructor

1. Observe that the project files are copied to your 
workspace

2. Open a file in an editor, add a comment, and 
save the file

3. Observe that the file is synchronized when you 
save the file
 Watch lower-right status area; confirm on host system

Synchronized Projects Sync-33



Optional Exercise
1. Modify Sync filters to not bring the *.o files and 

your executable back from the remote host 
 Rebuild and confirm the files don’t get copied

Synchronized Projects Sync-34



Eclipse CVS – “Team” Features
Objective

Learn how to use Eclipse source code repository 
features on your project

Contents
How the files look in the Project Explorer

Handling changes

Comparing files (diffs)

This module assumes project was created in 
previous module

CVS Source Code Repository CVS-1



“Team” Features

Eclipse supports integration with multiple 
version control systems (VCS)
CVS, SVN, Git, and others

Collectively known as “Team” services

Many features are common across VCS
Compare/merge

History

Check-in/check-out

Some differences
Version numbers

Branching

CVS-2CVS Source Code 
Repository



Two meanings for ‘Synchronize’

PTP’s synchronize
Copy files in synchronized projects between local and 

remote to mirror them

Team synchronize
Show differences between local project and source 

code repository versions

Basic-3CVS Source Code 
Repository



CVS Features

Shows version numbers next to 
each resource

Marks resources that have 
changed
Can also change color (preference 

option)

Context menu for Team operations

Compare to latest, another 
branch, or history

Synchronize* whole project (or 
any selected resources)

CVS-4CVS Source Code 
Repository

* Team synchronize



How to tell that you’ve
changed something

Open “calc.c”

Add comment at line 40

Save file

File will be marked “>”
to indicate that it has 
been modified

CVS-5CVS Source Code 
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Comparing single file
with what’s in the repository

 Right-click on “calc.c” and 
select Compare 
With>Latest from HEAD

 Even if you didn’t create project 
from CVS, you can try Compare 
With>Local History… 

 Compare editor will open 
showing differences 
between local (changed) 
file and the original

 Buttons allow changes to 
be merged from right to 
left

 Can also navigate 
between changes using 
buttons

CVS-6CVS Source Code 
Repository



Comparing your project
with what’s in the repository

 Right-click on project 
name (or any subset) 
and select 
Team>Synchronize 
with Repository

 Team Synchronizing 
perspective will open

 List of changed files 
appears

 Double-click on a file to 
see the diff viewer

 Buttons allow changes to 
be merged from right to 
left

 Can also navigate 
between changes using 
buttons CVS-7CVS Source Code 

Repository



Revert To The Latest Version 

To replace your project contents to the current 
contents of the project in the src code repo,

Right-click on the “shallow” project
… and select Replace With>Latest from HEAD

Review the resources that will be replaced, 
then click OK

CVS-8CVS Source Code 
Repository



Exercise
Check out the shallow project from CVS as a 

synchronized project - as described in this 
module

CVS Source Code Repository CVS-9

Optional Exercise
1. Name every person who modified the Makefile

2. Identify which parts of the Makefile changed 
since revision 1.3

Hint: Right-click the Makefile and select Team > Show History.  
Both of these can be done from the History view.



Editor Features
Objective

Learn about Eclipse editor features

Contents
Saving

Editor markers

Setting up include paths

Code analysis

Content assistance and templates

Editor Features Editor-1



Editors

 An editor for a resource (e.g. a file) opens when you 
double-click on a resource

 The type of editor depends on the type of the resource
 .c files are opened with the 

C/C++ editor by default

 You can use Open With to 
use another editor

 In this case the default
editor is fine (double-click)

 Some editors do not just edit raw text

 When an editor opens on a resource, it stays open across 
different perspectives

 An active editor contains menus and toolbars specific to that 
editor

Editor Features Editor-2



Saving File in Editor

When you change a file in the editor, 
an asterisk on the editor’s title bar 
indicates unsaved changes

Save the changes by using 
Command/Ctrl-S or File>Save

Undo last change using Command/Ctrl Z

Editor Features Editor-3



Editor and Outline View

 Double-click on 
source file 

 Editor will open in 
main view

 Outline view is 
shown for file in 
editor

 Console shows
results of build, 
local runs, etc.

Editor Features Editor-4



Source Code Editors & Markers

 A source code editor is a 
special type of editor for 
manipulating source 
code

 Language features are 
highlighted

 Marker bars for showing

 Breakpoints

 Errors/warnings

 Task Tags, Bookmarks

 Location bar for 
navigating to interesting 
features in the entire file

Icons:
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Include Paths (1)
 In order for editor and build features to work properly, Eclipse needs to know 

where your include files are located

 The build environment on the remote host knows your include files etc., but 
we must tell Eclipse so that indexing, search, completion, etc. will know where 
things are

Editor-6Editor Features

   
   
   
   
   
 

 Open Project Properties

 Expand C/C++ General

 Select Preprocessor 
Include Paths

 Click GNU C, then CDT 
User Setting Entries, 
then click Add…

 In upper right, select
File System Path in 
pulldown

 Check Contains System 
Headers

  A UNC-style path specifies 
//<connection>/<path>

 Enter Path
//trestles/opt/openmpi/incl
ude

 Select OK

       
       
           

       



Include Paths (2)

After adding include directory, it should 
appear in the list

 Bug: on Mac, it appears as blank.  Close and re-open the twisty to see 
the correct value. 

 Add second value:

//trestles/usr/include
... the same way

You should have
two entries:

Editor-7Editor Features



Include Paths (3)

Select OK

The C/C++ Indexer should run
Lower right status area indicates it

If not force it via Project Properties>Index>Rebuild

Editor-8Editor Features



Code Analysis (Codan)
If you see bug icons in the editor marker bar, they 

are likely suggestions from Codan
 If include files are set correctly, they should not appear.

Code checkers can flag possible errors, even if 
code is technically correct

To turn them off, use Preferences
Window > Preferences or Mac: Eclipse > Preferences

  C/C++ > Code Analysis 
and uncheck 
all problems

 Select OK to
close 
Preferences If icons don’t disappear: 

Right mouse on Project > 
Run C/C++ Code Analysis
You can also enable/disable 
this per project in Project 
PropertiesUncheck all
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Line Numbers

 Text editors can show line numbers in the 
left column

 To turn on line 
numbering:

 Right-mouse click in 
the editor marker bar
(at editor left edge)

 Click on Show Line 
Numbers

Editor Features Editor-10



 On demand hyperlink
 In main.c line 135:

 Hold down Command/Ctrl key

e.g. on call to initialise

 Click on initialise to navigate 

to its definition in the header file
(Exact key combination 

depends on your OS)

 E.g. Command/Ctrl and click on 
initialise

 Open declaration
 Right-click and select Open 

Declaration will also open the 

file in which the element is 
declared

 E.g. in main.c line 29 right-click 

on decs.h and select Open 
Declaration

Navigating to Other Files

Note: may need to left-click 
before right-click worksEditor Features Editor-11



 Note: remote includes must be set up 
correctly for this to work

 On demand hyperlink
 In main.c line 73:

 Ctrl-click on fprintf

 stdio.h on remote system opens

 Open declaration (or F3)
 In main.c, right-click and select 

Open Declaration e.g on <stdio.h>

 File from remote system is opened. 

 Hover over editor name tab to see remote 
location.

Navigating to Remote Files

Editor Features Editor-12



Content Assist & Templates
 Type an incomplete function name e.g. “get” into the editor, 

and hit ctrl-space 

 Select desired completion value with cursor or mouse

Hit ctrl-space again 
for code templates  Code Templates: type

‘for’ and Ctrl-space

More info on code templates later
Editor Features Editor-13



Hover Help

Hover the mouse over a program element in 
the source file to see additional information

Editor-14Editor Features



Inactive code

Inactive code will appear grayed out in the 
CDT editor

Editor-15Editor Features



Exercise
1. Open an editor by double clicking on a source file in the 

Project Explorer

2. Use the Outline View to navigate to a different line in 
the editor

3. Back in main.c, turn on line numbering

4. In main.c, ctrl-click on line 99, master_packet, should 
navigate to its definition in the file

5. In worker.c, line 132, hover over variable p to see info
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Optional Exercise
1. Type “for”, then activate content assist

 Select the for loop with temporary variable template, insert it, 
then modify the template variable

 Surround the code you just inserted with “#if 0” and “#endif” and 
observe that it is marked as inactive

 Save the file

1. What do these keys do in the editor?
 Ctrl+L;  Ctrl+Shift+P  (do it near some brackets)

 Ctrl+Shift+/;    

 Ctrl+Shift+Y  and Ctrl+Shift+X    (do it on a word or variable name 
e.g.)

 Alt+Down; Alt+Up

1. To make sure you didn’t do any damage,
 Select any source files you changed and do rightmouse > replace with .. 

 (if you made project from CVS) ….Latest from HEAD

 (If you made project from remote files) … Local History ….

 Observe that your changes are gone.
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MPI Programming
Objective

Learn about MPI features for your source files

Contents
Using Editor features for MPI

MPI Help features

Finding MPI Artifacts

MPI New Project Wizards

MPI Barrier Analysis

MPI Programming MPI-1



MPI-Specific Features

 PTP’s Parallel Language Development Tools (PLDT) has 
several features specifically for developing MPI code

Show MPI Artifacts

Code completion / Content Assist

Context Sensitive Help for MPI

Hover Help

MPI Templates in the editor

MPI Barrier Analysis

PLDT has similar features for OpenMP, UPC, 
OpenSHMEM, OpenACC

MPI-2MPI Programming



In Project Explorer, select a project, folder, or a 
single source file
 The analysis will be run on the selected resource(s)

MPI-3

Show MPI Artifacts

-3

 Run the analysis by 
clicking on drop-
down menu next to 
the analysis button

 Select  Show MPI 
Artifacts

MPI Programming
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MPI Artifact View

 Markers indicate the 
location of artifacts in 
editor

 The MPI Artifact View 
lists the type and location 
of each artifact

 Navigate to source code 
line by double-clicking on 
the artifact

 Run the analysis on 
another file (or entire 
project!) and its markers 
will be added to the view

 Click on column headings 
to sort 

 Remove markers via

MPI-4MPI Programming



MPI-5

MPI Editor Features
 Code completion will show all 

the possible MPI keyword 
completions

 Enter the start of a keyword 
then press <ctrl-space>

-5

 Hover over MPI API

 Displays the function 
prototype and a 
description

MPI Programming



MPI-6

Context Sensitive Help
 Click mouse, then press help 

key when the cursor is within a 
function name
 Windows: F1 key

 Linux: ctrl-F1 key

 MacOS X: Help key or 
HelpDynamic Help

 A help view appears (Related 
Topics) which shows 
additional information
(You may need to click on MPI 
API in editor again, to 
populate)

 Click on the function name to 
see more information

 Move the help view within your 
Eclipse workbench, if you like, 
by dragging its title tab

-6

Some special 
info has been 
added for MPI 
APIs

MPI Programming
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MPI Templates

Example: 
    MPI send-receive

Enter: 
   mpisr <ctrl-space>

Expands to a send-receive 
pattern

Highlighted variable names 
can all be changed at once

Type mpi <ctrl-space> <ctrl-
space> to see all templates

Add more templates using Eclipse preferences!
C/C++>Editor>Templates
Extend to other common patterns

-7

Allows quick entry of common patterns in MPI 
programming

MPI Programming



MPI Barrier Analysis

 Verify barrier 
synchronization in C/MPI 
programs

 For verified programs, lists 
barrier statements that 
synchronize together 
(match)

 For synchronization 
errors, reports counter 
example that illustrates 
and explains the error 

MPI-8

Local files only

MPI Programming



MPI Barrier Analysis (2)

MPI-9

Run the Analysis:

In the Project 
Explorer, select the 
project (or directory, 
or file) to analyze

Select the MPI 
Barrier Analysis 
action in the pull-
down menu

MPI Programming



MPI Barrier Analysis (3)

No Barrier Errors are found (no pop-up 
indicating error)

Two barriers are found

MPI-10MPI Programming



MPI Barrier Analysis Views

MPI Barriers view

Simply lists the barriers

Like MPI Artifacts view, 

double-click to navigate 

to source code line (all 

3 views)

Barrier Matches view

Groups barriers that 

match together in a 

barrier set – all 

processes must go 

through a barrier in the 

set to prevent a 

deadlock

Barrier Errors view 

If there are errors, a 

counter-example 

shows paths with 

mismatched number 

of barriers 
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Barrier Errors

Let’s cause a barrier mismatch error

Open worker.c in the editor by double-clicking 
on it in Project Explorer

At about line 125,
enter a barrier:
Type MPI_B

Hit Ctl-space

Select MPI_Barrier

Add communicator
arg MPI_COMM_WORLD   and closing semicolon

MPI-12MPI Programming



Barrier Errors (2)

Save the file
Ctl-S (Mac Command-S) or File > Save

Tab should lose asterisk indicating file saved

Run barrier analysis on shallow project again
Select shallow

project in Project
Explorer first

MPI-13MPI Programming



Barrier Errors (3)

Barrier Error is found

Hit OK to dismiss dialog

Code diverges on line 87
One path has 2 barriers, other has 1

MPI-14

Double-click 
on a row in 
Barrier Errors 
view to find 
the line it 
references in 
the code

MPI Programming



Fix Barrier Error

Fix the Barrier Error 
before continuing

Double-click on the
barrier in worker.c
to quickly navigate
to it

Remove the line and save the file

Re-run the barrier analysis to check that it has 
been fixed

MPI-15MPI Programming



Remove Barrier Markers

Run Barrier Analysis again to remove the error

Remove the Barrier Markers via the “X” in one 
of the MPI Barrier views

MPI-16MPI Programming



MPI New Project Wizards

Quick way to make a simple MPI project

File > New > C Project

“MPI Hello World”
is good for trying out
Eclipse for MPI

MPI-17MPI Features for 
Eclipse



MPI New Project Wizards (2)

Next> and fill in (optional) Basic Settings

MPI-18MPI Features for 
Eclipse

Next> and fill in MPI Project
                           Settings
Include path set in MPI 
Preferences can be added to 
project



MPI New Project Wizards (3)

Select Finish and “MPI Hello World” project
is created

MPI-19MPI Features for 
Eclipse



MPI Preferences

Settings for MPI New Project wizards

MPI Include paths, if set in MPI 
Preferences, are added in MPI New 
Project Wizard

MPI-20MPI Features for 
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Exercise

1. Find MPI artifacts in ‘shallow’ project
 Locate all the MPI communication (send/receive) 

calls

1. Use content assist to add an api call
 E.g., Type MPI_S, hit ctl-space

1. Use hover help

2. Use a template to add an MPI code template
 On a new line, type mpisr and ctl-space…
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Optional Exercise

1. Insert an MPI_Barrier function call into one of 
your source files using content assist
 E.g. Line 125 of worker.c

1. Save the file

2. Run Barrier Analysis on the project

3. Locate the source of the barrier error and 
remove the statement

4. Re-run barrier analysis to observe that the 
problem has been fixed
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Configuring SSH Tunnel

Tunnel-1SSH Tunnel



Configure the 
Synchronized Project -

SSH tunnel (1)

SSH Tunnel Tunnel-2

 If your machine access requires ssh access through a 
frontend/intermediate node, set up an ssh tunnel before configuring 
the project - from command line or e.g. Windows PuTTY, e.g.
ssh   -L  <port>:<target-host> <userid>@<frontend-host>
(For details see http://wiki.eclipse.org/PTP/FAQ)

 When you configure the connection for the project 

 Connection: New…

 The connection will use
the port for the ssh tunnel
(details on next slide)

http://wiki.eclipse.org/PTP/FAQ


Configure connection to 
remote host – SSH Tunnel (2)

SSH Tunnel Tunnel-3

 In Target Environment Configuration 
dialog, enter target name, 
and host information

 1. Specify Target name 

 2. If using a tunnel, select 
Localhost and enter userid and 
password for remote system

 For direct access, just 
select Remote Host, enter 
hostname, userid, password

 3. select the Advanced button 
to specify the port

 Select Finish

2.

Specify port for tunnel

1.

3.



Building a Project

Objective
Learn how to build an MPI program on a remote 

system

Contents
How to change build settings 

How to start a build and view build output

How to clean and rebuild a project

How to create build targets

Build-1Building a Project



Build Configurations

 A build configuration provides the 
necessary information to build the 
project

 The build configuration 
information is specified in the 
project properties

 Projects can have multiple build 
configurations, each configuration 
specifies a different set of options 
for a build

 Open the properties by right-
clicking on the project name in the 
Project Explorer view and 
selecting Properties (bottom of 
the context menu list)

Build-2Building a Project

Note: Fortran projects are a superset of 
C/C++ projects, so they have properties 
for both



Build Properties (1)

Build-3Building a Project

 C/C++ Build
 Main properties page

 Configure the build command

 Default is “make” but this can be changed to 
anything

 Build Variables
 Create/manage variables that can be used in other 

build configuration pages

 Environment
 Modify/add environment variables passed to build

 Logging
 Enable/disable build logging



Build Properties (2)

Build-4Building a Project

 Settings
 Binary parser selection (used to display binaries in 

Project Explorer)

 Error parser selection (used to parse the output from 
compiler commands)

 Tool Chain settings (managed projects only)

 Tool Chain Editor
 Allows the tools in a particular tool chain to be 

modified

 XL C/C++ Compiler
 Compiler settings for XL C/C++ compilers (if 

installed)

 C/C++ General/Preprocessor Include Paths…
 Set include paths here



Selecting Build Configuration

 Multiple build configurations may be available
 Synchronized projects will usually have a remote and a local build configuration

 Build configurations for different architectures

 The active build configuration will be used when the build button 
is selected

 The Build Configurations project context menu can be used to 
change the active configuration
 Right click on project, then select the build configuration from the Build 

Configurations > Set Active menu 

Build-5Building a Project



Building Synchronized Projects

 When the build button is selected, the 
“active” build configuration will be built 
on the remote system specified by the 
“active” synchronize configuration

 The build and synchronize configurations 
are independent
 It is possible to change which build 

configuration is active, but make sure this 
makes sense on the remote system specified in 
the synchronize configuration 

 Right mouse on Project, 
Synchronize > Manage…

 A build configuration can be associated 
with a synchronize configuration, so that 
it is automatically selected when the 
synchronize configuration is changed

Build-6Build



Configuring the Build Environment

 If the remote system has an 
environment system (such as 
Modules) installed, a custom 
set of modules can be 
configured for building C/C++ 
projects

 In the Manage Synchronize 
Configurations dialog, select 
the configuration you wish to 
change

 Check Use an environment 
management system to 
customize the remote build 
environment

Build-7Building a Project



Build Environment (2)

 Select a module from the 
Available Modules list and 
click the Add-> button to add 
them to the Selected 
Modules list

 Use the <-Remove button to 
remove modules from the 
Selected Modules list

 Use the Filter list field to 
quickly find modules with a 
given name

 Use the Up and Down 
buttons to change the order 
of the Selected Modules

 Click Select Defaults to load 
only those modules that are 
present in a new login shell

Build-8Building a Project



Build Environment (3)

 To build the project, Eclipse will
 Open a new Bash login shell

 Execute module purge

 Execute module load for each selected module

 Run make

 Module commands are displayed in the Console view during build

 Beware of modules that must be loaded in a particular order, or 
that contain common paths like /bin or /usr/bin

Build-9Building a Project



Build Environment (4)

 For this tutorial, we want to use gcc and Open MPI

 Navigate to gnu/4.6.1 in Available Modules and select Add ->

 Navigate to openmpi/1.4.3 and select Add ->

 Also add 
Tau/2.21.3
for later
use
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Start with original‘shallow’

Start with original ‘shallow’ code:
Project checked out from CVS:

Right mouse on project,  
Replace with > Latest from HEAD

Also see Compare With …

Other project:

Right mouse on project,
Restore from local history – finds deleted files

Right mouse on file, Compare With 
or Replace With

Build-11Building a Project

Changed file:



Starting the Build

 Select the project in Project Explorer

 Click on the     hammer button in toolbar to run a build 
using the active build configuration

 By default, the Build Configuration assumes there is a 
Makefile (or makefile) for the project

Build-12Building a Project



 Build output will be visible in console

Viewing the Build Output
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Build Problems

 Build problems will be 
shown in a variety of 
ways

 Marker on file

 Marker on editor line

 Line is highlighted

 Marker on overview ruler

 Listed in the Problems 
view 

 Double-click on line in 
Problems view to go 
to location of error in 
the editor

Building a Project Build-14



Forcing a Rebuild

 If no changes have been made, 
make doesn’t think a build is needed
e.g. if you only change the Makefile

 In Project Explorer, right click on 
project; Select Clean Project

 Build console will display results

 Rebuild project by clicking on 
build button again

Building a Project Build-15



Forcing a Resync

 Project should resync with remote 
system when things change

 Sometimes you may need to 
do it explicitly

 Right mouse on project,
Synchronize>Sync Active Now

 Status area in lower right shows
when Synchronization occurs

Building a Project Build-16



 By default
 The build button will run “make all”

 Cleaning a project will run “make clean”

 Sometimes, other build targets are 
required

 Open Make Target view

 Select project and click on New 
Make Target button

 Enter new target name

 Modify build command if desired

 New target will appear in view

 Double click on target to activate

Creating Make Targets
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Exercise

1. Start with your ‘shallow’ project

2. Build the project

3. Edit a source file and introduce a compile error

 In main.c, line 97, change ‘;’ to ‘:’

 Save, rebuild, and watch the Console view

 Use the Problems view to locate the error

 Locate the error in the source code by double 
clicking on the error in the Problems view

 Fix the error

1. Rebuild the project and verify there are no build errors

Building a Project
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Optional Exercise

1. Open the Makefile in Eclipse.  Note the line starting with 

“tags:” – this defines a make target named tags.

2. Open the Outline view while the Makefile is open.  What icon 
is used to denote make targets in the Outline?

3. Right-click the tags entry in the Outline view.  Add a Make 
Target for tags.

4. Open the Make Target view, and build the tags target.

5. Rename Makefile to Makefile.mk

6. Attempt to build the project; it will fail

7. In the project properties (under the C/C++ Build category), 
change the build command to:  make –f Makefile.mk

8. Build the project; it should succeed

Building a Project



Running an Application

Objective
Learn how to run an MPI program on a remote system

Contents
Creating a run configuration

Configuring the application run

Monitoring the system and jobs

Controlling jobs

Obtaining job output

Running an Application Run-1



Run-2

 Open the run configuration 
dialog Run>Run 
Configurations…

 Select Parallel Application

 Select the New button

Or, just double-click on 
Parallel Application
to create a new one 

Creating a Run Configuration

Note: We use “Launch Configuration” as a generic term to refer to either a 
“Run Configuration” or a “Debug Configuration”, which is used for debugging.

Running an Application



Run-3

Set Run Configuration Name

 Enter a name for this run configuration
 E.g. “shallow”

 This allows you to easily re-run the 
same application

 If the “shallow” project was selected 
when the dialog was opened, its name 
will be automatically entered

-3Running an Application



Run-4

Configuring the Target System
 In Resources tab, select a 

Target System Configuration 
that corresponds to your target 
system

 Use edu.sdsc.trestles.torque.batch

 Target system configurations 
can be generic or can be specific 
to a particular system

 Use the specific configuration if 
available, or the generic 
configuration that most closely 
matches your system

 You can type text in the box to 
filter the configurations in the 
list
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Configure the Connection

 Choose a connection to 
use to communicate with 
the target system

 If no connection has been 
configured, click on the 
New button to create a 
new one

 Fill in connection information, 
then click ok

 The new connection 
should appear in the 
dropdown list

 Select the connection you 
already have to 
trestles.sdsc.edu

 Select toggle if you don’t 
want to see popup again
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Resources Tab

 The content of the 
Resources tab will vary 
depending on the target 
system configuration 
selected 

 This example shows the 
TORQUE configuration

 For TORQUE, you will 
normally need to select 
the Queue and the 
Number of nodes

 For parallel jobs, choose 
the MPI Command and 
the MPI Number of 
Processes

See next slide
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Resources Tab (2)

 For this tutorial, use the following values
 Queue: shared

 Number of nodes: 1:ppn=5

 MPI Command: mpirun

 MPI Number of Processes: 5

 Leave other fields alone

 Configure modules for running the application
 Click on the Modules to Load: Configure… button

 Select the same modules used to build
 gnu/4.6.1

 openmpi/1.4.3
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Viewing the Job Script

 Some target 
configurations will 
provide a View Script  
button

 Click on this to view the 
job script that will be 
submitted to the job 
scheduler

 Batch scheduler 
configurations should 
also provide a means of 
importing a batch script
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Application Tab

 Select the Application tab

 Choose the Application 
program by clicking the 
Browse button and locating 
the executable on the 
remote machine 
 Use the same “shallow” 

executable

 Select Display output from 
all processes in a console 
view
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Arguments Tab (Optional)

 The Arguments tab lets 
you supply command-line 
arguments to the 
application 

 You can also change the 
default working directory 
when the application 
executes

-10Running an Application



Run-11

Environment Tab (Optional)

 The Environment tab 
lets you set environment 
variables that are passed 
to the job submission 
command

 This is independent of the 
Environment Management 
(module/softenv) support 
described on previous 
slide
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Synchronize Tab (Optional)

 The Synchronize tab lets 
you specify 
upload/download rules 
that are execute prior to, 
and after the job 
execution

 Click on the New 
upload/download rule 
buttons to define rules

 The rule defines which file 
will be 
uploaded/downloaded and 
where it will be put

 Can be used in 
conjunction with program 
arguments to supply input 
data to the application
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Common Tab (Optional)

 The Common tab is 
available for most launch 
configuration types (not 
just Parallel Application)

 Allows the launch 
configuration to be 
exported to an external 
file

 Can add the launch 
configuration to the 
favorites menu, which is 
available on the main 
Eclipse toolbar

 Select Run to launch
the job
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Run

Select Run to launch the job

You may be asked to switch to the System 
Monitoring Perspective

Select Remember my decision so you 
won’t be asked again

Select Yes to switch and launch the job

Run-14Building and Running



System Monitoring Perspective

 System view

 Jobs running 
on system

 Active jobs

 Inactive jobs

 Messages

 Console 

Run-15Running an Application
Scroll to see more



Moving views

The System Monitoring Perspective overlaps 
the Active Jobs and Inactive Jobs views

To split them apart and see both at once, 
drag the tab for the Inactive Jobs view to 
the lower half of its area, and let go of mouse
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System Monitoring

 System view, with 
abstraction of system 
configuration

 Hold mouse button 
down on a job in 
Active Jobs view to 
see where it is 
running in System 
view

 Hover over node in 
System view to see 
job running on node 
in Active Jobs view

-17

One node with 
16 cores
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 Job initially appears in 
Inactive Jobs view

 Moves to the Active Jobs 
view when execution 
begings

 Returns to Inactive Jobs 
view on completion

 Status refreshes 
automatically every 60 sec

 Can force refresh with menu
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 Right click on a job to open 
context menu

 Actions will be enabled IFF
 The job belongs to you

 The action is available on the 
target system

 The job is in the correct state for 
the action

 When job has COMPLETED, it 
will remain in the Inactive 
Jobs view
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 After status changes to 
COMPLETED, the output is 
available
 Right-click on the job 

 Select Get Job Output to display 
output sent to standard output

 Select Get Job Error to retrieve 
output sent to standard error

 Output/Error info shows in 
Console View

 Jobs can be removed by 
selecting Remove Job Entry

-20Running an Application
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Add a Monitor

You can monitor other systems too

In Monitors view, select the ‘+’ button to 
add a monitor

Choose monitor type and connection;
create a new connection if necessary

Run-21Running an Application

Double click 
new monitor 
to start



Run-22

Exercise

1. Start with your ‘shallow’ project

2. Create a run configuration

3. Complete the Resources tab

4. Select the executable in the Application tab

5. Submit the job

6. Check the job is visible in the Inactive Jobs view, 
moves to the Active Jobs view when it starts running 
(although it may be too quick to show up there), then 
moves back to the Inactive Jobs view when completed

7. View the job output

8. Remove the job from the Inactive Jobs view

Running an Application



Fortran

Objectives
Learn how to create and convert Fortran projects

Learn to use Fortran-specific editing features

Learn about Fortran-specific properties/preferences

Contents
Fortran projects

Using the Fortran editor

Fortran project properties and workbench preferences

Prerequisites
Basics (for exercises)

Fortran Projects Fortran-1



Ralph Johnson’s research group at UIUC used to meet at Pho-Tran…



…which became the name of their Fortran IDE.



Configuring Fortran Projects
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Project Properties

 Right-click Project

 Select Properties…

Project properties are settings 
that can be changed for each 
project

 Contrast with
workspace preferences, 
which are the same 
regardless of what 
project is being edited

 e.g., editor colors

 Set in Window

Preferences
(on Mac, Eclipse

Preferences)

 Careful! Dialog is 
very similar
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Converting to a Fortran Project

Are there categories labeled Fortran General 
and Fortran Build in the project properties?

No Fortran categories

If not, the project is not a Fortran Project
Switch to the Fortran Perspective

In the Fortran Projects view, right-click on the 
project, and click Convert to Fortran Project

Don’t worry; it’s still a C/C++ project, too

Every Fortran project is also a C/C++ Project

Do this 
once
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Project Location

 How to tell where a project 
resides?

 In the project properties 
dialog, select the 
Resource category
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Error Parsers

Are compiler errors not appearing in the 
Problems view?
Make sure the correct error parser is enabled

In the project properties, navigate to
C++ BuildSettings or Fortran BuildSettings

Switch to the Error Parsers tab

Check the error parser(s) for your compiler(s)

Do this 
once
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Fortran Source Form Settings

Fortran files are either free form or fixed form;
some Fortran files are preprocessed (#define, #ifdef, etc.)

 Source form determined by filename extension

 Defaults are similar to most Fortran compilers:
  

    Fixed form: .f .fix .for .fpp .ftn .f77
  

    Free form: .f08 .f03 .f95 .f90 < unpreprocessed
.F08 .F03 .F95 .F90 < preprocessed

    

Many features will not work if filename extensions 
are associated with the wrong source form
(outline view, content assist, search, refactorings, etc.)
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Fortran Source Form Settings

 In the project 
properties, select
Fortran General
Source Form  

 Select source form 
for each filename 
extension

 Click OK

Do this 
once
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Enabling Fortran Advanced Features

Some Fortran features are disabled by default 

Must be explicitly enabled
In the project properties dialog,

select Fortran General  Analysis/Refactoring

Click Enable
Analysis/
Refactoring

Close and re-open
any Fortran editors

This turns on the
“Photran Indexer”
Turn it off if it’s slow

Do this 
once
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Exercise

1. Convert shallow to a Fortran project

2. Make sure errors from the GNU Fortran 
compiler will be recognized

3. Make sure *.f90 files are treated as
“Free Form” which is unpreprocessed

4. Make sure search and refactoring will work in 
Fortran
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Advanced Editing

Code Templates
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Code Templates
(C/C++ and Fortran)

Auto-complete common code patterns
For loops/do loops, if constructs, etc.

Also MPI code templates

Included with content assist proposals
(when Ctrl-Space is pressed)

E.g., after the last line in tstep.f90, type “sub” and 
press Ctrl-Space

Press Enter to insert the template
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Code Templates (2)
(C/C++ and Fortran)

After pressing enter to insert the code 
template, completion fields are highlighted

Press Tab to move between completion fields

Changing one instance of a field changes all 
occurrences
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Exercise

 Open tstep.f90 and retype the last loop nest

 Use the code template to complete the do-loops

 Use content assist to complete variable names
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Custom Code Templates
(Fortran)

Customize code templates in Window  
Preferences  Fortran  Templates

Can import/export templates to XML files
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Search & Refactoring

Objectives
Develop proficiency using Eclipse’s textual and 

language-based search and navigation capabilities

Introduce common automated refactorings

Contents
Searching

Refactoring and Transformation

Prerequisites
Basics

Fortran

Advanced Features Advanced-1



Find/Replace within Editor

Simple Find within editor buffer

Ctrl-F (Mac: Command-F)
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Mark Occurrences
(C/C++ Only)

Double-click on a variable in the CDT editor

All occurrences in the source file are 
highlighted to make locating the variable 
easier

Alt-shift-O to turn off (Mac: Alt-Cmd-O)
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Language-Based Searching
(C/C++ and Fortran)

Advanced-4Advanced Features

 “Knows” what things can 
be declared in each 
language (functions, 
variables, classes, 
modules, etc.)

 E.g., search for every call 
to a function whose name 
starts with “get”
  

 Search can be project- or 
workspace-wide



Find References
(C/C++ and Fortran)

Finds all of the places where a variable, 
function, etc., is used
Right-click on an identifier in the editor

Click ReferencesWorkspace
or ReferencesProject

Search view
shows matches
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Open Declaration
(C/C++ and Fortran)

 Jumps to the declaration of 
a variable, function, etc., 
even if it’s in a different file

 Left-click to select 
identifier

 Right-click on identifier

 Click Open Declaration

 C/C++ only:
Can also Ctrl-click 
(Mac: Cmd-click) on an 
identifier to “hyperlink” to 
its declaration

Advanced-6Advanced Features

Goes to its declaration 
in copy.c



Search – Try It!

1. Find every call to MPI_Recv in Shallow.

2. In worker.c, on line 42, there is a declaration
float p[n][m].

a) What is m (local? global? function parameter?)

b) Where is m defined?

c) How many times is m used in the project?

3. Find every C function in Shallow whose name 
contains the word time
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Refactoring and Transformation
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Refactoring

 39 automated refactorings in Photran

(making changes to source code that don’t affect the behavior of the program)
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Refactoring Caveats

Photran can only refactor free form code that 
is not preprocessed
Determined by Source Form settings

(recall from earlier that these are configured in 
Project Properties: Fortran GeneralSource Form)

Advanced-10Advanced Features

Refactor menu will be empty if
 Refactoring not enabled in project properties

(recall from earlier that it is enabled in 
Project Properties: Fortran General Analysis/Refactoring)

 The file in the active editor is fixed form

 The file in the active editor is preprocessed

✔ Free Form, Unpreprocessed: .f08 .f03 .f95 .f90

✖ Free Form, Preprocessed: .F08 .F03 .F95 .F90

 Fixed Form: .f .fix .for .fpp .ftn .f77



Rename Refactoring
(also available in Fortran)

Changes the name of a variable, function, etc., 
including every use
(change is semantic, not textual, and can be workspace-wide)
  

Only proceeds if the new name will be legal
(aware of scoping rules, namespaces, etc.)

Switch to C/C++ Perspective

Open a source file

In the editor, click on a 
variable or function name

Select menu item 
RefactorRename

Or use context menu

Enter new name
Advanced-11Advanced Features

In Java (Murphy-Hill et al., 
ICSE 2008):



Rename in File
(C/C++ Only)

Advanced-12Advanced Features

 Position the caret 
over an identifier.

 Press Ctrl-1
(Command-1 on Mac).

 Enter a new name.  
Changes are 
propagated within 
the file as you type.



 Moves statements into a new function, replacing the 
statements with a call to that function

 Local variables are passed as arguments

Extract Function Refactoring

 Select a sequence of 
statements

 Select menu item 
Refactor
Extract Function…

 Enter new name

(also available in Fortran - “Extract Procedure”)
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 Fortran does not require variable declarations
(by default, names starting with I-N are integer variables; others are reals)

 This adds an IMPLICIT NONE statement and adds explicit 
variable declarations for all implicitly declared variables

Introduce IMPLICIT NONE Refactoring

 Introduce in a single file by 
opening the file and selecting 
RefactorCoding Style

Introduce IMPLICIT NONE…

 Introduce in multiple files by 
selecting them in the Fortran 
Projects view, right-clicking on 
the selection, and choosing 
RefactorCoding 
StyleIntroduce IMPLICIT 
NONE…
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 Interchange Loops   CAUTION: No check for behavior preservation

 Swaps the loop headers in a two-loop nest

 Select the loop nest, click menu item Refactor Do Loop 
Interchange Loops (Unchecked)… 

Loop Transformations
(Fortran only)

Advanced-15Advanced Features

Old version traverses
matrices in row-major 

order

New version traverses
in column-major order
(better cache performance)



Loop Transformations
(Fortran only)

Advanced-16Advanced Features

 Unroll Loop

 Select a loop, click RefactorDo LoopUnroll Loop… 

do i = 1, 10

  print *, 10*i

end do

do i = 1, 10, 4

  print *, 10*i

  print *, 10*(i+1)

  print *, 10*(i+2)

  print *, 10*(i+3) 

end do

Unroll 4×



Refactoring & Transformation – 
Exercises

In tstep.f90…

1. In init.c, extract the printf statements at 
the bottom of the file into a new function 
called print_banner

2. In worker.c, change the spellings of
neighbour_send and neighbour_receive
to American English

3. In tstep.f90, make the (Fortran) tstep 
subroutine IMPLICIT NONE
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NCSA/XSEDE Features

Objectives
Install NCSA’s GSI auth and XSEDE support plug-ins

Become familiar with the System menu

Contents
Capabilities

Installation

Prerequisites
(none)
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Additional Plug-ins from NCSA

NCSA publishes additional plug-ins can be 
added onto an existing PTP installation

Contribute a System menu to the menu bar 
with XSEDE- and NCSA-specific commands
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System Menu

 Open Web content in Eclipse:

 Open XSEDE User Portal

 Open User Guide for a machine

 Open an SSH terminal
(as an Eclipse view)

NCSA-3Advanced Features: NCSA/XSEDE 

Eclipse-integrated SSH terminals are provided 
by the Remote System Explorer (RSE), one of 
the features that is included in the Eclipse for 
Parallel Application Developers package.



System Menu

 Shortcuts for common PTP tasks:

 Add Remote Environment adds a 
Remote Tools connection for a 
particular machine

 Add System Monitor opens the 
System Monitoring perspective and 
begins monitoring a particular 
machine
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System Menu

 The plug-in is preconfigured with 
information about XSEDE and 
NCSA resources

 The bottom four commands 
generally prompt for a system

 Select System can be used to 
eliminate this prompt, so these 
commands always act on a 
particular system
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MyProxy Logon

 MyProxy Logon allows you 
to authenticate with a 
MyProxy server
 Often myproxy.teragrid.org

 It stores a “credential,” which 
is usually valid for 12 hours

 During these 12 hours, SSH 
connections to XSEDE 
resources will not require a 
password; they can use the 
stored credential
 However, you must enter the 

correct username for that 
machine!
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Installation

1. Click Help > Install New Software

2. Click Add to open the Add Repository dialog

3. In the Location field, enter

     http://forecaster.ncsa.uiuc.edu/updates/kepler

and then click OK to close the Add dialog.

1. Or, if you copied ncsa-update-size.zip from a USB 
drive, click Archive, select that file, and click OK.

4. Select the following:

1. GSI Authentication and MyProxy Logon Support

2. NCSA and XSEDE System Support

5. Click Next and complete the installation
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Parallel Debugging

Parallel Debugging

Objective
Learn the basics of debugging parallel programs

Contents
Launching a debug session

The Parallel Debug Perspective

Controlling sets of processes

Controlling individual processes

Parallel Breakpoints

Terminating processes

Debug-1



Debugging Setup

 Debugging requires interactive access to the application

 Can use any of the -Interactive target configurations

 Torque-Generic-Interactive

 PBS-Generic-Interactive

 OpenMPI-Generic-Interactive
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Create a Debug Configuration

 A debug configuration is 
essentially the same as a 
run configuration (like we 
used in the Running an 
Application module)

 It is possible to re-use an 
existing configuration and 
add debug information

 Use the drop-down next to 
the debug button (bug icon) 
instead of run button

 Select Debug 
Configurations… to open 
the Debug Configurations 
dialog
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Create a New Configuration

 Select the existing 
configuration

 Click on the new button to 
create a new configuration
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Configure the Resources Tab

 Select the new 
target system 
configuration

 Choose the queue

 Make sure number 
of nodes is correct

 Make sure the 
mpirun command is 
selected

 Select the number of 
processes (in this 
case use 5)

 Configure modules if 
required
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Configure the Application Tab (Optional)

 Select Application tab

 Make sure the Project is 
correct

 Select the application 
executable
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Configure the Debug Tab (Optional)

 Select Debugger tab

 Debugger will stop at 
main() by default

 By default the built-in 
SDM will be used
 Override this if you want to 

use your own SDM

 Click on Debug to launch 
the program
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Exercise

1. Open the debug configuration dialog

2. Create a new configuration

3. Select the edu.sdsc.trestles.torque.interactive.openmpi 
target configuration

4. Configure the Debug tab
 Queue: shared

 Number of nodes: 1:ppn=5

 MPI Command: mpirun

 MPI Number of Processes: 5

1. Launch the debugger
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 Parallel Debug 
view shows job 
and processes 
being debugged

 Debug view shows 
threads and call 
stack for individual 
processes

 Source view 
shows a current 
line marker for all 
processes

The Parallel Debug Perspective (1)
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The Parallel Debug Perspective (2)

 Breakpoints view
shows breakpoints 
that have been set 
(more on this later)

 Variables view 
shows the current 
values of variables 
for the currently 
selected process in 
the Debug view 

 Outline view (from 
CDT) of source 
code
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Stepping All Processes

 The buttons in the 
Parallel Debug View 
control groups of 
processes

 The Step Over button 
will step all processes 
one line

 The process icons will 
change to green 
(running), then back to 
yellow (suspended)

 Yhe current line marker 
will move to the next 
source line
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Stepping An Individual Process

 The buttons in the 
Debug view are used 
to control an 
individual process, in 
this case process 0

 The Step Over button 
will control just the 
one process

 There are now two 
current line markers, 
the first shows the 
position of process 0, 
the second shows the 
positions of processes 
1-4
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Process Sets (1)

 Traditional debuggers apply operations to a single 
process

 Parallel debugging operations apply to a single process 
or to arbitrary collections of processes 

 A process set is a means of simultaneously referring to 
one or more processes
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Process Sets (2)

 When a parallel debug session is first started, all 
processes are placed in a set, called the Root set 

 Sets are always associated with a single job

 A job can have any number of process sets

 A set can contain from 1 to the number of processes in 
a job

Parallel Debugging Debug-14



Operations On Process Sets

 Debug operations on the 
Parallel Debug view 
toolbar always apply to the 
current set:

 Resume, suspend, stop, 
step into, step over, step 
return

 The current process set is 
listed next to job name 
along with number of 
processes in the set

 The processes in process 
set are visible in right hand 
part of the view

Root set = all processes
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Create set Remove 
from set

Delete
set

Change
current set

Managing Process Sets

 The remaining icons in the toolbar of the Parallel 
Debug view allow you to create, modify, and delete 
process sets, and to change the current process set
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Creating A New Process Set

 Select the processes in 
the set by clicking and 
dragging, in this case, 
the last three

 The Create Set button 
enables a new process 
set to be created

 The set can be given a 
name, in this case 
workers

 The view is changed to 
display only the 
selected processes
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Stepping Using New Process Set

 With the workers set 
active, the Step Over 
button will now 
operated on only these 
processes

 Only the first line 
marker will move

 After stepping a couple 
more times, two line 
markers will be visible, 
one for the single 
master process, and 
one for the 4 worker 
processes
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Process Registration

Process set commands apply to groups of 
processes

For finer control and more detailed 
information, a process can be registered and 
isolated in the Debug view

Registered processes, including their stack 
traces and threads, appear in the Debug 
view

Any number of processes can be registered, 
and processes can be registered or 
un-registered at any time
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Process Registration (2)

 By default, process 0 was 
registered when the debug 
session was launched

 Registered processes are 
surrounded by a box and 
shown in the Debug view

 The Debug view only shows 
registered processes in the 
current set

 Since the “workers” set 
doesn’t include process 0, it 
is no longer displayed in the 
Debug view
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Registering A Process

 To register a process, 
double-click its process 
icon in the Parallel 
Debug view or select a 
number of processes and 
click on the register 
button

 To un-register a process, 
double-click on the 
process icon or select a 
number of processes and 
click on the unregister 
button

Individual 
(registered) 
processes

Groups (sets) 
of processes
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Current Line Marker

The current line marker is used to show the 
current location of suspended processes

In traditional programs, there is a single 
current line marker (the exception to this is 
multi-threaded programs) 

In parallel programs, there is a current line 
marker for every process

The PTP debugger shows one current line 
marker for every group of processes at the 
same location
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Multiple processes marker 

Registered process marker
 
Un-registered process marker

Colors And Markers

 The highlight color depends on 
the processes suspended at 
that line:
 Blue: All registered process(es)

 Orange: All unregistered 
process(es)

 Green: Registered or unregistered 
process with no source line (e.g. 
suspended in a library routine)

 The marker depends on the 
type of process stopped at that 
location

 Hover over marker for more 
details about the processes 
suspend at that location
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Exercise

1. From the initial debugger session, step all processes 

until the current line is just after MPI_Init (line 68)

2. Create a process set called “workers” containing 

processes 1-4

3. Step the “worker” processes twice, observe two line 

markers

4. Hover over markers to see properties

5. Switch to the “root” set

6. Step only process 0 twice so that all processes are now 

at line 71 (hint – use the debug view)
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 Apply only to processes in the particular set that is 
active in the Parallel Debug view when the breakpoint 
is created

 Breakpoints are colored depending on the active 
process set and the set the breakpoint applies to:
 Green indicates the breakpoint set is the same 

as the active set.

 Blue indicates some processes in the breakpoint set are 
also in the active set (i.e. the process sets overlap) 

 Yellow indicates the breakpoint set is different from the 
active set (i.e. the process sets are disjoint)

 When the job completes, the breakpoints are 
automatically removed

Breakpoints
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Creating A Breakpoint

 Select the process set that 
the breakpoint should apply 
to, in this case, the workers 
set

 Double-click on the left edge 
of an editor window, at the 
line on which you want to 
set the breakpoint, or right 
click and use the Parallel 
BreakpointToggle 
Breakpoint context menu

 The breakpoint is displayed 
on the marker bar
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Hitting the Breakpoint

 Switch back to the Root set 
by clicking on the Change 
Set button

 Click on the Resume button 
in the Parallel Debug view

 In this example, the three 
worker processes have hit the 
breakpoint, as indicated by 
the yellow process icons and 
the current line marker

 Process 0 is still running as its 
icon is green

 Processes 1-4 are suspended 
on the breakpoint
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More On Stepping

 The Step buttons are only 
enabled when all processes 
in the active set are 
suspended (yellow icon)

 In this case, process 0 is still 
running

 Switch to the set of 
suspended processes (the 
workers set)

 You will now see the Step 
buttons become enabled
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Breakpoint Information

Hover over breakpoint icon
Will show the sets this breakpoint applies to

Select Breakpoints view
Will show all breakpoints in all projects
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Use the menu in the breakpoints view to group 

breakpoints by type

Breakpoints sorted by breakpoint set (process 

set)

Breakpoints View
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 Apply to all processes and all jobs

 Used for gaining control at debugger startup

 To create a global breakpoint
 First make sure that no jobs are selected (click in white 

part of jobs view if necessary)

 Double-click on the left edge of an editor window

 Note that if a job is selected, the breakpoint will apply to 
the current set

Global Breakpoints
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Exercise

1. Select the “worker” process set

2. Create a breakpoint by double-clicking on right hand bar 

at line 88 (worker function)

3. Hover over breakpoint to see properties

4. Switch to “root” process set

5. Observer breakpoint color changes to blue

6. Resume all processes

7. Observe “worker” processes at breakpoint, and process 

0 still running (green icon)

8. Switch to “worker” process set

9. Step “worker” processes over worker() function

10.Observe output from program
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Terminating A Debug Session

 Click on the Terminate 
icon in the Parallel 
Debug view to 
terminate all processes 
in the active set

 Make sure the Root set 
is active if you want to 
terminate all processes

 You can also use the 
terminate icon in the 
Debug view to 
terminate the currently 
selected process
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Cancelling The Job

 Interactive jobs will continue 
until the reservation time has 
expired

 You can cancel the job once 
the debug session is finished

 Locate the job in the Active 
Jobs view
 Use the view menu to filter for 

only your jobs if there are too 
many

 Right click on the job and 
select Cancel Job
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Exercise

1. Switch to the “root” set

2. Terminate all processes

3. Switch to the System Monitoring perspective

4. Right-click on your running job and select Cancel
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Optional Exercise

1. Launch another debug job

2. Create a breakpoint at line 71 in main.c

3. Resume all processes

4. Select the Variables view tab if not already selected

5. Observe value of the “tid” variable

6. Register one of the worker processes

7. Select stack frame of worker process in Debug view

8. Observe value of the “tid” variable matches worker 

process

9. Switch to the breakpoints view, change grouping

10.Terminate all processes

11.Switch to the System Monitoring perspective and 

cancel the job
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Performance Tuning 
and Analysis Tools

Objective
Become familiar with tools integrated with PTP, to help 

enhance performance of parallel applications

Contents
Overview of ETFw and Performance Tools

Performance and Analysis 
Tools

Perf-1



PTP/External Tools Framework
formerly “Performance Tools Framework”

Goal:

 Reduce the “eclipse plumbing” 
necessary to integrate tools

 Provide integration for 
instrumentation, measurement, and 
analysis for a variety of performance 
tools

 Dynamic Tool Definitions: 
Workflows & UI

 Tools and tool workflows are specified in an XML file

 Tools are selected and configured in the launch 
configuration window

 Output is generated, managed and analyzed as 
specified in the workflow

 One-click ‘launch’ functionality

 Support for development tools such as TAU, PPW and 
others.

 Adding new tools is much easier than developing a full 
Eclipse plug-in
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SAX and JAXB Tool Definitions

Prior implementations of ETFW used a simple SAX 
based schema to define tool workflows

By default workflows now use the more powerful 
JAXB schema that defines PTP’s resource manager

Legacy workflows can still be loaded by selecting 
the SAX parser in PTP options
Window->Preferences->

Parallel Tools->External Tools

Performance and Analysis 
Tools
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Performance Tuning 
and Analysis Tools - TAU

Objective
Become familiar with tools integrated with PTP, to help 

enhance performance of parallel applications

Contents
Performance Tuning and external tools: 

PTP External Tools Framework (ETFw), TAU
Hands-on exercise using TAU with PTP
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TAU: Tuning and Analysis Utilities

 TAU is a performance evaluation tool

 It supports parallel profiling and tracing 
 Profiling shows you how much (total) time was spent in each routine 

 Tracing shows you when the events take place in each process along 
a timeline

 TAU uses a package called PDT (Performance Database Toolkit) for 
automatic instrumentation of the source code

 Profiling and tracing can measure time as well as hardware 
performance counters from your CPU (or GPU!)

 TAU can automatically instrument your source code (routines, 
loops, I/O, memory, phases, etc.)

 TAU runs on all HPC platforms and it is free (BSD style license)

 TAU has instrumentation, measurement and analysis tools
 paraprof is TAU’s 3D profile browser
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TAU Performance System Architecture
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PTP TAU plug-ins 
http://www.cs.uoregon.edu/research/tau

 TAU (Tuning and Analysis Utilities)

 First implementation of External Tools Framework (ETFw)

 Eclipse plug-ins wrap TAU functions, make them available 
from Eclipse

 Full GUI support for the TAU command line interface

 Performance analysis integrated with development 
environment
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TAU Integration with PTP

TAU: Tuning and 
Analysis Utilities
Performance data 

collection and analysis 
for HPC codes

Numerous features

Command line interface

The TAU Workflow:
Instrumentation

Execution

Analysis

TAU TAU-5



TAU PTP Installation

 This tutorial assumes that the TAU extensions for PTP 
are installed – they are not included in the 
“Eclipse for Parallel Application Developers”

 The installation section (Module 1) shows how to install 
TAU and other features from the PTP update site – 
be sure TAU was selected
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To confirm:
Help>Install New Software…
Select the link “What is already 
installed” at the bottom of the 
dialog
You should see the TAU 
Extension



Installing TAU Analysis Tools

 The TAU plugin can use ParaProf for visual analysis and TauDB 
for organization of profiles

 To install these utilities on Mac or Linux platforms: 

Download (browser, curl or wget) 
tau.uoregon.edu/tautools.tgz

tar -zxf tautools.tgz

cd tautools-2.22.2

./configure

Set path as shown (launch eclipse from this environment)

Run taudb_configure and follow the instructions

 Java WebStart: tau.uoregon.edu/paraprof

 TAU Installation, downloads and instructions: tau.uoregon.edu
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Assumptions

Obtain and install TAU*
 Download at tau.uoregon.edu

 The website includes setup and user guides

Set up the $PATH on the remote machine*
 For TAU you should be able to run ‘which pprof’ on a remote login 

and see a result from your TAU bin directory

 On trestles.sdsc.edu this is accomplished by loading the tau module 
in the environment manager for the build and launch configurations

Include ‘eclipse.inc’ in the makefile*
 Create an empty eclipse.inc file in the same directory as the 

makefile

 Place ‘include eclipse.inc’ in the makefile after regular compiler 
definitions

 ETFw will modify eclipse.inc to set CC/CXX/FC variables
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Selective Instrumentation

By default tau provides timing data for each 
subroutine of your application

Selective instrumentation allows you to 
include/exclude code from analysis and control 
additional analysis features
 Include/exclude source files or routines

 Add timers and phases around routines or arbitrary code

 Instrument loops

 Note that some instrumentation features require the PDT

Right click on calc.c, init.c, diag.c go to the Selective 
Instrumention option and select Instrument Loops

Note the creation of tau.selective (refresh if needed)
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Begin Profile Configuration

The ETFw uses the same run configurations and 
resource managers as debugging/launching

Click on the ‘Run’ menu or the right side of the 
Profile button

From the dropdown menu select ‘Profile 
configurations…’
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Select Configuration

 Select the shallow configuration 
prepared earlier

 The Resource and Application 
configuration tabs require little or 
no modification
 We are using the same resource 

manager and Torque settings

 Since we are using a makefile project 
the application will be rebuilt in and 
run from the previously selected 
location

TAU TAU-11

Performance Analysis tab is 
present in the Profile 
Configurations dialog



Select Tool/Workflow

Select the Performance Analysis tab and 
choose the TAU tool set in the ‘Select Tool’ 
dropdown box
Other tools may be available, either installed as 

plug-ins or loaded from workflow definition XML files

Configuration sub-panes appear depending on the 
selected tool

TAU TAU-12

Tabs may be 
hidden if the 
window is too 
small



Select TAU Configuration

Choose the TAU  Makefile tab:
All TAU configurations in 

remote installation are 
available

Check MPI and PDT 
checkboxes to filter listed 
makefiles

Make your selection in the 
Select Makefile: dropdown 
box

Select Makefile.tau-mpi-pdt
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Choose PAPI Hardware Counters

When a PAPI-enabled TAU 
configuration is selected the PAPI 
Counter tool becomes available
Select the ‘Select PAPI Counters’ 

button to open the tool

Open the PRESET subtree

Select PAPI_L1_DCM (Data cache 
misses)

Scroll down to select PAPI_FP_INS 
(Floating point instructions)

Invalid selections are automatically 
excluded

Select OK

Not available on trestles.sdsc.edu
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Compiler Options

TAU Compiler Options
 Set arguments to TAU compiler scripts

 Control instrumentation and 
compilation behavior

 Verbose shows activity of compiler 
wrapper

 KeepFiles retains instrumented source

 PreProcess handles C type ifdefs in 
fortran

 In the Selective Instrumentation tab 
select Internal then hit Apply

 Scroll to bottom of the Tau Compiler tab 
and activate TauSelectFile to use 
tau.selective

TAU TAU-15



Runtime Options

TAU Runtime options
Set environment variables used by 

TAU

Control data collection behavior

Verbose provides debugging info

Callpath shows call stack 
placement of events

Throttling reduces overhead

Tracing generates execution 
timelines

 Set Profile Format to merged
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Working with Profiles
 Profiles are uploaded to 

selected database

 A text summary may be 
printed to the console

 Profiles may be uploaded to 
the TAU Portal for viewing 
online

tau.nic.uoregon.edu

 Profiles may be copied to 
your workspace and loaded 
in ParaProf from the 
command line.  Select Keep 
Profiles
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Launch TAU Analysis

 Once your TAU launch is 

configured select ‘Profile’

 Notice that the project rebuilds with TAU compiler commands

 The project will execute normally but TAU profiles will be generated

 TAU profiles will be processed as specified in the launch 
configuration.

 If you have a local profile database  the run will show up in the 
Performance Data Management view

 Double click the new entry to view in ParaProf

 Right click on a function bar and select Show Source Code for 
source callback to Eclipse
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Paraprof

Use ParaProf for profile visualization to identify 
performance hotspots
Inefficient sequential computation 

Communication overhead

IO/Memory bottlenecks

Load imbalance

Suboptimal cache performance

Compare multiple trials in PerfExplorer to identify 
performance regressions and scaling issues 

To use ParaProf, install TAU from tau.uoregon.edu 
or use Java webstart from tau.uoregon.edu/paraprof 
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Exercise
 Multi-Trial profile comparison

1. Edit the shallow Makefile, adding -O3 to CFLAGS and FFLAGS

2. Rerun the analysis (Run->Profile Configurations. Hit Profile)

3. A second trial, distinguished by a new timestamp, will be 
generated 

 It will appear in your Performance Data Manager view if a profile 
database is available

 Also present in the Profile subdirectory of your project directory

 If you do not see a Profile directory right click on your project and go 
to Synchronization->'Sync All Now'

4. Load the two trials in paraprof (on the command line: paraprof 
/path/to/tauprofile.xml)

5. Open Windows->ParaProf Manager

6. Expand your database down to reveal all trials

7. Right click on each trial and click 'Add Mean to Comparison 
Window' to visualize the two trials side by side 

 
TAU TAU-20



Gcov and gprof support in linux tools
Objective

Learn how to use Eclipse-based interfaces to GNU tools 
Gcov and Gprof

Contents
Build with “-pg” for gprof profiling

Build with “-ftest-coverage –fprofile-arcs” for gcov

Run gcov to determine code coverage – which parts of 
your program are logically getting exercised

Run gprof to determined which parts of your program 
are taking most of the execution time

Linux-1Linux Tools



Linux Tools

What is Linux Tools?

http://eclipse.org/linuxtoo
ls/

Builds on CDT for C/C++

 Integrates popular native 
development tools such as 
Valgrind, OProfile, RPM, 
SystemTap, GCov, GProf, 
LTTng, etc. – into Eclipse
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Linux Tools - Installation

Some of the Linux Tools 
are included with Eclipse 
for Parallel Application 
Developers package

Everything you need for 
this tutorial is in the 
package

To install manually:
 Help > Install New Software

 In Work With: Select Kepler update 
site

 Under Linux Tools, Select the tools 
you want or just select all of them

 Some cannot be installed on all 
non-Linux platforms

 Click Next> … and continue to end of 
installation and restart Eclipse when 
prompted
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Linux Tools - usage

With a synchronized project, you only need gprof/gcov 
available on the remote system.  (Even the Windows 
client can view the gprof and gcov output files.)

Compiler flags
 -pg  to profile with gprof for the GNU compilers

 -ftest-coverage -fprofile-arcs   for gcov support
 It’s ok to use both at the same time at low optimization settings

Re-run the application

With synchronized projects, remember to re-sync to 
retrieve the resultant files

gprof -s shallow gmon_shallow.*  : creates a 
summary profile (gmon.sum) from MPI programs with a 
profile per rank
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Linux Tools – click to view
 Double-click gmon.* for gprof view

 Double-click *.gcno or *.gcda for gcov view
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Linux Tools – click to view
 Double-click gmon.* for gprof view

 Double-click *.gcno or *.gcda for gcov view, 
 It will ask for binary file location

 Coverage Result: for Windows, select src file only (do not select the whole 

binary file in the radio button of the dialog box)

Linux-6Linux Tools

Windows 
only

Windows only. 
Mac/Linux can show 
coverage for whole 
file  



Opening a profile with gprof viewer

Linux-7Linux Tools

Note: since we’ve changed filename from ‘gmon.out’  to gmon_shallow.xxx
we will force the gprof editor to be invoked for the files.  
Use Right mouse > Open With… > Other … and choose Gprof Editor



Gprof tab
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Double-click on gmon.out file to open 
gprof viewer



Run code, inspect gcov display

Linux-9Linux Tools

Double-click on a source file in gcov view to see 
code coverage highlighted in source file



Gcov with a production code, unexecuted region
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gprof with shallow project, MPI

The Makefile CFLAGS and FFLAGS are modified as shown to 
support profiling and coverage at the same time.
We have created the Makefile so you should just be able to 
uncomment these lines.
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Add compiler flags to Makefile



gprof with shallow project, MPI (2)

Setup the MPI run configuration with the Environment variable 
GMON_OUT_PREFIX defined with a /full/path/name for your 
individual MPI rank gmon outputs.  By default gmon.out is used but 
MPI doesn't do that well and you end up with a profile that's missing 
most of the information, so by using GMON_OUT_PREFIX, each MPI 
rank adds its process id to its gmon output filename. 

Linux-12Linux Tools

Modify Run Configuration
Run > Run Configurations … to modify existing Run Configuration  

Make this the fully qualified path+prefix 
for gmon output. E.g.
/home/userid/shallow/gmon_shallow
(Otherwise they end up in a scratch dir)



gprof with shallow project, MPI (3)
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Run from Run Configuration dialog

See build results in
   Console

See new
    files in Project Explorer
    (You may need to 
     force a Sync)



gprof with shallow project, 1 rank

Open gmon file with gprof viewer

Double-click on gmon.out file

    -or-  since gmon_shallow.xxx has non-standard file types ….

Right click on gmon_shallow.xxx file and select 
Rightmouse >Open With… Other…  and select 
Gprof Editor
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gprof with shallow project, 1 rank (2)

View gmon data with gprof viewer

Linux-15Linux Tools

It's interesting to 
compare the summary 
gmon output to that 
from one of the ranks.

This view shows a 
gmon.out file (you have 
a gmon_shallow.xxx 
file) from a single rank.



Gprof with shallow project, summary
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Aggregate the gmon output – invoke from a terminal:
     gprof -s shallow gmon_shallow.* 
This creates a gmon.sum file

Force a sync to
see the file in 
Project Explorer

Double-click to
open the gmon.sum
File with the
gprof viewer



Gprof viewer does not currently 
work well on Windows
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Windows: gprof with 
shallow project, 
summary, use a 
terminal window to 
create text file

a.Invoke cmd line gprof
b.Sync to see file
c.Double-click to view 
txt file

The linuxtools team 
knows about the issue 
with Juno/Kepler and 
they’re working on it.



Gprof viewer still useful on Windows
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Windows: Expand the 
gprof tab view of 
gmon.out (copy of one 
of the ranks output).

You can use the chart 
tool to make charts of 
the data in the gprof 
table you select.



Gcov with shallow project

The gcov view is simlar to the gprof view but keep in mind that you're 
looking at code coverage and not necessarily performance or timing 
information (though there is a relationship...code not executed is 
performing quite well ! ).  Also note that multiple executions will 
accumulate values in the gcov output files until they are removed or 
truncated to zero-length (2nd run to demonstrate this).

Double-click
on any of the
*.gcda or *.gcno
to open this
gcov viewer
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Gcov with shallow project, 
integration with CDT editor

Selecting (double click) a source code line from either the gcov or 
gprof view and you'll see the file and routine highlighted in the 
editor.  Also notice the support for the .f90 file and its routines.  
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Exercise

Follow directions in previous slides to

1. Add the compiler flags to Makefile 

2. Modify run configuration as described (add gmon 
prefix), and Run

3. View gmon and gcov files with gprof and gcov 
viewers
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Optional Exercise

1) Run the shallow application with gcov compiler flags enabled.
a)   Re-sync with Sync Active Now under Synchronization
b)   View the tstep.gcno file and note the count, then repeat 1)a-b , 

have the counts changed?

2) Compare the tstep.f90 loops at lines 61, 70, 80 in the gprof and 
gcov displays .

a) Change the Makefile to use –O3 with FFLAGS and clean/rebuild/re-
run

b) gprof –s shallow gmon_shallow.273*   [your most recent gmon_ 
files from the run you just finished ]

c) Re-sync the project
d) Does the gprof view of gmon.sum still exactly match up with the 

gcov display?  If not, what happened to the missing loop(s)?
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Tutorial Wrap-up

Objective
How to find more information on PTP

Learn about other tools related to PTP

See PTP upcoming features

Contents
Links to other tools, including performance tools

Planned features for new versions of PTP

Additional documentation

How to get involved
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Useful Eclipse Tools

 Linux Tools (autotools, valgrind, Oprofile, Gprof)

 http://eclipse.org/linuxtools (part of Parallel package)

 Python

 http://pydev.org

 Ruby

 http://www.aptana.com/products/radrails

 Perl
 http://www.epic-ide.org

 VI bindings
 Vrapper (open source) - http://vrapper.sourceforge.net

 viPlugin (commercial) - http://www.viplugin.com
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Online Information
Information about PTP

PTP online help 

http://help.eclipse.org

Main web site for downloads, documentation, etc.

http://eclipse.org/ptp

Wiki for designs, planning, meetings, etc.

http://wiki.eclipse.org/PTP

Information about Photran
Main web site for downloads, documentation, etc.

http://eclipse.org/photran
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Mailing Lists

 User Mailing Lists

 PTP

http://dev.eclipse.org/mailman/listinfo/ptp-user

 Photran

  http://dev.eclipse.org/mailman/listinfo/photran

 Major announcements (new releases, etc.) - low volume

http://dev.eclipse.org/mailman/listinfo/ptp-announce

 Developer Mailing Lists

 Developer discussions - higher volume 

http://dev.eclipse.org/mailman/listinfo/ptp-dev
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Getting Involved

See http://eclipse.org/ptp
Read the developer documentation on the wiki

http://wiki.eclipse.org/PTP

Join the mailing lists
Attend the monthly developer meetings

Conf Call Monthly: Second Tuesday, 1:00 pm ET
 Details on the PTP wiki

Attend the monthly user meetings
Teleconf Monthly: 4th Wednesday, 1:00 pm ET
Details on the PTP wiki
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PTP Tutorial Wrap-Up

XSEDE PTP BOF (Birds of a Feather session)
Tuesday 5:00-6:00 PM
La Mesa, South Tower, 4th Floor

Your feedback is valuable!

Thanks for attending

We hope you found it useful
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