Skip to main content
Jump to: navigation, search

Difference between revisions of "Xpand/Project Plan"

(New page: Reimplementation based on "Eclipse Xtext" will be started mid June. === Milestone 1 (due 2008-06-27) === * language described in Xtext grammar language * first strike-through (including b...)
 
 
(14 intermediate revisions by 4 users not shown)
Line 1: Line 1:
Reimplementation based on "Eclipse Xtext" will be started mid June.
+
== Under Development ==
  
=== Milestone 1 (due 2008-06-27) ===
+
Xpand 2.1.0 is planned for Eclipse Mars simultaneous release (June 2015).
* language described in Xtext grammar language
+
* first strike-through (including backend)
+
  
=== Milestone 2 (due 2008-0x-xx) ===
+
== Current Releases  ==
  
=== Milestone 3 (due 2008-0x-xx) ===
+
Current releases are available in [http://www.eclipse.org/modeling/m2t/downloads/?project=xpand Xpand download page].
  
=== Milestone 4 (due 2008-0x-xx) ===
+
*Version 2.0.0 was released on 2014/06/25 (Eclipse Luna)
 +
*Version 1.4.0 was released on 2013/06/26 (Eclipse Kepler)
 +
*Version 1.3.0 was released on 2013/02/26
 +
*Version 1.2.0 was released on 2012/06/27 (Eclipse Juno)
 +
*Version 1.1.0 was released on 2011/06/22 (Eclipse Indigo)
 +
*Version 1.0.1 was released on 2010/08/25 (Eclipse Helios)<br>
  
=== Milestone 5 (due 2008-0x-xx) ===
+
== Compatibility  ==
  
 +
Please note that the Xpand development team does its best to maintain downward compatibility towards Galileo (Eclipse 3.5). Following is the compatibility chart :
  
----
+
{| border="1"
 +
|-
 +
! Xpand
 +
! bgcolor="#cccccc" | Eclipse 4.3 - EMF 2.9
 +
! Eclipse 4.2 - EMF 2.8
 +
! Eclipse 3.8 - EMF 2.8
 +
! Eclipse 3.7 - EMF 2.7
 +
! Eclipse 3.6 - EMF 2.6
 +
! Eclipse 3.5 - EMF 2.5
 +
|-
 +
| bgcolor="#cccccc" | 2.0
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:yellow"  | 1)
 +
| style="text-align:center; background:yellow"  | 1)
 +
| style="text-align:center; background:yellow"  | 1)
 +
|-
 +
| 1.4
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
|-
 +
| 1.3
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
|-
 +
| 1.2
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
|-
 +
| 1.1
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
|-
 +
| 1.0
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" |
 +
| style="text-align:center; background:#46a546" | 
 +
| style="text-align:center; background:#46a546" | 
 +
| style="text-align:center; background:#46a546" | 
 +
| style="text-align:center; background:#46a546" | 
 +
|}
  
----
+
1) Xpand Incremental: EMF Compare 2.1 requires EMF 2.8<br>
 +
Xpand UML2 Typesystem: When using EMF UML2 4.x, EMF 2.8 is required
  
=== Features to be implemented ===
+
== More Information  ==
  
* static analysis
+
*[[Xpand/New And Noteworthy]]
 +
*[http://projects.eclipse.org/projects/modeling.m2t.xpand Xpand Project Dashboard]
 +
 
 +
<references />
 +
 
 +
[[Category:Xpand]] [[Category:DSL]] [[Category:M2T]]

Latest revision as of 17:53, 3 November 2014

Under Development

Xpand 2.1.0 is planned for Eclipse Mars simultaneous release (June 2015).

Current Releases

Current releases are available in Xpand download page.

  • Version 2.0.0 was released on 2014/06/25 (Eclipse Luna)
  • Version 1.4.0 was released on 2013/06/26 (Eclipse Kepler)
  • Version 1.3.0 was released on 2013/02/26
  • Version 1.2.0 was released on 2012/06/27 (Eclipse Juno)
  • Version 1.1.0 was released on 2011/06/22 (Eclipse Indigo)
  • Version 1.0.1 was released on 2010/08/25 (Eclipse Helios)

Compatibility

Please note that the Xpand development team does its best to maintain downward compatibility towards Galileo (Eclipse 3.5). Following is the compatibility chart :

Xpand Eclipse 4.3 - EMF 2.9 Eclipse 4.2 - EMF 2.8 Eclipse 3.8 - EMF 2.8 Eclipse 3.7 - EMF 2.7 Eclipse 3.6 - EMF 2.6 Eclipse 3.5 - EMF 2.5
2.0 1) 1) 1)
1.4
1.3
1.2
1.1
1.0

1) Xpand Incremental: EMF Compare 2.1 requires EMF 2.8
Xpand UML2 Typesystem: When using EMF UML2 4.x, EMF 2.8 is required

More Information


Back to the top