Jump to: navigation, search

XQuery Development Tools/Workspace Setup for Dummies

Introduction

This article is meant to give you detailed instructions on how to set up your Workspace in order to build and test XQDT on your machine. The steps described cover setting up minimal dependencies and development environment with Helios Classic. Larger packages will have some of the required features pre-installed.

Install Helios Dependencies

From the menu, choose "Help > Install New Software…"

Pick Helios site and install the following packages:

Collaboration

  • Eclipse EGit (Incubation)

General Purpose Tools

  • Dynamic Languages Toolkit - Core Frameworks
  • Eclipse Plug-In Development Environment

Programming Languages

  • Eclipse Java Development Tools

Web, XML, and Java EE Development

  • Eclipse Faceted Project Framework

Install WebTools Dependencies

From the menu, choose "Help > Install New Software…"

Click Add… to configure a new update site.

Enter Location: http://download.eclipse.org/webtools/repository/helios

Pick the WTP site you just added.

Uncheck 'Group items by category' and install the following package:

  • Eclipse XML Editors and Tools (must be version 3.2.0)

Get XQDT Source from Git

From the menu, choose "File > Import…"

Select Git > Projects from Git

Click Clone… to pull a new local repository.

Enter URI: ssh://git.eclipse.org/gitroot/webtools/org.eclipse.webtools.incubator.git

Enter committer credentials or clone will not be able to push back. [ ? TRUE ? ]

Select xquery-dev branch only, accept defaults after that.

Select the repository you just cloned.

Accept defaults to import existing projects.

At project list, select the following: (don't click Finish yet!)

  • com.google.gson
  • org.antlr.runtime_v31

Now type "org.eclipse.wst.xquery." in the filter box, and click Select All

If you won't be working on feature metadata, you may wish to deselect everything that ends in ".feature" to reduce clutter in your workspace.

Click Finish.

Set Up To Launch XQDT

From the menu, select "Run > Run Configurations…"

Select Eclipse Application

Create a New configuration.

Enter a name.

Select for Run a product: org.eclipse.platform.ide

If you wish to restrict the plugins loaded when testing:

  • Click Plug-ins tab.
  • Select for Launch with: plug-ins selected below only
  • Click Deselect All
  • Check the box next to Workspace
  • Click Add Required Plug-ins
  • Check org.eclipse.ui.ide.application [ ? WHY IS THIS NECESSARY ? ]
  • Click Apply