Difference between revisions of "XQuery Development Tools/Workspace Setup for Dummies"

From Eclipsepedia

Jump to: navigation, search
(Install Eclipse 3.7 (Indigo) Dependencies)
 
(24 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
= Introduction =
 
= Introduction =
This article is meant to give you detailed instructions on how to set up your Workspace in order to build and test XQDT on your machine. We assume that you already have an Eclipse installation that meets the requirements below.
+
This article is meant to give you detailed instructions on how to set up your Workspace in order to build and test XQDT on your machine. The steps described cover setting up minimal dependencies and development environment with Helios Classic.  Larger packages will have some of the required features pre-installed.
  
= Requirements =
+
= Install Eclipse 3.7 (Indigo) Dependencies =
* Eclipse at least 3.4 (Ganymede)
+
* Dynamic Languages Toolkit (DLTK) Core Frameworks SDK, version 1.0
+
** EMF Common
+
** EMF ECore
+
* Faceted Project Framework
+
  
= Installing the requirements =
+
From the menu, choose '''Help''' > '''Install New Software…'''
  
== Eclipse ==
+
Pick the "Indigo - http://download.eclipse.org/releases/indigo" site in the "Work with" drop-down list and install the following packages (if not already installed):
We assume that you already have an Eclipse installation. You can have the latest one from here:
+
[http://www.eclipse.org/downloads/ Eclipse Downloads Page]
+
  
== DLTK ==
+
'''Collaboration'''
In order to have have access also to the DLTK Framework source code you must install, besides the DLTK Core Framewors, also the DLTK Core Frameworks SDK. For this, follow the following steps in Eclipse:
+
* Eclipse EGit
  
* Eclipse 3.5
+
'''General Purpose Tools'''
# Help menu -> Install New Software...
+
* Dynamic Languages Toolkit - Core Frameworks
# Click the "Add" button and in the pop up dialog, add only "http://download.eclipse.org/technology/dltk/updates-dev/1.0" in the "Location" field. Click "OK"
+
* Eclipse Plug-In Development Environment (this is, most probably, already installed)
# In the tree view, expand the "Dynamic Languages Toolkit (DLTK)" node and select: "Dynamic Languages Toolkit - Core Frameworks SDK". This feature includes both the DLTK binaries and the source code of the DLTK Core Frameworks. Click "Next".
+
# On the "Install Details" page, click "Next".
+
# On the "Review Licenses" page, select "I accepts the terms of the license agreements". Note on this page that DLTK will automatically pull its own dependency: "EMF - Eclipse Modeling Framework Core Runtime". Click "Finish" and wait for the installation to complete.
+
# Restart Eclipse when prompted.
+
  
* Eclipse 3.4
+
'''Programming Languages'''
# Help menu -> Software Updates...
+
* Eclipse Java Development Tools (this is, most probably, already installed)
# In the "Available Software" tab, click the "Add Site..." button and in the pop up dialog, add "http://download.eclipse.org/technology/dltk/updates-dev/1.0" in the "Location" field. Click "OK"
+
# In the tree view, expand the newly added site and in the "Dynamic Languages Toolkit (DLTK)" group, select: "Dynamic Languages Toolkit - Core Frameworks SDK". This feature includes both the DLTK binaries and the source code of the DLTK Core Frameworks. Click "Install..." and wait for the install wizard to appear.
+
# On the "Install" page, make sure "Dynamic Languages Toolkit - Core Frameworks SDK" is selected. Click "Next".
+
# On the "Review Licenses" page, select "I accepts the terms of the license agreements". Note on this page that DLTK will automatically pull its own dependency: "EMF - Eclipse Modeling Framework Core Runtime". Click "Finish" and wait for the installation to complete.
+
# Restart Eclipse when prompted.
+
  
== Faceted Project Framework ==
+
'''Web, XML, and Java EE Development'''
The Faceted Project Framework is available from the [http://download.eclipse.org/webtools/downloads/ WebTools Project download site] or from the WebTools update site.
+
* Eclipse Faceted Project Framework
 +
* Eclipse XML Editors and Tools (this will bring down the Structured Source Editor; we are trying to build the new XQuery editor based on this one instead on the DLTK source editor)
  
* Eclipse 3.5 (update site)
+
Finish the installation wizard and restart your Eclipse.
# Help menu -> Install New Software...
+
# Select the "Galileo - http://download.eclipse.org/releases/galileo" update site in the "Work with" drop-down list.
+
# In the tree view, expand the "Web, XML, and Java EE Development" node and select: "Eclipse Faceted Project Framework". Click "Next".
+
# On the "Install Details" page, click "Next".
+
# On the "Review Licenses" page, select "I accepts the terms of the license agreement". Click "Finish" and wait for the installation to complete.
+
# Restart Eclipse when prompted.
+
  
* Eclipse 3.4 or 3.5 (download)
+
One mode dependency:
# Go to the [http://download.eclipse.org/webtools/downloads/ WebTools Project download site]. And click on the latest release. (We tested this with version 3.1.2)
+
# From the "Faceted Project Framework" category, download the "wtp-common-fproj" package. (No SDK or JDT packages are needed)
+
# Unzip the archive in your Eclipse "dropins" directory.
+
  
= Getting the XQDT code =
+
'''ANTLR Runtime 3.2'''
# Open the "New Project" wizard.
+
 
# Select the "Projects from CVS" wizard from the "CVS" category. Click "Next"
+
The current XQuery parser is generated using ANTLR. ANTLR Runtime 3.2 is available through the Eclipse Orbit project. http://download.eclipse.org/tools/orbit/downloads/. Click on the latest release or stable build and on the build information page copy the update URL under "Orbit Build Repository". Use this URL as an update site in Eclipse. Select andt install "ANTLR Runtime" from the "All Orbit Bundles" category. Make sure this is version 3.2.0, otherwise send us a message. Thanks! ;)
# On the next page fill in only the repository location information below and click "Next":
+
 
** Host: dev.eclipse.org
+
= Get XQDT Source from Git =
** Repository path: /cvsroot/webtools
+
 
** User: anonymous
+
* From the menu, choose '''File''' > '''Import…'''
# On the "Select Module" page select the "Use existing module (this will...)" option.
+
* Select '''Git''' > '''Projects from Git'''
# In the tree view navigate to: incubator -> source editing -> plugins.
+
* Click '''Clone…''' to pull a new local repository.
# select the following plugins:
+
* Enter URI: git://git.eclipse.org/gitroot/webtools/org.eclipse.webtools.incubator.git
** com.google.gson
+
* If you are a committer enter your credentials. Thus you will be able to push changes back.
** org.antlr.runtime_v31
+
* Select xquery-dev branch only, accept defaults after that.
** all the plugins starting with "org.eclipse.wst.xquery."
+
* Select the repository you just cloned: '''org.eclipse.webtools.incubator'''
# Click "Next".
+
* Accept the default to '''Import Existing Projects'''.
# On the "Check Out As" page, make sure the "Check out into the workspace as projects" option is selected. Click "Finish".
+
* Click Finish.
 +
* You might wanna create new Working Sets to group the projects (in your Package Explorer you must make sure that '''Working Sets''' is selected in the Package Explorer's '''Top Level Elements''' menu item)
 +
** "XQDT tests" for all projects having the name ending with "test"
 +
** "XQDT features" for all projects having the name ending with "feature"
 +
** "XQDT Zorba" for all projects containing "zorba" in the name
 +
** "XQDT 28msec" for all projects containing "set" in the name
 +
** "XQDT Marklogic" for all projects containing "marklogic" in the name
 +
 
 +
Now your workspace should not have any other errors that:
 +
* Marklogic plugins errors but someone is on it right now.
 +
* "An API baseline has not been set for the current workspace." error is showing up in your problem view. Disable it for now from the '''Preferences''' > '''Plug-in Development''' > '''API Baselines''' by changing the '''Missing API baseline''' option to '''Warning'''
 +
 
 +
If you have other problems than these, send us a message. Thanks!
 +
 
 +
= Set Up To Launch XQDT =
 +
 
 +
From the menu, select '''Run''' > '''Run Configurations…'''
 +
 
 +
Select Eclipse Application
 +
 
 +
Create a New configuration.
 +
 
 +
Enter a name.
 +
 
 +
Select for Run a product: '''org.eclipse.platform.ide'''
 +
 
 +
If you wish to restrict the plugins loaded when testing:
 +
* Click Plug-ins tab.
 +
* Select for Launch with: '''plug-ins selected below only'''
 +
* Click Deselect All
 +
* Add all the plugins that you want to run from the '''Workspace''' category.
 +
* Click Add Required Plug-ins
 +
* Click Apply and Run
 +
 
 +
This should keep you now busy for a while.
 +
 
 +
[[Category:XQuery Development Tools]]

Latest revision as of 07:41, 20 September 2011

Contents

[edit] Introduction

This article is meant to give you detailed instructions on how to set up your Workspace in order to build and test XQDT on your machine. The steps described cover setting up minimal dependencies and development environment with Helios Classic. Larger packages will have some of the required features pre-installed.

[edit] Install Eclipse 3.7 (Indigo) Dependencies

From the menu, choose Help > Install New Software…

Pick the "Indigo - http://download.eclipse.org/releases/indigo" site in the "Work with" drop-down list and install the following packages (if not already installed):

Collaboration

  • Eclipse EGit

General Purpose Tools

  • Dynamic Languages Toolkit - Core Frameworks
  • Eclipse Plug-In Development Environment (this is, most probably, already installed)

Programming Languages

  • Eclipse Java Development Tools (this is, most probably, already installed)

Web, XML, and Java EE Development

  • Eclipse Faceted Project Framework
  • Eclipse XML Editors and Tools (this will bring down the Structured Source Editor; we are trying to build the new XQuery editor based on this one instead on the DLTK source editor)

Finish the installation wizard and restart your Eclipse.

One mode dependency:

ANTLR Runtime 3.2

The current XQuery parser is generated using ANTLR. ANTLR Runtime 3.2 is available through the Eclipse Orbit project. http://download.eclipse.org/tools/orbit/downloads/. Click on the latest release or stable build and on the build information page copy the update URL under "Orbit Build Repository". Use this URL as an update site in Eclipse. Select andt install "ANTLR Runtime" from the "All Orbit Bundles" category. Make sure this is version 3.2.0, otherwise send us a message. Thanks! ;)

[edit] Get XQDT Source from Git

  • From the menu, choose File > Import…
  • Select Git > Projects from Git
  • Click Clone… to pull a new local repository.
  • Enter URI: git://git.eclipse.org/gitroot/webtools/org.eclipse.webtools.incubator.git
  • If you are a committer enter your credentials. Thus you will be able to push changes back.
  • Select xquery-dev branch only, accept defaults after that.
  • Select the repository you just cloned: org.eclipse.webtools.incubator
  • Accept the default to Import Existing Projects.
  • Click Finish.
  • You might wanna create new Working Sets to group the projects (in your Package Explorer you must make sure that Working Sets is selected in the Package Explorer's Top Level Elements menu item)
    • "XQDT tests" for all projects having the name ending with "test"
    • "XQDT features" for all projects having the name ending with "feature"
    • "XQDT Zorba" for all projects containing "zorba" in the name
    • "XQDT 28msec" for all projects containing "set" in the name
    • "XQDT Marklogic" for all projects containing "marklogic" in the name

Now your workspace should not have any other errors that:

  • Marklogic plugins errors but someone is on it right now.
  • "An API baseline has not been set for the current workspace." error is showing up in your problem view. Disable it for now from the Preferences > Plug-in Development > API Baselines by changing the Missing API baseline option to Warning

If you have other problems than these, send us a message. Thanks!

[edit] Set Up To Launch XQDT

From the menu, select Run > Run Configurations…

Select Eclipse Application

Create a New configuration.

Enter a name.

Select for Run a product: org.eclipse.platform.ide

If you wish to restrict the plugins loaded when testing:

  • Click Plug-ins tab.
  • Select for Launch with: plug-ins selected below only
  • Click Deselect All
  • Add all the plugins that you want to run from the Workspace category.
  • Click Add Required Plug-ins
  • Click Apply and Run

This should keep you now busy for a while.