Jump to: navigation, search

Difference between revisions of "XQuery Development Tools/Workspace Setup for Dummies"

Line 57: Line 57:
 
Now type "org.eclipse.wst.xquery." in the filter box, and click Select All
 
Now type "org.eclipse.wst.xquery." in the filter box, and click Select All
  
Now deselect everything that ends in ".feature:" [ ? CORRECT ? ]
+
If you won't be working on feature metadata, you may wish to deselect everything that ends in ".feature" to reduce clutter in your workspace.
  
 
Click Finish.
 
Click Finish.
Line 88: Line 88:
  
 
* Click Apply
 
* Click Apply
 
= PREVIOUS INSTRUCTIONS BELOW =
 
 
= Requirements =
 
* Eclipse at least 3.5 (Galileo) with PDE plug-ins. For example, one of the packages: "Eclipse Classic" or "Eclipse for RCP/Plug-in Developers"
 
** '''NOTE:''' Watch out to download the package to match your platform (32 or 64 bit)
 
* Dynamic Languages Toolkit (DLTK) Core Frameworks SDK, version 1.0
 
** EMF Common
 
** EMF ECore
 
* Faceted Project Framework
 
 
= Installing the requirements =
 
 
== Eclipse ==
 
We assume that you already have an Eclipse installation. You can have the latest one from here:
 
[http://www.eclipse.org/downloads/ Eclipse Downloads Page]
 
 
== DLTK ==
 
In order to have have access also to the DLTK Framework source code you must install, besides the DLTK Core Framewors, also the DLTK Core Frameworks SDK. For this, follow the following steps in Eclipse:
 
 
# Help menu -> Install New Software...
 
# Click the "Add" button and in the pop up dialog, add only "http://download.eclipse.org/technology/dltk/updates-dev/1.0" in the "Location" field. Click "OK"
 
# In the tree view, expand the "Dynamic Languages Toolkit (DLTK)" node and select: "Dynamic Languages Toolkit - Core Frameworks SDK". This feature includes both the DLTK binaries and the source code of the DLTK Core Frameworks. Click "Next".
 
# On the "Install Details" page, click "Next".
 
# On the "Review Licenses" page, select "I accepts the terms of the license agreements". Note on this page that DLTK will automatically pull its own dependency: "EMF - Eclipse Modeling Framework Core Runtime". Click "Finish" and wait for the installation to complete.
 
# Restart Eclipse when prompted.
 
 
== Faceted Project Framework ==
 
The Faceted Project Framework is available from the [http://download.eclipse.org/webtools/downloads/ WebTools Project download site] or from the WebTools update site.
 
 
* Eclipse 3.5 (update site)
 
# Help menu -> Install New Software...
 
# Select the "Galileo - http://download.eclipse.org/releases/galileo" update site in the "Work with" drop-down list.
 
# In the tree view, expand the "Web, XML, and Java EE Development" node and select: "Eclipse Faceted Project Framework". Click "Next".
 
# On the "Install Details" page, click "Next".
 
# On the "Review Licenses" page, select "I accepts the terms of the license agreement". Click "Finish" and wait for the installation to complete.
 
# Restart Eclipse when prompted.
 
 
= Getting the XQDT code =
 
# Open the "New Project" wizard.
 
# Select the "Projects from CVS" wizard from the "CVS" category. Click "Next"
 
# On the next page fill in only the repository location information below and click "Next":
 
## Host: dev.eclipse.org
 
## Repository path: /cvsroot/webtools
 
## User: anonymous
 
# On the "Select Module" page select the "Use existing module (this will...)" option.
 
# In the tree view navigate to: incubator -> source editing -> plugins.
 
# select the following plugins:
 
## com.google.gson
 
## org.antlr.runtime_v31
 
## all the plugins starting with "org.eclipse.wst.xquery."
 
# Click "Next".
 
# On the "Check Out As" page, make sure the "Check out into the workspace as projects" option is selected. Click "Finish".
 
 
= Running XQDT from your Workspace =
 
# Open the "Run/Debug configurations..." Dialog.
 
# Create one new "Eclipse Application".
 
# Change the name of the "New_configuration" to "XQDT".
 
# On the "Plug-ins" tab, select the "plug-ins selected below only" option from the "Launch with" drop-down list.
 
# In the tree view below, from the "Workspace" group, select all the plugins starting with "org.eclipse.wst.xquery.".
 
# Click the "Add Required Plug-ins".
 
# Click "Run"/"Debug"
 
 
 
 
'''HAPPY PROGRAMMING / DEBUGGING !!!'''
 
  
 
[[Category:XQuery Development Tools]]
 
[[Category:XQuery Development Tools]]

Revision as of 12:52, 28 July 2010

Introduction

This article is meant to give you detailed instructions on how to set up your Workspace in order to build and test XQDT on your machine. The steps described cover setting up minimal dependencies and development environment with Helios Classic. Larger packages will have some of the required features pre-installed.

Install Helios Dependencies

From the menu, choose "Help > Install New Software…"

Pick Helios site and install the following packages:

Collaboration

  • Eclipse EGit (Incubation)

General Purpose Tools

  • Dynamic Languages Toolkit - Core Frameworks
  • Eclipse Plug-In Development Environment

Programming Languages

  • Eclipse Java Development Tools

Web, XML, and Java EE Development

  • Eclipse Faceted Project Framework

Install WebTools Dependencies

From the menu, choose "Help > Install New Software…"

Click Add… to configure a new update site.

Enter Location: http://download.eclipse.org/webtools/repository/helios

Pick the WTP site you just added.

Uncheck 'Group items by category' and install the following package:

  • Eclipse XML Editors and Tools (must be version 3.2.0)

Get XQDT Source from Git

From the menu, choose "File > Import…"

Select Git > Projects from Git

Click Clone… to pull a new local repository.

Enter URI: ssh://git.eclipse.org/gitroot/webtools/org.eclipse.webtools.incubator.git

Enter committer credentials or clone will not be able to push back. [ ? TRUE ? ]

Select xquery-dev branch only, accept defaults after that.

Select the repository you just cloned.

Accept defaults to import existing projects.

At project list, select the following: (don't click Finish yet!)

  • com.google.gson
  • org.antlr.runtime_v31

Now type "org.eclipse.wst.xquery." in the filter box, and click Select All

If you won't be working on feature metadata, you may wish to deselect everything that ends in ".feature" to reduce clutter in your workspace.

Click Finish.

Set Up To Launch XQDT

From the menu, select "Run > Run Configurations…"

Select Eclipse Application

Create a New configuration.

Enter a name.

Select for Run a product: org.eclipse.platform.ide

If you wish to restrict the plugins loaded when testing:

  • Click Plug-ins tab.
  • Select for Launch with: plug-ins selected below only
  • Click Deselect All
  • Check the box next to Workspace
  • Click Add Required Plug-ins
  • Check org.eclipse.ui.ide.application [ ? WHY IS THIS NECESSARY ? ]
  • Click Apply