Jump to: navigation, search

Difference between revisions of "WTP Smoke Test Results R320 03042010"

(3/4)
 
(Smoke Test Promotion votes)
 
(22 intermediate revisions by 12 users not shown)
Line 1: Line 1:
== Smoke Test Promotion votes ==
+
== Smoke Test Promotion votes ==
 
+
 
+
{| border="3" cellpadding="5"
+
|+ This Week's Results
+
|Project ||Vote ||Initials Comments
+
  
 +
{| cellpadding="5" border="3"
 +
|+ This Week's Results
 
|-
 
|-
| Java EE
+
| Project
| align="center" | [[Image:Questionmark.gif]]
+
| Vote
|
+
| Initials Comments
 
|-
 
|-
|JSF
+
| Java EE
| align="center" | [[Image:Questionmark.gif]]
+
| align="center" | [[Image:Checkmark.gif]]  
|
+
| kit
 +
J2ee 1.4:<br> 1. verify that there is an ejb-client-jar tag in the ejb-jar.xml deployment descriptor -&gt; there is no such tag<br> 2. EJB interfaces should be in the EJB client project instead of in the EJB project -&gt; All classes are in the EJB project, the EJB Client project is empty<br> Reported as https://bugs.eclipse.org/bugs/show_bug.cgi?id=304813 <br />
 +
(cdb) I won't pass the test, until SAP verifies... but we can't recreate this issue - please look at bug comments <br />
 +
(dw) Based on bug and mailing list comments, I'll mark this as "ok to promote" even though its a bad regression in doclet ejbs that has to be fixed for milestone.
 
|-
 
|-
|Dali
+
| JSF
| align="center" |[[Image:Questionmark.gif]]
+
| align="center" | [[Image:Checkmark.gif]]  
|
+
| [https://bugs.eclipse.org/bugs/show_bug.cgi?id=304867 Bug 304867 - WPE fails to open (throws NPE)] - Verified in build I-3.2.0-20100305211931
 
|-
 
|-
|Server
+
| Dali
| align="center" |[[Image:Questionmark.gif]]
+
| align="center" | [[Image:Checkmark.gif]]
|
+
| njh
 +
|-
 +
| Server  
 +
| align="center" | [[Image:Checkmark.gif]]  
 +
|  
 +
EY
 +
 
 +
Passed with defect:
 +
 
 +
#Error when removing application from the server - https://bugs.eclipse.org/bugs/show_bug.cgi?id=304845
 +
 
 
|-
 
|-
|Web Services, WSDL
+
| Web Services, WSDL  
| align="center" |[[Image:Questionmark.gif]]
+
| align="center" | [[Image:Checkmark.gif]]  
|[[Image:Questionmark.gif]]Web Services
+
| [[Image:Checkmark.gif]]Web Services (rl)
 +
[[Image:Checkmark.gif]]WSDL (rl)
  
[[Image:Questionmark.gif]]WSDL
+
[[Image:Checkmark.gif]]JAXWS (sc)
  
[[Image:Questionmark.gif]]JAXWS
 
 
|-
 
|-
|Source Editing
+
| Source Editing  
| align="center" |[[Image:Questionmark.gif]]
+
| align="center" | [[Image:Fail.gif]]  
|[[Image:Questionmark.gif]]XML + JSP
+
| [[Image:Checkmark.gif]]XML + JSP (ICT)
 +
[[Image:Checkmark.gif]]XSD (rl)
  
[[Image:Questionmark.gif]]XSD
+
[[Image:Fail.gif]]JSDT (cmj) - https://bugs.eclipse.org/bugs/show_bug.cgi?id=304825 - [content assist] No content assist proposals showing up in HTML pages <br />
 +
(ns) I've verified in wtp-I-3.2.0-20100306173837, that JavaScript proposals are being included in HTML pages again. If this is the only thing holding back JSDT's promotion, then I think we can promote it now.
  
[[Image:Questionmark.gif]]JSDT
+
[[Image:Checkmark.gif]]XSL (dac)
  
[[Image:Questionmark.gif]]XSL
 
 
|-
 
|-
|Release Engineering
+
| Release Engineering  
| align="center" |[[Image:Questionmark.gif]]
+
| align="center" | [[Image:Checkmark.gif]]  
|
+
| (dw) Just the expected Junit failures and versioning issues.
 
|}
 
|}
  
 +
<br>
  
 
  Smoke Test ok to promote vote = [[Image:Checkmark.gif]]
 
  Smoke Test ok to promote vote = [[Image:Checkmark.gif]]
Line 51: Line 63:
 
  Smoke Test Pending = [[Image:Questionmark.gif]]
 
  Smoke Test Pending = [[Image:Questionmark.gif]]
  
 +
<br>
  
=====[[WTP Smoke Test Results | Back to the WTP Smoke Test Results Main Page]]=====
+
===== [[WTP Smoke Test Results|Back to the WTP Smoke Test Results Main Page]] =====

Latest revision as of 19:44, 6 March 2010

Smoke Test Promotion votes

This Week's Results
Project Vote Initials Comments
Java EE Checkmark.gif kit

J2ee 1.4:
1. verify that there is an ejb-client-jar tag in the ejb-jar.xml deployment descriptor -> there is no such tag
2. EJB interfaces should be in the EJB client project instead of in the EJB project -> All classes are in the EJB project, the EJB Client project is empty
Reported as https://bugs.eclipse.org/bugs/show_bug.cgi?id=304813
(cdb) I won't pass the test, until SAP verifies... but we can't recreate this issue - please look at bug comments
(dw) Based on bug and mailing list comments, I'll mark this as "ok to promote" even though its a bad regression in doclet ejbs that has to be fixed for milestone.

JSF Checkmark.gif Bug 304867 - WPE fails to open (throws NPE) - Verified in build I-3.2.0-20100305211931
Dali Checkmark.gif njh
Server Checkmark.gif

EY

Passed with defect:

  1. Error when removing application from the server - https://bugs.eclipse.org/bugs/show_bug.cgi?id=304845
Web Services, WSDL Checkmark.gif Checkmark.gifWeb Services (rl)

Checkmark.gifWSDL (rl)

Checkmark.gifJAXWS (sc)

Source Editing Fail.gif Checkmark.gifXML + JSP (ICT)

Checkmark.gifXSD (rl)

Fail.gifJSDT (cmj) - https://bugs.eclipse.org/bugs/show_bug.cgi?id=304825 - [content assist] No content assist proposals showing up in HTML pages
(ns) I've verified in wtp-I-3.2.0-20100306173837, that JavaScript proposals are being included in HTML pages again. If this is the only thing holding back JSDT's promotion, then I think we can promote it now.

Checkmark.gifXSL (dac)

Release Engineering Checkmark.gif (dw) Just the expected Junit failures and versioning issues.


Smoke Test ok to promote vote = Checkmark.gif
Smoke Test do not promote vote = Fail.gif
Smoke Test Pending = Questionmark.gif


Back to the WTP Smoke Test Results Main Page