WTP Compatibility Tests

From Eclipsepedia

Revision as of 15:34, 4 January 2007 by Deboer.ca.ibm.com (Talk | contribs)

Jump to: navigation, search

Web Tools Compatibility Test Information

WTP 1.5 <-> WTP 2.0 Background Information
  • WTP 1.5 -> WTP 2.0
  • Each team should create a test scenario to load projects or artifacts from WTP 1.5 and attempt to load, display, edit, and run them on a WTP 2.0 workspace. The links should be published here.
  • Possible coordinated compatibility JUnit which will run as part of the builds where each team can add 1.5 metadata or projects and methods to exercise their function on WTP 2.0. Java EE team has a current JUnit to be used as an example.
  • Workspace migration testing will mainly consist of a few workspaces with multiple types of content, settings, and a lot of views and perspectives open.
  • Questions remain about what exactly we need to test and we will have to gather feedback from each component team. Be wary of anything written out to settings or extension point changes.
  • WTP 2.0 -> WTP 1.5
  • We should support shared projects in a team environment where one user is on WTP 1.5 and one is on WTP 2.0, so we will need some backwards compatibility testing.


Compatibility Test Table
December 18, 2006
Component Platform(s) Compatibility Test Coverage
ATF
Common
Data Tools
Java EE
JSF
JPA
Server Windows or Linux
  • Create server and one or more projects in WTP 1.5.x. Include a runnable JSP, servlet, or html file.
  • Use Run on Server and make sure the web browser appears.
  • Reopen workspace with WTP 2.0.
  • Make sure the server still appears in the servers view, the project is added to the server.
  • Use Run on Server and make sure it still works.
Web Services Windows XP
  • Create top-down, bottom-up Web service and Web service client with WTP 1.5.2.
  • Open up WTP 1.5.2 workspace with WTP 2.0 driver.
    • Ensure that Web services and Web service client still works.
    • Go through creating top-down/bottom-up Web service and Web service client again on existing projects and ensure that they work.
    • Save WTP 2.0 workspace.
  • Re-open WTP 2.0 workspace in WTP 1.5.2.
    • Ensure that Web services and Web service client still works.
    • Go through creating top-down/bottom-up Web service and Web service client again on existing projects and ensure that they work.
XML and JSP



Back to the Web Tools Project Main Wiki Page