Skip to main content
Jump to: navigation, search

Difference between revisions of "WTP 3.16 (2019-12) - New Help for Old Friends"

m (Reference)
m
Line 15: Line 15:
 
|-
 
|-
 
!Plugin || 3.15 BREE || 3.16 BREE || 3.15 plugin version || 3.16 plugin version  
 
!Plugin || 3.15 BREE || 3.16 BREE || 3.15 plugin version || 3.16 plugin version  
 +
|-
 +
|'''Web Services'''
 
|-
 
|-
 
|org.eclipse.jst.ws.uddiregistry
 
|org.eclipse.jst.ws.uddiregistry
Line 20: Line 22:
 
|JavaSE-1.8
 
|JavaSE-1.8
 
|1.0.650
 
|1.0.650
 +
|1.1.0
 +
|-
 +
|org.eclipse.jst.ws.ui
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.0.650
 +
|1.1.0
 +
|-
 +
|org.eclipse.wst.command.env.core
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.0.350
 +
|1.1.0
 +
|-
 +
|org.eclipse.wst.command.env.ui
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.1.250
 +
|1.2.0
 +
|-
 +
|org.eclipse.wst.ws.parser
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.0.650
 +
|1.1.0
 +
|-
 +
|org.eclipse.wst.ws.ui
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.1.350
 +
|1.2.0
 +
|-
 +
|org.eclipse.wst.wsdl
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.2.550
 +
|1.3.0
 +
|-
 +
|org.eclipse.wst.wsdl.ui
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.2.850
 +
|1.3.0
 +
|-
 +
|org.eclipse.wst.wsdl.validation
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.1.750
 +
|1.2.0
 +
|-
 +
|org.eclipse.wst.wsi
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.0.700
 +
|1.1.0
 +
|-
 +
|org.eclipse.wst.wsi.ui
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.0.650
 +
|1.1.0
 +
|-
 +
|org.eclipse.jst.ws.axis.consumption.core.tests
 +
|J2SE-1.4
 +
|JavaSE-1.8
 +
|1.0.250
 
|1.1.0
 
|1.1.0
 
|-
 
|-

Revision as of 10:44, 31 October 2019

This page collects notes and pointers to changes coming up in the WTP 3.16 (2019-12) release.

This page acts as a central "jumping off" point for those adopters of WTP that are moving up from a previous version of WTP. Most of this information may be already contained in various mailing lists and Bugzilla reports, but it is believed best to have a central place to get people started. Adopters: if you run into trouble or notice things that are not covered here, please update this page and/or let us know (such as by opening a bug, or sending a note to wtp-dev). Web Tools is a Platform and we strive to provide compatible API evolution with clear migration paths, instructions, etc.

One thing we have learned in the past is that some adopters do not move with us to every new release. Some early adopters went from 0.7 directly to 1.5, for example. Unfortunately, it is difficult to present the information in that way, covering multiple changes across multiple version ranges, so those types of migrations have to read about migrating to each version.

Note: as these notes develop and grow in number, they may occasionally be re-organized into categories, etc.

New, Noteworthy, or Interesting Changes

Modifications to Bundle-RequiredExecutionEnvironment and Minor bundle version numbers

Bundle-RequireExecutionEnvironment changes between WTP 3.15 and 3.16
Plugin 3.15 BREE 3.16 BREE 3.15 plugin version 3.16 plugin version
Web Services
org.eclipse.jst.ws.uddiregistry J2SE-1.4 JavaSE-1.8 1.0.650 1.1.0
org.eclipse.jst.ws.ui J2SE-1.4 JavaSE-1.8 1.0.650 1.1.0
org.eclipse.wst.command.env.core J2SE-1.4 JavaSE-1.8 1.0.350 1.1.0
org.eclipse.wst.command.env.ui J2SE-1.4 JavaSE-1.8 1.1.250 1.2.0
org.eclipse.wst.ws.parser J2SE-1.4 JavaSE-1.8 1.0.650 1.1.0
org.eclipse.wst.ws.ui J2SE-1.4 JavaSE-1.8 1.1.350 1.2.0
org.eclipse.wst.wsdl J2SE-1.4 JavaSE-1.8 1.2.550 1.3.0
org.eclipse.wst.wsdl.ui J2SE-1.4 JavaSE-1.8 1.2.850 1.3.0
org.eclipse.wst.wsdl.validation J2SE-1.4 JavaSE-1.8 1.1.750 1.2.0
org.eclipse.wst.wsi J2SE-1.4 JavaSE-1.8 1.0.700 1.1.0
org.eclipse.wst.wsi.ui J2SE-1.4 JavaSE-1.8 1.0.650 1.1.0
org.eclipse.jst.ws.axis.consumption.core.tests J2SE-1.4 JavaSE-1.8 1.0.250 1.1.0

See also WTP Releng BREEs.

Reference

This document covers ONLY changes between WTP 3.15 and WTP 3.16. See the the category overview for other releases.

Back to the top