Skip to main content
Jump to: navigation, search

Difference between revisions of "Visualizing Output with ICE"

(VisIt)
(Plot Toolbar)
 
(55 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
Currently, ICE features three plugins for visualizing and plotting simulation output data:
 
Currently, ICE features three plugins for visualizing and plotting simulation output data:
  
* '''VisIt Tools''' - An interactive 3-D visualization tool for rendering meshes, scalar plots, contour plots, and more.
+
* '''VisIt Tools''' An interactive 3-D visualization tool for rendering meshes, scalar plots, contour plots, and more.
  
* '''ParaView Tools''' - Another interactive 3-D visualization tool offered as an alternative to VisIt.
+
* '''ParaView Tools''' Another interactive 3-D visualization tool offered as an alternative to VisIt.
  
* '''CSV Plotting Tools''' - A customizable 2-D data plotting utility for <tt>.csv</tt> data files.
+
* '''CSV Plotting Tools''' A customizable 2-D data plotting utility for comma-separated value (CSV or <tt>.csv</tt>) data files.
 
+
[[File:ICE_VisIt.png|400px|ICE's VisIt tool for 3D visualzation]]
+
[[File:ICE_CSVPlotter.png|434px|ICE's CSV plotter for 2D graphing]]
+
  
 
== Prerequisites ==
 
== Prerequisites ==
Line 14: Line 11:
 
To use the VisIt tools, ICE requires the installation of Lawrence Livermore National Laboratory's [https://wci.llnl.gov/simulation/computer-codes/visit/ VisIt] software (version '''2.8.2''' to '''2.9.2''') either locally or on a remote machine.
 
To use the VisIt tools, ICE requires the installation of Lawrence Livermore National Laboratory's [https://wci.llnl.gov/simulation/computer-codes/visit/ VisIt] software (version '''2.8.2''' to '''2.9.2''') either locally or on a remote machine.
  
There are currently two ways to interact with VisIt through ICE.
+
The VisIt website also offers [https://wci.llnl.gov/simulation/computer-codes/visit/datafiles example data files] that you can use to familiarize yourself with the VisIt tools.
#Using the "[[#Project_Explorer_.28Option_1.29|Project Explorer]]" (Novice) is an easier task and does not require the user to manually connect to VisIt in each session.
+
#Using the "[[#Project_Explorer_.28Option_1.29|Visualization Perspective]]" (Advanced) requires more work but enables the user to send Python commands to the VisIt client.
+
 
+
The VisIt website offers [https://wci.llnl.gov/simulation/computer-codes/visit/datafiles example data files] that you can use to familiarize yourself with the VisIt tools.
+
  
 
===ParaView===
 
===ParaView===
Using the ParaView tools requires an installation of [http://www.paraview.org/download/ ParaView] (version 5.0 or newer) on a Linux or Mac OS X machine.
+
Using the ParaView tools requires an installation of Kitware's [http://www.paraview.org/download/ ParaView] (version '''5.0''' or newer).
  
The "[[#Project_Explorer_.28Option_1.29|Project Explorer]]" allows a user to configure and launch a ParaView session through ICE. There is currently no mechanism for launching ParaView in the "Visualization Perspective."
+
The user will also need to acquire the ParaView server script (<tt>http_pvw_server.py</tt>) by contacting the [https://www.eclipse.org/ice/#contact-us ICE development team].
  
 
===CSV Plotting Tools===
 
===CSV Plotting Tools===
The CSV plotting tools are built into ICE and require no additional software to be installed.
+
The comma-separated value (CSV) plotting tools are built into ICE and require no additional software to be installed.
 
+
----
The "[[#Visualization_Perspective_.28Option_2.29|Visualization Perspective]]" allows a user to configure and launch a visualization session using <tt>.csv</tt> data files. There is currently no mechanism for launching a visualization using <tt>.csv</tt> data files in the "Project Explorer."
+
 
+
== Visualizing Output ==
+
 
+
=== Using the Project Explorer (Option 1) ===
+
  
Although not as feature rich as the "Visualization Perspective," using and configuring the "Project Explorer" view for VisIt and ParaView makes the process easier for a novice user.
+
== Configuring Project Explorer ==
 +
ICE's "Project Explorer" view allows the user to import data files and launch a visualization session. Currently, ICE supports VisIt, ParaView, and <tt>.csv</tt> data files. VisIt and ParaView applications are called directly from ICE, and the <tt>.csv</tt> visualization engine is built into ICE with no need for third-party software.
  
==== Adding the Data File ====
+
=== Opening the Project Explorer View ===
The data file must first be placed in the "Project Explorer." This view lists files imported into ICE. To access the "Project Explorer," use the the main menu bar at the top of the window and navigate to:
+
Within ICE, the user will need to have the "Project Explorer" view open. If this view is not yet part of your workflow, use the the main menu bar at the top of the window and navigate to:
  
 
''Window'' > ''Show View'' > ''Other''
 
''Window'' > ''Show View'' > ''Other''
Line 47: Line 36:
 
[[File:Show_view_project_explorer_stc.png]]
 
[[File:Show_view_project_explorer_stc.png]]
  
By default, the "Project Explorer" should automatically import the &nbsp;<tt>ICEFiles/default</tt>&nbsp;  and &nbsp;<tt>ICEFiles/itemDB</tt>&nbsp; folders. If it does not, or if you want to import a different folder into ICE, right click in the "Project Explorer" view and select ''Import...'' from the context menu.
+
=== Creating a Project ===
 +
The next step is to create a project in which the visualization data files will reside. If you have an existing project into which you would like to import data files, you can skip this step.
  
In the resulting "Import" dialog, select ''General'' > ''File System'' from the tree and then click the ''Next'' button.
+
First, right click in the white space of the "Project Explorer" view pane.
  
[[file:Import_view_visit_stc.png]]
+
In the resulting context menu, select: ''New'' > ''Project''.
  
From the resulting "File System" dialog, you can then select directories and/or files to import into the "Project Explorer."
+
[[File:Right_click_new_project_ICE_stc.png]]
  
In this example, we're loading a 3-D silo from VisIt's library of examples into "Project 1."
+
This will present the user with the "New Project" wizard. For this tutorial we're going to select ''General'' > ''Project'' and then click the ''Next'' button.
  
[[File:ProjectExplorerImportFilesDialog_ICE.png]]
+
[[File:Create_project_one_stc.png]]
  
For <tt>.csv</tt> files, you can simply double click their listing in the "Project Explorer" view to open them.  
+
In the next screen of the wizard, create a project name ("Project 1" in this case). You can also choose where to place the project files if you do not want them in the default ICE location.
  
Similarly, VisIt and ParaView files can be opened by double clicking, but you must first establish a connection to VisIt or ParaView.
+
When you've added your project name and are satisfied with the project path, click ''Finish''.
 +
 
 +
[[File:Create_project_two_stc.png]]
 +
 
 +
Your new project should now appear in the "Project Explorer."
 +
 
 +
[[File:select_project_ICE_stc.png]]
 +
 
 +
=== Adding the Data File ===
 +
<!-- New way -->
 +
The latest versions of ICE make adding the data file to your project a very simple affair.
 +
 
 +
First, within the "Project Explorer" view, select the project that you would like to associate with the file you are about to import. In this example, we're looking at "Project 1."
 +
 
 +
[[File:Select_project_ICE_stc.png]]
 +
 
 +
Next, simply click the ''Import'' button in ICE's main toolbar.
 +
 
 +
[[File:Import_file_ICE_stc.png]]
 +
 
 +
This will present a file import dialog where the user can navigate to the desired data file. Once found, select the file, and click ''Open.''
 +
 
 +
If needed, you can also select and import multiple files at once.
 +
 
 +
[[File:Import_dialog_ICE_stc.png]]
 +
 
 +
The data file should now appear in the "Project Explorer" view, nested under your project (e.g., "Project 1").
 +
 
 +
[[File:Data_file_in_project_ICE_stc.png]]
 +
 
 +
The visualizations for these data files are launched directly from the "Project Explorer" view. For <tt>.csv</tt> files, you can simply double click their listing in the "Project Explorer" view to open them.
 +
 
 +
Similarly, VisIt and ParaView files can be opened by double clicking, but you must first establish a connection to the [[#Configuring_the_VisIt_Connection|VisIt]] or [[#Configuring_the_ParaView_Connection|ParaView]] application.  
 
<br />
 
<br />
 
<br />
 
<br />
 +
----
 +
 +
== Visualizing Output ==
 +
Currently, ICE features three plugins for visualizing and plotting simulation output data: VisIt Tools, ParaView Tools, and CSV Plotting Tools. All three plugins, and their implementation within ICE, are described below.
  
 +
=== VisIt Tools ===
 
==== Configuring the VisIt Connection ====
 
==== Configuring the VisIt Connection ====
  
Line 82: Line 109:
 
** On a '''Windows''' machine with VisIt installed in the default location, the path would be:
 
** On a '''Windows''' machine with VisIt installed in the default location, the path would be:
 
*** <tt>C:\Users\[UserName]\AppData\Local\Programs\LLNL\VisIt 2.9.2\</tt>
 
*** <tt>C:\Users\[UserName]\AppData\Local\Programs\LLNL\VisIt 2.9.2\</tt>
**On a '''Linux''' machine, the path will be based on where you extracted the &nbsp;<tt>visit2_9_2.linux-x86</tt>&nbsp; folder, ending with &nbsp;<tt>~/visit2_9_2.linux-x86_64/bin</tt>. For example, if unzipped to the desktop, it would be:
+
**On a '''Linux''' machine, the path will be based on where you extracted the &nbsp;<tt>visit2_9_2.linux-x86</tt>&nbsp; folder, ending with &nbsp;<tt>~/visit2_9_2.linux-x86_64/bin</tt>. For example, if extracted to the desktop, it would be:
 
***<tt>/home/[UserName]/Desktop/visit2_9_2.linux-x86_64/bin/</tt>
 
***<tt>/home/[UserName]/Desktop/visit2_9_2.linux-x86_64/bin/</tt>
 
**On '''Mac OS X''', VisIt should be installed in the machine's "Applications" directory, unless otherwise specified by the user.
 
**On '''Mac OS X''', VisIt should be installed in the machine's "Applications" directory, unless otherwise specified by the user.
Line 92: Line 119:
  
 
If you are connecting to a remote host, you may be prompted to "allow" the connection to the remote host. Click ''Yes'' to trust the connection, and enter the credentials for the remote machine in the prompt.
 
If you are connecting to a remote host, you may be prompted to "allow" the connection to the remote host. Click ''Yes'' to trust the connection, and enter the credentials for the remote machine in the prompt.
 +
 +
==== VisIt Plot Editor ====
 +
 +
Once a connection with VisIt has been established, the "Plot Editor" view will appear and display the contents of the file that was imported into "Project 1." This view allows the user to manipulate the visualization just as they would with the VisIt GUI.
 +
 +
If at any point you should close the "Plot Editor," simply double click on the imported file to redraw the visualization.
 +
 +
[[File:Visit_visualizer_ICE_stc.png]]
 +
 +
A VisIt plot editor will allow you to choose the mesh and scalar to be modeled and to choose the model's representation. These editors also feature a slider at the bottom, allowing the user to interact with time data.
 +
 +
[[File:TimeSliderWidget_ICE.png]]
 +
 +
The arrow buttons move to the previous or next time step, and the triangle button enables the "Plot Editor" to play the simulation automatically. The last button on the right displays playback options.
 +
 +
The visualization's current time step is also displayed, and you can manually drag the slider along the timeline to choose a specific time step to display.
 +
 +
==== Executing Python Commands ====
 +
 +
While many of VisIt's features are already accessible in ICE, work to enable a more robust feature set is ongoing. In the meantime, features not yet integrated into ICE can still be accessed via Python commands by clicking the Python script button located in the "Plot Editor."
 +
 +
[[File:ICE_VisItPythonScriptButton.png]]
 +
 +
Writing Python scripts for VisIt is beyond the scope of this tutorial. However, you are welcome to refer to the [https://wci.llnl.gov/simulation/computer-codes/visit/manuals VisIt Python Interface Manual] provided by the VisIt development team at Lawrence Livermore National Laboratory.
 
<br />
 
<br />
 
<br />
 
<br />
  
 +
=== ParaView Tools ===
 
==== Configuring the ParaView Connection ====
 
==== Configuring the ParaView Connection ====
  
Line 106: Line 158:
 
[[File:Add_para_connection_stc.png]]
 
[[File:Add_para_connection_stc.png]]
  
The default values supplied automatically by ICE should be fine for most users. However, some fields may need to be changed to accommodate a user's configuration, and you can click on each cell to edit the parameter.
+
ICE automatically supplies some, but not all, parameters when adding a ParaView connection (e.g., the user will need to specify their <tt>http_pvw_server.py</tt> path). Below is a list of parameters required (unless otherwise noted) for full ParaView functionality in a given configuration.
 +
 
 +
{{note|The user will also need to acquire the ParaView server script (<tt>http_pvw_server.py</tt>) by contacting the [https://www.eclipse.org/ice/#contact-us ICE development team].}}
  
 
* '''Host:''' The default value for this field is "localhost," which is used for connecting to a local installation of ParaView on a user's machine; keep this setting if you are running ParaView on the same machine as the ICE framework. To launch a remote ParaView connection, the remote hostname/address should be entered into this field.
 
* '''Host:''' The default value for this field is "localhost," which is used for connecting to a local installation of ParaView on a user's machine; keep this setting if you are running ParaView on the same machine as the ICE framework. To launch a remote ParaView connection, the remote hostname/address should be entered into this field.
Line 116: Line 170:
 
**On '''Mac OS X''', ParaView's executable should be installed in the machine's "Applications" directory, unless otherwise specified by the user. Therefore, the path would simply be:
 
**On '''Mac OS X''', ParaView's executable should be installed in the machine's "Applications" directory, unless otherwise specified by the user. Therefore, the path would simply be:
 
***<tt>/Applications/</tt>
 
***<tt>/Applications/</tt>
*'''Server Script Path:''' The full path to the &nbsp;<tt>http_pvw_server.py</tt>&nbsp; file, ending with the folder containing it. For example, if the file is on your desktop, the path might be (for Linux): <tt>/home/[UserName]/Desktop/</tt>.
+
*'''Server Script Path:''' The full path to the &nbsp;<tt>http_pvw_server.py</tt>&nbsp; file, ending with the folder containing it. For example, if the file is on your desktop, the path might be:
*'''Visualizer Port:''' Port number for the ParaView web visualizer. The default number (9601) should work but can be changed if needed. If changed, it must differ from the ParaView port number (9600).
+
**'''Windows:''' <tt>C:\Users\[UserName]\Desktop\</tt>
 +
**'''Linux:''' <tt>/home/[UserName]/Desktop/</tt>
 +
**'''Mac OS X:''' <tt>/Users/[UserName]/Desktop/</tt>
 +
*'''Port:''' The default port number for ParaView is 9600. However, if you are using both VisIt and ParaView within ICE, this value should differ for each application, and this number needs to be changed to avoid connection errors (e.g., from 9600 to 9603 for ParaView).
 +
*'''Web Visualizer Port:''' The default port number for the ParaView web visualizer is 9601. If changed, it must differ from the ParaView (and VisIt) port number.
 
*'''Remote OS:''' The operating system of the remote machine on which ParaView will be launched. If you are launching ParaView on your local machine, ignore this cell.
 
*'''Remote OS:''' The operating system of the remote machine on which ParaView will be launched. If you are launching ParaView on your local machine, ignore this cell.
 
*'''Remote ParaView Version Number:''' The version of ParaView you are using. This may be ignored unless you are launching a remote ParaView session on a Linux machine. You can check your installation's version number by looking inside the top level &nbsp;<tt>lib</tt>&nbsp; directory. The &nbsp;<tt>lib</tt>&nbsp; directory should contain a folder named &nbsp;<tt>paraview-</tt>&nbsp; followed by the version number.
 
*'''Remote ParaView Version Number:''' The version of ParaView you are using. This may be ignored unless you are launching a remote ParaView session on a Linux machine. You can check your installation's version number by looking inside the top level &nbsp;<tt>lib</tt>&nbsp; directory. The &nbsp;<tt>lib</tt>&nbsp; directory should contain a folder named &nbsp;<tt>paraview-</tt>&nbsp; followed by the version number.
  
Once finished, click ''Apply'', and then click ''OK''. ICE will open ParaView and connect to it.
+
Once finished, click ''Apply'', and then click ''OK''. ICE will then launch a ParaView session.
  
 
[[File:Para_connection_apply_stc.png]]
 
[[File:Para_connection_apply_stc.png]]
Line 129: Line 187:
 
<br />
 
<br />
  
==== Plot Editors ====
+
==== ParaView Plot Editor ====
  
Once a connection with VisIt or ParaView has been established, the "Plot Editor" view will appear and display the contents of the file that was imported into "Project 1." This view allows the user to manipulate the visualization just as they would with the VisIt or ParaView GUI.
+
Once a connection with ParaView has been established, the "Plot Editor" view will appear and display the contents of the file that was imported into "Project 1." This view allows the user to manipulate the visualization just as they would with the ParaView GUI.
 
+
For <tt>.csv</tt> files, right clicking or using the ''Select series...'' button in the upper left of the "Plot Editor" pane allows the user to add or remove data series from the graph.
+
  
 
If at any point you should close the "Plot Editor," simply double click on the imported file to redraw the visualization.
 
If at any point you should close the "Plot Editor," simply double click on the imported file to redraw the visualization.
Line 139: Line 195:
 
[[File:Visit_visualizer_ICE_stc.png]]
 
[[File:Visit_visualizer_ICE_stc.png]]
  
Similarly, a VisIt and ParaView plot editor will allow you to choose the mesh and scalar to model and the model's representation. These editors also feature a slider at the bottom, allowing the user to interact with time data.
+
A ParaView plot editor will allow you to choose the mesh and scalar to be modeled and to choose the model's representation. These editors also feature a slider at the bottom, allowing the user to interact with time data.
  
 
[[File:TimeSliderWidget_ICE.png]]
 
[[File:TimeSliderWidget_ICE.png]]
  
The arrow buttons move to the previous or next time step, and the triangle button causes the Plot Editor to play the simulation automatically. The final button displays playback options. The current time is displayed, and you can manually drag the slider along the timeline to choose a specific time step to display.  
+
The arrow buttons move to the previous or next time step, and the triangle button enables the "Plot Editor" to play the simulation automatically. The last button on the right displays playback options.
  
The ParaView plot editor will also have a ''Launch in Web Visualizer'' button to open the file in ParaView's Web Visualizer inside of ICE. The full functionality of the Web Visualizer is beyond the scope of this article, but interested readers can learn more from the [http://www.paraview.org/ParaView3/Doc/Nightly/www/js-doc/index.html#!/guide/web_visualizer official documentation.]
+
The visualization's current time step is also displayed, and you can manually drag the slider along the timeline to choose a specific time step to display.  
  
=== Using the Visualization Perspective (Option 2) ===
+
The ParaView plot editor also has a ''Launch in Web Visualizer'' button to open the file in ParaView's Web Visualizer inside of ICE. The full functionality of the Web Visualizer is beyond the scope of this article, but interested readers can learn more from the [http://www.paraview.org/ParaView3/Doc/Nightly/www/js-doc/index.html#!/guide/web_visualizer official documentation.]
 +
<br />
 +
<br />
 +
=== CSV Plot Tools ===
  
Using the "Visualization Perspective" (Option 2) gives the user more control over their visualization within ICE. To access the "Visualization Perspective," which includes various UI components necessary for visualization that are not exposed in the default ICE perspective, use the the main menu bar at the top of the window and navigate to:
+
Unlike VisIt and ParaView, no connection configuration is necessary for launching a CSV visualization session. Out of the box, ICE includes basic CSV data-plotting utilities for fast and easy x, y graph visualizations. This section describes how to open your <tt>.csv</tt> data files from the "Project Explorer" and render them in the "Plot Editor."
  
''Window'' > ''Open Perspective'' > ''Other''...
+
First, add your <tt>.csv</tt> data file to the "Project Explorer" (see [[#Adding_the_Data_File|Adding the Data File]]) using the ''Import'' button in the ICE toolbar.
  
In the resulting dialog window, select ''Visualization'' and click ''OK''.
+
{{note|ICE's CSV "Plot Editor" can only open ''local'' files.}}
  
[[File:Perspective_dialog_ICE_stc.png]]
+
Next, double click the newly-imported <tt>.csv</tt> file as it appears in your "Project Explorer" (<tt>fib8v.csv</tt> in this example) to render the visualization in the "Plot Editor."
  
Alternatively, you can also access the same pop-up dialog by clicking the ''Open Perspective'' button (stylized as a "+") in  the upper right-hand corner of the ICE workbench.
+
[[File:Csv_plotted_ICE_stc.png]]
  
[[File:ICE_OpenPerspective.png]]
+
The user can also edit the <tt>.csv</tt> within ICE by clicking on the ''Data'' tab in the "Plot Editor" view.
  
Once the "Visualization Perspective" opens, you should notice the workbench contains some new UI components. Make note of the panels highlighted below, as this tutorial will refer to them in the following sections.
+
[[File:Csv_data_tab_ICE_stc.png]]
  
[[File:ICE_VisualizationPerspective.png]]
+
{{note|The CSV "Plot Editor" requires data to be in an [''m'' × ''n''] format, meaning that files that contain rows with empty values cannot be plotted. Furthermore, the first row is expected to include column headers—the variable names—while each subsequent row should include the numerical data in columns.}}
  
==== VisIt in the Visualization Perspective ====
+
==== Selecting a Series ====
  
Once the "Visualization Perspective" has loaded, the first step is to connect to the VisIt installation (local or remote) through ICE. To do this, click on the ''Launch VisIt'' button in the top-left of the ICE toolbar.
+
By default, the first series in the file will be used as the independent variable (used to determine the x-axis values of all points), and the second series is graphed as a dependent variable. Both can be changed.
 
+
[[File:ICE_VisItLaunchButton.png]]
+
 
+
This action will prompt a dialog that offers three options for connecting to VisIt.
+
 
+
[[File:ICE_VisItLaunchOptions.png]]
+
 
+
The connection dialog gives the user three options: (1) launch VisIt locally, (2) Launch VisIt remotely, and (3) connect to an existing VisIt session.
+
 
+
===== Launch VisIt Locally =====
+
If you installed VisIt on your local machine, use the ''Browse'' button to direct ICE to your local installation directory. Using this method will launch a new VisIt session. Optionally, you can also set a port number (default 9600) and—if you want to share your VisIt session with another user—a password.
+
* '''Path:''' The path to VisIt should end with the folder containing the VisIt executable.
+
** On a '''Windows''' machine with VisIt installed in the default location, the path would be:
+
*** <tt>C:\Users\[UserName]\AppData\Local\Programs\LLNL\VisIt 2.9.2\</tt>
+
**On a '''Linux''' machine, the path will be based on where you extracted the contents of the &nbsp;<tt>visit2_9_2.linux-x86_64</tt>&nbsp; archive, ending with &nbsp;<tt>~/visit2_9_2.linux-x86_64/bin</tt>. For example, if unzipped to the desktop, it would be:
+
***<tt>/home/[UserName]/Desktop/visit2_9_2.linux-x86_64/bin/</tt>
+
**On '''Mac OS X''', VisIt should be installed in the machine's "Applications" directory, unless otherwise specified by the user.
+
***<tt>/Applications/VisIt.app/Contents/Resources/bin/</tt>
+
 
+
===== Launch VisIt Remotely =====
+
If you installed VisIt on a remote machine, specify the hostname and full path to the VisIt installation directory. Using this method will launch a new VisIt session. Optionally, you can specify a port number (default 9600) and—if you want to share your VisIt session with another user—a password. If you need or want to use an external gateway or proxy to access the remote VisIt installation, you may also specify its URL and port number.
+
 
<br />
 
<br />
 
<br />
 
<br />
 +
===== Changing the Independent Variable =====
 +
To set the independent (variable) series, right click in the ''Plot Editor'' and select ''Set independent series...''
  
===== Connect to Existing VisIt Session =====
+
[[File:Csv_plot_viewer_context_menu_ICE_stc.png]]
If you would like to connect to a VisIt session already running somewhere else, specify the hostname, port number, and password as they are set on the VisIt session; you will need to obtain this information from the person who initially configured the VisIt session. If you need or want to use an external gateway or proxy to access the remote VisIt installation, you may also specify its URL and port number.
+
  
{{tip|If you need to find the VisIt installation in Windows, find a shortcut to VisIt either on your desktop or in the start menu. Right-click the shortcut and open its ''Properties''. The path to the VisIt executable's directory will be shown next to ''Target''.}}
+
In the resulting dialog, make your selection, and click ''OK''.
 
+
Regardless of which method you choose to connect to VisIt, enter a ''Connection name'' at the bottom of the dialog. This will allow you to re-use this connection information in the future.
+
 
+
If you are connecting to an existing session, specify a ''Window ID'' between 1 and 16. Which ''Window ID'' you use depends on how you would like to connect to VisIt. If multiple users connect using the same ''Window ID'', they will all see and be able to interact with the same VisIt view. However, if you would like multiple users to each have their own unique session—each with its own controls—assign a unique ''Window ID'' to each user. The VisIt installation can support up to 16 unique window IDs at a time.
+
 
+
Once you are done configuring the connection to VisIt, click the ''Finish'' button at the bottom. If configured correctly, ICE will then initiate a connection to VisIt.
+
 
+
===== Adding/Removing Files =====
+
 
+
To open a file, find the green "+" icon in the ''Visualization File Viewer''. Clicking directly on the green "+" icon will prompt a local file browser to pop up. However, if your file is located on a remote machine, or if you would like to add a file set, click on the drop-down button next to the green "+" icon.
+
 
+
[[File:ICE_VisItAddFileButton.png]]
+
 
+
This will offer you four ways to open file(s):
+
* Open a local file
+
* Open a remote file
+
* Open a local file set
+
* Open a local SILO set
+
Once you have selected your file(s), they should appear in the ''Visualization File Viewer''.
+
 
+
Lastly, if you would like to remove a file from the ''Visualization File Viewer'' list, select it, and click the red "X" button.
+
{{warning|When using the VisIt utilities, you currently cannot open ''local'' files with ''remote'' VisIt sessions or ''remote'' files with ''local'' VisIt sessions.}}
+
 
+
===== Adding/Removing Plots =====
+
 
+
To begin adding plots, select your file in the ''Visualization File Viewer'' and click the green "+" icon in the ''VisIt Plot Viewer''.
+
 
+
[[File:ICE_VisItAddPlotButton.png]]
+
 
+
If there is any plottable data in your file, a dialog will pop up with a list of options to choose from. This can include mesh plots, scalar plots, vector plots, material block plots, and so forth. If there are multiple plots of each type available, you can select them all by checking off the entire category, or expand it to check off only selected plots.
+
 
+
[[File:ICE_VisItPlotSelection.png]]
+
 
+
When you are done selecting your plot(s), click ''OK''. The selected plots should be added to the list in the ''VisIt Plot Viewer''.
+
 
+
Lastly, if you would like to remove a plot from the ''VisIt Plot Viewer'' list, select it and click the red "X" button.
+
 
+
===== Rendering Plots =====
+
 
+
To render a plot, ''double'' click it in the ''VisIt Plot Viewer'', and it will appear in the main ''VisIt Editor''.
+
 
+
The ''VisIt Plot Viewer'' contains a drop-down menu with a list of plotting styles available for the currently selected plot. Depending on your selected plot, this can include mesh, pseudo-color, contour, volume, and so forth. Use this drop-down menu to select the plotting style you prefer, and the ''VisIt Editor'' will update in real time.
+
 
+
[[File:ICE_VisItPlotStyleMenu.png]]
+
 
+
The ''VisIt Editor'' is also interactive in that you can move your plot around by clicking and dragging the canvas or zoom by using the mouse wheel. This may not necessarily be useful for 2D plots but enables a fully rotatable look at 3D plots as in the example below.
+
 
+
[[File:ICE_VisIt3DNoise.png|625px|]]
+
 
+
Lastly, if there is any time series data associated to your plot, you can manually walk through the time steps, or play them continuously as a short video, using the playback buttons located in the ''VisIt Plot Viewer''.
+
 
+
[[File:ICE_VisItPlaybackButtons.png]]
+
 
+
===== Executing Python Commands =====
+
 
+
While many of VisIt's features are already accessible in ICE, work to enable a more robust feature set is on-going. In the meantime, features not yet integrated into ICE can still be accessed via Python commands by clicking the Python script button located in the ''VisIt Plot Viewer''.
+
 
+
[[File:ICE_VisItPythonScriptButton.png]]
+
 
+
Writing Python scripts for VisIt is beyond the scope of this tutorial. However, you are welcome to refer to the [https://wci.llnl.gov/simulation/computer-codes/visit/manuals VisIt Python Interface Manual] provided by the VisIt development team at Lawrence Livermore National Laboratory.
+
 
+
==== CSV Plot Viewer in the Visualization Perspective ====
+
 
+
ICE includes, out of the box, basic CSV data plotting utilities for fast and easy x/y graph visualizations. This section describes how to open your CSV data using the ''Plot Editor'' in the ''[[#Visualization Perspective|Visualization Perspective]]''.
+
 
<br />
 
<br />
 
<br />
 
<br />
===== Adding/Removing Files =====
+
===== Changing the Graphed Series =====
 +
There are two ways to select the graphed series.
  
To open a file, find the green "+" icon in the ''Visualization File Viewer''. Clicking directly on the green "+" icon will prompt a local file browser to pop up. You can also access this option by clicking on the drop-down button next to the green "+" icon.
+
'''1. Graph a single series, removing all others.''' Click the ''Select series...'' button in the upper left corner.
  
[[File:ICE_VisItAddFileButton.png]]
+
[[File:Select_series_button_ICE_stc.png]]
  
This will offer you four ways to open file(s):
+
Choose which series to graph by making the appropriate selection in the resulting dialog window. Click ''OK''.
* Open a local file
+
* Open a remote file
+
* Open a local file set
+
* Open a local SILO set
+
  
{{note|ICE's ''CSV Plot Viewer'' can only open ''local'' files, so when opening CSV files for plotting, you need only  click the green "+" button to select and add local files.}}
+
'''2. Graph multiple series.''' Right click in the ''Plot Editor'', then click ''Select series...'' within the resulting context menu.  
  
Once you have selected your file(s), they should appear in the ''Visualization File Viewer''.
+
[[File:Csv_plot_viewer_context_menu_ICE_stc.png]]
  
Lastly, if you would like to remove a file from the ''Visualization File Viewer'' list, select it, and click the red "X" button.
+
Choose which series to graph by selecting the appropriate check boxes in the resulting dialog window. After making a selection, click ''OK''.
  
Alternatively, you may open .csv files directly through the Project Explorer. This may be done by clicking ''Window -> Show View -> Other...'' and selecting ''Project Explorer''. Within the Project Explorer, right click and click ''Import...''
+
You can also remove all graphed series by right clicking in the "Plot Editor" and choosing ''Remove all series''.
 
+
[[File:ICE_CSV_Plot_Editor_Import_File1.png]]
+
 
+
In the pop-up window, select ''General -> File System'' as shown above, then click next
+
 
+
[[File:ICE_CSV_Plot_Editor_Import_File2.png]]
+
 
+
Select the directory housing the data you wish to visualize in the ''From Directory'' field, then select which sub-directories and/or files you wish to import in the two boxes below it. Select the folder to import the files into in the ''Into folder'' field and click ''Next''. The files will appear within the selected folder in the ''Project Explorer'', and can be opened by double clicking them or right clicking and selecting ''Open With -> PlotEditor''.
+
 
+
{{note|The ''CSV Plot Viewer'' requires data to be in an [''m'' x ''n''] format, meaning that files that contain rows with empty values cannot be plotted. Furthermore, the first row is expected to include column headers—the variable names—while each subsequent row should include the numerical data in columns.}}
+
 
<br />
 
<br />
 
<br />
 
<br />
===== Selecting Series =====
+
==== Plot Toolbar ====
  
By default, the first series in the file will be used as the independent variable while the second is graphed as a dependent variable. These can both be changed.
+
The plotting widget used by ICE's CSV "Plot Editor" includes a toolbar with helpful utilities for navigating your plotted data or customizing the plot's appearance. You can hover over each button with your cursor to view a tool tip describing what each button does.
 
+
To set the independent series, which is used to determine the x-axis values of all points, right click in the ''Plot Editor'' and select ''Set independent series...'', which will open a new window. Select the series you want and click the ''OK'' button.
+
 
+
There are two ways to select the graphed series. The ''Select series...'' button in the upper left corner will allow you to select a single series to graph, removing all others. You may graph multiple series by right clicking in the ''Plot Editor'' and clicking ''Select series...''. You may then choose which series to graph by clicking the check boxes in the new window and clicking the ''OK'' button. Finally, you may remove all graphed series by right clicking and choosing ''Remove all series''.
+
<br />
+
<br />
+
===== Plot Toolbar =====
+
  
The plotting widget used by ICE's ''CSV Plot Editor'' includes a toolbar with helpful utilities for navigating your plotted data or customizing the plot's appearance. You can hover the mouse cursor over each button to view a tool tip describing what the button does.
+
[[File:Csv_toolbar_ICE_stc.png]]
  
Clicking the first button will open a dialog that allows you to customize the appearance of the plot or individual series on the plot, including titles, scales, grids, colors, and fonts. The last button allows you to save the current appearance of the plot to a <tt>.png</tt> image file. Feel free to try out the different utilities available in this toolbar.
+
Clicking the first button will open a dialog that allows you to customize the appearance of the plot or individual series on the plot—including titles, scales, grids, colors, and fonts. The last button allows you to save the current plot as a <tt>.png</tt> image file. Feel free to try out the different utilities available in this toolbar.

Latest revision as of 10:29, 1 February 2017

Currently, ICE features three plugins for visualizing and plotting simulation output data:

  • VisIt Tools – An interactive 3-D visualization tool for rendering meshes, scalar plots, contour plots, and more.
  • ParaView Tools – Another interactive 3-D visualization tool offered as an alternative to VisIt.
  • CSV Plotting Tools – A customizable 2-D data plotting utility for comma-separated value (CSV or .csv) data files.

Prerequisites

VisIt

To use the VisIt tools, ICE requires the installation of Lawrence Livermore National Laboratory's VisIt software (version 2.8.2 to 2.9.2) either locally or on a remote machine.

The VisIt website also offers example data files that you can use to familiarize yourself with the VisIt tools.

ParaView

Using the ParaView tools requires an installation of Kitware's ParaView (version 5.0 or newer).

The user will also need to acquire the ParaView server script (http_pvw_server.py) by contacting the ICE development team.

CSV Plotting Tools

The comma-separated value (CSV) plotting tools are built into ICE and require no additional software to be installed.


Configuring Project Explorer

ICE's "Project Explorer" view allows the user to import data files and launch a visualization session. Currently, ICE supports VisIt, ParaView, and .csv data files. VisIt and ParaView applications are called directly from ICE, and the .csv visualization engine is built into ICE with no need for third-party software.

Opening the Project Explorer View

Within ICE, the user will need to have the "Project Explorer" view open. If this view is not yet part of your workflow, use the the main menu bar at the top of the window and navigate to:

Window > Show View > Other

In the resulting "Show View" dialog, select:

General > Project Explorer and click OK.

Show view project explorer stc.png

Creating a Project

The next step is to create a project in which the visualization data files will reside. If you have an existing project into which you would like to import data files, you can skip this step.

First, right click in the white space of the "Project Explorer" view pane.

In the resulting context menu, select: New > Project.

Right click new project ICE stc.png

This will present the user with the "New Project" wizard. For this tutorial we're going to select General > Project and then click the Next button.

Create project one stc.png

In the next screen of the wizard, create a project name ("Project 1" in this case). You can also choose where to place the project files if you do not want them in the default ICE location.

When you've added your project name and are satisfied with the project path, click Finish.

Create project two stc.png

Your new project should now appear in the "Project Explorer."

Select project ICE stc.png

Adding the Data File

The latest versions of ICE make adding the data file to your project a very simple affair.

First, within the "Project Explorer" view, select the project that you would like to associate with the file you are about to import. In this example, we're looking at "Project 1."

Select project ICE stc.png

Next, simply click the Import button in ICE's main toolbar.

Import file ICE stc.png

This will present a file import dialog where the user can navigate to the desired data file. Once found, select the file, and click Open.

If needed, you can also select and import multiple files at once.

Import dialog ICE stc.png

The data file should now appear in the "Project Explorer" view, nested under your project (e.g., "Project 1").

Data file in project ICE stc.png

The visualizations for these data files are launched directly from the "Project Explorer" view. For .csv files, you can simply double click their listing in the "Project Explorer" view to open them.

Similarly, VisIt and ParaView files can be opened by double clicking, but you must first establish a connection to the VisIt or ParaView application.


Visualizing Output

Currently, ICE features three plugins for visualizing and plotting simulation output data: VisIt Tools, ParaView Tools, and CSV Plotting Tools. All three plugins, and their implementation within ICE, are described below.

VisIt Tools

Configuring the VisIt Connection

Creating a default VisIt connection will enable ICE to automatically connect to VisIt at launch. To start:

  • Windows or Linux: in ICE's toolbar, select Window > Preferences, then Visualization > VisIt in the tree of the "Preferences" page.
  • Mac OS X: in ICE's toolbar, select ICE > Preferences, then Visualization > VisIt in the tree of the "Preferences" page.

Press the new row button (stylized as a "+" symbol) in the upper-right corner of the resulting dialog box.

VisItPreferencePage ICE.png

The default values supplied automatically by ICE should be fine for most users. However, two fields may need to be changed to accommodate a user's configuration, and you can click on each cell to edit the parameter.

  • Host: The default value for this field is "localhost," which is used for connecting to a local installation of VisIt on a user's machine. To launch a remote VisIt connection, the remote hostname/address should be entered into this field.
  • Path: If correctly installed, the VisIt path should populate in ICE by default. If not, the user should add the full path to the local VisIt installation. The path should end with the folder containing the VisIt executable.
    • On a Windows machine with VisIt installed in the default location, the path would be:
      • C:\Users\[UserName]\AppData\Local\Programs\LLNL\VisIt 2.9.2\
    • On a Linux machine, the path will be based on where you extracted the  visit2_9_2.linux-x86  folder, ending with  ~/visit2_9_2.linux-x86_64/bin. For example, if extracted to the desktop, it would be:
      • /home/[UserName]/Desktop/visit2_9_2.linux-x86_64/bin/
    • On Mac OS X, VisIt should be installed in the machine's "Applications" directory, unless otherwise specified by the user.
      • /Applications/VisIt.app/Contents/Resources/bin/

Once finished, press Apply, then OK. ICE will then open VisIt and connect to it.

Visit connection apply stc.png

If you are connecting to a remote host, you may be prompted to "allow" the connection to the remote host. Click Yes to trust the connection, and enter the credentials for the remote machine in the prompt.

VisIt Plot Editor

Once a connection with VisIt has been established, the "Plot Editor" view will appear and display the contents of the file that was imported into "Project 1." This view allows the user to manipulate the visualization just as they would with the VisIt GUI.

If at any point you should close the "Plot Editor," simply double click on the imported file to redraw the visualization.

Visit visualizer ICE stc.png

A VisIt plot editor will allow you to choose the mesh and scalar to be modeled and to choose the model's representation. These editors also feature a slider at the bottom, allowing the user to interact with time data.

TimeSliderWidget ICE.png

The arrow buttons move to the previous or next time step, and the triangle button enables the "Plot Editor" to play the simulation automatically. The last button on the right displays playback options.

The visualization's current time step is also displayed, and you can manually drag the slider along the timeline to choose a specific time step to display.

Executing Python Commands

While many of VisIt's features are already accessible in ICE, work to enable a more robust feature set is ongoing. In the meantime, features not yet integrated into ICE can still be accessed via Python commands by clicking the Python script button located in the "Plot Editor."

ICE VisItPythonScriptButton.png

Writing Python scripts for VisIt is beyond the scope of this tutorial. However, you are welcome to refer to the VisIt Python Interface Manual provided by the VisIt development team at Lawrence Livermore National Laboratory.

ParaView Tools

Configuring the ParaView Connection

As with VisIt, creating a default ParaView connection will enable ICE to automatically connect to ParaView at launch. To start:

  • Windows or Linux: in ICE's toolbar, select Window > Preferences, then Visualization > ParaView in the tree of the "Preferences" page.
  • Mac OS X: in ICE's toolbar, select ICE > Preferences, then Visualization > ParaView in the tree of the "Preferences" page.

Press the new row button (stylized as a "+" symbol) in the upper-right corner of the resulting dialog box.

Add para connection stc.png

ICE automatically supplies some, but not all, parameters when adding a ParaView connection (e.g., the user will need to specify their http_pvw_server.py path). Below is a list of parameters required (unless otherwise noted) for full ParaView functionality in a given configuration.

Note.png
The user will also need to acquire the ParaView server script (http_pvw_server.py) by contacting the ICE development team.


  • Host: The default value for this field is "localhost," which is used for connecting to a local installation of ParaView on a user's machine; keep this setting if you are running ParaView on the same machine as the ICE framework. To launch a remote ParaView connection, the remote hostname/address should be entered into this field.
  • Path: If correctly installed, the ParaView path should populate in ICE by default. If not, the user should add the full path to the local ParaView installation. The path should end with the folder containing the ParaView executable.
    • On a Windows machine, the path will be based on where you extracted the contents of the  ParaView-5.2.0-Qt4-OpenGL2-Windows-64bit.zip  archive. For example, if you unzipped to the desktop without renaming the archive, the path would be:
      • C:\Users\[UserName]\Desktop\ParaView-5.2.0-Qt4-OpenGL2-Windows-64bit\
    • On a Linux machine, the path will be based on where you extracted the contents of the  ParaView-5.2.0-Qt4-OpenGL2-MPI-Linux-64bit.tar.gz  archive. For example, if you unzipped to the desktop without renaming the archive, the path would be:
      • /home/[UserName]/Desktop/ParaView-5.2.0-Qt4-OpenGL2-MPI-Linux-64bit/
    • On Mac OS X, ParaView's executable should be installed in the machine's "Applications" directory, unless otherwise specified by the user. Therefore, the path would simply be:
      • /Applications/
  • Server Script Path: The full path to the  http_pvw_server.py  file, ending with the folder containing it. For example, if the file is on your desktop, the path might be:
    • Windows: C:\Users\[UserName]\Desktop\
    • Linux: /home/[UserName]/Desktop/
    • Mac OS X: /Users/[UserName]/Desktop/
  • Port: The default port number for ParaView is 9600. However, if you are using both VisIt and ParaView within ICE, this value should differ for each application, and this number needs to be changed to avoid connection errors (e.g., from 9600 to 9603 for ParaView).
  • Web Visualizer Port: The default port number for the ParaView web visualizer is 9601. If changed, it must differ from the ParaView (and VisIt) port number.
  • Remote OS: The operating system of the remote machine on which ParaView will be launched. If you are launching ParaView on your local machine, ignore this cell.
  • Remote ParaView Version Number: The version of ParaView you are using. This may be ignored unless you are launching a remote ParaView session on a Linux machine. You can check your installation's version number by looking inside the top level  lib  directory. The  lib  directory should contain a folder named  paraview-  followed by the version number.

Once finished, click Apply, and then click OK. ICE will then launch a ParaView session.

Para connection apply stc.png

If you are connecting to a remote host, you may be prompted to "allow" the connection to the remote host. Click Yes to trust the connection, and enter the credentials for the remote machine in the prompt.

ParaView Plot Editor

Once a connection with ParaView has been established, the "Plot Editor" view will appear and display the contents of the file that was imported into "Project 1." This view allows the user to manipulate the visualization just as they would with the ParaView GUI.

If at any point you should close the "Plot Editor," simply double click on the imported file to redraw the visualization.

Visit visualizer ICE stc.png

A ParaView plot editor will allow you to choose the mesh and scalar to be modeled and to choose the model's representation. These editors also feature a slider at the bottom, allowing the user to interact with time data.

TimeSliderWidget ICE.png

The arrow buttons move to the previous or next time step, and the triangle button enables the "Plot Editor" to play the simulation automatically. The last button on the right displays playback options.

The visualization's current time step is also displayed, and you can manually drag the slider along the timeline to choose a specific time step to display.

The ParaView plot editor also has a Launch in Web Visualizer button to open the file in ParaView's Web Visualizer inside of ICE. The full functionality of the Web Visualizer is beyond the scope of this article, but interested readers can learn more from the official documentation.

CSV Plot Tools

Unlike VisIt and ParaView, no connection configuration is necessary for launching a CSV visualization session. Out of the box, ICE includes basic CSV data-plotting utilities for fast and easy x, y graph visualizations. This section describes how to open your .csv data files from the "Project Explorer" and render them in the "Plot Editor."

First, add your .csv data file to the "Project Explorer" (see Adding the Data File) using the Import button in the ICE toolbar.

Note.png
ICE's CSV "Plot Editor" can only open local files.


Next, double click the newly-imported .csv file as it appears in your "Project Explorer" (fib8v.csv in this example) to render the visualization in the "Plot Editor."

Csv plotted ICE stc.png

The user can also edit the .csv within ICE by clicking on the Data tab in the "Plot Editor" view.

Csv data tab ICE stc.png

Note.png
The CSV "Plot Editor" requires data to be in an [m × n] format, meaning that files that contain rows with empty values cannot be plotted. Furthermore, the first row is expected to include column headers—the variable names—while each subsequent row should include the numerical data in columns.


Selecting a Series

By default, the first series in the file will be used as the independent variable (used to determine the x-axis values of all points), and the second series is graphed as a dependent variable. Both can be changed.

Changing the Independent Variable

To set the independent (variable) series, right click in the Plot Editor and select Set independent series...

Csv plot viewer context menu ICE stc.png

In the resulting dialog, make your selection, and click OK.

Changing the Graphed Series

There are two ways to select the graphed series.

1. Graph a single series, removing all others. Click the Select series... button in the upper left corner.

Select series button ICE stc.png

Choose which series to graph by making the appropriate selection in the resulting dialog window. Click OK.

2. Graph multiple series. Right click in the Plot Editor, then click Select series... within the resulting context menu.

Csv plot viewer context menu ICE stc.png

Choose which series to graph by selecting the appropriate check boxes in the resulting dialog window. After making a selection, click OK.

You can also remove all graphed series by right clicking in the "Plot Editor" and choosing Remove all series.

Plot Toolbar

The plotting widget used by ICE's CSV "Plot Editor" includes a toolbar with helpful utilities for navigating your plotted data or customizing the plot's appearance. You can hover over each button with your cursor to view a tool tip describing what each button does.

Csv toolbar ICE stc.png

Clicking the first button will open a dialog that allows you to customize the appearance of the plot or individual series on the plot—including titles, scales, grids, colors, and fonts. The last button allows you to save the current plot as a .png image file. Feel free to try out the different utilities available in this toolbar.

Back to the top