Jump to: navigation, search

Difference between revisions of "Visual Editor Project"

(See Also)
 
(19 intermediate revisions by 9 users not shown)
Line 1: Line 1:
The Eclipse Visual Editor project is a platform for creating GUI builders within Eclipse. The project currently provides support for [http://en.wikipedia.org/wiki/WYSIWYG WYSIWYG] editing of Swing/AWT and [[SWT]]/[[RCP]] user interfaces.
+
=== '''The Visual Editor project has been archived and is no longer active. The '''[http://www.eclipse.org/windowbuilder/ '''WindowBuilder''']''' project is the current tool for "visual" WYSIWIG editing of AWT/Swing, SWT/JFace, and GWT user interfaces in Eclipse.'''  ===
  
== Supported Platforms ==
+
----
The Visual Editor is currently supported on the following platforms:
+
* Win32 - Swing/AWT, SWT
+
* Linux
+
** GTK2/x86 - Swing/AWT, SWT
+
** GTK2/x86_64 - Swing/AWT, SWT
+
** GTK2/ppc - Swing/AWT, SWT
+
** Motif - Swing/AWT
+
* Mac OS X 10.4 - Swing, SWT
+
  
SWT development requires Java 1.4.2 or later.
+
The Eclipse Visual Editor project is a platform for creating GUI builders within Eclipse. The project currently provides support for [http://en.wikipedia.org/wiki/WYSIWYG WYSIWYG] editing of Swing/AWT and [[SWT]]/[[RCP]] user interfaces.  
  
== Release History ==
+
NOTE: Current official builds of the Visual Editor require [http://archive.eclipse.org/eclipse/downloads/drops/R-3.2.2-200702121330/index.php Eclipse 3.2 (Callisto)].
  
* [http://download.eclipse.org/tools/ve/downloads/drops/R-1.2.2_jem-200610271615/index.html 1.2.2_jem] ('''Current Release''') - Fri, 27 Oct 2006
+
== Supported Platforms  ==
* [http://download.eclipse.org/tools/ve/downloads/drops/R-1.2.1-200609261748/index.html 1.2.1] - Tue, 26 Sep 2006
+
* [http://download.eclipse.org/tools/ve/downloads/drops/R-1.2-200606280938/index.html 1.2] - Wed, 28 Jun 2006
+
* [http://download.eclipse.org/tools/ve/downloads/drops/R-1.1.0.1-200509071822/index.html 1.1.0.1] - Wed, 7 Sep 2005
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-1.1-200507221721/index.html 1.1] - Fri, 22 Jul 2005
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0.2.2-200506291842/index.html 1.0.2.2] - Wed, 29 Jun 2005
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0.2.1-200503171200/index.html 1.0.2.1] - Thu, 17 Mar 2005
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0.2-200412091401/index.html 1.0.2] - Thu, 9 Dec 2004
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0.1.1-200410221351/index.html 1.0.1.1] - Fri, 22 Oct 2004
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0-200409191449/index.html 1.0] - Sun, 19 Sep 2004
+
* [http://archive.eclipse.org/tools/ve/downloads/drops/R-0.5.0-200312051712/index.html 0.5.0] - Fri, 5 Dec 2003
+
  
== See Also ==
+
The Visual Editor is currently supported on the following platforms:
  
* [http://www.eclipse.org/vep/ Visual Editor Project website]
+
*Win32 - Swing/AWT, SWT
* [http://www.eclipse.org/vep/WebContent/docs/v1.2/plan/vep-plan-1.2.html VE 1.2 Development Plan]
+
*Linux
* [[SWT | Standard Widget Toolkit]]
+
**GTK2/x86 - Swing/AWT, SWT
* [http://www.eclipse.org/rcp/ Rich Client Platform]
+
**GTK2/x86_64 - Swing/AWT, SWT
* [http://java.sun.com/docs/books/tutorial/uiswing/TOC.html Sun's Swing Tutorial]
+
**GTK2/ppc - Swing/AWT, SWT
 +
**Motif - Swing/AWT
 +
*Mac OS X 10.4 - Swing, SWT
 +
 
 +
SWT development requires Java 1.4.2 or later.
 +
 
 +
== Development Resources  ==
 +
 
 +
*[https://bugs.eclipse.org/bugs/buglist.cgi?bug_file_loc=;bug_file_loc_type=allwordssubstr;bug_id=;bug_status=UNCONFIRMED;bug_status=NEW;bug_status=ASSIGNED;bug_status=REOPENED;bugidtype=include;chfieldfrom=;chfieldto=Now;chfieldvalue=;classification=Tools;email1=;email2=;emailtype1=substring;emailtype2=substring;field0-0-0=noop;keywords=;keywords_type=allwords;longdesc=;longdesc_type=allwordssubstr;product=VE;query_format=advanced;short_desc=;short_desc_type=allwordssubstr;status_whiteboard=;status_whiteboard_type=allwordssubstr;type0-0-0=noop;value0-0-0=;votes=;query_based_on=;columnlist=bug_severity%2Cpriority%2Cop_sys%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Ctarget_milestone%2Cstatus_whiteboard Open Bugs]
 +
 
 +
*'''[[VE/Update|How To Install VE 1.4 for Eclipse 3.4 Ganymede / Eclipse 3.5 Galileo]]''' ''(subject to change, '''unsupported''')''
 +
*[[VE/Installing|How To Install VE 1.3 for Eclipse 3.3 Europa / Eclipse 3.4 Ganymede]] ''(subject to change, '''unsupported''')''
 +
*[[VE/Roadmap|Roadmap for the VE 1.3 Release]]
 +
*[[VE/Documentation|VE Documentation]]
 +
 
 +
== Release History  ==
 +
 
 +
*[http://www.eclipse.org/vep/downloads/?showAll=1&hlbuild=R200909301124&project=ve#R200909301124 1.4.0] - 30 Sep 2009 (requires Eclipse 3.4/3.5)
 +
*[http://download.eclipse.org/tools/ve/downloads/drops/R-1.2.3_jem-200701301117/ 1.2.3_jem] - 30 Jan 2007 (requires Eclipse 3.2)
 +
*[http://download.eclipse.org/tools/ve/downloads/drops/R-1.2.1-200609261748/ 1.2.1] - 26 Sep 2006
 +
*[http://download.eclipse.org/tools/ve/downloads/drops/R-1.1.0.1-200509071822/ 1.1.0.1] - 7 Sep 2005
 +
*[http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0.2.2-200506291842/ 1.0.2.2] - 29 Jun 2005
 +
*[http://archive.eclipse.org/tools/ve/downloads/drops/R-1.0.1.1-200410221351/ 1.0.1.1] - 22 Oct 2004
 +
*[http://archive.eclipse.org/tools/ve/downloads/drops/R-0.5.0-200312051712/ 0.5.0] - 5 Dec 2003
 +
 
 +
== See Also  ==
 +
 
 +
*[http://www.eclipse.org/vep/ Visual Editor Project website]  
 +
*[http://www.eclipse.org/vep/WebContent/docs/v1.2/plan/vep-plan-1.2.html VE 1.2 Development Plan]  
 +
*[[SWT|Standard Widget Toolkit]]  
 +
*[http://www.eclipse.org/rcp/ Rich Client Platform]  
 +
*[http://java.sun.com/docs/books/tutorial/uiswing/TOC.html Sun's Swing Tutorial]
 +
 
 +
[[Category:VE]]

Latest revision as of 23:21, 17 April 2012

The Visual Editor project has been archived and is no longer active. The WindowBuilder project is the current tool for "visual" WYSIWIG editing of AWT/Swing, SWT/JFace, and GWT user interfaces in Eclipse.


The Eclipse Visual Editor project is a platform for creating GUI builders within Eclipse. The project currently provides support for WYSIWYG editing of Swing/AWT and SWT/RCP user interfaces.

NOTE: Current official builds of the Visual Editor require Eclipse 3.2 (Callisto).

Supported Platforms

The Visual Editor is currently supported on the following platforms:

  • Win32 - Swing/AWT, SWT
  • Linux
    • GTK2/x86 - Swing/AWT, SWT
    • GTK2/x86_64 - Swing/AWT, SWT
    • GTK2/ppc - Swing/AWT, SWT
    • Motif - Swing/AWT
  • Mac OS X 10.4 - Swing, SWT

SWT development requires Java 1.4.2 or later.

Development Resources

Release History

See Also