Difference between revisions of "Virgo/Community/Migrating from 3.5.x to 3.6.0"

From Eclipsepedia

Jump to: navigation, search
(New page: = Support for Java 7 with a Limitation = Virgo 3.6.0 supports Java 7 (see [https://bugs.eclipse.org/bugs/show_bug.cgi?id=382710 bug 382710]), but there is a known performance problem with ...)
 
Line 1: Line 1:
 
= Support for Java 7 with a Limitation =
 
= Support for Java 7 with a Limitation =
Virgo 3.6.0 supports Java 7 (see [https://bugs.eclipse.org/bugs/show_bug.cgi?id=382710 bug 382710]), but there is a known performance problem with the Spring framework on JDK 1.7.0_06 or newer (see [https://jira.springsource.org/browse/SPR-9781 SPR-9781]). This will be fixed in Spring 3.2 and once Virgo supports Spring 3.1 ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=357102 bug 357102]) it should be possible for users to upgrade to Spring 3.2 as described in the [http://wiki.eclipse.org/Virgo/FAQ#How_can_I_change_the_version_of_Spring_framework_in_the_user_region.3F FAQ].
+
Virgo 3.6.0 supports Java 7 (see [https://bugs.eclipse.org/bugs/show_bug.cgi?id=382710 bug 382710]), but there is a known performance problem with the Spring framework on JDK 1.7.0_06 or newer (see [https://jira.springsource.org/browse/SPR-9781 SPR-9781]). This will be fixed in Spring 3.2 and, given that Virgo 3.6.0 supports Spring 3.1 ([https://bugs.eclipse.org/bugs/show_bug.cgi?id=357102 bug 357102]), it should be possible for users to upgrade to Spring 3.2 as described in the [http://wiki.eclipse.org/Virgo/FAQ#How_can_I_change_the_version_of_Spring_framework_in_the_user_region.3F FAQ].

Revision as of 11:06, 8 November 2012

Support for Java 7 with a Limitation

Virgo 3.6.0 supports Java 7 (see bug 382710), but there is a known performance problem with the Spring framework on JDK 1.7.0_06 or newer (see SPR-9781). This will be fixed in Spring 3.2 and, given that Virgo 3.6.0 supports Spring 3.1 (bug 357102), it should be possible for users to upgrade to Spring 3.2 as described in the FAQ.