Jump to: navigation, search

Difference between revisions of "VE/Update"

< VE
Line 1: Line 1:
<blockquote><table style="border: 1px red dashed; padding:10px"><tr><td>'''''There are currently no scheduled builds VE builds at Eclipse.org. Instead, [http://www.soyatec.com Soyatec Web services] provides this <b style="color:orange">temporary</b> [http://update.soyatec.org/Ganymede/ve/1.4 VE 1.4 Update Site]. Nothing on this page is officially supported and is subject to change without notice. If you see an error or omission, please feel free to [http://wiki.eclipse.org/index.php?title=VE/Update&action=edit edit it].<br/><br/>Please contact [mailto:ve-dev@eclipse.org ve-dev@eclipse.org] if you'd like to help this project.'''''</td></tr></table></blockquote>
 
 
<blockquote><table style="border: 1px red dashed; padding:10px"><tr><td>'''''If installing from the provided [http://update.soyatec.org/Ganymede/ve/1.4 VE 1.4 Update Site] you get an error message like <b style="color:red">No repository found at http://www.soyatec.org/update</b> then you can manually installed the plugin downloading from [http://update.soyatec.org/Ganymede/org.eclipse.ve_1.4.0.v20080528.zip VE 1.4.0 archive for manual install].'''''</td></tr></table></blockquote>
 
  
 
==Install VE 1.4 from Update Manager ==
 
==Install VE 1.4 from Update Manager ==
Line 13: Line 10:
 
* VE 1.4 requires [[EMF/EMF_2.3/JVM_Requirements|EMF 2.4]], which requires [[IRC_FAQ#I_just_installed_Eclipse_on_Linux.2C_but_it_does_not_start._What_is_the_problem.3F|JDK 5.0]] or later.
 
* VE 1.4 requires [[EMF/EMF_2.3/JVM_Requirements|EMF 2.4]], which requires [[IRC_FAQ#I_just_installed_Eclipse_on_Linux.2C_but_it_does_not_start._What_is_the_problem.3F|JDK 5.0]] or later.
  
* [[Image:Update-site.png|thumb]] Start eclipse, then start the Install Manager.
+
* Start eclipse, then start the Install Manager.
 
{{codeblock|
 
{{codeblock|
 
  Help > Software Updates... > Available Software
 
  Help > Software Updates... > Available Software
   Add Site... > ''add the VE 1.4 Update site: http://update.soyatec.org/Ganymede/ve/1.4''
+
   Add Site... > ''add the VE 1.4 Update site: http://download.eclipse.org/tools/ve/updates/1.4''
 
}}
 
}}
  
* [[Image:Soyatec-ve.png|thumb]] Expand the VE site, select "Visual Editor", and hit "Install..."
+
*Expand the VE site, select "Visual Editor" or "Visual Editor SDK" (if you want sources), and hit "Install..."
 
+
After restarting Eclipse, launch <code>Help > About Eclipse SDK</code>. You should find the following VE plugins.
+
 
+
[[Image:Ve-plugins.png]]
+
 
+
-----
+
 
+
Author: Yves YANG (yves.yang@soyatec.com) - VE Committer
+
  
 +
After restarting Eclipse, launch <code>Help > About Eclipse > Plug-in Details</code>. You should find the following VE plugins.
  
 
[[Category:VE]]
 
[[Category:VE]]

Revision as of 15:44, 5 May 2009

Install VE 1.4 from Update Manager

  • Download and install one of the following standard Eclipse 3.4 Ganymede distributions for Java development:
- "Eclipse IDE for Java EE Developers"
- "Eclipse IDE for Java Developers"
- "Eclipse for RCP/Plug-in Developers"
- "Eclipse IDE for Java and Report Developers"
  • Start eclipse, then start the Install Manager.
Help > Software Updates... > Available Software
  Add Site... > add the VE 1.4 Update site: http://download.eclipse.org/tools/ve/updates/1.4
  • Expand the VE site, select "Visual Editor" or "Visual Editor SDK" (if you want sources), and hit "Install..."

After restarting Eclipse, launch Help > About Eclipse > Plug-in Details. You should find the following VE plugins.