Jump to: navigation, search

Difference between revisions of "VE/Installing"

< VE
(Wikifi)
Line 1: Line 1:
 
Step by step installation of VE. Please edit me and add the steps.  Thank!
 
Step by step installation of VE. Please edit me and add the steps.  Thank!
  
 +
'''Contributed by Chris Dolan:'''
  
Contributed by Chris Dolan:
+
I got it to work once I figured out the JEM stuff.  In the end, these are the steps that worked for me.
  
I got it to work once I figured out the JEM stuff.  In the end, these are the steps that worked for me.  Note: these are likely not the minimal steps, just one working solution.
+
Note: These are likely not the minimal steps, just one working solution.
  
 
+
#Fully uninstall any old version of VE or JEM (not just disable)
1) Fully uninstall any old version of VE or JEM (not just disable)
+
#via the Europa update site, install prerequisites for WTP:
 
+
#*org.eclipse.datatools
2) via the Europa update site, install prerequisites for WTP:
+
#*org.eclipse.wst
 
+
#*org.eclipse.jst
2a) org.eclipse.datatools
+
#*org.eclipse.jpt
 
+
#Install the 3.0M1 milestone release of WTP SDK, which is the authoritative source of JEM 2.0.0:
2b) org.eclipse.wst
+
##Go to http://download.eclipse.org/webtools/downloads/
 
+
##Click the 3.0M1 build
2c) org.eclipse.jst
+
##Download the wtp-sdk zip
 
+
##Unpack the .zip file somewhere
2d) org.eclipse.jpt
+
##In that extracted folder, there is an "eclipse" subdir
 
+
##In that subdir, create a file called ".eclipseextension"
3) Install the 3.0M1 milestone release of WTP SDK, which is the authoritative source of JEM 2.0.0:
+
##In eclipse, go to Help > Software Updates > Manage Configuration
 
+
##Click "Add an Extension Location"
3a) Go to http://download.eclipse.org/webtools/downloads/
+
##Select the WTP "eclipse" subdir from above
 
+
#Install the build of VE:
3b) Click the 3.0M1 build
+
##Go to http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855
 
+
##Click "Visual Editor patched as in bug 202562"
3c) Download the wtp-sdk zip
+
##Click org.eclipse.visualeditor-1.3.0.200709121813.zip
 
+
##Unpack the .zip file somewhere
3d) Unpack the .zip file somewhere
+
##In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir
 
+
##Rename that subdir to "eclipse"
3e) In that extracted folder, there is an "eclipse" subdir
+
##In that "eclipse" subdir, create a file called ".eclipseextension"
 
+
##In eclipse, go to Help > Software Updates > Manage Configuration
3f) In that subdir, create a file called ".eclipseextension"
+
##Click "Add an Extension Location"
 
+
##Select the VE "eclipse" subdir from above
3h) In eclipse, go to Help > Software Updates > Manage Configuration
+
 
+
3i) Click "Add an Extension Location"
+
 
+
3j) Select the WTP "eclipse" subdir from above
+
 
+
4) Install the build of VE:
+
 
+
4a) Go to http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855
+
 
+
4b) Click "Visual Editor patched as in bug 202562"
+
 
+
4c) Click org.eclipse.visualeditor-1.3.0.200709121813.zip
+
 
+
4d) Unpack the .zip file somewhere
+
 
+
4e) In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir
+
 
+
4f) Rename that subdir to "eclipse"
+
 
+
4g) In that "eclipse" subdir, create a file called ".eclipseextension"
+
 
+
 
+
4i) In eclipse, go to Help > Software Updates > Manage Configuration
+
 
+
4j) Click "Add an Extension Location"
+
 
+
4k) Select the VE "eclipse" subdir from above
+

Revision as of 19:39, 26 September 2007

Step by step installation of VE. Please edit me and add the steps. Thank!

Contributed by Chris Dolan:

I got it to work once I figured out the JEM stuff. In the end, these are the steps that worked for me.

Note: These are likely not the minimal steps, just one working solution.

  1. Fully uninstall any old version of VE or JEM (not just disable)
  2. via the Europa update site, install prerequisites for WTP:
    • org.eclipse.datatools
    • org.eclipse.wst
    • org.eclipse.jst
    • org.eclipse.jpt
  3. Install the 3.0M1 milestone release of WTP SDK, which is the authoritative source of JEM 2.0.0:
    1. Go to http://download.eclipse.org/webtools/downloads/
    2. Click the 3.0M1 build
    3. Download the wtp-sdk zip
    4. Unpack the .zip file somewhere
    5. In that extracted folder, there is an "eclipse" subdir
    6. In that subdir, create a file called ".eclipseextension"
    7. In eclipse, go to Help > Software Updates > Manage Configuration
    8. Click "Add an Extension Location"
    9. Select the WTP "eclipse" subdir from above
  4. Install the build of VE:
    1. Go to http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855
    2. Click "Visual Editor patched as in bug 202562"
    3. Click org.eclipse.visualeditor-1.3.0.200709121813.zip
    4. Unpack the .zip file somewhere
    5. In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir
    6. Rename that subdir to "eclipse"
    7. In that "eclipse" subdir, create a file called ".eclipseextension"
    8. In eclipse, go to Help > Software Updates > Manage Configuration
    9. Click "Add an Extension Location"
    10. Select the VE "eclipse" subdir from above