Jump to: navigation, search

Difference between revisions of "VE/Installing"

< VE
m
(VE 1.5)
 
(20 intermediate revisions by 3 users not shown)
Line 1: Line 1:
This document contains tips and suggestions for installing VE 1.3 for Eclipse 3.3. Nothing on this page is officially supported and is subject to change without notice.
+
<blockquote><table style="border: 1px red dashed; padding:10px"><tr><td>'''''This document contains 1 method for installing <b style="color:red">VE 1.3</b> for Eclipse 3.4 Ganymede (or Eclipse 3.3 Europa). For <b style="color:orange">VE 1.4</b>, see [[VE/Update|Installing VE from Update Site]]. Nothing on this page is officially supported and is subject to change without notice. If you see an error or omission, please feel free to [http://wiki.eclipse.org/index.php?title=VE/Installing&action=edit edit it]. '''''</td></tr></table></blockquote>
  
There are three contributed ways to install VE:
 
  
  
== ehecht.com ==
+
=VE 1.5=
  
* See http://www.ehecht.com/eclipse_ve/ve.html
+
* See [[VE/Update|Installing VE from Update Site]].
  
 +
=VE 1.4=
  
== Chris Dolan (on behalf of Avid Technology Inc.) ==
+
* See [[VE/Update|Installing VE from Update Site]].
  
I got it to work once I figured out the JEM stuff.  In the end, these are the steps that worked for me.
+
=VE 1.3=
  
Note: These are likely not the minimal steps, just one working solution.
+
==Download Eclipse for Java EE Developers==
  
=== Uninstall old VE ===
+
* Download and install [http://www.eclipse.org/downloads/packages/ Eclipse 3.4 Ganymede]. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
#Fully uninstall any old version of VE or JEM (not just disable)
+
  
=== Install WTP Prereqs ===
+
* VE 1.3 requires [[EMF/EMF_2.3/JVM_Requirements|EMF 2.4]], which requires [[IRC_FAQ#I_just_installed_Eclipse_on_Linux.2C_but_it_does_not_start._What_is_the_problem.3F|JDK 5.0]] or later.
#Via the Europa update site, install prerequisites for WTP:
+
#*org.eclipse.datatools
+
#*org.eclipse.wst
+
#*org.eclipse.jst
+
#*org.eclipse.jpt
+
  
=== Install the 3.0M1 milestone release of WTP SDK, which is the authoritative source of JEM 2.0.0 ===
+
<blockquote><table style="border: 1px blue dashed; padding:10px"><tr><td>[[Image:Ve-for-ganymede-install-list.png|right|thumb]] Alternatively, you can use a smaller Ganymede bundle or the "Classic" [http://download.eclipse.org/eclipse/downloads/drops/R-3.4-200806172000/ Eclipse 3.4 SDK], then using the [http://download.eclipse.org/releases/ganymede// Ganymede update site], install the following features:
##Go to http://download.eclipse.org/webtools/downloads/
+
:: EMF Ecore Mapping 2.4
##Click the 3.0M1 build
+
:: Graphical Editing Framework GEF 3.4
##Download the wtp-sdk zip
+
:: JST Web Core 3.0
##Unpack the .zip file somewhere
+
:: JST Web UI 3.0
##In that extracted folder, there is an "eclipse" subdir
+
:: WST Common Core 3.0
##In that subdir, create a file called ".eclipseextension"
+
</td></tr></table></blockquote>
##In eclipse, go to Help > Software Updates > Manage Configuration
+
##Click "Add an Extension Location"
+
##Select the WTP "eclipse" subdir from above
+
  
=== Install VE From SourceForge ===
+
==Download VE==
##Go to http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855
+
##Click "Visual Editor patched as in bug 202562"
+
##Click org.eclipse.visualeditor-1.3.0.200709121813.zip
+
##Unpack the .zip file somewhere
+
##In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir
+
##Rename that subdir to "eclipse"
+
##In that "eclipse" subdir, create a file called ".eclipseextension"
+
##In eclipse, go to Help > Software Updates > Manage Configuration
+
##Click "Add an Extension Location"
+
##Select the VE "eclipse" subdir from above
+
  
===Restart Eclipse===
+
* Download the latest VE build from [http://www.ehecht.com/eclipse_ve/ve.html ehecht.com] and unzip into the eclipse/ folder (Eclipse 3.3) or into the new [[Equinox_p2_Getting_Started#Dropins|dropins/]] folder (Eclipse 3.4).
#*If that fails, try restarting Eclipse with the [[Graphical Eclipse FAQs#I have just installed a plug-in but I do not see any indication of it in my workspace. What do I do.3F|-clean argument]].
+
  
 +
== See Also ==
  
== Daniel Young ==
+
* [[VE/Installing/Archived|Other installation methods]] have been archived.
 
+
===Setup / Downloads===
+
 
+
Instead of installing the prerequisites for wtp or wtp itself
+
* Download the 3.0M1 milestone release of WTP (the runtime is sufficient) Inside the archive under eclipse / plugins locate and extract all the org.eclipse.jem* files to your plugin folder (in your main ,extension or link folder)
+
* Go to your features folder and create a folder for each file extracted (name them the same as the plugin files)
+
* Inside each folder create a feature.properties and feature.xml file with the following contents:
+
 
+
* All feature.properties should look like this:
+
featureName=Java EMF Model
+
providerName=Eclipse.org
+
updateSiteName=Visual Editor update site
+
 
+
* featureName should be changed in each file e.g. featurename=Java EMF Model - BeanInfo
+
 
+
===Revise feature.xml files===
+
 
+
*Paste the following into the relevant feature.xml file
+
 
+
====org.eclipse.jem_2.0.0.v200705302225====
+
 
+
<pre>
+
<?xml version="1.0" encoding="UTF-8"?>
+
<feature
+
      id="org.eclipse.jem"
+
      label="%featureName"
+
      version="2.0.0.v200705302225"
+
      provider-name="%providerName"
+
      image="eclipse_update_120.jpg">
+
  <description>
+
      %description
+
  </description>
+
  <copyright url="http://www.eclipse.org/legal/epl-v10.html">
+
      Copyright (c) 2002-2007 IBM Corporation and others.
+
All rights reserved.  This program and the accompanying materials
+
are made available under the terms of the Eclipse Public License v1.0
+
which accompanies this distribution, and is available at
+
http://www.eclipse.org/legal/epl-v10.html
+
  </copyright>
+
  <license url="%licenseURL">
+
      %license
+
  </license>
+
  <url>
+
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
  </url>
+
  <requires>
+
      <import plugin="org.eclipse.emf.ecore.xmi"/>
+
      <import plugin="org.eclipse.jem.proxy"/>
+
      <import plugin="org.eclipse.core.runtime"/>
+
      <import plugin="org.eclipse.jem.util"/>
+
  </requires>
+
  <plugin
+
        id="org.eclipse.jem"
+
        download-size="0"
+
        install-size="0"
+
        version="2.0.0.v200705302225"
+
        unpack="false"/>
+
</feature></pre>
+
 
+
====org.eclipse.jem.workbench_2.0.0.v200705302225====
+
 
+
<pre><?xml version="1.0" encoding="UTF-8"?>
+
<feature
+
      id="org.eclipse.jem.workbench"
+
      label="%featureName"
+
      version="2.0.0.v200705302225"
+
      provider-name="%providerName"
+
      image="eclipse_update_120.jpg">
+
  <description>
+
      %description
+
  </description>
+
  <copyright url="http://www.eclipse.org/legal/epl-v10.html">
+
      Copyright (c) 2002-2007 IBM Corporation and others.
+
All rights reserved.  This program and the accompanying materials
+
are made available under the terms of the Eclipse Public License v1.0
+
which accompanies this distribution, and is available at
+
http://www.eclipse.org/legal/epl-v10.html
+
  </copyright>
+
  <license url="%licenseURL">
+
      %license
+
  </license>
+
  <url>
+
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
  </url>
+
  <requires>
+
      <import plugin="org.eclipse.jem"/>
+
      <import plugin="org.eclipse.jdt.core"/>
+
      <import plugin="org.eclipse.core.resources"/>
+
      <import plugin="org.eclipse.emf.ecore.xmi"/>
+
      <import plugin="org.eclipse.core.runtime"/>
+
      <import plugin="org.eclipse.jem.util"/>
+
  </requires>
+
  <plugin
+
        id="org.eclipse.jem.workbench"
+
        download-size="0"
+
        install-size="0"
+
        version="2.0.0.v200705302225"
+
        unpack="false"/>
+
</feature></pre>
+
 
+
====org.eclipse.jem.util_2.0.0.v200708131600====
+
 
+
<pre><?xml version="1.0" encoding="UTF-8"?>
+
<feature
+
      id="org.eclipse.jem.util"
+
      label="%featureName"
+
      version="2.0.0.v200708131600"
+
      provider-name="%providerName"
+
      image="eclipse_update_120.jpg">
+
  <description>
+
      %description
+
  </description>
+
  <copyright url="http://www.eclipse.org/legal/epl-v10.html">
+
      Copyright (c) 2002-2007 IBM Corporation and others.
+
All rights reserved.  This program and the accompanying materials
+
are made available under the terms of the Eclipse Public License v1.0
+
which accompanies this distribution, and is available at
+
http://www.eclipse.org/legal/epl-v10.html
+
  </copyright>
+
  <license url="%licenseURL">
+
      %license
+
  </license>
+
  <url>
+
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
  </url>
+
  <requires>
+
      <import plugin="org.eclipse.core.runtime"/>
+
      <import plugin="org.eclipse.core.resources"/>
+
      <import plugin="org.eclipse.emf.ecore"/>
+
      <import plugin="org.eclipse.emf.ecore.xmi"/>
+
      <import plugin="com.ibm.icu"/>
+
  </requires>
+
  <plugin
+
        id="org.eclipse.jem.util"
+
        download-size="0"
+
        install-size="0"
+
        version="2.0.0.v200708131600"
+
        unpack="false"/>
+
</feature></pre>
+
 
+
====org.eclipse.jem.ui_2.0.0.v200705302225====
+
 
+
<pre><?xml version="1.0" encoding="UTF-8"?>
+
<feature
+
      id="org.eclipse.jem.ui"
+
      label="%featureName"
+
      version="2.0.0.v200705302225"
+
      provider-name="%providerName"
+
      image="eclipse_update_120.jpg">
+
  <description>
+
      %description
+
  </description>
+
  <copyright url="http://www.eclipse.org/legal/epl-v10.html">
+
      Copyright (c) 2002-2007 IBM Corporation and others.
+
All rights reserved.  This program and the accompanying materials
+
are made available under the terms of the Eclipse Public License v1.0
+
which accompanies this distribution, and is available at
+
http://www.eclipse.org/legal/epl-v10.html
+
  </copyright>
+
  <license url="%licenseURL">
+
      %license
+
  </license>
+
  <url>
+
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
  </url>
+
  <requires>
+
    <import plugin="org.eclipse.jdt.core"/>
+
<import plugin="org.eclipse.ui"/>
+
<import plugin="org.eclipse.jdt.ui"/>
+
<import plugin="org.eclipse.jem.beaninfo"/>
+
<import plugin="org.eclipse.ui.ide"/>
+
<import plugin="org.eclipse.debug.ui"/>
+
<import plugin="org.eclipse.jem.proxy"/>
+
<import plugin="org.eclipse.jdt.launching"/>
+
<import plugin="org.eclipse.jdt.debug.ui"/>
+
<import plugin="org.eclipse.jem.util"/>
+
<import plugin="org.eclipse.core.runtime"/>
+
<import plugin="org.eclipse.ui.editors"/>
+
  </requires>
+
  <plugin
+
        id="org.eclipse.jem.ui"
+
        download-size="0"
+
        install-size="0"
+
        version="2.0.0.v200705302225"
+
        unpack="false"/>
+
</feature></pre>
+
 
+
====org.eclipse.jem.proxy_2.0.0.v200705302225====
+
 
+
<pre><?xml version="1.0" encoding="UTF-8"?>
+
<feature
+
      id="org.eclipse.jem.proxy"
+
      label="%featureName"
+
      version="2.0.0.v200705302225"
+
      provider-name="%providerName"
+
      image="eclipse_update_120.jpg">
+
  <description>
+
      %description
+
  </description>
+
  <copyright url="http://www.eclipse.org/legal/epl-v10.html">
+
      Copyright (c) 2002-2007 IBM Corporation and others.
+
All rights reserved.  This program and the accompanying materials
+
are made available under the terms of the Eclipse Public License v1.0
+
which accompanies this distribution, and is available at
+
http://www.eclipse.org/legal/epl-v10.html
+
  </copyright>
+
  <license url="%licenseURL">
+
      %license
+
  </license>
+
  <url>
+
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
  </url>
+
  <requires>
+
    <import plugin="org.eclipse.jdt.launching"/>
+
<import plugin="org.eclipse.jdt.core"/>
+
<import plugin="org.eclipse.debug.core"/>
+
<import plugin="org.eclipse.jem.util"/>
+
<import plugin="org.eclipse.pde.core"/>
+
<import plugin="org.eclipse.core.runtime"/>
+
<import plugin="org.eclipse.ui"/>
+
  </requires>
+
  <plugin
+
        id="org.eclipse.jem.proxy"
+
        download-size="0"
+
        install-size="0"
+
        version="2.0.0.v200705302225"
+
        unpack="false"/>
+
</feature></pre>
+
 
+
====org.eclipse.jem.beaninfo_2.0.0.v200705302225====
+
 
+
<pre><?xml version="1.0" encoding="UTF-8"?>
+
<feature
+
      id="org.eclipse.jem.beaninfo"
+
      label="%featureName"
+
      version="2.0.0.v200705302225"
+
      provider-name="%providerName"
+
      image="eclipse_update_120.jpg">
+
  <description>
+
      %description
+
  </description>
+
  <copyright url="http://www.eclipse.org/legal/epl-v10.html">
+
      Copyright (c) 2002-2007 IBM Corporation and others.
+
All rights reserved.  This program and the accompanying materials
+
are made available under the terms of the Eclipse Public License v1.0
+
which accompanies this distribution, and is available at
+
http://www.eclipse.org/legal/epl-v10.html
+
  </copyright>
+
  <license url="%licenseURL">
+
      %license
+
  </license>
+
  <url>
+
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
+
  </url>
+
  <requires>
+
    <import plugin="org.eclipse.jem.proxy"/>
+
<import plugin="org.eclipse.jdt.core"/>
+
<import plugin="org.eclipse.jem.workbench"/>
+
<import plugin="org.eclipse.jem"/>
+
<import plugin="org.eclipse.ui"/>
+
<import plugin="org.eclipse.core.runtime"/>
+
<import plugin="org.eclipse.debug.core"/>
+
<import plugin="org.eclipse.jem.util"/>
+
<import plugin="org.eclipse.emf.ecore.change"/>
+
  </requires>
+
  <plugin
+
        id="org.eclipse.jem.beaninfo"
+
        download-size="0"
+
        install-size="0"
+
        version="2.0.0.v200705302225"
+
        unpack="false"/>
+
</feature></pre>
+
 
+
=== Install GEF and EMF, VE ===
+
 
+
* Install GEF and EMF/SDO from the Europa site or their update sites.
+
:* GEF: [http://download.eclipse.org/tools/gef/update-site/milestones/site.xml milestones], [http://download.eclipse.org/tools/gef/update-site/releases/site.xml releases]
+
:* EMF/SDO: [http://download.eclipse.org/modeling/emf/updates/site.xml milestones], [http://download.eclipse.org/modeling/emf/updates/site.xml releases]
+
* Install VE [[#Install VE From SourceForge | as above]].
+
 
+
=== Restart eclipse ===
+
 
+
== Paulg's VE Install ==
+
Did this with a fresh install of the Eclipse Yoxos distribution on Windows XP and Java SE, but it can apply to any other, with a few changes.
+
 
+
Be sure to download all the plugins you will need before making this install, because once you finish VE installation, some updates may crash it.
+
 
+
Before you can install VE, I advice to make a backup copy of your eclipse folder, even if it's a fresh install, you won't have to download all the other plugins again is you screw up. After that, there are some things you need to install first.
+
===WTP Installation(prerequisite)===
+
All the files needed for WTP can be downloaded from [http://download.eclipse.org/webtools/downloads/drops/R3.0/S-3.0M6-20080404175400/ here]
+
 
+
'''Prerequisites'''
+
 
+
* EMF v2.4 Runtime Minimum executable code. ([http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/S-3.4M6-200803301350/eclipse-SDK-3.4M6-win32.zip eclipse-SDK-3.4M6-win32.zip])
+
* EMF XSD v2.4 Runtime Minimum executable code. ([http://www.eclipse.org/downloads/download.php?file=/modeling/emf/emf/downloads/drops/2.4.0/S200804012208/emf-runtime-2.4.0M6.zip emf-runtime-2.4.0M6.zip])
+
* Graphical Editing Framework (GEF) ([http://www.eclipse.org/downloads/download.php?file=/tools/gef/downloads/drops/3.4.0/S200804012217/GEF-SDK-3.4.0M6.zip GEF-SDK-3.4.0M6.zip])
+
* Data Tools Platform (DTP) (required only for EJB or JPT development) ([http://www.eclipse.org/downloads/download.php?file=/datatools/downloads/1.6/dtp-sdk-1.6M6.zip dtp-sdk-1.6M6.zip])
+
* Eclipse Test Framework (required only for Automated JUnit tests)(optional) ([http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/S-3.4M6-200803301350/eclipse-test-framework-3.4M6.zip eclipse-test-framework-3.4M6.zip])
+
 
+
'''WTP Installer'''
+
 
+
''App Developers:'' This non-SDK package is for most users. It includes the runnable code and end-user documentation for those using the tools to develop web applications. [http://www.eclipse.org/downloads/download.php?file=/webtools/downloads/drops/R3.0/S-3.0M6-20080404175400/wtp-S-3.0M6-20080404175400.zip Link]
+
 
+
'''WTP Installation procedure'''
+
 
+
First we will start on the prerequisites.
+
 
+
Before you do anything, make sure you close eclipse. Then unzip each file anywhere you like and copy  the files and directories of the eclipse folder that was inside each zip file to your eclipse installation folder(e.i. C:\eclipse) and click overwrite all if prompted.
+
 
+
Run eclipse and go to '''Help->About Eclipse Plattform->Plugin Details''' to see if everythings was installed correctly.
+
 
+
Close eclipse again and let's do the actual WTP installation. Follow the same procedure as we did for the prerequisites and copy the file to your eclipse folder.
+
 
+
===VE Installation===
+
Make sure eclipse is close.
+
 
+
#Go to [http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855 http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855]
+
#Click '''"Visual Editor patched as in bug 202562"'''
+
#Click org.eclipse.visualeditor-1.3.0.200709121813.zip
+
#Unpack the .zip file somewhere
+
#In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir, copy what's in that directory to your eclipse installation dir, say yes if prompted to overwrite.
+
 
+
Open eclipse again and go to '''Window->Preferences->Java'''. If after expanding 'Java' you see Visual Editor at the bottom, then you are good to go.
+
 
+
You can check on the Help and do some further configuration. I opened some expample files for Swing and they worked fine.
+
  
 
[[Category:VE]]
 
[[Category:VE]]

Latest revision as of 15:58, 16 November 2010

This document contains 1 method for installing VE 1.3 for Eclipse 3.4 Ganymede (or Eclipse 3.3 Europa). For VE 1.4, see Installing VE from Update Site. Nothing on this page is officially supported and is subject to change without notice. If you see an error or omission, please feel free to edit it.


VE 1.5

VE 1.4

VE 1.3

Download Eclipse for Java EE Developers

  • Download and install Eclipse 3.4 Ganymede. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
Ve-for-ganymede-install-list.png
Alternatively, you can use a smaller Ganymede bundle or the "Classic" Eclipse 3.4 SDK, then using the Ganymede update site, install the following features:
EMF Ecore Mapping 2.4
Graphical Editing Framework GEF 3.4
JST Web Core 3.0
JST Web UI 3.0
WST Common Core 3.0

Download VE

  • Download the latest VE build from ehecht.com and unzip into the eclipse/ folder (Eclipse 3.3) or into the new dropins/ folder (Eclipse 3.4).

See Also