Jump to: navigation, search

Difference between revisions of "VE/Installing"

< VE
(Install VE 1.4 from Update Manager)
(VE 1.5)
 
(4 intermediate revisions by 2 users not shown)
Line 1: Line 1:
<blockquote><table style="border: 1px red dashed; padding:10px"><tr><td>'''''This document contains two methods for installing VE 1.3 for Eclipse 3.4 Ganymede (or Eclipse 3.3 Europa). Nothing on this page is officially supported and is subject to change without notice. If you see an error or omission, please feel free to [http://wiki.eclipse.org/index.php?title=VE/Installing&action=edit edit it]. '''''</td></tr></table></blockquote>
+
<blockquote><table style="border: 1px red dashed; padding:10px"><tr><td>'''''This document contains 1 method for installing <b style="color:red">VE 1.3</b> for Eclipse 3.4 Ganymede (or Eclipse 3.3 Europa). For <b style="color:orange">VE 1.4</b>, see [[VE/Update|Installing VE from Update Site]]. Nothing on this page is officially supported and is subject to change without notice. If you see an error or omission, please feel free to [http://wiki.eclipse.org/index.php?title=VE/Installing&action=edit edit it]. '''''</td></tr></table></blockquote>
  
==Install VE 1.4 from Update Manager ==
 
Author: Yves YANG (yves.yang@soyatec.com) - VE Committer
 
  
For a technical reason, we have met a problem to integrate VE build system in Eclipse. We provide here a temporary solution to install VE via [http://www.soyatec.com Soyatec Web services]. If someone familiarizes with releng and intents to help us to fix this problem, please contact ve-dev@eclipse.org. 
 
 
* Download and install [http://www.eclipse.org/downloads/packages/ Eclipse 3.4 Ganymede] for Java development. It could be one of the following standard distributions: 
 
:: - "Eclipse IDE for Java EE Developers"
 
:: - "Eclipse IDE for Java Developers"
 
:: - "Eclipse for RCP/Plug-in Developers"
 
:: - "Eclipse IDE for Java and Report Developers"
 
* Start eclipse and call update manager via the menu: Helps->Softwares Update...
 
Switch to "Available Softwares" Tab and click on the button "Add site..". In the coming dialog, put the
 
URL http://update.soyatec.org/Ganymede/ve/1.4
 
  
[[Image:Update-site.png]]
+
=VE 1.5=
  
* Open all nodes, select the check box "Visual Editor" and click the button "Install"
+
* See [[VE/Update|Installing VE from Update Site]].
  
[[Image:Soyatec-ve.png]]
+
=VE 1.4=
  
After restart Eclipse, if you check the installed plugins: Help-> About Eclipse SDK, You should find follwoing VE plugins:
+
* See [[VE/Update|Installing VE from Update Site]].
  
[[Image:Ve-plugins.png]]
+
=VE 1.3=
  
 
==Download Eclipse for Java EE Developers==
 
==Download Eclipse for Java EE Developers==
  
* Download and install [http://www.eclipse.org/downloads/packages/ Eclipse 3.4 Ganymede]. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
+
* Download and install [http://www.eclipse.org/downloads/packages/ Eclipse 3.4 Ganymede]. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
 +
 
 +
* VE 1.3 requires [[EMF/EMF_2.3/JVM_Requirements|EMF 2.4]], which requires [[IRC_FAQ#I_just_installed_Eclipse_on_Linux.2C_but_it_does_not_start._What_is_the_problem.3F|JDK 5.0]] or later.
  
 
<blockquote><table style="border: 1px blue dashed; padding:10px"><tr><td>[[Image:Ve-for-ganymede-install-list.png|right|thumb]] Alternatively, you can use a smaller Ganymede bundle or the "Classic" [http://download.eclipse.org/eclipse/downloads/drops/R-3.4-200806172000/ Eclipse 3.4 SDK], then using the [http://download.eclipse.org/releases/ganymede// Ganymede update site], install the following features:
 
<blockquote><table style="border: 1px blue dashed; padding:10px"><tr><td>[[Image:Ve-for-ganymede-install-list.png|right|thumb]] Alternatively, you can use a smaller Ganymede bundle or the "Classic" [http://download.eclipse.org/eclipse/downloads/drops/R-3.4-200806172000/ Eclipse 3.4 SDK], then using the [http://download.eclipse.org/releases/ganymede// Ganymede update site], install the following features:

Latest revision as of 15:58, 16 November 2010

This document contains 1 method for installing VE 1.3 for Eclipse 3.4 Ganymede (or Eclipse 3.3 Europa). For VE 1.4, see Installing VE from Update Site. Nothing on this page is officially supported and is subject to change without notice. If you see an error or omission, please feel free to edit it.


VE 1.5

VE 1.4

VE 1.3

Download Eclipse for Java EE Developers

  • Download and install Eclipse 3.4 Ganymede. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
Ve-for-ganymede-install-list.png
Alternatively, you can use a smaller Ganymede bundle or the "Classic" Eclipse 3.4 SDK, then using the Ganymede update site, install the following features:
EMF Ecore Mapping 2.4
Graphical Editing Framework GEF 3.4
JST Web Core 3.0
JST Web UI 3.0
WST Common Core 3.0

Download VE

  • Download the latest VE build from ehecht.com and unzip into the eclipse/ folder (Eclipse 3.3) or into the new dropins/ folder (Eclipse 3.4).

See Also