Jump to: navigation, search

Difference between revisions of "VE/Installing"

< VE
m (ehecht.com)
m (note Eclipse 3.4)
Line 1: Line 1:
This document contains tips and suggestions for installing VE 1.3 for Eclipse 3.3. Nothing on this page is officially supported and is subject to change without notice.
+
This document contains tips and suggestions for installing VE 1.3 for Eclipse 3.3 Europa (or 3.4 Ganymede). Nothing on this page is officially supported and is subject to change without notice.
  
 
There are three contributed ways to install VE:
 
There are three contributed ways to install VE:
Line 5: Line 5:
  
 
== ehecht.com ==
 
== ehecht.com ==
* Download and install [http://www.eclipse.org/downloads/packages/ Ganymede]. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
+
* Download and install [http://www.eclipse.org/downloads/packages/ Eclipse 3.4 Ganymede]. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
:* [[Image:Ve-for-ganymede-install-list.png|right|thumb]] Alternatively, you can use a smaller Ganymede bundle or the "Classic" [http://download.eclipse.org/eclipse/downloads/drops/R-3.4-200806172000/ Eclipse SDK], then using the [http://download.eclipse.org/releases/ganymede// Ganymede update site], install the following features:
+
:* [[Image:Ve-for-ganymede-install-list.png|right|thumb]] Alternatively, you can use a smaller Ganymede bundle or the "Classic" [http://download.eclipse.org/eclipse/downloads/drops/R-3.4-200806172000/ Eclipse 3.4 SDK], then using the [http://download.eclipse.org/releases/ganymede// Ganymede update site], install the following features:
 
:: EMF Ecore Mapping 2.4
 
:: EMF Ecore Mapping 2.4
 
:: Graphical Editing Framework GEF 3.4
 
:: Graphical Editing Framework GEF 3.4

Revision as of 00:58, 5 July 2008

This document contains tips and suggestions for installing VE 1.3 for Eclipse 3.3 Europa (or 3.4 Ganymede). Nothing on this page is officially supported and is subject to change without notice.

There are three contributed ways to install VE:


ehecht.com

  • Download and install Eclipse 3.4 Ganymede. The "Eclipse IDE for Java EE Developers" bundle contains all plugins needed.
EMF Ecore Mapping 2.4
Graphical Editing Framework GEF 3.4
JST Web Core 3.0
JST Web UI 3.0
WST Common Core 3.0

Chris Dolan (on behalf of Avid Technology Inc.)

I got it to work once I figured out the JEM stuff. In the end, these are the steps that worked for me.

Note: These are likely not the minimal steps, just one working solution.

Uninstall old VE

  1. Fully uninstall any old version of VE or JEM (not just disable)

Install WTP Prereqs

  1. Via the Europa update site, install prerequisites for WTP:
    • org.eclipse.datatools
    • org.eclipse.wst
    • org.eclipse.jst
    • org.eclipse.jpt

Install the 3.0M1 milestone release of WTP SDK, which is the authoritative source of JEM 2.0.0

    1. Go to http://download.eclipse.org/webtools/downloads/
    2. Click the 3.0M1 build
    3. Download the wtp-sdk zip
    4. Unpack the .zip file somewhere
    5. In that extracted folder, there is an "eclipse" subdir
    6. In that subdir, create a file called ".eclipseextension"
    7. In eclipse, go to Help > Software Updates > Manage Configuration
    8. Click "Add an Extension Location"
    9. Select the WTP "eclipse" subdir from above

Install VE From SourceForge

    1. Go to http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855
    2. Click "Visual Editor patched as in bug 202562"
    3. Click org.eclipse.visualeditor-1.3.0.200709121813.zip
    4. Unpack the .zip file somewhere
    5. In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir
    6. Rename that subdir to "eclipse"
    7. In that "eclipse" subdir, create a file called ".eclipseextension"
    8. In eclipse, go to Help > Software Updates > Manage Configuration
    9. Click "Add an Extension Location"
    10. Select the VE "eclipse" subdir from above

Restart Eclipse


Daniel Young

Setup / Downloads

Instead of installing the prerequisites for wtp or wtp itself

  • Download the 3.0M1 milestone release of WTP (the runtime is sufficient) Inside the archive under eclipse / plugins locate and extract all the org.eclipse.jem* files to your plugin folder (in your main ,extension or link folder)
  • Go to your features folder and create a folder for each file extracted (name them the same as the plugin files)
  • Inside each folder create a feature.properties and feature.xml file with the following contents:
  • All feature.properties should look like this:
featureName=Java EMF Model
providerName=Eclipse.org
updateSiteName=Visual Editor update site
  • featureName should be changed in each file e.g. featurename=Java EMF Model - BeanInfo

Revise feature.xml files

  • Paste the following into the relevant feature.xml file

org.eclipse.jem_2.0.0.v200705302225

<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.jem"
      label="%featureName"
      version="2.0.0.v200705302225"
      provider-name="%providerName"
      image="eclipse_update_120.jpg">
   <description>
      %description
   </description>
   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2002-2007 IBM Corporation and others.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html
   </copyright>
   <license url="%licenseURL">
      %license
   </license>
   <url>
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
   </url>
   <requires>
      <import plugin="org.eclipse.emf.ecore.xmi"/>
      <import plugin="org.eclipse.jem.proxy"/>
      <import plugin="org.eclipse.core.runtime"/>
      <import plugin="org.eclipse.jem.util"/>
   </requires>
   <plugin
         id="org.eclipse.jem"
         download-size="0"
         install-size="0"
         version="2.0.0.v200705302225"
         unpack="false"/>
</feature>

org.eclipse.jem.workbench_2.0.0.v200705302225

<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.jem.workbench"
      label="%featureName"
      version="2.0.0.v200705302225"
      provider-name="%providerName"
      image="eclipse_update_120.jpg">
   <description>
      %description
   </description>
   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2002-2007 IBM Corporation and others.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html
   </copyright>
   <license url="%licenseURL">
      %license
   </license>
   <url>
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
   </url>
   <requires>
      <import plugin="org.eclipse.jem"/>
      <import plugin="org.eclipse.jdt.core"/>
      <import plugin="org.eclipse.core.resources"/>
      <import plugin="org.eclipse.emf.ecore.xmi"/>
      <import plugin="org.eclipse.core.runtime"/>
      <import plugin="org.eclipse.jem.util"/>
   </requires>
   <plugin
         id="org.eclipse.jem.workbench"
         download-size="0"
         install-size="0"
         version="2.0.0.v200705302225"
         unpack="false"/>
</feature>

org.eclipse.jem.util_2.0.0.v200708131600

<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.jem.util"
      label="%featureName"
      version="2.0.0.v200708131600"
      provider-name="%providerName"
      image="eclipse_update_120.jpg">
   <description>
      %description
   </description>
   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2002-2007 IBM Corporation and others.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html
   </copyright>
   <license url="%licenseURL">
      %license
   </license>
   <url>
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
   </url>
   <requires>
      <import plugin="org.eclipse.core.runtime"/>
      <import plugin="org.eclipse.core.resources"/>
      <import plugin="org.eclipse.emf.ecore"/>
      <import plugin="org.eclipse.emf.ecore.xmi"/>
      <import plugin="com.ibm.icu"/>
   </requires>
   <plugin
         id="org.eclipse.jem.util"
         download-size="0"
         install-size="0"
         version="2.0.0.v200708131600"
         unpack="false"/>
</feature>

org.eclipse.jem.ui_2.0.0.v200705302225

<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.jem.ui"
      label="%featureName"
      version="2.0.0.v200705302225"
      provider-name="%providerName"
      image="eclipse_update_120.jpg">
   <description>
      %description
   </description>
   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2002-2007 IBM Corporation and others.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html
   </copyright>
   <license url="%licenseURL">
      %license
   </license>
   <url>
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
   </url>
   <requires>
     	<import plugin="org.eclipse.jdt.core"/>
	<import plugin="org.eclipse.ui"/>
	<import plugin="org.eclipse.jdt.ui"/>
	<import plugin="org.eclipse.jem.beaninfo"/>
	<import plugin="org.eclipse.ui.ide"/>
	<import plugin="org.eclipse.debug.ui"/>
	<import plugin="org.eclipse.jem.proxy"/>
	<import plugin="org.eclipse.jdt.launching"/>
	<import plugin="org.eclipse.jdt.debug.ui"/>
	<import plugin="org.eclipse.jem.util"/>
	<import plugin="org.eclipse.core.runtime"/>
	<import plugin="org.eclipse.ui.editors"/>
   </requires>
   <plugin
         id="org.eclipse.jem.ui"
         download-size="0"
         install-size="0"
         version="2.0.0.v200705302225"
         unpack="false"/>
</feature>

org.eclipse.jem.proxy_2.0.0.v200705302225

<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.jem.proxy"
      label="%featureName"
      version="2.0.0.v200705302225"
      provider-name="%providerName"
      image="eclipse_update_120.jpg">
   <description>
      %description
   </description>
   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2002-2007 IBM Corporation and others.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html
   </copyright>
   <license url="%licenseURL">
      %license
   </license>
   <url>
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
   </url>
  <requires>
     	<import plugin="org.eclipse.jdt.launching"/>
	<import plugin="org.eclipse.jdt.core"/>
	<import plugin="org.eclipse.debug.core"/>
	<import plugin="org.eclipse.jem.util"/>
	<import plugin="org.eclipse.pde.core"/>
	<import plugin="org.eclipse.core.runtime"/>
	<import plugin="org.eclipse.ui"/>
   </requires>
   <plugin
         id="org.eclipse.jem.proxy"
         download-size="0"
         install-size="0"
         version="2.0.0.v200705302225"
         unpack="false"/>
</feature>

org.eclipse.jem.beaninfo_2.0.0.v200705302225

<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.jem.beaninfo"
      label="%featureName"
      version="2.0.0.v200705302225"
      provider-name="%providerName"
      image="eclipse_update_120.jpg">
   <description>
      %description
   </description>
   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2002-2007 IBM Corporation and others.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html
   </copyright>
   <license url="%licenseURL">
      %license
   </license>
   <url>
      <update label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
      <discovery label="%updateSiteName" url="http://download.eclipse.org/tools/gef/update-site/releases/site.xml"/>
   </url>
   <requires>
     	<import plugin="org.eclipse.jem.proxy"/>
	<import plugin="org.eclipse.jdt.core"/>
	<import plugin="org.eclipse.jem.workbench"/>
	<import plugin="org.eclipse.jem"/>
	<import plugin="org.eclipse.ui"/>
	<import plugin="org.eclipse.core.runtime"/>
	<import plugin="org.eclipse.debug.core"/>
	<import plugin="org.eclipse.jem.util"/>
	<import plugin="org.eclipse.emf.ecore.change"/>
   </requires>
   <plugin
         id="org.eclipse.jem.beaninfo"
         download-size="0"
         install-size="0"
         version="2.0.0.v200705302225"
         unpack="false"/>
</feature>

Install GEF and EMF, VE

  • Install GEF and EMF/SDO from the Europa site or their update sites.

Restart eclipse

Paulg's VE Install

Did this with a fresh install of the Eclipse Yoxos distribution on Windows XP and Java SE, but it can apply to any other, with a few changes.

Be sure to download all the plugins you will need before making this install, because once you finish VE installation, some updates may crash it.

Before you can install VE, I advice to make a backup copy of your eclipse folder, even if it's a fresh install, you won't have to download all the other plugins again is you screw up. After that, there are some things you need to install first.

WTP Installation(prerequisite)

All the files needed for WTP can be downloaded from here

Prerequisites

WTP Installer

App Developers: This non-SDK package is for most users. It includes the runnable code and end-user documentation for those using the tools to develop web applications. Link

WTP Installation procedure

First we will start on the prerequisites.

Before you do anything, make sure you close eclipse. Then unzip each file anywhere you like and copy the files and directories of the eclipse folder that was inside each zip file to your eclipse installation folder(e.i. C:\eclipse) and click overwrite all if prompted.

Run eclipse and go to Help->About Eclipse Plattform->Plugin Details to see if everythings was installed correctly.

Close eclipse again and let's do the actual WTP installation. Follow the same procedure as we did for the prerequisites and copy the file to your eclipse folder.

VE Installation

Make sure eclipse is close.

  1. Go to http://sourceforge.net/project/showfiles.php?group_id=131065&package_id=154855
  2. Click "Visual Editor patched as in bug 202562"
  3. Click org.eclipse.visualeditor-1.3.0.200709121813.zip
  4. Unpack the .zip file somewhere
  5. In that extracted folder, there is an " org.eclipse.visualeditor-1.3.0.200709121813" subdir, copy what's in that directory to your eclipse installation dir, say yes if prompted to overwrite.

Open eclipse again and go to Window->Preferences->Java. If after expanding 'Java' you see Visual Editor at the bottom, then you are good to go.

You can check on the Help and do some further configuration. I opened some expample files for Swing and they worked fine.