Jump to: navigation, search

Difference between revisions of "Tycho/Release Notes/0.25"

Line 17: Line 17:
 
</pluginRepositories>
 
</pluginRepositories>
 
</pre>
 
</pre>
 
=== SNAPSHOT site docs ===
 
 
Refer to the [https://hudson.eclipse.org/tycho/job/tycho-sitedocs/ws/target/staging/index.html latest SNAPSHOT site docs for Tycho] and [https://hudson.eclipse.org/tycho/job/tycho.extras-sitedocs/ws/target/staging/index.html Tycho Extras].
 
  
 
== New and Noteworthy ==
 
== New and Noteworthy ==
Line 37: Line 33:
  
 
* The eclipse bundles used by Tycho internally (mostly p2) have been update to Neon M6 (<strike>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=485427 bug 485427]</strike>)
 
* The eclipse bundles used by Tycho internally (mostly p2) have been update to Neon M6 (<strike>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=485427 bug 485427]</strike>)
* As a consequence, Tycho now requires Java 8 to run
+
* As a consequence, <b>Tycho now requires Java 8 to run</b>
 
** Note that you can still [https://eclipse.org/tycho/sitedocs/tycho-compiler-plugin/compile-mojo.html#useJDK build against] and [https://eclipse.org/tycho/sitedocs/tycho-surefire/tycho-surefire-plugin/test-mojo.html#useJDK run tests] with other JDKs with maven toolchains
 
** Note that you can still [https://eclipse.org/tycho/sitedocs/tycho-compiler-plugin/compile-mojo.html#useJDK build against] and [https://eclipse.org/tycho/sitedocs/tycho-surefire/tycho-surefire-plugin/test-mojo.html#useJDK run tests] with other JDKs with maven toolchains
 +
* tycho-versions-plugin will now extend version ranges if the new version would be outside the range (<strike>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=477328 bug 477328]</strike> and (<strike>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=478996 bug 478996]</strike>)
  
 
=== Feature Version Qualifiers ===
 
=== Feature Version Qualifiers ===

Revision as of 03:20, 8 April 2016

Staged release

Tycho 0.25.0 is staged for release. To try it out, simply add the following snippet to your (parent) pom.xml or settings.xml, and set the property for the Tycho version (e.g. tycho-version) to 0.25.0.

<pluginRepositories>
   <pluginRepository>
     <id>tycho-0.25.0-staged</id>
     <url>https://oss.sonatype.org/content/repositories/orgeclipsetycho-1035/</url>
   </pluginRepository>
</pluginRepositories>

New and Noteworthy

Complete list of bug fixes and enhancements in 0.25.0

p2

Test Execution

  • Support for JUnit categories has been added. (bug 386964). You can now include and/or exclude tests annotated with @Category.

Other

  • The eclipse bundles used by Tycho internally (mostly p2) have been update to Neon M6 (bug 485427)
  • As a consequence, Tycho now requires Java 8 to run
  • tycho-versions-plugin will now extend version ranges if the new version would be outside the range (bug 477328 and (bug 478996)

Feature Version Qualifiers

When computing aggregated qualifiers for features, Tycho will now recognize timestamps in the following form anywhere within the qualifier of direct included features or bundles (bug 482086):

  • yyyyMMddHHmm
  • yyyyMMdd-HHmm
  • yyyyMMdd

List of JVM arguments for the EclipseRun Plugin

The one-line-parameter <argLine> has been deprecated. JVM parameters can be configured now as a list of arguments (bug 486799):

 <jvmArgs> 
   <args>-Xdebug</args>
   <args>-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=1044</args>
 </jvmArgs>