Jump to: navigation, search

Difference between revisions of "Tycho/Release Notes/0.17"

(Complier Plugin)
m (adapt version navigation to new theme)
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
 
<css>
 
<css>
   #bodyContent{ position:relative; }
+
   #main-page-content{ position:relative; }
   #versionNav{ position:absolute; top: 0px; right: 0px; margin-right: 1em; font-size: 84%; line-height: 1.2em; color: rgb(125, 125, 125); }
+
   #versionNav{ position:absolute; top: 0px; right: 0px; border-color: transparent; background: transparent; }
</css>
+
</css>  
<div id="versionNav">[[Tycho/Release Notes/0.16|&lt; Previous Version]] | [[Tycho/Release Notes/0.18|Next Version &gt;]]</div>
+
<div id="versionNav" class="alert alert-small alert-warning">[[Tycho/Release Notes/0.16|&lt; Previous Version]] | [[Tycho/Release Notes/0.18|Next Version &gt;]]</div>
  
 
== New and Noteworthy  ==
 
== New and Noteworthy  ==
Line 11: Line 11:
 
==== Compiler Plugin ====
 
==== Compiler Plugin ====
  
* (INCOMPATIBLE CHANGE) <tt>eclipse-plugin</tt> and <tt>eclipse-test-plugin</tt> modules which neither have and explicit [http://www.eclipse.org/tycho/sitedocs/tycho-compiler-plugin/compile-mojo.html compiler source/target level] configuration nor have an [http://wiki.eclipse.org/Tycho/Execution_Environments#Execution_environment_configuration execution environment] configuration are now compiled with a source & target level of 1.6 instead of 1.5. Modules with any explicit configuration, e.g. a <tt>Bundle-RequiredExecutionEnvironment</tt> header in the manifest, are not affected. If you are building for <tt>J2SE-1.5</tt> or even more restricted execution environments, it is recommended to set the new <tt>target-platform-configuration</tt> parameter <tt>&lt;executionEnvironmentDefault&gt;</tt> in your parent POM.
+
* (INCOMPATIBLE CHANGE) <tt>eclipse-plugin</tt> and <tt>eclipse-test-plugin</tt> modules which neither have and explicit [http://www.eclipse.org/tycho/sitedocs/tycho-compiler-plugin/compile-mojo.html compiler source/target level] configuration nor have an [[Tycho/Execution Environments#Execution environment configuration|execution environment]] configuration are now compiled with a source & target level of 1.6 instead of 1.5. Modules with any explicit configuration, e.g. a <tt>Bundle-RequiredExecutionEnvironment</tt> header in the manifest, are not affected. If you are building for <tt>J2SE-1.5</tt> or even more restricted execution environments, it is recommended to set the new <tt>target-platform-configuration</tt> parameter [[Tycho/Execution Environments#Execution environment configuration|<tt>&lt;executionEnvironmentDefault&gt;</tt>]] in your parent POM.
 
* The JDT compiler bundled with Tycho has been updated to Kepler M6.
 
* The JDT compiler bundled with Tycho has been updated to Kepler M6.
 
* The <tt>tycho-compiler-plugin</tt> has a new <tt>compilerArgs</tt> parameter that allows to specify arbitrary compiler arguments (see [https://bugs.eclipse.org/bugs/show_bug.cgi?id=400307#c3 bug 400307])  
 
* The <tt>tycho-compiler-plugin</tt> has a new <tt>compilerArgs</tt> parameter that allows to specify arbitrary compiler arguments (see [https://bugs.eclipse.org/bugs/show_bug.cgi?id=400307#c3 bug 400307])  

Latest revision as of 03:34, 18 September 2014

New and Noteworthy

List of all bug fixes and enhancements in 0.17.0

Compiler Plugin

  • (INCOMPATIBLE CHANGE) eclipse-plugin and eclipse-test-plugin modules which neither have and explicit compiler source/target level configuration nor have an execution environment configuration are now compiled with a source & target level of 1.6 instead of 1.5. Modules with any explicit configuration, e.g. a Bundle-RequiredExecutionEnvironment header in the manifest, are not affected. If you are building for J2SE-1.5 or even more restricted execution environments, it is recommended to set the new target-platform-configuration parameter <executionEnvironmentDefault> in your parent POM.
  • The JDT compiler bundled with Tycho has been updated to Kepler M6.
  • The tycho-compiler-plugin has a new compilerArgs parameter that allows to specify arbitrary compiler arguments (see bug 400307)
  • The compilation bootclasspath can now be customized in toolchains.xml when using useJDK=BREE (bug 389856).
  • tycho-compiler-plugin:
    • low-level configuration errors will now fail the build (bug 385613)
    • annotation processor arguments (-Akey=value) are now supported

Target Platform & Dependency Resolution

  • It is now possible to specify multiple target files in target-platform-configuration. Note that these target files are resolved separately, i.e. they each need to resolve successfully when opened with the target editor in Eclipse. Also note that it is not possible to activate multiple target files in the Eclipse PDE (see bug 392652).
  • p2 repository and proxy authentication now works with maven-encrypted passwords (bug 386910 and bug 394023)
  • The Equinox and p2 versions bundled with Tycho has been updated to Kepler M6.
    • This includes an update to a new major version (4.1.3) of the bundled Apache httpclient library.

Packaging

Test Execution

  • Unit tests can now run on pre-filled workspace data (bug 401288)

Source Features

  • Source feature generation has been improved, docs updated accordingly:
    • (INCOMPATIBLE CHANGE) No longer rely on existence of magic folder sourceTemplateFeature/ when determining whether to generate a source feature
    • Label, description, branding plugin and other attributes are now taken over from the original feature by default. See bugs 374349, 375165 and 378424 for details. It's recommended to rely on feature.properties to set name and other text values in the original feature; then you can easily customize/override the generated source feature values by creating a sourceTemplateFeature/feature.properties file if required

Other

  • Documentation for the Maven plugins from tycho-extras published
  • (INCOMPATIBLE CHANGE) Runtime of tycho-eclipserun-plugin is now resolved from explicitly configured p2 repositorie(s) only (see bug 395281 for details and migration guide)
  • The mirror goal of tycho-p2-extras-plugin now allows to skip downloading pack200 artifacts and supports p2 query language. See Tycho/Additional Tools
  • tycho-versions-plugin will now also update versions of .product files in eclipse-repository projects
  • (INCOMPATIBLE CHANGE) remove duplicated compiler invocation for eclipse-test-plugin (bug 383866)