Jump to: navigation, search

Tigrestripe Diagram Options

Revision as of 05:01, 1 November 2010 by Rcraddoc.cisco.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

< To: Tigerstripe
Within Tigerstripe you can create both Class and Instance diagrams. This article describes how you can alter the appearance of the digrams by changing line drawing style, controlling the containers that are shown and so on.

Styles

Open the properties View in eclipse ( "Window-> Show View-> Other-> General-> Properties" ). In the "Appearance" tab of the properties view you will see the options that can be changed for the selected node or line. Most of these are self explanatory, eg font, colour etc.

Line Style

The format of lines between objects (ie for Associations, Extends relationships etc) can be controlled in a number of ways. Of particular interest are those setting in the "Routing" section:

  1. Oblique/Rectilinear - This controls the style in terms of whther the lines are drawn at angles )Oblique), or always at right angles to the diagram frame(Rectilinear).
  2. Avoid Obstructions - When enabled the line will never be drawn across a node on the diagram, but will "go around" any obestruction that is found.

Note that thsese settings are "per line" - ie you can mix and match styles within the same diagram.

Hide/ Show

Whole diagram

Right-click on the background of the diagram, and select the "Hide/Show" option from the menu. There are 4 options (whcih work for teh whole diagram):

  1. Hide Stereotypes - if you enable this, then the steroetypes will not be shown above the artifact name (<<aSterepotype>>).
  2. Hide default values - when enabled, default values for attributes and method argumnets will be removed form the digram display.
  3. Hide packages within compartments - if an attribute or method argumnet/return type has a type of "com.mycompany.other.AType", the text in a compartment can get very long. By hiding the package the type here would be shortened to "Atype" thus simplfying the diagram.
  4. Hide Artifact Packages - each Diagram has a "base package" - normally the package where the diagram is stored. Any artifact dragged onto the diagram from other packages will have a fully qualified name displayed. USing the hide, you can just show the last segment of the FQN for all artifacts on teh diagram, irrespective of their package.

Per node settings

Nodes describes the way in which Entities, Datatype etc are shown on the diagram. Typically nodes shown a numner of "compartments" - one for the name, one for attributes, one for methods etc (where applicable).

Select a node for an artifact and right click, then select the "Filters" option. Select the "Show/Hide compartment", and you can select to either show all compartments, or just show the Name comprtament. This is useful for example, when you have a "high-level diagram" and want to show relationships between objects without showing the deatiled attribute lists.

If you select a node for an artifact and right click, there is one further hide/show option - that of hiding the Extends relationship.

Per line settings

Select a line for a relationship and right click, then select the "Filters" option. Select the "Show/Hide Connector labels" and you can select to either show or hide all of the labels. If you want more "fine-grained" control of whch labels are shown, then right-click and sleect the "Hide/Show Details" option. You can then select a number of options as to which labels are shown and hidden.

Preferences

Rather than constantly change these setting for every diagram, you can set *some* of the values through preferences, so that all new diagrams pick up the desired behaviour. Go to "Window-> Preferences-> Tigerstripe-> Diagram",and set your preferred values.

If you have a digram open when you change preferences, you can apply the settigs to the existing diagram elements.