Skip to main content
Jump to: navigation, search

Teneo/Hibernate/Download and Install

< Teneo‎ | Hibernate
Revision as of 04:49, 23 January 2010 by Mtaal.elver.org (Talk | contribs) (New page: __TOC__ The installation method for Teneo depends on the target environment(Eclipse/OSGI or web container). Both cases are discussed on this page. This page also describes where to find ...)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)


The installation method for Teneo depends on the target environment(Eclipse/OSGI or web container). Both cases are discussed on this page. This page also describes where to find the example projects used in the tutorials in the wiki.

Teneo is build and tested on Eclipse 3.5 (Teneo 1.1.*) and Eclipse 3.6 (Teneo 1.2.*). This page assumes that you have a running Eclipse 3.5/3.6 available.

Dependencies

To run Teneo you need the following software:

  • EMF 2.5 (Teneo 1.1.*) or 2.6 (Teneo 1.2.*)
  • Hibernate 3.3.2 and its dependencies
  • Apache commons logging
  • JDBC driver

Download and install using the update manager (for usage in Eclipse/OSGI)

http://www.elver.org/eclipse/update

http://download.eclipse.org/modeling/emf/updates/interim/


Download directly

Teneo can be downloaded directly from this page. Note that it is always better to use a maintenance build, also for maintenance builds all the test cases pass. Maintenance builds are listed a bit lower on the download page.

Download and Install Teneo for usage within a Web Container

For usage within a web container it is easier

Download and Install Example Projects for Tutorials

Back to the top