Talk:EGit/User Guide

From Eclipsepedia

Jump to: navigation, search

Fetch from Upstream problem

Problem:

"Fretch From Upstream" and "Push To Upstream" is alway grayed out


Solution:

(from http://stackoverflow.com/questions/8756006/eclipse-egit-push-to-remote-menu-choice-is-grayed-out)

"...

1. Right click your project, choose Team→Show in Repositories View. You will switch perspectives and be in the Git Repositories tab.

2. Right-click "Remotes" and choose "Create Remote". For "Remote name", enter "origin". Click OK.

3. Click Change. Enter your information as you did during your initial push. Click Save.

You should now be able to push by merely right-clicking on your project, then Team→Push to Upstream.

Because the remote was added under the project in question, each project can have its own upstream origin and they will not interfere (whereas the Window > Preferences solution is a global setting).

... Use the name "origin" for the remote, which is absolutely necessary."

branch_status label decoration

This user guide is currently (2012-06-23) missing an explanation for the "branch_status" label decoration. Also, the default project text decoration has changed

from

{dirty:>} {name} [{repository} {branch}]

to

{dirty:>} {name} [{repository} {branch}{ branch_status}]

--Abdull 16:54, 23 June 2012 (UTC)

Edit Features Stop Working in Git Project

Several features of eclipse, including auto-complete, syntax error highlighting, and class loader, no longer work, but only in the eclipse project related or linked to my git repository.

I downloaded and installed the latest stable version of eclipse, and then did the "install software" to install the latest git plugin.

These eclipse features still function in other "projects". I tried copying the files in this folder to another folder using the native file manager, then deleting the folders/files named: .git, .gitignore, and .project, then importing this as "General -> File Folder", as a plain PHP project. But the eclipse features don't work here either. I may as well be using Notepad or TextEdit instead, without these features.

System: - MacOS X Lion version 10.7.3 - Eclipse for PHP Developers - Version: Helios Release - Build id: 20100617-1415 - Eclipse EGit 1.3.0.201202151440-r org.eclipse.egit.feature.group - Eclipse IDE for PHP Developers 1.3.0.20100617-0520 epp.package.php

I even tried adding "-clean" to the eclipse startup file as described by http://www.eclipsezone.com/eclipse/forums/t61566.html on my original eclipse, and it apparently did nothing.

Is anyone else experiencing this issue? Please help. G