Difference between revisions of "Stardust/Source Code"

From Eclipsepedia

Jump to: navigation, search
(Where to go from here?)
(Maven Configuration)
(19 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 +
== Browsing the Source Code ==
 +
For initial quick browsing of the source code please go to http://git.eclipse.org/c/?q=stardust.
 +
 
== Installing Git  ==
 
== Installing Git  ==
  
Line 10: Line 13:
 
== Downloading the Source Code  ==
 
== Downloading the Source Code  ==
  
*Create a new folder where you like to download the sources (e.g. C:\stardust\git)
+
*Create a new folder where you like to download the sources (e.g. C:\stardust\git)  
 
*Create a new file, e.g. cloneStardust.cmd, and copy the following commands
 
*Create a new file, e.g. cloneStardust.cmd, and copy the following commands
<pre>git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.build.tools.git build.tools
+
<pre>git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.build.tools.git build.tools
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.ui.common.git common
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.components.git components
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.components.git components
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.deploy.jee.git deploy.jee
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.documentation.git documentation
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.documentation.git documentation
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.engine.git engine
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.engine.git engine
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.ide.git ide
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.examples.git examples
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.ide.simulation.git ide.simulation
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.git org.eclipse.stardust
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.ide.wst.git ide.wst
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ide.git ide
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.git org.eclipse.stardust
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ide.simulation.git ide.simulation
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.product.git product
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ide.wst.git ide.wst
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.reporting.rt.git reporting.rt
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.product.git product
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.reporting.app.web.git reporting.app.web
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.reporting.app.web.git reporting.app.web
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.reporting.ui.git reporting.ui
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.reporting.rt.git reporting.rt
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.ui.web.git ui.web
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.reporting.ui.git reporting.ui
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.repository.git repository
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.repository.git repository
git clone http://git.eclipse.org/gitroot//stardust/org.eclipse.stardust.ui.common.git ui.common
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ui.common.git ui.common
</pre>
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ui.web.git ui.web
*Save the file
+
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ui.web.mobile.git ui.web.mobile
*Go to your git installation and open git shell (e.g. execute git-cmd.bat on windows)
+
</pre>  
 +
*Save the file  
 +
*Go to your git installation and open git shell (e.g. execute git-cmd.bat on windows)  
 
*Change to your just created download folder and execute cloneStardust.cmd
 
*Change to your just created download folder and execute cloneStardust.cmd
 
+
<blockquote>The above mentioned commands will checkout the master branch per default. Please note that the currently '''active branche''' is '''I_4_3 for Kepler''' driven builds. You can checkout by adding the '''"-b &lt;branch-name&gt;"''' parameter to the git command. </blockquote>
 
If you run git clone behind a HTTP proxy specify proxy details first.  
 
If you run git clone behind a HTTP proxy specify proxy details first.  
 
<pre>git config --global http.proxy http://&lt;user&gt;:&lt;password&gt;@proxy:port</pre>
 
<pre>git config --global http.proxy http://&lt;user&gt;:&lt;password&gt;@proxy:port</pre>
Line 51: Line 56:
 
<br>java16.home=C:/Program Files/Java/jdk1.6.0_32<br>  
 
<br>java16.home=C:/Program Files/Java/jdk1.6.0_32<br>  
 
m2.home=C:/tools/apache-maven-3.0.4<br><br>
 
m2.home=C:/tools/apache-maven-3.0.4<br><br>
 +
If you don't want to use the preconfigured Maven settings file [your stardust git dir]/build.tools/conf/m2/settings.xml then you have to specify the path of the actual settings file in your [your stardust git dir]/build.tools/etc/private.properties file, e.g
 +
<pre>mvn.settings=C:/Program Files/Maven/conf/settings.xml
 +
</pre>
 
Make sure that you use forward slashes in property files!
 
Make sure that you use forward slashes in property files!
  
==== Maven Configuration  ====
 
  
Open your maven settings.xml file (either in your user home\.m2 folder or in your maven_home\conf folder) and add this entry in the&lt;servers&gt; tag:&nbsp;<source lang="sql">
 
<server>
 
  <id>stardust-3rdparty-repo</id>
 
  <username>stardust.contributor</username>
 
  <password>\{DESede\}BKab8uCs+3KRLHy/l2AeHQ==</password>
 
</server>
 
</source> (Copy exactly as is. No need to replace anything here.)
 
  
 
==== Running the Builds  ====
 
==== Running the Builds  ====
  
 
Make sure your machine is connected to the internet, open a command line in your build folder and then execute these two commands replacing [build_tools_home] with the absolute path to your build.tools sub folder:  
 
Make sure your machine is connected to the internet, open a command line in your build folder and then execute these two commands replacing [build_tools_home] with the absolute path to your build.tools sub folder:  
<pre>set MAVEN_OPTS=-Xmx768m -XX:MaxPermSize=128m</pre> <pre>mvn -f product/components-pom.xml -Pipp-build -Dbuild.tools.home=[build_tools_home] install</pre>  
+
<pre>set MAVEN_OPTS=-Xmx768m -XX:MaxPermSize=128m</pre>  
 +
<pre>mvn -f product/components-pom.xml -s [build_tools_home]/conf/m2/settings.xml -P stardust-build -Dbuild.tools.home=[build_tools_home] install</pre>  
 
For instance:<br>  
 
For instance:<br>  
  
mvn -f product/components-pom.xml -Pipp-build -Dbuild.tools.home=c:/stardustbuild/build.tools install<br>  
+
mvn -f product/components-pom.xml -s c:/stardustbuild/build.tools/conf/m2/settings.xml -P stardust-build -Dbuild.tools.home=c:/stardustbuild/build.tools install<br>  
  
 
Depending on your connection speed and other factors the completion of the second command can take up to several hours.<br>
 
Depending on your connection speed and other factors the completion of the second command can take up to several hours.<br>
After build of components finished successfully, you should find the resulting artefacts in your local maven repository.<br><br> Now the eclipse p2 repository with the Stardust eclipse plug-ins can be built. Run the following command replacing&nbsp;[build_tools_home] with the absolute path to your build.tools sub folder:  
+
After build of components finished successfully, you should find the resulting artifacts in your local maven repository at [build_tools_home]/build/m2-repo.<br><br> Now the eclipse p2 repository with the Stardust eclipse plug-ins can be built. Run the following command replacing&nbsp;[build_tools_home] with the absolute path to your build.tools sub folder:  
<pre>mvn clean install -f product/pom.xml -Pfull-build,force-overwrite,ipp-build -Dbuild.tools.home=[build_tools_home]</pre>  
+
<pre>mvn clean install -f product/pom.xml -s [build_tools_home]/conf/m2/settings.xml -P force-overwrite,stardust-build -Dbuild.tools.home=[build_tools_home]</pre>  
 
for instance:  
 
for instance:  
  
''mvn clean install -f product/pom.xml -Pforce-overwrite,ipp-build -Dbuild.tools.home=C:/stardustbuild/build.tools''  
+
''mvn clean install -f product/pom.xml -s C:/stardustbuild/build.tools/conf/m2/settings.xml -Pforce-overwrite,stardust-build -Dbuild.tools.home=C:/stardustbuild/build.tools''  
  
This will trigger the build of the p2 repository. After the build has finished successful, you will find the repository in the sub folder&nbsp;: <br>  
+
This will trigger the build of the p2 repository.<br><br>
 +
The above mentioned commands assumes that you're using the Maven settings file which is located in [build_tools_home]/conf/m2/. If you like to use the one of your user home folder or the one of your Maven installation folder (in this case please add the mvn.settings property in [build_tools_home]/etc/private.properties which is described above) then you can remove the "-s [build_tools_home]/conf/m2/settings.xml" parameter from the build commands.<br>
  
''stardust/repository/org.eclipse.stardust.modeling.repository/target/repository/ ''  
+
After the build has finished successful, you will find the repository in the sub folder&nbsp;: <br>
 +
 
 +
''[your stardust git dir]/repository/org.eclipse.stardust.modeling.repository/target/repository/''  
  
 
and zipped as an update site:  
 
and zipped as an update site:  
  
''stardust/repository/org.eclipse.stardust.modeling.repository/target/org.eclipse.stardust.modeling.repository.zip ''<br>
+
''[your stardust git dir]/repository/org.eclipse.stardust.modeling.repository/target/stardust-offline-site-9.9.9-SNAPSHOT.zip''<br>
  
==== Where to go from here?<br> ====
+
==== Where to go from here?<br> ====
  
Now you can use the build result, a local eclipse update site,&nbsp;to install Stardust. Follow the instructions in the section [[/../Knowledge_Base/Getting_Started/Installation#Local_Eclipse_Update_Site_.28offline.29|Local Eclipse Update Site (offline)]]<br>
+
Now you can use the build result, a local eclipse update site,&nbsp;to install Stardust. Follow the instructions in the section [[Stardust/Knowledge_Base/Getting_Started/Installation#Local_Eclipse_Update_Site|Local Eclipse Update Site (offline)]]<br>  
  
Next check out the resource in the [[/../Knowledge_Base|Stardust Knowledge Base]], especially the [[/../Knowledge_Base#Getting_Started|Getting Started]] section. You may also want to check out the [http://www.eclipse.org/forums/index.php?t=thread&frm_id=225 Forum] to post questions or just exchange thoughts with the community.<br>
+
Next check out the resource in the [[Stardust/Knowledge Base|Stardust Knowledge Base]], especially the [[Stardust/Knowledge Base#Getting_Started|Getting Started]] section. You may also want to check out the [http://www.eclipse.org/forums/index.php?t=thread&frm_id=225 Forum] to post questions or just exchange thoughts with the community.<br>
  
 
== Troubleshooting<br>  ==
 
== Troubleshooting<br>  ==
Line 108: Line 112:
  
 
If your are using <u>Maven 3.0.4 behind a proxy</u> please see [[Stardust/Knowledge_Base/Build_and_Change_Management/Maven/Basic_Setup#Troubleshooting|here]] on how to fix the issue.
 
If your are using <u>Maven 3.0.4 behind a proxy</u> please see [[Stardust/Knowledge_Base/Build_and_Change_Management/Maven/Basic_Setup#Troubleshooting|here]] on how to fix the issue.
 +
 +
== Importing projects into Eclipse  ==
 +
 +
After you have executed the build you can import the projects into Eclipse. Although we're using Maven as the main dependency management system we have currently some projects which are using Ivy for the dependency management (this will be slowly but surely changed sooner or later). Because of the fact that the IvyDE plugin can handle Ivy and Maven projects we have adjusted all projects to work with this plugin.
 +
 +
==== Installing IvyDE plugin ====
 +
At first you have to install the IvyDE plugin. To do that just click on "Install new Software..." in the Help menu item of Eclipse. In the upcoming dialog press the "Add..." button and provide the following URL http://www.apache.org/dist/ant/ivyde/updatesite. Please install "Apache IvyDE" and optionaly "Apache IvyDE Resolve Visualizer". These can be found in the section "Apache IvyDE Eclipse plugins".
 +
 +
==== Import build.tools project ====
 +
Now import the ''build.tools'' project with help of the "Existing Projects into Workspace" wizard of the import dialog of Eclipse.
 +
 +
==== Configure IvyDE plugin ====
 +
After the installation of IvyDE and the ''build.tools'' project import, open the preferences dialog of Eclipse which can be found in the ''Window'' menu item and click on ''Ivy'' in the left panel. Now configure the plugin as follows:
 +
* ''Advanced'': enable "Use extended resolve id"
 +
* ''Classpath Container'': enable "Resolve dependencies in workspace"
 +
* ''Settings/Ivy settings path'': ${workspace_loc:build.tools/ivysettings-eclipse.xml}
 +
** this assumes that you have already imported the ''build.tools'' project in Eclipse
 +
 +
==== Importing all projects ====
 +
In the last step you can import all remaining projects into Eclipse with the "Existing Projects into Workspace" wizard of the import dialog of Eclipse. As the root directory you can choose the GIT checkout folder. As a result of this all projects are listed in the ''Projects'' view. Please remove the marker left of the project ''stardust-hazelcast-ra'' because it is currently not used. After this click on the "Resolve All" button which can you find in the IvyDE toolbar:<br><br>
 +
[[Image:ResolveAll-Button.png]]
 +
 +
This step can take some time. Therefore we're suggesting to open the ''Ivy Console'' in the Console view to see/validate the resolve progress.
  
 
== Binary Distribution  ==
 
== Binary Distribution  ==

Revision as of 07:51, 6 May 2013

Contents

Browsing the Source Code

For initial quick browsing of the source code please go to http://git.eclipse.org/c/?q=stardust.

Installing Git

To checkout the source code you need to install git first. You have different options:

  • git scm installs a minimal environment to run Git. It comes with a Bash,a Perl interpreter, the Git executable plus dependencies.
  • msysgit installs a build environment for Git on Windows. It includes git scm.

After installtion you can open a git shell to run git commands (git bash or git-cmd.bat).

Downloading the Source Code

  • Create a new folder where you like to download the sources (e.g. C:\stardust\git)
  • Create a new file, e.g. cloneStardust.cmd, and copy the following commands
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.build.tools.git build.tools
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.components.git components
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.deploy.jee.git deploy.jee
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.documentation.git documentation
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.engine.git engine
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.examples.git examples
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.git org.eclipse.stardust
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ide.git ide
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ide.simulation.git ide.simulation
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ide.wst.git ide.wst
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.product.git product
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.reporting.app.web.git reporting.app.web
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.reporting.rt.git reporting.rt
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.reporting.ui.git reporting.ui
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.repository.git repository
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ui.common.git ui.common
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ui.web.git ui.web
git clone http://git.eclipse.org/gitroot/stardust/org.eclipse.stardust.ui.web.mobile.git ui.web.mobile
  • Save the file
  • Go to your git installation and open git shell (e.g. execute git-cmd.bat on windows)
  • Change to your just created download folder and execute cloneStardust.cmd
The above mentioned commands will checkout the master branch per default. Please note that the currently active branche is I_4_3 for Kepler driven builds. You can checkout by adding the "-b <branch-name>" parameter to the git command.

If you run git clone behind a HTTP proxy specify proxy details first.

git config --global http.proxy http://<user>:<password>@proxy:port

Building Stardust

Build Tools

After check out as described above you can build Stardust source code. You need Apache Ant and Apache Maven. If you do not already have those tools installed please download them from their official website and install them accordingly to their installation instructions in a location of your choice, later called ANT_HOME and M2_HOME. We suggest Ant 1.8.4 and Maven 3.0.4, but other similar versions should work as well. After those preparations are done perform the following steps ( also see the readme.txt in the product folder).

Environment-specific Changes

Make sure your environment variables ANT_HOME, M2_HOME and JAVA_HOME are set correctly. Also add ant and maven to your %Path% environment variable. Create a file called private.properties in the folder [your stardust git dir]/build.tools/etc. Modify the file with a text editor and add the following content:

java16.home=[your java home path]
m2.home=[your maven home path]

for instance:
java16.home=C:/Program Files/Java/jdk1.6.0_32
m2.home=C:/tools/apache-maven-3.0.4

If you don't want to use the preconfigured Maven settings file [your stardust git dir]/build.tools/conf/m2/settings.xml then you have to specify the path of the actual settings file in your [your stardust git dir]/build.tools/etc/private.properties file, e.g

mvn.settings=C:/Program Files/Maven/conf/settings.xml

Make sure that you use forward slashes in property files!


Running the Builds

Make sure your machine is connected to the internet, open a command line in your build folder and then execute these two commands replacing [build_tools_home] with the absolute path to your build.tools sub folder:

set MAVEN_OPTS=-Xmx768m -XX:MaxPermSize=128m
mvn -f product/components-pom.xml -s [build_tools_home]/conf/m2/settings.xml -P stardust-build -Dbuild.tools.home=[build_tools_home] install

For instance:

mvn -f product/components-pom.xml -s c:/stardustbuild/build.tools/conf/m2/settings.xml -P stardust-build -Dbuild.tools.home=c:/stardustbuild/build.tools install

Depending on your connection speed and other factors the completion of the second command can take up to several hours.
After build of components finished successfully, you should find the resulting artifacts in your local maven repository at [build_tools_home]/build/m2-repo.

Now the eclipse p2 repository with the Stardust eclipse plug-ins can be built. Run the following command replacing [build_tools_home] with the absolute path to your build.tools sub folder:

mvn clean install -f product/pom.xml -s [build_tools_home]/conf/m2/settings.xml -P force-overwrite,stardust-build -Dbuild.tools.home=[build_tools_home]

for instance:

mvn clean install -f product/pom.xml -s C:/stardustbuild/build.tools/conf/m2/settings.xml -Pforce-overwrite,stardust-build -Dbuild.tools.home=C:/stardustbuild/build.tools

This will trigger the build of the p2 repository.

The above mentioned commands assumes that you're using the Maven settings file which is located in [build_tools_home]/conf/m2/. If you like to use the one of your user home folder or the one of your Maven installation folder (in this case please add the mvn.settings property in [build_tools_home]/etc/private.properties which is described above) then you can remove the "-s [build_tools_home]/conf/m2/settings.xml" parameter from the build commands.

After the build has finished successful, you will find the repository in the sub folder :

[your stardust git dir]/repository/org.eclipse.stardust.modeling.repository/target/repository/

and zipped as an update site:

[your stardust git dir]/repository/org.eclipse.stardust.modeling.repository/target/stardust-offline-site-9.9.9-SNAPSHOT.zip

Where to go from here?

Now you can use the build result, a local eclipse update site, to install Stardust. Follow the instructions in the section Local Eclipse Update Site (offline)

Next check out the resource in the Stardust Knowledge Base, especially the Getting Started section. You may also want to check out the Forum to post questions or just exchange thoughts with the community.

Troubleshooting

If you experience any problems downloading the source code or building Stardust then please contact us via the Forum.

Error retrieving BIRT Runtime

If you get the error below or something similar while running the p2 repository build (step 2) then this is caused by an instabilty of the connection with the Eclipse server. Retrying the same build command at a later point in time should resolve the issue.

[ivy:retrieve]  Server access Error: Read timed out 
url=http://download.eclipse.org/birt/downloads/drops/R-R1-2_6_2-201102191842/birt-runtime-2_6_2.zip

Errors fetching Dependencies

If you encounter errors during the build that indicate missing dependencies which could not be fetched from the repositories then try cleaning the ivy cache folder .ivy in your user.home (e.g. C:\Users\your.name\.ivy, if it exists) and the maven repository (check settings.xml in M2_HOME/etc and/or user.home/.m2 to determine the location).

If your are using Maven 3.0.4 behind a proxy please see here on how to fix the issue.

Importing projects into Eclipse

After you have executed the build you can import the projects into Eclipse. Although we're using Maven as the main dependency management system we have currently some projects which are using Ivy for the dependency management (this will be slowly but surely changed sooner or later). Because of the fact that the IvyDE plugin can handle Ivy and Maven projects we have adjusted all projects to work with this plugin.

Installing IvyDE plugin

At first you have to install the IvyDE plugin. To do that just click on "Install new Software..." in the Help menu item of Eclipse. In the upcoming dialog press the "Add..." button and provide the following URL http://www.apache.org/dist/ant/ivyde/updatesite. Please install "Apache IvyDE" and optionaly "Apache IvyDE Resolve Visualizer". These can be found in the section "Apache IvyDE Eclipse plugins".

Import build.tools project

Now import the build.tools project with help of the "Existing Projects into Workspace" wizard of the import dialog of Eclipse.

Configure IvyDE plugin

After the installation of IvyDE and the build.tools project import, open the preferences dialog of Eclipse which can be found in the Window menu item and click on Ivy in the left panel. Now configure the plugin as follows:

  • Advanced: enable "Use extended resolve id"
  • Classpath Container: enable "Resolve dependencies in workspace"
  • Settings/Ivy settings path: ${workspace_loc:build.tools/ivysettings-eclipse.xml}
    • this assumes that you have already imported the build.tools project in Eclipse

Importing all projects

In the last step you can import all remaining projects into Eclipse with the "Existing Projects into Workspace" wizard of the import dialog of Eclipse. As the root directory you can choose the GIT checkout folder. As a result of this all projects are listed in the Projects view. Please remove the marker left of the project stardust-hazelcast-ra because it is currently not used. After this click on the "Resolve All" button which can you find in the IvyDE toolbar:

ResolveAll-Button.png

This step can take some time. Therefore we're suggesting to open the Ivy Console in the Console view to see/validate the resolve progress.

Binary Distribution

All Stardust source code has been submitted to the Eclipse git repository. A complete binary distribution requires libraries which are still pending approval by Eclipse legal, hence no binary distribution is available yet. One will be available for download form the project website as soon as the libraries have been approved.

Compliance

  • The products libraries have been reviewed for license conflicts.
  • Dependencies that did not comply with the Eclipse Public License (EPL) have been replaced
  • The source has been submitted to the Eclipse foundation where it was reviewed with regards to intellectual property rights and licensing.
  • The source was refactored. All package names were change to the eclipse package names.