Difference between revisions of "Sirius/1.0.0M4"

From Eclipsepedia

Jump to: navigation, search
(Created page with "Sirius 1.0.0M4 is a milestone release which has been included in Luna M4. The project is still in incubation at this time. See also [http://dev.eclipse.org/mhonarc/lists/siri...")
 
(Availability)
 
Line 12: Line 12:
 
It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.
 
It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.
  
''Juno users'': Sirius depends on a version of the Guava library which is not available by default from a Juno install. You need to add the Orbit update-site at http://download.eclipse.org/tools/orbit/downloads/drops/R20130827064939/repository/ if you want to install Sirius on Juno.
+
''Juno users'': Sirius depends on more recent versions of some components that what is available by default from a Juno install. You need to add the following update-sites if you want to install Sirius on Juno:
 +
* Orbit: http://download.eclipse.org/tools/orbit/downloads/drops/R20130827064939/repository/
 +
* Acceleo 3.4: http://download.eclipse.org/acceleo/updates/releases/3.4/
 +
* EEF 1.2: http://download.eclipse.org/modeling/emft/eef/updates/nightly/1.2/
  
 
== Compatibility ==
 
== Compatibility ==

Latest revision as of 10:51, 27 February 2014

Sirius 1.0.0M4 is a milestone release which has been included in Luna M4. The project is still in incubation at this time.

See also the announce on the mailing list.

[edit] Availability

Sirius 1.0.0M4 was released on 2013-12-16 (tag v1.0.0M4, commit 679983850e861e2584b90dc90a150e5621ca7c7d). It is available from the following update sites:

It is recommended you use the update-site matching the version of Eclipse you use to avoid potential issues at runtime.

Juno users: Sirius depends on more recent versions of some components that what is available by default from a Juno install. You need to add the following update-sites if you want to install Sirius on Juno:

[edit] Compatibility

Sirius 1.0.0M4 is compatible with the following versions of Eclipse:

  • Eclipse 3.8/4.2 (Juno)
  • Eclipse 4.3 (Kepler)
  • Eclipse 4.4M4 (Luna)

[edit] New & Noteworthy

The main difference between 0.9.0 and 1.0.0M4 is the removal of most deprecated APIs in Sirius (except in the few cases where we could not provide a better replacement). The list of bugs fixed in this version can be seen on Bugzilla.