Jump to: navigation, search

Scout/Release/Juno

< Scout
Revision as of 12:53, 30 January 2012 by Mvi.bsiag.com (Talk | contribs)

Eclipse Scout (Juno Release)

ScoutIcon32c.jpg

This Wiki page is to cover the relevant aspects to fulfill the release review as described here for Eclipse Scout release 3.8 (Juno).

  • Eclipse Scout is a mature and open framework for modern, service oriented business applications.
  • Scout substantially boosts developer productivity and is simple to learn.
  • User friendly applications are straight forward to implement with Scout’s comprehensive set of user interface components.
  • Completely based on Java/Eclipse, Scout Applications are easy to integrate in most IT environments.


Useful Links

Scout Release Review Documentation

Planning Document

Link to project plan as [XML document]

New and Noteworthy

New and Noteworthy

End-of-Life

With Scout 3.8 (Juno Release):

  • Scout integration for Apache Axis (web services) is no longer supported. As a replacement, we implemented JAX-WS integration into both Scout runtime and the Scout SDK. See the corresponding entry in our forum

Bugzilla Tickets

Target Environment

All of Eclipse Scout is "pure" Java code and has no direct dependence on the underlying operating system. The chief dependence is therefore on the Java Runtime (JRE) itself. For Juno the following JREs are supported:

  • Oracle Java 6
  • Oracle Java 7

Beside the JRE Eclipse Scout also requires a compatible Eclipse platform. For Juno release of Scout the following Eclipse platforms are supported:

  • Eclipse Galileo (3.5) Limited support only: Scout Web UI (RAP) is not supported (see below).
  • Eclipse Helios (3.6)
  • Eclipse Indigo (3.7)
  • Eclipse Juno (3.8 / 4.2)

The RAP (Rich Ajax Platform) UI for Eclipse Scout requires at least the following browser versions:

  • Microsoft Internet Explorer 9
  • Mozilla Firefox 9
  • Google Chrome 16
  • Apple Safari 5

Compatibility with Previous Releases

To do (jgu), see [requirements]

Support for Eclipse 3.8 workbench

While Juno plans to provide Eclipse 4.2 as the primary platform, the Eclipse Project will also be providing a 3.8 based version as well. This is done since it is anticipated some adopters may not be able to move to 4.2 right away, and may need to wait for their own "release train" to get lined up.

We will support our adopters in a similar way: Eclipse Scout will support 3.8 as a secondary platform (while 4.2 will be the primary platform). But we anticipate having only one stream of development. Scout will continue to work with the 3.8 and 4.2 platform, using the compatibility layer, and no 4.2 specific APIs. For Juno we will make sure that Scout will also compile against 3.8 to ensure that we do not introduce new API useage that breaks on 3.8.

However, We will not actively test Scout against 3.8. but will focus our Juno testing efforts on 4.2. We will accept bugs as equally valid if they are reported when running on either 3.8 or 4.2. We will provide this type of one-stream, dual-platform support for Juno and its two coordinated maintenance releases.

Build Process

To do (jgu)

Ramp down Policy

We use daily builds. No API changes after M6, no new features after M7. In the RC phase only bugs marked P2 or higher or severity major or higher will be fixed.

Unit Tests

Unit tests are executed during the nightly build of Eclipse Scout RT and Eclipse Scout SDK. The test suites contain simple unit tests as well as GUI tests. The latter are based on Scout's testing support bundles which is built on top of java.awt.Robot. Therefore our GUI tests require a fully-fledged desktop environment. The tests are currently executed on BSI's infrastructure.

Current Project Metrics

project metrics for Eclipse Scout provided on [ohloh]

Previous Release Documentation