Jump to: navigation, search

Difference between revisions of "STEM Source Code"

(Accessing the STEM Source Code Repository with SVN)
(Downloading and installing the SVN plugin)
Line 19: Line 19:
 
</ul>
 
</ul>
  
===Downloading and installing the SVN plugin===
+
=== Install a SVN Team Provider ===
To access the STEM SVN repository, you need to install an SVN plugin in Eclipse for instance Subclipse. For Eclipse 3.4, open Help->Software Updates. Click the "Available Software" tab and "Add Site". Type this location:
+
The STEM source code is currently housed in a Subversion (SVN) repository hosted by the Eclipse Foundation.  Eclipse does not include a built-in SVN client with their SDK distribution, so you will need to install one into your Eclipse environment. ''Optionally, you can check out the code using a command-line client and import the projects into Eclipse.''
  
http://subclipse.tigris.org/update_1.6.x
+
Most people use one of two SVN client plug-ins for Eclipse:
 
+
* ''' [http://subclipse.tigris.org/ Subclipse] '''
Select these components (at minimum):  
+
** [http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA Subclipse Installation Guide]
 
+
* ''' [http://www.eclipse.org/subversive/ Eclipse Subversive] '''
Under "Core SVNKit Library", select "SVNKit Library" <br/>
+
** [http://www.eclipse.org/subversive/documentation/gettingStarted/aboutSubversive/install.php Subversive Installation Guide]
Under "Optional JNA Library", select "JNA Library" <br/>
+
Under "Subclipse", select "Subclipse Integration for Mylyn", "Subversion Revision Graph" and "SVNKit Client Adapter" <br/>
+
 
+
Click Install and restart Eclipse when prompted
+
  
 
===Accessing the STEM Source Code Repository with SVN===
 
===Accessing the STEM Source Code Repository with SVN===

Revision as of 12:01, 29 July 2011

STEM Contents Page

STEM Source Code

All of the files that constitute the STEM project are maintained in a “source code control” system. Anyone can obtain a copy of the files in the system, but only people designated as “committers” are allowed to add new files or make other changes to the repository. Since STEM graduated to a top level technology project, the source code repository is SVN.

The only files that are in the repository are those that cannot be derived from others. For instance, Java source files would be in the repository, but not Java class files.

The following sections cover some of the more common SVN tasks that you would use for STEM development. For more information:

Install a SVN Team Provider

The STEM source code is currently housed in a Subversion (SVN) repository hosted by the Eclipse Foundation. Eclipse does not include a built-in SVN client with their SDK distribution, so you will need to install one into your Eclipse environment. Optionally, you can check out the code using a command-line client and import the projects into Eclipse.

Most people use one of two SVN client plug-ins for Eclipse:

Accessing the STEM Source Code Repository with SVN

Open the SVN Repositories window (Window->Show View->Other, SVN->SVN Repositories). Right click anywhere in the empty window and select New->Repository Location... Enter the following Url:

http://dev.eclipse.org/svnroot/technology/org.eclipse.stem/

The repository is also available for browsing here.


For a instructions on checking out and building the STEM source code, see the Setting Up your STEM Development Environment guide.

How do I send someone a patch?

If you have modified a project that you checked out from SVN, you may want to send those changes to someone else. This often occurs when you do not have commit rights, but want to send the changes to someone who does. To create a patch file:

  1. Select the changed project in the Navigator or other view.
  2. Context Menu->Team->Create Patch...
  3. Select a location for the patch.
  4. Use E-mail or other delivery method to send the patch to someone else.
  5. If the patch is associated with a Bugzilla item, it is a good idea to append to the Bugzilla item with the patch as an attachment.

Note that Create patch can be run with multiple projects selected.

How do I apply a patch that someone sent me?

To apply a patch, such as one generated in the previous step, do the following:

  1. Select the changed project in the Navigator or other view.
  2. Context Menu->Team->Apply Patch...
  3. Fill in the location of the patch file
  4. Click Next. A summary of changed files will appear.
  5. Click Finish. The changes are now merged into the workspace.
  6. Context Menu->Team->Synchronize with Repository.
  7. After testing the patch, if you have commit access, you may then commit the changes into the repository.

Committer access to SVN

Developers with commit rights have individual user ids and passwords in the Eclipse project development repository. As a committer you can use SSH (Secure SHell) to connect to the SVN repository as follows. Go to a Repository View and add a new SVN repository location. When asked for the url enter:

svn+ssh://dev.eclipse.org/svnroot/technology/org.eclipse.stem

Enter your user name and password and Finish. Once your information is authenticated, you can browse the repository and add projects to your workspace. If you do some changes that you'd like to contribute, after testing and ensuring that you have followed the contribution guidelines, you are free to release your changes to the repository. Of course, you can only release changes to projects for which you have commit rights. The current list of committers for STEM can be found here.

Note that you can use the SSH protocol and your Eclipse user id to access projects for which you are not a committer but you will not be able to release changes.