Difference between revisions of "STEM Source Code"

From Eclipsepedia

Jump to: navigation, search
(How do I apply a patch that someone sent me?)
(Committer access to CVS)
Line 86: Line 86:
 
</ol>
 
</ol>
  
===Committer access to CVS===
+
===Committer access to SVN===
  
Developers with commit rights have individual user ids and passwords in the Eclipse project development repository. As a committer you can use SSH (Secure SHell) to connect to the CVS repository as follows. Go to a Repository View and add a new CVS repository location. When asked for the repository location enter the following:
+
Developers with commit rights have individual user ids and passwords in the Eclipse project development repository. As a committer you can use SSH (Secure SHell) to connect to the SVN repository as follows. Go to a Repository View and add a new SVN repository location. When asked for the url enter:
  
{| style="width:60%;" border="0" cellpadding="2"
+
svn+ssh://dev.eclipse.org/svnroot/technology/org.eclipse.stem
|+Committer CVS Connection Information
+
|-
+
| '''Host''' || dev.eclipse.org  
+
|-
+
| '''Repository Paths''' || /cvsroot/technology  
+
|-
+
| '''User''' || (your committer user id, supplied by the webmaster)
+
|-
+
| '''Password''' || (your committer password)
+
|-
+
| '''Connection Type''' || extssh
+
|-
+
|}
+
  
Once your information is authenticated, you can browse the repository and add projects to your workspace. If you do some changes that you'd like to contribute, after testing and ensuring that you have followed the contribution guidelines, you are free to release your changes to the repository. Of course, you can only release changes to projects for which you have commit rights. The current list of committers for OHF can be found [http://www.eclipse.org/ohf/committers/index.php here].
+
Enter your user name and password and Finish.
 +
Once your information is authenticated, you can browse the repository and add projects to your workspace. If you do some changes that you'd like to contribute, after testing and ensuring that you have followed the contribution guidelines, you are free to release your changes to the repository. Of course, you can only release changes to projects for which you have commit rights. The current list of committers for STEM can be found [http://www.eclipse.org/projects/project_summary.php?projectid=technology.stem here].
  
 
Note that you can use the SSH protocol and your Eclipse user id to access projects for which you are not a committer but you will not be able to release changes.
 
Note that you can use the SSH protocol and your Eclipse user id to access projects for which you are not a committer but you will not be able to release changes.
 
More information about CVS usage with Eclipse is available [http://wiki.eclipse.org/index.php/CVS_Howto  here].
 

Revision as of 15:48, 1 September 2009

STEM Contents Page

Contents

STEM Source Code

All of the files that constitute the STEM project are maintained in a “source code control” system. Anyone can obtain a copy of the files in the system, but only people designated as “committers” are allowed to add new files or make other changes to the repository. Since STEM graduated to a top level technology project, the source code repository is SVN.

The only files that are in the repository are those that cannot be derived from others. For instance, Java source files would be in the repository, but not Java class files.

The following sections cover some of the more common SVN tasks that you would use for STEM development. For more information:

Downloading and installing the SVN plugin

To access the STEM SVN repository, you need to install an SVN plugin in Eclipse for instance Subclipse. For Eclipse 3.4, open Help->Software Updates. Click the "Available Software" tab and "Add Site". Type this location:

http://subclipse.tigris.org/update_1.6.x

Select these components (at minimum):

Under "Core SVNKit Library", select "SVNKit Library"
Under "Optional JNA Library", select "JNA Library"
Under "Subclipse", select "Subclipse Integration for Mylyn", "Subversion Revision Graph" and "SVNKit Client Adapter"

Click Install and restart Eclipse when prompted

Accessing the STEM Source Code Repository with SVN

Open the SVN Repositories window (Window->Show View->Other, SVN->SVN Repositories). Right click anywhere in the empty window and select New->Repository Location... Enter the following Url:

svn://dev.eclipse.org/svnroot/technology/org.eclipse.stem

The username is "guest" and the leave the password empty.


To import the STEM plugin projects from SVN, follow these steps:

  • In the SVN Repositores view, open the repository you just created (svn://dev.eclipse.org/svnroot/technology/org.eclipse.stem)
    • Open trunk
    • Select all projects under trunk, right-click and select "checkout". Leave all setting the way they are in the wizard that pops up, simply select Finish

At this point, all of the selected projects will be checked out and then built (assuming automatic builds have been enabled in your Eclipse installation. You can specify this by selecting Window->Preferences, then General->Workspace. Check "Build Automatically" and "Refresh Automatically")

Now you're ready to follow the rest of the instructions prepare for running STEM:

[2]

The repository is also available for browsing here.

How do I send someone a patch?

If you have modified a project that you checked out from SVN, you may want to send those changes to someone else. This often occurs when you do not have commit rights, but want to send the changes to someone who does. To create a patch file:

  1. Select the changed project in the Navigator or other view.
  2. Context Menu->Team->Create Patch...
  3. Select a location for the patch.
  4. Use E-mail or other delivery method to send the patch to someone else.
  5. If the patch is associated with a Bugzilla item, it is a good idea to append to the Bugzilla item with the patch as an attachment.

Note that Create patch can be run with multiple projects selected.

How do I apply a patch that someone sent me?

To apply a patch, such as one generated in the previous step, do the following:

  1. Select the changed project in the Navigator or other view.
  2. Context Menu->Team->Apply Patch...
  3. Fill in the location of the patch file
  4. Click Next. A summary of changed files will appear.
  5. Click Finish. The changes are now merged into the workspace.
  6. Context Menu->Team->Synchronize with Repository.
  7. After testing the patch, if you have commit access, you may then commit the changes into the repository.

Committer access to SVN

Developers with commit rights have individual user ids and passwords in the Eclipse project development repository. As a committer you can use SSH (Secure SHell) to connect to the SVN repository as follows. Go to a Repository View and add a new SVN repository location. When asked for the url enter:

svn+ssh://dev.eclipse.org/svnroot/technology/org.eclipse.stem

Enter your user name and password and Finish. Once your information is authenticated, you can browse the repository and add projects to your workspace. If you do some changes that you'd like to contribute, after testing and ensuring that you have followed the contribution guidelines, you are free to release your changes to the repository. Of course, you can only release changes to projects for which you have commit rights. The current list of committers for STEM can be found here.

Note that you can use the SSH protocol and your Eclipse user id to access projects for which you are not a committer but you will not be able to release changes.