Difference between revisions of "STEM Installation Guide"

From Eclipsepedia

Jump to: navigation, search
(Downloading and Installing STEM)
(Downloading and Installing STEM)
Line 48: Line 48:
  
 
== Downloading and Installing STEM ==
 
== Downloading and Installing STEM ==
The STEM application is bundled as a platform-specific, zipped archive and does not contain an installer.  To install STEM, download the appropriate bundle and unzip it to an appropriate installation path.
+
The STEM application is bundled as a platform-specific, zipped archive and does not contain an installer.  To install STEM, download the appropriate bundle and unzip it to your desired installation path.
  
 
<span style="color:#ff0000">'''STEM install paths cannot contain whitespace characters.  Ensure that the install path contains no spaces, tabs, etc.'''</span>
 
<span style="color:#ff0000">'''STEM install paths cannot contain whitespace characters.  Ensure that the install path contains no spaces, tabs, etc.'''</span>

Revision as of 17:43, 9 November 2012

STEM TOP BAR.gif

Contents

Back to STEM Contents Page

STEM Video on YouTubeTM

The following url contains a full length tutorial on STEM. http://www.youtube.com/watch?v=LfiibQX4IFE We are in the process of creating versions in several different languages.

Getting Started

There are two paths to running STEM: from a downloaded binary installed as a standalone application or built from source and launched in Eclipse. Here are some considerations regarding which path to choose:

  • If you want to use STEM to compose models, scenarios and run simulations, follow this guide to download and install STEM as a standalone application
  • If you want to extend or add new functionality to STEM, including new disease and computational models, you need to build STEM from source. See the Setting up a STEM Development Environment page for more instructions.

Prerequisites

STEM is a Java application built on top of the Eclipse Rich Client Platform (RCP). To run STEM, please verify you have the following prerequisites installed:

  1. A workstation running an Eclipse-supported operating system:
    • Windows (XP, Vista, 7)
    • Linux (GTK)
    • Mac OS X (10.5 or later)
  2. A supported Java Standard Edition (J2SE) 6.0 JVM from either Oracle (Sun) or IBM (32-bit or 64-bit)
    Oracle Java SE 6.0 (6.0.26 or higher)
    IBM Java SE 6.0
    • Note: Mac OS X users can use the version included with the operating system
    • Note: The GNU for Java (GCJ) compiler and libraries are not supported. If you're running on Linux, it's strongly recommend you use an Oracle or IBM JRE.
    • Note: While STEM should work with Java 7, it is not tested or supported at this time
  3. A utility to decompress zipped archives
    Most operating systems have this built-in

Which File To Download?

The STEM Project publishes several different binary versions of the application. Please consider these options when choosing which to download.

32-bit vs. 64-bit

Most modern operating systems from 2009 and on support 64-bit (x86_64) compiled binaries. The 64-bit version of STEM can take advantage of larger memory spaces (beyond 2 GB), which is necessary to run very large (global) simulations.

The STEM project publishes both 32-bit (x86) and 64-bit (x86_64) versions of the application for each supported operating system. The version you download strictly depends on whether you have a 32-bit or 64-bit Java Runtime Environment (JRE) installed. If you have a 64-bit JRE installed, download the x86_64 version. Otherwise, download the x86 version.

Some 64-bit JREs can run in 32-bit mode. Please see your JRE's documentation for instructions.

Release, Milestone, or Integration Builds

The best version of STEM to download is generally the latest Release. In addition to being fully tested and stable, it's approved for distribution by the Eclipse Foundation and subject to the terms of the Eclipse Software User Agreement and the Eclipse Public License.

However, power users or those looking for the latest feature may choose to download the latest Weekly Integration, Milestone, or Release Candidate build. These builds may not be stable and are not sanctioned by the Eclipse Foundation. Use at your own risk.

Downloading and Installing STEM

The STEM application is bundled as a platform-specific, zipped archive and does not contain an installer. To install STEM, download the appropriate bundle and unzip it to your desired installation path.

STEM install paths cannot contain whitespace characters. Ensure that the install path contains no spaces, tabs, etc.

If you already have STEM 1.4 or newer installed and wish to upgrade, see the STEM Updates section.

  1. In your browser, go to the STEM Downloads page
  2. Choose the appropriate bundle to download (see previous section for details) and click the link
  3. On the mirrors page, select a nearby mirror site. This will begin the download.
  4. If prompted, choose to Save the file. Note where the file is downloading to.
  5. Wait while the STEM bundle downloads...
    Note: STEM is approximately 150 MB in size. Depending on your connection and mirror speeds, the download will take from a few minutes to an hour or more.
  6. When the download finishes, open the folder where the downloaded file sits
  7. Extract/unzip the STEM archive
    Note: On most systems, double clicking the the .zip file will automatically extract it.
  8. Extracting the archive should create a folder called stem. Move this folder to the path you wish to install STEM at.
    IMPORTANT REMINDER: Verify that the install path does not contain whitespace or non-ASCII characters, including spaces, tabs, etc.
    • Windows users may want to place stem folder in a drive root. Example is c:\stem
    • Mac OS X users may want to place the stem folder in the Applications folder
  9. Optionally, you can create a shortcut on your desktop, start menu, dock, etc to quickly launch STEM

That's it! STEM is now installed. See the next section for instructions running STEM.

Launching and Running STEM

Installing/Running the STEM Application

You can run STEM in two ways: as a user or as a developer.

As a user, you can run a standalone version of STEM as a modeling and simulation tool. If you run Windows, Linux or Mac and have Java 6 installed, you can download the STEM application and use it as a standalone application. To download STEM, use this link STEM downloads We recommend you get the latest version of the code available under "Integration Weekly Builds"

As a developer, you can use any platform supported by Eclipse. You will also need to install Java and download the Eclipse development tools and the STEM source code. Follow the instructions here: Getting the STEM source

Either way you run STEM, please be aware that Eclipse does not permit use of a space character in any url or path. 
Please be sure not use a space character in your workspace path.

Running STEM as a Standalone Application

If you want to first run STEM as an application, we provide a standalone version of STEM that requires only that you have Java 6 or higher installed.

You can get the file by going to this page and downloading the latest integration weekly build for your environment.

Once you have downloaded the zip file (Warning: the download is a very large file and will take awhile to download.), you will have to "unzip" the file into your favorite directory.

This is a self-contained stand-alone version of STEM that is launched by double-clicking on the "STEM.exe" executable file in the root directory of the expanded archive (windows). You'll need to have Java 1.6 installed for it to run, but if you do and it's on the path, you should be greeted by the STEM "splash screen" while it starts up. The Eclipse application at this point shows the STEM Simulation Perspective.
STEM Simulation screen.
Simulation1.jpg

  • The Help->Help Context menubar selection has extensive information on running STEM.
  • The following "views" are shown in the STEM Simulation window.
    • Map
      Canvas that will show the image of the geographic area where the simulation is being run.
    • Simulation Control view
      Panel that both describes the status of the simulation and provides buttons to start and stop the simulation.
    • Scenarios
      The Scenarios window is use to select a prebuilt scenario for a simulation. By selecting leaves in the tree, you can discover an existing scenario for running a simulation. Select the scenario of choice and click the Run or Advance icon on the toolbar.
    • ErrorLog
      This log will contain information about any errors that occur while running the application. If things don't work as you expect, check this view to see if there are any errors or exceptions that have occurred. Note that the ErrorLog on the secondary Eclipse will show errors and exceptions that occur in the application being tested but stdout/stderr will be sent to the Console of the Primary Eclipse. Thus, if an exception is caught by the application and not passed to the built-in log facility, it will only show up on the Primary console. Likewise, if an exception is not caught and sent to stdout/stderr, then it will show up only on the secondary ErrorLog. Confusing!


There are also secondary application that may be selected from the Windows menu.

  • Select windows
    • Select GoogleEarth View
      This is an interface between STEM and the GoogleEarth application.

The basic idea of the GoogleEarth Interface is to allow the information about the geographic spread of diseases to be reflected on the GoogleEarth Web map. Detailed instructions for using the GoogleEarth Interface are included below. [1]

Installing Additional STEM Features

See section on STEM Add-ons

STEM uses the Automated Eclipse Updates to make it easier for users to install additional features to STEM. Today, one feature you may want to add is the Earth Science data plugin that contains global climate data for the years 2001-2010. This plugin is required if you want to use the Anopheles Mosquito model for example.

See the main article for instructions to install new features into STEM.

Updating STEM

Starting with version 1.4, you can use the update mechanism built into STEM to perform upgrades without re-downloading the full installation bundle. Most of the time, this means you don't have to re-download the large denominator data sets packaged in STEM or have to export and import your scenarios.

  1. Verify the computer is connected to a network and launch STEM
    If STEM is already open, save all edited files and stop any running simulations
  2. Open the Help Menu and choose Check for Updates
    STEM-Update-CheckForUpdatesMenu.png
  3. Wait while STEM contacts the updates server and checks for new versions
    • If no updates are available, a message saying No updates were found will appear. Click OK to return to STEM.
    • If an update is available, the Available Updates wizard will appear
  4. On the Available Updates page, verify STEM is selected, and click Next
    STEM-Update-AvailableUpdates.png
  5. Verify the list of items to be installed is correct and click Next
  6. Review the the licenses of the software being installed to verify you still accept
    If you accept the terms, select I Accept the terms of the license agreements and click Finish
    If you do not accept the terms, click Cancel
  7. Wait while STEM downloads and installs the updates
  8. If prompted with a security warning about installing unsigned software, click OK
  9. When prompted to apply changes, verify all open files are saved and click Restart Now
  10. STEM should automatically restart. If not, relaunch it manually.

Checking the Version of STEM Installed

After updating STEM, the version displayed on the splash screen at startup may not change to reflect the new version. To verify STEM updated successfully, check the STEM Installation Details.

  1. Open the Help menu and select About STEM
  2. Click Installation Details
  3. In the STEM Installation Details dialog, verify the installed version for STEM
    STEM-Update-InstalledDetailsVersion.png

Updating to Latest Integration or Milestone Build

By default, the STEM update feature only checks for the latest, official release approved by the Eclipse Foundation. However, users will often want to take advantage of new features published in weekly integration and/or periodic milestone and release candidate builds. You can easily configure STEM to download and install these updates.

  1. Launch STEM
  2. Open the Window menu and select Preferences
    On Mac OS X, Preferences is under the STEM menu
  3. In the Preferences window, expand Install/Update and select Available Software Sites
  4. Under Available Software Sites, Click Add
  5. In the Add Site dialog, enter the appropriate Name and Location
    For weekly integration builds:
    • Name: STEM Integration Builds
    • Location: http://download.eclipse.org/stem/update-site/integration/
    For periodic milestone and release candidate builds:
    • Name: STEM Stable Builds
    • Location: http://download.eclipse.org/stem/update-site/stable/
  6. Click OK to add the site
  7. Click OK to save Preferences and return to STEM
  8. Follow the steps in the previous section to update STEM
  9. To disable checking for non-release versions, disable or remove the sites added to the Available Software Sites list


Setting up the STEM Development Environment in Eclipse

If you might contribute to STEM development or if you want to always have the most recent code, then you will need to install Eclipse.

Go to tutorial on Setting up a STEM Development Environment