Skip to main content
Jump to: navigation, search

Difference between revisions of "SMILA/FAQ"

(New page: == FAQ == === Launching Smila === # "I started EILF.exe but EILF package isn´t in the tree of jconsole" #* create a new connection #* change your connection by declaring port "9004" und...)
 
(Launching a new crawler bundle)
Line 24: Line 24:
 
#** set the start level to 4 and the autostart to true
 
#** set the start level to 4 and the autostart to true
 
# “Could not find crawler id” while launching Smila with EILF.EXE
 
# “Could not find crawler id” while launching Smila with EILF.EXE
#* your bundle is´nt in config.ini or the start level isn´t correct.
+
#* your bundle isn`t in config.ini or the start level isn´t correct.
 
#** insert your bundle in config.ini like:
 
#** insert your bundle in config.ini like:
 
#** org.eclipse.eilf.connectivity.framework.crawler.owncrawler@5:start, \
 
#** org.eclipse.eilf.connectivity.framework.crawler.owncrawler@5:start, \
 +
#* include folder schemas/,OSGI-INF/ and file plugin.xml to the build.properties file of your bundle

Revision as of 10:37, 12 September 2008

FAQ

Launching Smila

  1. "I started EILF.exe but EILF package isn´t in the tree of jconsole"
    • create a new connection
    • change your connection by declaring port "9004" under remote
    • push "Connect" and change to MBeans.

Building Smila

  1. “Build Failed - Out of Memory - Java heap space” while building with EILF.builder
    • Ant hasn´t enough heap space to build the project. Use VM-arguments for expand the heap space.
      • Choose "Open external tool dialog" and select your ant-build profile. - Change to the tab "JRE" and insert in the VM Arguments textbox: "-Xms40m -Xmx512m"
      • Save and build again.


Launching a new crawler bundle

  1. “Could not find crawler id” while launching Smila with EILF.launch
    • your launcher didn´t start your new crawlerbundle
      • add your bundle by opening "Run dialog" and choose your EILF-profile
      • choose your bundle in list and check it on
      • set the start level to 4 and the autostart to true
  2. “Could not find crawler id” while launching Smila with EILF.EXE
    • your bundle isn`t in config.ini or the start level isn´t correct.
      • insert your bundle in config.ini like:
      • org.eclipse.eilf.connectivity.framework.crawler.owncrawler@5:start, \
    • include folder schemas/,OSGI-INF/ and file plugin.xml to the build.properties file of your bundle

Back to the top