Skip to main content
Jump to: navigation, search

SMILA/Documentation/HowTo/Howto set up dev environment

< SMILA‎ | Documentation‎ | HowTo
Revision as of 03:46, 2 April 2009 by Rrausch.brox.de (Talk | contribs) (Define target platform)

Setup an Eclipse instance/installation for SMILA

Set-up for SMILA developers

Installed Eclipse and delta-pack

If you still have not installed an eclipse and/or a delta-pack, you may download it from:

Checkout SMILA sources from Eclipse svn

You may check out our sources from:

http://dev.eclipse.org/svnroot/rt/org.eclipse.smila/


Import sources into Eclipse

If you don´t check out our sources into Eclipse, you have to import the sources into Eclipse see below:

Click File --> Import --> General --> Existing Projects into Workspace --> Next --> Select root folder of local trunk --> Finish


Define target platform

The goal of the following set up is to use Eclipse installation as target platform with adding the plug-ins from SMILA.extensions folder.

  • Click Window --> Preferences --> Plug-in Development --> Target Platform

Target.PNG


  • Click Add... --> Select File System --> Click Next --> Click Add --> Select SMILA.extension folder under local trunk
Launch SMILA in Eclipse

There is a folder SMILA.launch located in our trunk. This folder contains two launch configuration files for Eclipse. With these two files (one for windows (SMILA) and one for linux(SMILA-linux)) you have the possibility to start SMILA in Eclipse. Follow the steps below:

  • Click Debug --> Debug Configurations and expand OSGI Framework
  • Select launch file for your environment and press Debug

Launch-smila.png


  • If everything is started correctly, you will get an output in the Eclipse Console like below:

Console.png

Set-up for SMILA integrators

Installed Eclipse and delta-pack

If you still have not installed an eclipse and/or a delta-pack, you may download it from:

Define target platform

Start Ecliplse and set up a new workspace. After that you have to define a new target platform see below:

  • Download SMILA from http://www.eclipse.org/smila/downloads.php
  • Unzip SMILA-incubation-***.zip into a directory (e.g. E:\SMILA).
  • Download SMILA-test-plugins.zip from http://demo1.brox.de/pipelets/SMILA-test-plugins.zip
  • Unzip SMILA-test-plugins.zip into the plugins folder of your SMILA installation (e.g. E:\SMILA\plugins).
  • Click Window --> Preferences --> Plug-in Development --> Target Platform --> Click Browse --> Select SMILA installation folder (e.g E:\SMILA). --> Apply --> OK

Copyright © Eclipse Foundation, Inc. All Rights Reserved.