Jump to: navigation, search

Difference between revisions of "SMILA/Documentation/HowTo/Howto set up dev environment"

(Add example projects)
 
(15 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
<br> This HowTo describes the necessary steps for setting up a SMILA development environment.  
 
<br> This HowTo describes the necessary steps for setting up a SMILA development environment.  
  
==== Preconditions  ====
+
=== Preconditions  ===
  
 
Here is the list of things that you will definitely need for developing SMILA components:  
 
Here is the list of things that you will definitely need for developing SMILA components:  
  
* JDK 1.7
+
* JDK 1.7 (Java 8 is not yet supported by SMILA).
* Recent Eclipse SDK - This HowTo was tested with [http://download.eclipse.org/eclipse/downloads/drops4/R-4.2-201206081400/ Eclipse Classic SDK 4.2] (Juno Release) <br>  
+
* Eclipse SDK - This HowTo was tested with [http://download.eclipse.org/eclipse/downloads/drops4/R-4.4.1-201409250400/ Eclipse Classic SDK 4.4.1] (Luna Release) <br>
  
==== Getting the source code ====
+
=== Getting the source code ===
  
There is more than one way of getting the code into your Eclipse workspace. The following sections will describe how to get the source code via SVN (recommended!).  
+
There is more than one way of getting the code into your Eclipse workspace. The following sections will describe how to get the source code from the Git repository (recommended!).  
  
 
As an alternative, you could download the complete source code from the [http://www.eclipse.org/smila/downloads.php release download page] or the [http://build.eclipse.org/rt/smila/nightly/ nightly build downloads] and unpack the archive into your workspace.  
 
As an alternative, you could download the complete source code from the [http://www.eclipse.org/smila/downloads.php release download page] or the [http://build.eclipse.org/rt/smila/nightly/ nightly build downloads] and unpack the archive into your workspace.  
  
===== Installing SVN Provider =====
+
==== Installing Git Provider ====
''(skip this section if SVN Team Provider is already installed in your eclipse IDE)''
+
  
* Install ''Subversive SVN Team Provider'' and ''Subversive SVN JDT Ignore Extensions'' from the Eclipse software repository.<br>
+
''(skip this section if Git Team Provider is already installed in your Eclipse IDE - most current Eclipse Packages do contain it)''
 +
 
 +
* Install ''Eclipse Git Team Provider'' and ''Java Implementaton of Git'' from the Eclipse software repository.
 
* Restart Eclipse.  
 
* Restart Eclipse.  
* Select ''Windows &gt; Preferences &gt; Team &gt; SVN''. This should open the ''Subversive Connector Discovery'' window.
 
* Select the Subversive SVN Connector that you wish to use. We suggest to take the latest SVN Kit that is offered. At the time of writing it was SVN Kit 1.3.5.
 
  
===== Get source code from SVN =====
+
==== Get source code from Git ====
  
There are two ways for this, automatically by using the ''Project Set File'' or manually. Both are described in the following:  
+
* Open the "Git" perspective
 +
* Select "Clone a Git repository"
 +
* Enter one of the following URIs for read-only access:
 +
** <tt>git://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git</tt>
 +
** <tt>http://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git</tt>
 +
(** Committers: use <tt>ssh://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git</tt> for read-write access and enter your credentials below)
 +
* Click "Next". In the following dialog ensure that branch "master" and other branches you need are selected (there are no other branches at the time of writing ;-)
 +
* Enter the desired location of your clone of the Git repository. You can put this into your current workspace, but this is not necessary.
 +
** You can activate the "Import all existing projects after clone finishes" now to import ALL projects, or you can manually import them afterwards to be a bit more selective.
 +
* Click "Finish". The Git repository will be cloned now. This will probably take a few minutes.
 +
* Switch to the "Plug-in Development" perspective.
 +
* To import the projects into the workspace (if not done automatically):
 +
** Open "File" -> "Import ..." and select "Git"/"Projects from Git". Click "Next" and select "Existing local repository". Click "Next" and select "org.eclipse.smila.core - ...". Click "Next".
 +
** Select "Import existing projects" and "core" in the tree below, and click "Next". Make sure all projects are selected and click "Finish".
 +
* After a while a "Problem occurred" dialog will open and there will be lots of compile errors. This is OK, we will fix this now.
  
''manually checking out and importing the projects:''
 
* Use your favorite SVN client to check out SMILA's source code from the repository located at:<br> <tt>https://dev.eclipse.org/svnroot/rt/org.eclipse.smila/trunk/core</tt>. If you later want to be able to build a SMILA distribution, all SMILA projects should be located in the same directory.
 
::'''Hint:''' ''We recommend to check out the {{code|trunk/core}} as opposed to importing the projects through IDE SVN integrations. By doing so, you can easily get new projects just by updating your working copy and reimporting the sources.''
 
* Import all SMILA project into your workspace:
 
** Click ''File'' &gt; ''Import'' &gt; ''General'' &gt; ''Existing Projects into Workspace'' &gt; ''Next.''
 
** Select the folder that contains all SMILA projects --&gt; (all projects should be selected automatically) &gt; ''Finish''.
 
  
''automatic checkout and import by using the Project Set File:''
+
=== Defining the target platform  ===
* In eclipse, create an SVN repository location with URL <tt>https://dev.eclipse.org/svnroot/rt/org.eclipse.smila</tt>
+
* Checkout <tt>trunk/releng</tt>
+
* Right click on <tt>SMILA.releng/devenv.SMILA-core.psf</tt>
+
* Click ''Import Project Set...'' and choose "No To All"
+
::'''Hint:''': ''New projects should always be added to the .psf file so you can import them (as before): right click on .psf file and click on "Import Project Set...", be sure to click "No To All" to the question whether to overwrite existing projects in the workspace, otherwise it will check out everything again instead of ignoring the projects, that are already checked out. If projects are removed you have to remove them manually from the workspace, this can't be handled via .psf file.''
+
  
After having imported the source code into your workspace, it will show up a lot of errors. Don't worry, they'll disappear after the next steps below.
+
The target platform defines the set of bundles and features that you are developing against. SMILA ships a ''Target Definition File'' that you can open in your IDE to configure the target platform automatically. This file contains all the references needed for developing SMILA with Eclipse Luna (Release 4.4.1).
  
==== Defining the target platform ====
+
==== Using the target platform provided by SMILA ====
  
The target platform defines the set of bundles and features that you are developing against. SMILA ships a ''Target Definition File'' that you can open in your IDE to configure the target platform automatically. This file contains all the references needed for developing SMILA with Eclipse Juno (Release 4.2).
+
* Import project "SMILA.devenv" from the "releng" directory of your local Git repository (same procedure as for importing the other projects).
 +
* Open the file <tt>SMILA.devenv/SMILA.target</tt> with the ''Target Definition'' editor. <br>Eclipse starts downloading the referenced bundles/features which it tells you by stating "Resolving Target Definition" in its status bar. Be patient, this will take a while. After it has finished, you can click the link "Set as Target Platform" on the top right of the ''Target Definition'' editor. Doing so will cause Eclipse to start re-compiling the sources and all error markers should be gone when finished.
 +
** If you have the Checkstyle Eclipse plugin installed in your IDE, you will still get error messages. See [[/SMILA/Development_Guidelines#Checkstyle Checkstyle configuration]] for instructions on how to fix this.
  
===== Using the target platform provided by SMILA =====
+
==== Defining the target platform manually  ====
 
+
* Checkout <tt>../org.eclipse.smila/trunk/releng</tt>  (''if you haven't already done before'')
+
* Open the file <tt>SMILA.releng/devenv/SMILA.target</tt> with the ''Target Definition'' editor. <br>Eclipse starts downloading the referenced bundles/features which it tells you by stating "Resolving Target Definition" in its status bar. Be patient, this will take quite a while. After it has finished, you can click the link "Set as Target Platform" on the top right of the ''Target Definition'' editor. Doing so will cause Eclipse to start re-compiling the sources and all error markers should be gone when finished.
+
 
+
===== Defining the target platform manually  =====
+
  
 
* Instead of using the target definition file provided by SMILA (see above) you can also [[SMILA/Development Guidelines/Howto set up target platform|manually set your own target platform]].
 
* Instead of using the target definition file provided by SMILA (see above) you can also [[SMILA/Development Guidelines/Howto set up target platform|manually set your own target platform]].
  
==== Launching SMILA in Eclipse IDE  ====
+
=== Launching SMILA in Eclipse IDE  ===
  
 
If you've checked out SMILA's trunk correctly, you should have a project called '''SMILA.launch''' in your workspace. This project contains the SMILA's launch configuration for Eclipse IDE. To start SMILA directly in your Eclipse IDE, just follow the steps below:  
 
If you've checked out SMILA's trunk correctly, you should have a project called '''SMILA.launch''' in your workspace. This project contains the SMILA's launch configuration for Eclipse IDE. To start SMILA directly in your Eclipse IDE, just follow the steps below:  
Line 75: Line 74:
 
</source>
 
</source>
  
==== You're done  ====
+
=== You're done  ===
  
 
Congratulations! You've just successfully checked out and configured your SMILA development environment and you can now start [[SMILA/Development Guidelines/Create a bundle (plug-in)|developing your own bundles]].
 
Congratulations! You've just successfully checked out and configured your SMILA development environment and you can now start [[SMILA/Development Guidelines/Create a bundle (plug-in)|developing your own bundles]].
  
==== Additional steps ====
+
=== Additional steps ===
  
 
The following steps may be needed for special purposes. If you are a SMILA user who only wants to integrate an own component you won't need them.   
 
The following steps may be needed for special purposes. If you are a SMILA user who only wants to integrate an own component you won't need them.   
  
===== Delta Pack =====
+
==== Checkstyle configuration ====
''(only needed for building the software outside of eclipse IDE)''
+
 
+
For building the software you may need to add a "Delta Pack" to an Eclipse SDK installation. You can download it from the [http://download.eclipse.org/eclipse/downloads/drops4/R-4.2-201206081400/ here]. After downloading, you can copy the contained plugins and features in your eclipse installation.
+
 
+
===== Checkstyle configuration =====
+
  
 
If you have the [http://eclipse-cs.sourceforge.net/ Eclipse Checkstyle plugin] installed, you will get a lot of error messages complaining about missing check configurations when Eclipse builds the workspace.
 
If you have the [http://eclipse-cs.sourceforge.net/ Eclipse Checkstyle plugin] installed, you will get a lot of error messages complaining about missing check configurations when Eclipse builds the workspace.
(''Hint: For installing the Checkstyle plugin, use location: "http://eclipse-cs.sf.net/update/"'')
 
  
 
<source lang="text">
 
<source lang="text">
Line 99: Line 92:
 
</source>
 
</source>
  
You can solve this by importing them:
+
You can solve this by [[SMILA/Development_Guidelines#Checkstyle|setup your Checkstyle configuration]].
* Open ''Window -> Preferences'' and go to ''Checkstyle''.
+
 
* Click ''New...'', enter <tt>SMILA Checkstyle</tt> as the name, click ''Import...'', and select ''SMILA.builder/checkstyle/smila_checkstyle-5.xml'' from your workspace. Click ''OK''.
+
==== Setting up the Eclipse build ====
* Click ''New...'' again, enter <tt>SMILA Test Checkstyle</tt> as the name, click ''Import...'', and select ''SMILA.builder/checkstyle/smila-test_checkstyle-5.xml'' from your workspace. Click ''OK''.
+
 
* Select <tt>SMILA Checkstyle</tt> and click ''Set as Default''.
+
See [[SMILA/Documentation/HowTo/Howto_build_a_SMILA-Distribution]] for details on how to setup a build for SMILA.
* Click ''OK''. <br> Now you should not get those error messages again.
+
 
 +
==== Add <tt>examples</tt> projects ====
 +
 
 +
The <tt>examples</tt> directory of the repository contains three simple bundles that demonstrate how to develop SMILA pipelets and workers. You can import them to your workspace just like the other projects.
  
===== Enabling the BPEL Designer =====
+
==== Enabling the BPEL Designer ====
  
If you want to work with the SMILA extensions for Eclipse BPEL designer, you need to check out the bundles from <tt>trunk/tooling</tt>. Currently, the required bundles are:  
+
If you want to work with the SMILA extensions for Eclipse BPEL designer, you need to clone the Git repository at <tt>http://git.eclipse.org/gitroot/smila/org.eclipse.smila.tooling.git</tt> (or <tt>git://...</tt> or <tt>ssh://...</tt>). Currently, the required bundles are:
  
 
*<tt>org.eclipse.smila.processing.designer.model</tt>  
 
*<tt>org.eclipse.smila.processing.designer.model</tt>  

Latest revision as of 04:22, 19 December 2014


This HowTo describes the necessary steps for setting up a SMILA development environment.

Preconditions

Here is the list of things that you will definitely need for developing SMILA components:

  • JDK 1.7 (Java 8 is not yet supported by SMILA).
  • Eclipse SDK - This HowTo was tested with Eclipse Classic SDK 4.4.1 (Luna Release)

Getting the source code

There is more than one way of getting the code into your Eclipse workspace. The following sections will describe how to get the source code from the Git repository (recommended!).

As an alternative, you could download the complete source code from the release download page or the nightly build downloads and unpack the archive into your workspace.

Installing Git Provider

(skip this section if Git Team Provider is already installed in your Eclipse IDE - most current Eclipse Packages do contain it)

  • Install Eclipse Git Team Provider and Java Implementaton of Git from the Eclipse software repository.
  • Restart Eclipse.

Get source code from Git

(** Committers: use ssh://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git for read-write access and enter your credentials below)

  • Click "Next". In the following dialog ensure that branch "master" and other branches you need are selected (there are no other branches at the time of writing ;-)
  • Enter the desired location of your clone of the Git repository. You can put this into your current workspace, but this is not necessary.
    • You can activate the "Import all existing projects after clone finishes" now to import ALL projects, or you can manually import them afterwards to be a bit more selective.
  • Click "Finish". The Git repository will be cloned now. This will probably take a few minutes.
  • Switch to the "Plug-in Development" perspective.
  • To import the projects into the workspace (if not done automatically):
    • Open "File" -> "Import ..." and select "Git"/"Projects from Git". Click "Next" and select "Existing local repository". Click "Next" and select "org.eclipse.smila.core - ...". Click "Next".
    • Select "Import existing projects" and "core" in the tree below, and click "Next". Make sure all projects are selected and click "Finish".
  • After a while a "Problem occurred" dialog will open and there will be lots of compile errors. This is OK, we will fix this now.


Defining the target platform

The target platform defines the set of bundles and features that you are developing against. SMILA ships a Target Definition File that you can open in your IDE to configure the target platform automatically. This file contains all the references needed for developing SMILA with Eclipse Luna (Release 4.4.1).

Using the target platform provided by SMILA

  • Import project "SMILA.devenv" from the "releng" directory of your local Git repository (same procedure as for importing the other projects).
  • Open the file SMILA.devenv/SMILA.target with the Target Definition editor.
    Eclipse starts downloading the referenced bundles/features which it tells you by stating "Resolving Target Definition" in its status bar. Be patient, this will take a while. After it has finished, you can click the link "Set as Target Platform" on the top right of the Target Definition editor. Doing so will cause Eclipse to start re-compiling the sources and all error markers should be gone when finished.

Defining the target platform manually

Launching SMILA in Eclipse IDE

If you've checked out SMILA's trunk correctly, you should have a project called SMILA.launch in your workspace. This project contains the SMILA's launch configuration for Eclipse IDE. To start SMILA directly in your Eclipse IDE, just follow the steps below:

  • Click Run--> Debug Configurations and expand OSGI Framework.
  • Select the SMILA launch file.
  • Click Debug.
    If everything works fine, you will get an output in the Console view similar to the following:
osgi> Persistence bundle starting...
ProviderTracker: New service detected...
ProviderTracker: Added service org.eclipse.persistence.jpa.osgi.PersistenceProviderOSGi
Persistence bundle started.
[INFO ] Context /zookeeper: Registered handler(1) ZooKeeperAdminHandler, pattern /(.*)$
[INFO ] Added worker webFetcher to WorkerManager.
...
[INFO ] HTTP server has SMILA handler RequestDispatcher for context /smila.
[INFO ] HTTP server started successfully on port 8080.

You're done

Congratulations! You've just successfully checked out and configured your SMILA development environment and you can now start developing your own bundles.

Additional steps

The following steps may be needed for special purposes. If you are a SMILA user who only wants to integrate an own component you won't need them.

Checkstyle configuration

If you have the Eclipse Checkstyle plugin installed, you will get a lot of error messages complaining about missing check configurations when Eclipse builds the workspace.

Errors running builder 'Checkstyle Builder' on project 'org.eclipse.smila.utils'.
Fileset from project "org.eclipse.smila.utils" has no valid check configuration.
...

You can solve this by setup your Checkstyle configuration.

Setting up the Eclipse build

See SMILA/Documentation/HowTo/Howto_build_a_SMILA-Distribution for details on how to setup a build for SMILA.

Add examples projects

The examples directory of the repository contains three simple bundles that demonstrate how to develop SMILA pipelets and workers. You can import them to your workspace just like the other projects.

Enabling the BPEL Designer

If you want to work with the SMILA extensions for Eclipse BPEL designer, you need to clone the Git repository at http://git.eclipse.org/gitroot/smila/org.eclipse.smila.tooling.git (or git://... or ssh://...). Currently, the required bundles are:

  • org.eclipse.smila.processing.designer.model
  • org.eclipse.smila.processing.designer.ui

To compile them you need additional bundles from the Eclipse BPEL Designer in your target platform. See SMILA/BPEL Designer for more information.