Skip to main content
Jump to: navigation, search

Difference between revisions of "SMILA/Documentation/HowTo/Howto set up dev environment"

m (Define target platform)
(Using the target platform provided by SMILA)
 
(111 intermediate revisions by 11 users not shown)
Line 1: Line 1:
[[Category:SMILA]]
+
<br> This HowTo describes the necessary steps for setting up a SMILA development environment.
=== Setup an Eclipse instance/installation for SMILA ===
+
  
=== Set-up for SMILA developers ===
+
=== Preconditions  ===
  
===== Installed Eclipse and delta-pack =====
+
Here is the list of things that you will definitely need for developing SMILA components:  
If you still have not installed an eclipse and/or a delta-pack, you may download it from:
+
::* '''Eclipse download location:''' http://www.eclipse.org/downloads/
+
::* '''Delta-pack download location:''' http://download.eclipse.org/eclipse/downloads/
+
  
===== Checkout SMILA sources from Eclipse svn =====
+
* JDK 1.7 (Java 8 is not yet supported by SMILA).
You may check out our sources from:
+
* Eclipse SDK - This HowTo was tested with [http://download.eclipse.org/eclipse/downloads/drops4/R-4.4.2-201502041700/ Eclipse Classic SDK 4.4.2] (Luna SR2 Release) <br>
<pre>http://dev.eclipse.org/svnroot/rt/org.eclipse.smila/</pre>
+
  
 +
=== Getting the source code ===
  
===== Import sources into Eclipse =====
+
There is more than one way of getting the code into your Eclipse workspace. The following sections will describe how to get the source code from the Git repository (recommended!).
If you don´t check out our sources into Eclipse, you have to import the sources into Eclipse see below:
+
  
Click File --> Import --> General --> Existing Projects into Workspace --> Next --> Select root folder of local trunk --> Finish
+
As an alternative, you could download the complete source code from the [http://www.eclipse.org/smila/downloads.php release download page] or the [http://build.eclipse.org/rt/smila/nightly/ nightly build downloads] and unpack the archive into your workspace.
  
 +
==== Installing Git Provider ====
  
===== Define target platform =====
+
''(skip this section if Git Team Provider is already installed in your Eclipse IDE - most current Eclipse Packages do contain it)''
The goal of the following set up is to use Eclipse installation as target platform with adding the plug-ins from SMILA.extensions folder.
+
::* Click Window --> Preferences --> Plug-in Development --> Target Platform
+
  
[[Image:Target.PNG]]
+
* Install ''Eclipse Git Team Provider'' and ''Java Implementaton of Git'' from the Eclipse software repository.
 +
* Restart Eclipse.  
  
 +
==== Get source code from Git ====
  
::* Click Add... --> Select File System --> Click Next --> Click Add --> Select SMILA.extension folder under local trunk
+
* Open the "Git" perspective
 +
* Select "Clone a Git repository"
 +
* Enter one of the following URIs for read-only access:
 +
** <tt>git://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git</tt>
 +
** <tt>http://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git</tt>
 +
(** Committers: use <tt>ssh://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git</tt> for read-write access and enter your credentials below)
 +
* Click "Next". In the following dialog ensure that branch "master" and other branches you need are selected (there are no other branches at the time of writing ;-)
 +
* Enter the desired location of your clone of the Git repository. You can put this into your current workspace, but this is not necessary.
 +
** You can activate the "Import all existing projects after clone finishes" now to import ALL projects, or you can manually import them afterwards to be a bit more selective.
 +
* Click "Finish". The Git repository will be cloned now. This will probably take a few minutes.
 +
* Switch to the "Plug-in Development" perspective.
 +
* To import the projects into the workspace (if not done automatically):
 +
** Open "File" -> "Import ..." and select "Git"/"Projects from Git". Click "Next" and select "Existing local repository". Click "Next" and select "org.eclipse.smila.core - ...". Click "Next".
 +
** Select "Import existing projects" and "core" in the tree below, and click "Next". Make sure all projects are selected and click "Finish".
 +
* After a while a "Problem occurred" dialog will open and there will be lots of compile errors. This is OK, we will fix this now.
  
===== Launch SMILA in Eclipse =====
 
  
There is a folder '''SMILA.launch''' located in our trunk. This folder contains two launch configuration files for Eclipse. With these two files (one for windows (SMILA) and one for linux(SMILA-linux)) you have the possibility to start SMILA in Eclipse. Follow the steps below:
+
=== Defining the target platform  ===
::* Click '''Debug''' --> '''Debug Configurations''' and expand '''OSGI Framework'''
+
::* Select launch file for your environment and press '''Debug'''
+
[[Image:Launch-smila.png]]
+
:: <br/>
+
::* If everything is started correctly, you will get an output in the '''Eclipse Console''' like below:
+
[[Image:Console.png]]
+
  
=== Set-up for SMILA integrators ===
+
The target platform defines the set of bundles and features that you are developing against. SMILA ships a ''Target Definition File'' that you can open in your IDE to configure the target platform automatically. This file contains all the references needed for developing SMILA with Eclipse Luna SR2 (Release 4.4.2).
  
===== Installed Eclipse and delta-pack =====
+
==== Using the target platform provided by SMILA ====
If you still have not installed an eclipse and/or a delta-pack, you may download it from:
+
::* '''Eclipse download location:''' http://www.eclipse.org/downloads/
+
::* '''Delta-pack download location:''' http://download.eclipse.org/eclipse/downloads/
+
  
===== Define target platform =====
+
* Import project "SMILA.devenv" from the "releng" directory of your local Git repository (same procedure as for importing the other projects).
Start Ecliplse and set up a new workspace. After that you have to define a new target platform see below:
+
* Open the file <tt>SMILA.devenv/SMILA.target</tt> with the ''Target Editor''. <br>Eclipse starts downloading the referenced bundles/features which it tells you by stating "Resolving Target Definition" in its status bar. Be patient, this will take a while. After it has finished, you can click the link "Set as Target Platform" on the top right of the ''Target Definition'' editor. Doing so will cause Eclipse to start re-compiling the sources and all error markers should be gone when finished.
 +
* If you have the Checkstyle Eclipse plugin installed in your IDE, you will still get error messages. See [[SMILA/Development_Guidelines#Checkstyle |Checkstyle configuration]] for instructions on how to fix this.
  
:* Download SMILA from http://www.eclipse.org/smila/downloads.php
+
==== Defining the target platform manually  ====
:* Unzip SMILA-incubation-***.zip into a directory (e.g. E:\SMILA).  
+
 
:* Download SMILA-test-plugins.zip from http://demo1.brox.de/pipelets/SMILA-test-plugins.zip
+
* Instead of using the target definition file provided by SMILA (see above) you can also [[SMILA/Development Guidelines/Howto set up target platform|manually set your own target platform]].
:* Unzip SMILA-test-plugins.zip into the plugins folder of your SMILA installation (e.g. E:\SMILA\plugins).  
+
 
:* Click Window --> Preferences --> Plug-in Development --> Target Platform --> Click Browse --> Select SMILA installation folder (e.g E:\SMILA). --> Apply --> OK
+
=== Launching SMILA in Eclipse IDE  ===
 +
 
 +
If you've checked out SMILA's trunk correctly, you should have a project called '''SMILA.launch''' in your workspace. This project contains the SMILA's launch configuration for Eclipse IDE. To start SMILA directly in your Eclipse IDE, just follow the steps below:  
 +
 
 +
* Click <span style="font-style: italic;">Run</span>--&gt; ''Debug Configurations'' and expand '''''OSGI Framework'''''<b>.</b>
 +
* Select the ''SMILA'' launch file.
 +
* Click '''Debug'''. <br> If everything works fine, you will get an output in the '''Console''' view similar to the following:
 +
 
 +
<source lang="text">
 +
osgi> Persistence bundle starting...
 +
ProviderTracker: New service detected...
 +
ProviderTracker: Added service org.eclipse.persistence.jpa.osgi.PersistenceProviderOSGi
 +
Persistence bundle started.
 +
[INFO ] Context /zookeeper: Registered handler(1) ZooKeeperAdminHandler, pattern /(.*)$
 +
[INFO ] Added worker webFetcher to WorkerManager.
 +
...
 +
[INFO ] HTTP server has SMILA handler RequestDispatcher for context /smila.
 +
[INFO ] HTTP server started successfully on port 8080.
 +
</source>
 +
 
 +
=== You're done  ===
 +
 
 +
Congratulations! You've just successfully checked out and configured your SMILA development environment and you can now start [[SMILA/Development Guidelines/Create a bundle (plug-in)|developing your own bundles]].
 +
 
 +
=== Additional steps ===
 +
 
 +
The following steps may be needed for special purposes. If you are a SMILA user who only wants to integrate an own component you won't need them. 
 +
 
 +
==== Checkstyle configuration ====
 +
 
 +
If you have the [http://eclipse-cs.sourceforge.net/ Eclipse Checkstyle plugin] installed, you will get a lot of error messages complaining about missing check configurations when Eclipse builds the workspace.
 +
 
 +
<source lang="text">
 +
Errors running builder 'Checkstyle Builder' on project 'org.eclipse.smila.utils'.
 +
Fileset from project "org.eclipse.smila.utils" has no valid check configuration.
 +
...
 +
</source>
 +
 
 +
You can solve this by [[SMILA/Development_Guidelines#Checkstyle|setup your Checkstyle configuration]].
 +
 
 +
==== Setting up the Eclipse build ====
 +
 
 +
See [[SMILA/Documentation/HowTo/Howto_build_a_SMILA-Distribution]] for details on how to setup a build for SMILA.
 +
 
 +
==== Add <tt>examples</tt> projects ====
 +
 
 +
The <tt>examples</tt> directory of the repository contains three simple bundles that demonstrate how to develop SMILA pipelets and workers. You can import them to your workspace just like the other projects.
 +
 
 +
==== Enabling the BPEL Designer ====
 +
 
 +
If you want to work with the SMILA extensions for Eclipse BPEL designer, you need to clone the Git repository at <tt>http://git.eclipse.org/gitroot/smila/org.eclipse.smila.tooling.git</tt> (or <tt>git://...</tt> or <tt>ssh://...</tt>). Currently, the required bundles are:
 +
 
 +
*<tt>org.eclipse.smila.processing.designer.model</tt>  
 +
*<tt>org.eclipse.smila.processing.designer.ui</tt>
 +
 
 +
To compile them you need additional bundles from the [http://www.eclipse.org/bpel Eclipse BPEL Designer] in your target platform. See [[SMILA/BPEL Designer]] for more information.
 +
 
 +
 
 +
[[Category:SMILA]]

Latest revision as of 15:34, 4 May 2015


This HowTo describes the necessary steps for setting up a SMILA development environment.

Preconditions

Here is the list of things that you will definitely need for developing SMILA components:

  • JDK 1.7 (Java 8 is not yet supported by SMILA).
  • Eclipse SDK - This HowTo was tested with Eclipse Classic SDK 4.4.2 (Luna SR2 Release)

Getting the source code

There is more than one way of getting the code into your Eclipse workspace. The following sections will describe how to get the source code from the Git repository (recommended!).

As an alternative, you could download the complete source code from the release download page or the nightly build downloads and unpack the archive into your workspace.

Installing Git Provider

(skip this section if Git Team Provider is already installed in your Eclipse IDE - most current Eclipse Packages do contain it)

  • Install Eclipse Git Team Provider and Java Implementaton of Git from the Eclipse software repository.
  • Restart Eclipse.

Get source code from Git

(** Committers: use ssh://git.eclipse.org/gitroot/smila/org.eclipse.smila.core.git for read-write access and enter your credentials below)

  • Click "Next". In the following dialog ensure that branch "master" and other branches you need are selected (there are no other branches at the time of writing ;-)
  • Enter the desired location of your clone of the Git repository. You can put this into your current workspace, but this is not necessary.
    • You can activate the "Import all existing projects after clone finishes" now to import ALL projects, or you can manually import them afterwards to be a bit more selective.
  • Click "Finish". The Git repository will be cloned now. This will probably take a few minutes.
  • Switch to the "Plug-in Development" perspective.
  • To import the projects into the workspace (if not done automatically):
    • Open "File" -> "Import ..." and select "Git"/"Projects from Git". Click "Next" and select "Existing local repository". Click "Next" and select "org.eclipse.smila.core - ...". Click "Next".
    • Select "Import existing projects" and "core" in the tree below, and click "Next". Make sure all projects are selected and click "Finish".
  • After a while a "Problem occurred" dialog will open and there will be lots of compile errors. This is OK, we will fix this now.


Defining the target platform

The target platform defines the set of bundles and features that you are developing against. SMILA ships a Target Definition File that you can open in your IDE to configure the target platform automatically. This file contains all the references needed for developing SMILA with Eclipse Luna SR2 (Release 4.4.2).

Using the target platform provided by SMILA

  • Import project "SMILA.devenv" from the "releng" directory of your local Git repository (same procedure as for importing the other projects).
  • Open the file SMILA.devenv/SMILA.target with the Target Editor.
    Eclipse starts downloading the referenced bundles/features which it tells you by stating "Resolving Target Definition" in its status bar. Be patient, this will take a while. After it has finished, you can click the link "Set as Target Platform" on the top right of the Target Definition editor. Doing so will cause Eclipse to start re-compiling the sources and all error markers should be gone when finished.
  • If you have the Checkstyle Eclipse plugin installed in your IDE, you will still get error messages. See Checkstyle configuration for instructions on how to fix this.

Defining the target platform manually

Launching SMILA in Eclipse IDE

If you've checked out SMILA's trunk correctly, you should have a project called SMILA.launch in your workspace. This project contains the SMILA's launch configuration for Eclipse IDE. To start SMILA directly in your Eclipse IDE, just follow the steps below:

  • Click Run--> Debug Configurations and expand OSGI Framework.
  • Select the SMILA launch file.
  • Click Debug.
    If everything works fine, you will get an output in the Console view similar to the following:
osgi> Persistence bundle starting...
ProviderTracker: New service detected...
ProviderTracker: Added service org.eclipse.persistence.jpa.osgi.PersistenceProviderOSGi
Persistence bundle started.
[INFO ] Context /zookeeper: Registered handler(1) ZooKeeperAdminHandler, pattern /(.*)$
[INFO ] Added worker webFetcher to WorkerManager.
...
[INFO ] HTTP server has SMILA handler RequestDispatcher for context /smila.
[INFO ] HTTP server started successfully on port 8080.

You're done

Congratulations! You've just successfully checked out and configured your SMILA development environment and you can now start developing your own bundles.

Additional steps

The following steps may be needed for special purposes. If you are a SMILA user who only wants to integrate an own component you won't need them.

Checkstyle configuration

If you have the Eclipse Checkstyle plugin installed, you will get a lot of error messages complaining about missing check configurations when Eclipse builds the workspace.

Errors running builder 'Checkstyle Builder' on project 'org.eclipse.smila.utils'.
Fileset from project "org.eclipse.smila.utils" has no valid check configuration.
...

You can solve this by setup your Checkstyle configuration.

Setting up the Eclipse build

See SMILA/Documentation/HowTo/Howto_build_a_SMILA-Distribution for details on how to setup a build for SMILA.

Add examples projects

The examples directory of the repository contains three simple bundles that demonstrate how to develop SMILA pipelets and workers. You can import them to your workspace just like the other projects.

Enabling the BPEL Designer

If you want to work with the SMILA extensions for Eclipse BPEL designer, you need to clone the Git repository at http://git.eclipse.org/gitroot/smila/org.eclipse.smila.tooling.git (or git://... or ssh://...). Currently, the required bundles are:

  • org.eclipse.smila.processing.designer.model
  • org.eclipse.smila.processing.designer.ui

To compile them you need additional bundles from the Eclipse BPEL Designer in your target platform. See SMILA/BPEL Designer for more information.

Back to the top