Difference between revisions of "SMILA/Development Guidelines/How to set up integration environment"

From Eclipsepedia

Jump to: navigation, search
(WORK IN PROGRESS)
 
(31 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
[[Category:SMILA]]
 
[[Category:SMILA]]
  
 +
{{note|This is outdated, please refer to [[SMILA/Development Guidelines/Howto set up dev environment|How to set up the development environment]]}}
  
 
This how-to describes the necessary steps for setting up SMILA integration environment. Normally this setup is only interesting for SMILA integrators who just want to integrate their components in SMILA. SMILA committers and contributors should work with another setup described at [[SMILA/Development Guidelines/Howto set up dev environment|How to set up the development environment]].
 
This how-to describes the necessary steps for setting up SMILA integration environment. Normally this setup is only interesting for SMILA integrators who just want to integrate their components in SMILA. SMILA committers and contributors should work with another setup described at [[SMILA/Development Guidelines/Howto set up dev environment|How to set up the development environment]].
Line 8: Line 9:
 
Here is the list of things that you will definitely need for developing SMILA components:
 
Here is the list of things that you will definitely need for developing SMILA components:
 
#JDK 1.6
 
#JDK 1.6
#Eclipse SDK - This howto was tested with [http://www.eclipse.org/downloads/packages/eclipse-classic-362/heliossr2 Eclipse 3.6.2]
+
#Eclipse SDK - This howto was tested with [http://download.eclipse.org/eclipse/downloads/drops/R-3.7.1-201109091335/index.php Eclipse SDK 3.7.1 (Indigo SR1)] (it might still work with Eclipse SDK 3.6.2, too).
 
#SMILA binary distribution
 
#SMILA binary distribution
  
Line 14: Line 15:
  
 
Just pick up the latest binary distribution of SMILA:
 
Just pick up the latest binary distribution of SMILA:
* [http://build.eclipse.org/rt/smila/nightly/ nightly build] - the following currently works only with the nightly build
+
* [http://www.eclipse.org/smila/downloads.php release 0.9 or higher] or
* [http://www.eclipse.org/smila/downloads.php release 0.9 or higher] - not yet available
+
* [http://build.eclipse.org/rt/smila/nightly/ nightly build]  
  
 
Simply unzip the file you downloaded into a new directory on your local hard disk and you've done with the installation.
 
Simply unzip the file you downloaded into a new directory on your local hard disk and you've done with the installation.
Line 21: Line 22:
 
==== Create a new Workspace and setup target platform ====
 
==== Create a new Workspace and setup target platform ====
  
Start your Eclipse SDK and let it create a new workspace at a location of your choice. Then you use the SMILA binaries as the target platform for plugin develoment. This enables you to create own bundles that can use the code in the SMILA bundles:
+
Extract your eclipse SDK (be sure, it's just the plain SDK and no JEE-IDE) into another directory, named e.g. eclipse-SDK). This will save you lots of trouble when setting up the target environment.
  
* Open Windows -> Preferences
+
Start your Eclipse SDK and create a new workspace at a location of your choice. Then use the SMILA binaries as the target platform for plugin develoment. This enables you to create own bundles that can use the code in the SMILA bundles:
* Window --> Preferences --> Plug-in Development --> Target Platform --> Add...
+
 
* Initialize the target definition with: Nothing --> Next
+
'''To set up the target platform'''
* Insert some sensible name (how about "SMILA", maybe? ;-)
+
 
* In the "Location" tab, click "Add"
+
* Open "Windows" -> "Preferences".
** Select "Installation" --> Click "Next"
+
* Select "Plug-in Development" --> "Target Platform" --> "Add".
** In the "Location" slot, browse to your directory where you installed SMILA (do not press <Enter>)  
+
* Initialize the target definition with: "Nothing --> Next".
** --> click "Finish"
+
* Enter a reasonable name (how about "SMILA", maybe? ;-).
* In the "Location" tab, click "Add" again
+
* In the "Locations" tab, click "Add".
** select "Features" --> Click "Next"
+
** Select "Installation" --> Click "Next".
** in the "Location" slot select "${eclipse_home}"
+
** Click "Browse" and navigate to the directory where you installed SMILA (do not press <Enter> yet).
** select Features "org.eclipse.platform" and "org.eclipse.jdt"
+
** --> Click "Finish".
** --> click "Finish"
+
* Back on the "Locations" tab, click "Add" again.
* switch to "Content" tab:
+
** Select "Features" --> Click "Next"
** filter for "junit" and deselect the bundles "org.junit (4.8.1)" and  "org.junit4 (4.8.1)". Only "org.junit (3.8.2)" must be selected.
+
** Click "Browse..." and select the eclipse-SDK (see above) and click OK.
* --> click "Finish"
+
** Select the features "org.eclipse.jdt" and "org.eclipse.platform".
* Set the new target platform active
+
** --> Click "Finish"
* --> click "OK", you're done.
+
* Switch to the "Content" tab:
 +
** Filter for "junit" and deselect the bundles "org.junit (4.8.1)" and  "org.junit4 (4.8.1)". Only "org.junit (3.8.2)" must be selected.
 +
* --> Click "Finish"
 +
* Select the new target platform.
 +
* --> Click "OK", you're done.
  
 
==== Create a launch configuration for SMILA ====
 
==== Create a launch configuration for SMILA ====
  
 
Getting right the launch configuration for SMILA is a bit tedious, so we prepared an example package:  
 
Getting right the launch configuration for SMILA is a bit tedious, so we prepared an example package:  
* Either checkout the contents of [https://dev.eclipse.org/svnroot/rt/org.eclipse.smila/trunk/examples https://dev.eclipse.org/svnroot/rt/org.eclipse.smila/trunk/examples] from our SVN repository into your workspace
 
* or download them as one package from [http://build.eclipse.org/rt/smila/nightly/SMILA-integrator-examples.zip http://build.eclipse.org/rt/smila/nightly/SMILA-integrator-examples.zip] and unpack and import them into your workspace.
 
  
In the menu, open "Run" -> "Run Configurations" or "Debug Configurations" and you should find an entry "OSGi Frameworks" -> "SMILA". Select it and click "Run" or "Debug" and SMILA should start just like when started from the command line. The configuration of this SMILA instance is in your workspace in "SMILA.application/configuration".
+
'''To import the example package'''
 +
 
 +
* Either checkout the contents of [https://dev.eclipse.org/svnroot/rt/org.eclipse.smila/trunk/examples https://dev.eclipse.org/svnroot/rt/org.eclipse.smila/trunk/examples] from our SVN repository into your workspace and your finished.
 +
* Or download them as one package from [http://www.eclipse.org/downloads/download.php?file=/rt/smila/releases/0.9/SMILA-0.9-integrator-examples.zip 0.9 release] or [http://build.eclipse.org/rt/smila/nightly/SMILA-integrator-examples.zip nightly build], unzip them, and do the following:
 +
**Select "File" > "Import".
 +
**Select "General" > "Existing Projects into Workspace" and click "Next".
 +
**Click "Browse", navigate to the folder where you have unpacked the ZIP.
 +
**Confirm with "OK".
 +
**Select all projects, enable the option "Copy projects into workspace", and click "Finish".
 +
*Now you should have the following projects in your workspace:
 +
**<tt>org.eclipse.smila.integration.feature</tt>
 +
**<tt>org.eclipse.smila.integration.pipelet</tt>
 +
**<tt>org.eclipse.smila.integration.worker</tt>
 +
**<tt>org.eclipse.smila.integration.worker.test</tt>
 +
**<tt>SMILA.application</tt>
 +
 
 +
To launch SMILA, you need only the "SMILA.application" project. The other bundles contain examples for developing integration components like workers, pipelets, etc.
 +
 
 +
'''To launch SMILA'''
 +
 
 +
* Select "Run" -> "Run Configurations" or "Debug Configurations".
 +
* Select "OSGi Frameworks" -> "SMILA".
 +
* Click "Run" or "Debug" and SMILA should start just like when started from the command line.
 +
 
 +
Find the configuration of this SMILA instance in your workspace in "SMILA.application/configuration".
 +
 
 +
For further information on implementing in SMILA see the [[SMILA/HowTo|HowTo manuals]].
  
 
[[Category:SMILA]]
 
[[Category:SMILA]]

Latest revision as of 05:52, 20 January 2012


Note.png
This is outdated, please refer to How to set up the development environment


This how-to describes the necessary steps for setting up SMILA integration environment. Normally this setup is only interesting for SMILA integrators who just want to integrate their components in SMILA. SMILA committers and contributors should work with another setup described at How to set up the development environment.

Contents

[edit] Preconditions

Here is the list of things that you will definitely need for developing SMILA components:

  1. JDK 1.6
  2. Eclipse SDK - This howto was tested with Eclipse SDK 3.7.1 (Indigo SR1) (it might still work with Eclipse SDK 3.6.2, too).
  3. SMILA binary distribution

[edit] Install the binary distribution

Just pick up the latest binary distribution of SMILA:

Simply unzip the file you downloaded into a new directory on your local hard disk and you've done with the installation.

[edit] Create a new Workspace and setup target platform

Extract your eclipse SDK (be sure, it's just the plain SDK and no JEE-IDE) into another directory, named e.g. eclipse-SDK). This will save you lots of trouble when setting up the target environment.

Start your Eclipse SDK and create a new workspace at a location of your choice. Then use the SMILA binaries as the target platform for plugin develoment. This enables you to create own bundles that can use the code in the SMILA bundles:

To set up the target platform

  • Open "Windows" -> "Preferences".
  • Select "Plug-in Development" --> "Target Platform" --> "Add".
  • Initialize the target definition with: "Nothing --> Next".
  • Enter a reasonable name (how about "SMILA", maybe? ;-).
  • In the "Locations" tab, click "Add".
    • Select "Installation" --> Click "Next".
    • Click "Browse" and navigate to the directory where you installed SMILA (do not press <Enter> yet).
    • --> Click "Finish".
  • Back on the "Locations" tab, click "Add" again.
    • Select "Features" --> Click "Next"
    • Click "Browse..." and select the eclipse-SDK (see above) and click OK.
    • Select the features "org.eclipse.jdt" and "org.eclipse.platform".
    • --> Click "Finish"
  • Switch to the "Content" tab:
    • Filter for "junit" and deselect the bundles "org.junit (4.8.1)" and "org.junit4 (4.8.1)". Only "org.junit (3.8.2)" must be selected.
  • --> Click "Finish"
  • Select the new target platform.
  • --> Click "OK", you're done.

[edit] Create a launch configuration for SMILA

Getting right the launch configuration for SMILA is a bit tedious, so we prepared an example package:

To import the example package

  • Either checkout the contents of https://dev.eclipse.org/svnroot/rt/org.eclipse.smila/trunk/examples from our SVN repository into your workspace and your finished.
  • Or download them as one package from 0.9 release or nightly build, unzip them, and do the following:
    • Select "File" > "Import".
    • Select "General" > "Existing Projects into Workspace" and click "Next".
    • Click "Browse", navigate to the folder where you have unpacked the ZIP.
    • Confirm with "OK".
    • Select all projects, enable the option "Copy projects into workspace", and click "Finish".
  • Now you should have the following projects in your workspace:
    • org.eclipse.smila.integration.feature
    • org.eclipse.smila.integration.pipelet
    • org.eclipse.smila.integration.worker
    • org.eclipse.smila.integration.worker.test
    • SMILA.application

To launch SMILA, you need only the "SMILA.application" project. The other bundles contain examples for developing integration components like workers, pipelets, etc.

To launch SMILA

  • Select "Run" -> "Run Configurations" or "Debug Configurations".
  • Select "OSGi Frameworks" -> "SMILA".
  • Click "Run" or "Debug" and SMILA should start just like when started from the command line.

Find the configuration of this SMILA instance in your workspace in "SMILA.application/configuration".

For further information on implementing in SMILA see the HowTo manuals.