Difference between revisions of "SCA/Components/SCA Samples"

From Eclipsepedia

< SCA
Jump to: navigation, search
(How to use samples)
Line 4: Line 4:
  
 
== How to use samples ==
 
== How to use samples ==
 +
 +
=== Register Tuscany for SCA samples ===
 +
First, you have to install Apache Tuscany to be able to test the sample applications. See the first section on Installing Tuscany to test your SCA applications. You can download it on: ([http://incubator.apache.org/tuscany/sca-java-releases.html http://incubator.apache.org/tuscany/sca-java-releases.html])
 +
 +
Then, you have to register Tuscany for SCA samples:
 +
# Select '''Window > Preferences....'''
 +
# Select '''SOA Tools > SCA Tools'''.
 +
# Set the '''Tuscany directory'''
 +
# Click on the '''Ok''' button.[[Image:Scaexamples4.png]]
 +
 +
=== Creating samples ===
 +
Different samples are available to test the SCA Composite Designer, they are described in the following sections. The samples projects are automatically created :
 +
# Select '''File > New > Sample....'''
 +
# Select '''SCA > SCA Examples''' and click '''Next'''.[[Image:Scaexamples1.png]]
  
 
== Restaurant sample ==
 
== Restaurant sample ==

Revision as of 11:32, 26 May 2008

You can test the SCA Composite Designer and see some possibilities of SCA through the following samples.

This section provides a step-by-step description for creating and testing a sample project.

Contents

How to use samples

Register Tuscany for SCA samples

First, you have to install Apache Tuscany to be able to test the sample applications. See the first section on Installing Tuscany to test your SCA applications. You can download it on: (http://incubator.apache.org/tuscany/sca-java-releases.html)

Then, you have to register Tuscany for SCA samples:

  1. Select Window > Preferences....
  2. Select SOA Tools > SCA Tools.
  3. Set the Tuscany directory
  4. Click on the Ok button.Scaexamples4.png

Creating samples

Different samples are available to test the SCA Composite Designer, they are described in the following sections. The samples projects are automatically created :

  1. Select File > New > Sample....
  2. Select SCA > SCA Examples and click Next.Scaexamples1.png

Restaurant sample

Restaurant - RMI Service

Restaurant - RMI Reference

Restaurant - Script

Restaurant - Composite