Jump to: navigation, search

Difference between revisions of "Riena/Toolbox"

m (Using the 'new project' templates)
m (Setup)
Line 21: Line 21:
  
  
So now you are all setup. To see it running:
+
So now you are all setup. To see it running, follow the instructions below.
 
+
* Create a new Plug-in Project (Would you like to create a rich client application = yes) 
+
* Select "Riena Hello World" or "Riena Mail Template" from the list of templates and finish creating the new template
+
* Show View -> Other -> Riena Toolbox -> AssemblyEditor
+
* The Assembly Editor now shows the assemblies from all projects in the workspace
+
** You may need to refresh the editor if it was open before creating the new project
+
  
 
=Wizards=
 
=Wizards=

Revision as of 10:52, 15 March 2013

{{#eclipseproject:rt.riena}}


The Riena Toolbox is a IDE Support for Riena for Eclipse 3.6 and above. It consists of Wizards for generating some simple Riena Apps, a tree based editor for the Assembly-Extensionpoints and an Previewer for RCP-Views and SWT-Composites.

Note: Make sure that you use the same Java-version to start your Eclipse-IDE and for compiling your workspace, because the Riena Toolbox uses classloaders to dynamically load and instantiate classes. That doesn't work if you run the Eclipse IDE with Java 1.5 and in your workspace has classes that were compiled with a newer Java version (e.g. 1.6 or 1.7).

Setup

  • Install and run Eclipse
  • Help => Install New Software...
  • Select all components from http://download.eclipse.org/rt/riena/toolbox/20120424
    • Uncheck "Contact all update sites during install to find required software"
  • Complete the installation (Eclipse will ask you to restart)


So now you are all setup. To see it running, follow the instructions below.

Wizards

The easiest way to start building a Riena application is to use a template included in the Riena UI Wizard Feature. Of course, you can also write a Riena app from scratch.

Using the 'new project' templates

  1. Install the Riena Toolbox
  2. Create a new Plug-in Project (File > New > Plug-in Project > Next)
  3. Choose a project name > Next
  4. On the Content page:
    1. "This plug-in will make contributions to the UI" => Yes
    2. "Would you like to create a rich client application?" => Yes
  5. The Templates page offers three "Riena" templates (picture below). Choose either one and hit Next or Finish.
    • Riena pde templates.png
If you picked the "Riena Hello World" or "Riena Mail Template"
start the resulting project with Run As -> Eclipse Application.
If you picked the "Riena Client/Server Template"
use the launch configurations that are included in the project. Start the server first, then the client.

Take a look at the code in the projects and have fun.

AssemblyEditor

The Riena assembly in short is a set of extensions that define the navigation structure of Riena applications. Assemblies define the way the navigationtree of a Riena-Application looks like.

The AssemblyEditor is an improved treebased editor like the PDE extensionpoint editor, that offers much more comfort when editing assemblies. Besides having a richer editor for the navigationtree the AssemblyEditor can generate Javacode like Views/Controller from a template. So instead of creating a SubModuleView, registering it under the extensionpoint org.eclipse.ui.views, you can just let the AssemblyEditor do all the tedious work for you.

Furthermore the AssemblyEditor can generate missing getRidget-calls in the SubModuleController for the corresponding Widgets. We support a roundtrip engineering at this point, so you can edit your SubModuleController like you are used to and let the AssemblyEditor update your missing getRidget-calls.

To generate the configureRidgets-method or the missing getRidget-calls open the submoduleview and press strl+alt+r or use the context menu in the java editor.

AssemblyEditor 1.png

Previewer

Riena is based on Eclipse RCP and therefore uses RCP-Views as a basis for the SubModuleViews. RCP-Views can only be viewed have to be registered as an extenionpoint and thus an Eclipse workbench has to be started to view the RCP-View. The Riena Previewer solves this issue by giving you the opportunity to preview any RCP-View oder SWT-Composite without starting the application at all. To show a preview just right click on a RCP-View or SWT-Composite in the Package Explorer and choose "Preview". Besides you just preview the content of the active editor by pressing strg + shift + p.

Previewer 1.png