Skip to main content
Jump to: navigation, search

Difference between revisions of "Riena/Toolbox"

(Wizards)
Line 9: Line 9:
  
 
=Wizards=
 
=Wizards=
 +
 +
The easiest way to start building a Riena application is to use a template included in the Riena UI Wizard Feature. Of course, you can also write a Riena app from scratch.
 +
=== Using the 'new project' templates ===
 +
 +
# Install the '''Riena Toolbox''' from [[Riena/Downloads_–_Installation_–_Setup]]
 +
# Create a new Plug-in Project (File > New > Plug-in Project > Next)
 +
# Choose a project name > Next
 +
# On the Content page:
 +
## "This plug-in will make contributions to the UI" => Yes
 +
## "Would you like to create a rich client application?" => Yes
 +
# The Templates page offers three "Riena" templates (picture below). Choose either one and hit Next or Finish.
 +
#* [[Image:Riena_pde_templates.png|350x350px]]
 +
 +
; If you picked the "Riena Hello World" or "Riena Mail Template"
 +
: start the resulting project with Run As -> Eclipse Application.
 +
; If you picked the "Riena Client/Server Template"
 +
: use the launch configurations that are included in the project. Start the server first, then the client.
 +
 +
Take a look at the code in the projects and have fun.
 +
 
=AssemblyEditor=
 
=AssemblyEditor=
 
The Riena assembly in short is a set of extensions that define the navigation structure of Riena applications. Assemblies define the way the  [http://wiki.eclipse.org/Riena/Navigation navigationtree] of a Riena-Application looks like.
 
The Riena assembly in short is a set of extensions that define the navigation structure of Riena applications. Assemblies define the way the  [http://wiki.eclipse.org/Riena/Navigation navigationtree] of a Riena-Application looks like.

Revision as of 03:24, 16 March 2011


Wizards

The easiest way to start building a Riena application is to use a template included in the Riena UI Wizard Feature. Of course, you can also write a Riena app from scratch.

Using the 'new project' templates

  1. Install the Riena Toolbox from Riena/Downloads_–_Installation_–_Setup
  2. Create a new Plug-in Project (File > New > Plug-in Project > Next)
  3. Choose a project name > Next
  4. On the Content page:
    1. "This plug-in will make contributions to the UI" => Yes
    2. "Would you like to create a rich client application?" => Yes
  5. The Templates page offers three "Riena" templates (picture below). Choose either one and hit Next or Finish.
    • Riena pde templates.png
If you picked the "Riena Hello World" or "Riena Mail Template"
start the resulting project with Run As -> Eclipse Application.
If you picked the "Riena Client/Server Template"
use the launch configurations that are included in the project. Start the server first, then the client.

Take a look at the code in the projects and have fun.

AssemblyEditor

The Riena assembly in short is a set of extensions that define the navigation structure of Riena applications. Assemblies define the way the navigationtree of a Riena-Application looks like.

The AssemblyEditor is an improved treebased editor like the PDE extensionpoint editor, that offers much more comfort when editing assemblies. Besides having a richer editor for the navigationtree the AssemblyEditor can generate Javacode like Views/Controller from a template. So instead of creating a SubModuleView, registering it under the extensionpoint org.eclipse.ui.views, you can just let the AssemblyEditor do all the tedious work for you.

Furthermore the AssemblyEditor can generate missing getRidget-calls in the SubModuleController for the corresponding Widgets. We support a roundtrip engineering at this point, so you can edit your SubModuleController like you are used to and let the AssemblyEditor update your missing getRidget-calls.

AssemblyEditor 1.png

Previewer

Riena is based on Eclipse RCP and therefore uses RCP-Views as a basis for the SubModuleViews. RCP-Views can only be viewed have to be registered as an extenionpoint and thus an Eclipse workbench has to be started to view the RCP-View. The Riena Previewer solves this issue by giving you the opportunity to preview any RCP-View oder SWT-Composite without starting the application at all. To show a preview just right click on a RCP-View or SWT-Composite in the Package Explorer and choose "Preview". Besides you just preview the content of the active editor by pressing strg + shift + p.

Previewer 1.png

Back to the top