Jump to: navigation, search

Difference between revisions of "Riena/E4"

Line 1: Line 1:
 
This page is a start page that describes the current situation of Riena running on E4.
 
This page is a start page that describes the current situation of Riena running on E4.
This bug is also references by [[https://bugs.eclipse.org/bugs/show_bug.cgi?id=370445|Bug 370445]]
+
This bug is also references by [[https://bugs.eclipse.org/bugs/show_bug.cgi?id=370445 Bug 370445]]
  
 
'''Setup Targetplatforms'''
 
'''Setup Targetplatforms'''

Revision as of 09:19, 3 February 2012

This page is a start page that describes the current situation of Riena running on E4. This bug is also references by [Bug 370445]

Setup Targetplatforms


Setup workspace

  • Select 3.8 as your active target platform
  • Clone the Riena Repo from Git using the URL git://git.eclipse.org/gitroot/riena/org.eclipse.riena.git
  • open the org.eclipse.riena.releng projectSet.psf file and checkout the projects that are listed there into your workspace
  • all the remaining "compile errors" are because there is no API baseline set, you can change the warning for that to ignore (in the Preferences) and you should have a workspace with no compile errors for 3.8

Start the Riena example based on 3.8

  • Target Platform 3.8 is still the activated one (from the setup)
  • Start the launcher "SWT Example Application", make sure you switch to the plugins tab and click "Add required plug-ins"
  • If all goes well that should bring up a working Riena example client
  • You can click in the navigation (left and top) and see the Riena navigation as it is supposed to work

Start the Riena example based on 4.2

  • Switch the Target Platform to 4.2
  • You get compile errors.
    • Open SubApplicationView
    • comment out the line in error (we use an internal Workbench method :-) and the if statement around it
  • Start SWT Example Application launcher as above (click on Add required plug-ins)