Jump to: navigation, search

Remus/Getting started

Welcome to the Getting started guide. This page covers the installation of additional components for Remus and provides a brief introduction how to create new information units, search for information and howto share your information through a repository connector.

Installing Remus

The easiest way to install Remus in your IDE is via the Marketplace. Open the Marketplace Client (Help -> Eclipse Marketplace...) and search for "Remus'" or navigate alternatively to the Marketplace Webinterface. After the installation restart your Eclipse and you'll see new buttons in the toolbar and a new perspective.

Toolbar after Remus Installation

Installing additional components

The default installation installs neither information types nor remote repository connectors. They can be installed also via the Eclipse Marketplace client. To install additional components open the Marketplace and switch the Marketplace (see Pic 1).

Picture 2:Use the link under the listing to switch the marketplace


Picture 3:Select Remus Marketplace to install information types and connectors

After you have chosen the Remus Marketplace (see Pic 2) you are able to browse through the available components for Remus. To install one or multiple components select the elements you wan to be installed and step through the wizard. After a restart your selected components are installed and ready to use.

Creating information units

The creation of information follows the methodology of creating new files in Eclipse. Via New->Other or Ctrl+N you can create new information units (see Pic 4). Your information structure is accessible in the Navigation window on the right. This view is accessible either in the Information Management perspective or via Window->Show View-->Remus-->Navigation.

The application has two type of containers for information units.

  1. Projects
  2. Categories

Projects are the top-level containers and can contain categories and information units. A category can be created within a project or under another category.

Picture 3:Select Remus Marketplace to install information types and connectors

Editing information units

Information units are represented in an editor and opened in Eclipses Editor-Area. The most information types have at least two sub-pages, the first is a read-only view which is optimized for browsing through information, the second sub page is for editing the information unit.

Picture 4: Editor of a plaintext information unit

Search

Searching through your information pool can be done via the search-field in the toolbar or the search view. The search results are opened in a separate editor. You can browse through the search results with Ctrl+ArrowLeft or Ctrl+ArrowRight. With the additional information unit Favorite Search you can save a search query as information unit. For an overview of supported search queries see here.

Search toolbar.png