Skip to main content
Jump to: navigation, search

Difference between revisions of "Platform/How to Contribute"

(Fix typo Setting up your SDK for code contributions)
m (Update image width limit based on result of https://bugs.eclipse.org/bugs/show_bug.cgi?id=547897)
 
(26 intermediate revisions by 11 users not shown)
Line 10: Line 10:
 
== Bug triage==
 
== Bug triage==
  
If you are interested to help with bug solving, the Eclipse platform project has a huge backlog of existing bug reports. It is often not possible for the committer to re-test all old bug reports. A contributor can re-test bug reports and report if they are already solved. If you want to help in this area, please send a message to the [https://dev.eclipse.org/mailman/listinfo/platform-ui-dev platform.ui mailing list]. We can nominate you to give you rights to close bugs via the process described [https://wiki.eclipse.org/Bug_Reporting_FAQ#Bug_Editing_and_Triage Platform Bug triage process].  
+
If you are interested to help with bug solving, the Eclipse platform project has a huge backlog of existing bug reports. It is often not possible for the committer to re-test all old bug reports. A contributor can re-test bug reports and report if they are already solved. If you want to help in this area, please send a message to the [https://accounts.eclipse.org/mailing-list/platform-dev platform-dev@eclipse.org mailing list]. We can nominate you to give you rights to close bugs via the process described [https://wiki.eclipse.org/Bug_Reporting_FAQ#Bug_Editing_and_Triage Platform Bug triage process].
  
 
== Setting up your SDK for code contributions ==
 
== Setting up your SDK for code contributions ==
  
Our goal is to have a completely automated installer for setting up your workspace to contribute to Eclipse. There are still some manual steps in this setup guide but we're working on eliminating them.
+
There are two main ways to prepare your IDE to contribute to the Eclipse Platform.  
  
Before we start, please note the installer works only on the 64bit version of Java. So if you strictly need to use a 32bit version, please, follow [https://wiki.eclipse.org/index.php?title=Platform_UI/How_to_Contribute&oldid=394080 this same contribution guide as updated to Nov'2015]
+
* Manual SDK setup: the classic way, most used by committers with custom IDEs.  
 +
* Oomph automated setup: good for occasional contributors, it makes easy to contribute to multiple Platform projects.  
  
Go to [https://eclipse.org/downloads/ Eclipse Downloads] and download the installer for your platform.
+
If interested in contributing with Oomph, read: [https://wiki.eclipse.org/Platform_UI/How_to_Contribute/Oomph How to Contribute to Eclipse Platform using Oomph] or [https://wiki.eclipse.org/Eclipse_Platform_SDK_Provisioning Eclipse Platform SDK Provisioning].
  
[[File:uisetup-1-download_eclipse.png|border]]
+
The rest of this section explains the manual set-up.
  
Launch the installer.
+
First, you need to set up your environment. You need to:
  
If you see a yellow exclamation mark in the top-right, it means the installer is out-of-date. Click on the exclamation mark and then click on the word UPDATE. After the installer finishes updating, it will restart and you can continue with these steps.
+
# Get an Eclipse SDK
 +
# Install the tools we use during development
 +
# Get the code for Platform UI
 +
# Use the correct target platform
  
Click on the menu button in the upper-right.
 
  
[[File:uisetup-2-Installer_Screen.png]]
+
Active branches
  
Click on ADVANCED MODE...
+
Our currently active branches:
  
[[File:Uisetup-3-Advanced_Mode.png]]
+
* master - development towards the next release
  
Select "Eclipse IDE for Eclipse Committers"
+
=== [1] Get an Eclipse SDK ===
  
Select "Latest (Neon)"
+
To get the required updates from other subprojects it is recommended to use a recent I-Build for the Eclipse SDK for contributions. See from http://download.eclipse.org/eclipse/downloads/ for the latest download.
  
Select the location of a 64-bit 1.8 JDK.
+
=== [2] Install the development tools ===
  
Click Next
+
The Eclipse SDK development requires that certain plug-ins are installed in your IDE. The Eclipse platform team provides a file from which these plug-ins can be installed. Download the following file onto your computer: http://git.eclipse.org/c/platform/eclipse.platform.ui.git/plain/releng/org.eclipse.ui.releng/platformUiTools.p2f
  
[[File:uisetup-4-Select_Product.png]]
+
You can install the plug-ins described by this file by using ''File>Import...>Install>Install Software Items from File''.
  
Click the checkbox next to the Platform > UI
+
=== [3] Get the code for Platform UI ===
  
You may also select other projects in this menu.
+
* Use ''File>Import...>Team>Team Project Set'' to import the Platform UI projects into your workspace. Use http://git.eclipse.org/c/platform/eclipse.platform.ui.git/plain/releng/org.eclipse.ui.releng/platformUiProjectsGerrit.psf as input.
  
Click Next
+
==== [3.1] Use Gerrit for clone/push ====
  
[[File:uisetup-5-Click_The_Down_Arrow.png]]
 
  
Fill in the "Root install folder" with the parent folder under which you want all your Eclipse installs to go. (If you've run the installer before, it will remember your decision and you won't see this again unless you click "Show all variables").
+
'''Pushing a Gerrit commit''': Make sure you use the signed-of-by and change-id buttons before you create your commit. If you haven't, just amend your commit and add them.  Then you can push a commit for review by switching to the Git Repositories view, right-clicking on the repo, and selecting '''Push to Gerrit...'''.  You want to enter the branch you are pushing to, for example '''refs/for/master'''.  That will create a Gerrit review, and the review URL will be in the dialog that contains the status. The git command line equivalent would be:
  
Fill in "Installation folder name" with the name you want to give this Eclipse installation.
+
git push origin HEAD:refs/for/master
  
Click on "Platform UI Git or Gerrit Repository" and select the one starting with SSH.
+
Now you can commit and ''Team->Push to Upstream'' will push your commits directly to Eclipse Gerrit instance. First time push dialog will ask you for your Gerrit username and password, which you can see if you are logged into Gerrit under [https://git.eclipse.org/r/#/settings/http-password ''Settings->HTTP Password''].
  
Fill in your gerrit username. Alternatively, if you don't plan to contribute anything back to Eclipse you can use the default selection and omit filling in a username.
+
==== [3.2] Use ssh for clone/push ====
  
Leave the other values set to their defaults.
+
Use http://git.eclipse.org/c/platform/eclipse.platform.ui.git/plain/releng/org.eclipse.ui.releng/platformUiProjects.psf.
  
Click Next
+
Please note that the user id of your host will be used as gerrit user id to connect to eclipse servers. If they are not matching you have three solutions:
 +
* Modify URL directly in the file to specify gerrit user id, ssh://gerritUserid@git... instead of ssh://git
 +
* Modify the URL to point to the ''https'' version of the Gerrit repo location, https://gerritUserid@git...
 +
* Modify URL directly in the file in order to point to http://git.eclipse.org/gitroot for anonymous access (you won't be able to push changes for review).
  
[[File:uisetup-6-Edit_Variables.png]]
+
When using ssh, you also need to upload your ssh key if not already done. See [https://wiki.eclipse.org/Gerrit#Git_over_SSH Gerrit over SSH] for more information.  When using ''https'' with Gerrit, you'll need to set your https password in Gerrit.  See [https://wiki.eclipse.org/Gerrit#Git_over_HTTPS Gerrit over HTTPS].
  
Click Next, Click Finish.
+
When you are using ssh with a passphrase you probably get ''USERAUTH fail'' errors (possible import wizard bug). As workaround start cloning a repository listed in the team project set via the default EGit wizard over ssh. After you entered the passphrase you should see the available branches -- you can now abort the EGit wizard and retry importing the team project set as JGit should have been cached the ssh information.
  
Accept the license agreements.
+
=== [4] Prepare API tooling ===
  
Wait for the message "Press Finish to close the dialog" then do that thing.
+
Eclipse provides rich set of API's.  
 +
Read about what an API is and how API's are evolving here:
 +
* https://wiki.eclipse.org/Evolving_Java-based_APIs
 +
* https://wiki.eclipse.org/Evolving_Java-based_APIs_2
  
Wait for the new Eclipse workspace to start up, initialize, and build.
+
API changes need to be properly reflected in bundle versions.
 +
Read about this here:
 +
* https://wiki.eclipse.org/Version_Numbering
  
=== Launching Eclipse ===
+
If we contribute code to Eclipse, we always should make sure that our changes do not break API and do not violate version rules!
When you want to launch Eclipse again, you'll find the executable in the "Root install folder" you selected above. The executable will be here:
+
  
<Root install folder>/<Installation folder name>/eclipse
+
If the commit one want to merge contains an API change, '''before''' merge one should '''always''' load the patch into the IDE and run a clean build on related project.
  
For example, if I'm on Linux and selected ~/oomph for my root install folder and platform-master for my installation folder name, the executable I launch to run Eclipse will be called:
+
Before doing so one should also make sure API tooling is properly configured, one uses right API baseline and preferences are properly set:
  
~/oomph/platform-master/eclipse/eclipse
+
* Preferences -> Plug in Development -> [x] Workspace Plug-Ins override target platform plugins...
 +
* Preferences -> Plug in Development -> [ ] Disable API builder (must be unset!)
 +
* Preferences -> Plug in Development -> Target Platform is set to "Running Platform" and you are using a recent nightly SDK build.
 +
* Preferences -> Plug in Development -> API Baselines -> [x] _latest_release_ (must be created manually and point to plain SDK installation of the last official SDK release).
  
=== Running specific builds ===
+
If after that you see API errors in the workspace, please consider to read the proposed solution, compare that with the information you can get at [1], [2] and [3] and apply appropriated fix (or "-1" on the Gerrit patch).
  
If you want to always be using the latest integration build or - say - a specific nightly build, follow these steps after you've finished installing Eclipse as described above.
+
There can be multiple possible API error fixes proposed by PDE, but only one can be the right one - unfortunately we still require the power of human brain to apply the '''right''' fix.
  
Go to the download site for the integration build you wish to use (or any integration build if you want to auto-upgrade to each integration build).
+
Basic rule is: during a development cycle (e.g. 4.12) we only increment one version segment '''one time''' according to the rules [1], [2] and [3]. Only in case of human errors we have to bump the same version segment
 +
twice (once the wrong version is built and '''published''' we can't simply revert it so we must increase again...).
 +
'''Note''': We never decrement versions if they were already published via official SDK build.
  
The download page for each build will contain two links to update sites. One is for the stream (which always points to the latest build of that type) and the other is for that specific build. Copy the URL for the one you want. The links look like this on the download page:
+
Decision about '''which''' bundle version segment to change should be always based on [1], [2] and [3], not just on PDE "quick fix" proposals. In doubt - ask on the [https://accounts.eclipse.org/mailing-list/platform-dev platform-dev mailing list].
  
[[File:Upsetup-Eclipse Download Page.png]]
+
[1] https://wiki.eclipse.org/Version_Numbering
  
Go to Window > Preferences > Install/Update > Available Software Sites
+
[2] https://wiki.eclipse.org/Evolving_Java-based_APIs
Add...
+
Paste the URL of the update site and type in any name.
+
Click OK > OK
+
Go to Help > Check for updates
+
Install any updates it finds
+
Restart Eclipse if prompted
+
 
+
You will then be running the specific build you selected. If you selected a stream rather than a specific build, you can update to the latest build of that type by rerunning the "Check for updates" command.
+
 
+
=== Active branches ===
+
 
+
Our currently active branches:
+
 
+
* master - development towards the next release
+
* R4_5_maintenance - fixes for 4.5.x/Mars service releases, no active development but sometimes we cherry pick patches from master to it
+
 
+
=== Use ssh for clone/push ===
+
 
+
When using ssh, you also need to upload your ssh key if not already done. See [https://wiki.eclipse.org/Gerrit#Git_over_SSH Gerrit over SSH] for more information.  When using ''https'' with Gerrit, you'll need to set your https password in Gerrit.  See [https://wiki.eclipse.org/Gerrit#Git_over_HTTPS Gerrit over HTTPS].
+
 
+
When you are using ssh with a passphrase you probably get ''USERAUTH fail'' errors (possible import wizard bug). As workaround start cloning a repository listed in the team project set via the default EGit wizard over ssh. After you entered the passphrase you should see the available branches -- you can now abort the EGit wizard and retry importing the team project set as JGit should have been cached the ssh information.
+
  
=== 4. Tweaks for after your environment is set up ===
+
[3] https://wiki.eclipse.org/Evolving_Java-based_APIs_2
  
'''Build Path problems''': if you have build path problems for org.eclipse.core.expressions* you need to go to ''Preferences>Java>Installed JREs'' and add the missing JREs.  This usually involves getting an install for 1.4, 1.5, 1.6, and 1.7.
+
=== [5] Tweaks for after your environment is set up ===
  
'''Running the tests''': you should be able to run a couple of pre-filled launch configs from ''Run>Run Configurations''. '''on linux''': The launch configs often come with DISPLAY=:1.0.  You should either run a vnc server or remove that variable from the environment tab.  An example of a $HOME/.vnc/xstartup that works for the Platform UI tests is:
+
'''Running the tests''': you should be able to run a couple of pre-filled launch configs from ''Run>Run Configurations''.
 +
 
 +
'''On Linux''': The launch configs often come with DISPLAY=:1.0.  You should either run a vnc server or remove that variable from the environment tab.  An example of a $HOME/.vnc/xstartup that works for the Platform UI tests is:
  
 
  #!/bin/sh
 
  #!/bin/sh
Line 136: Line 131:
 
   
 
   
 
  exec metacity --replace --sm-disable
 
  exec metacity --replace --sm-disable
 
 
==== Use Gerrit for clone/push ====
 
 
'''Pushing a Gerrit commit''': Make sure you use the signed-of-by and change-id buttons before you create your commit.  If you haven't, just amend your commit and add them.  Then you can push a commit for review by switching to the Git Repositories view, right-clicking on the repo, and selecting '''Push to Gerrit...'''.  You want to enter the branch you are pushing to, for example '''refs/for/master'''.  That will create a Gerrit review, and the review URL will be in the dialog that contains the status.  The git command line equivalent would be:
 
 
git push origin HEAD:refs/for/master
 
 
Now you can commit and ''Team->Push to Upstream'' will push your commits directly to Eclipse Gerrit instance. First time push dialog will ask you for your Gerrit username and password, which you can see if you are logged into Gerrit under [https://git.eclipse.org/r/#/settings/http-password ''Settings->HTTP Password''].
 
  
 
== Contributing Code==
 
== Contributing Code==
Line 177: Line 163:
 
  https://&lt;userid&gt;@git.eclipse.org/r/platform/eclipse.platform.ua
 
  https://&lt;userid&gt;@git.eclipse.org/r/platform/eclipse.platform.ua
 
  ssh://&lt;userid&gt;@git.eclipse.org:29418/platform/eclipse.platform.ua
 
  ssh://&lt;userid&gt;@git.eclipse.org:29418/platform/eclipse.platform.ua
 +
 +
 +
=== Experimenting with a fork ===
 +
 +
While you're still in experimentation phase and your code is not ready to be proposed as a contribution, we recommend you to work with a '''fork''' of the Git repository and to work with your '''branches on this fork'''. This process will make it easier for you to turn your experiment into a proposal as a Gerrit patch proposal (see below) when ready.
 +
 +
You can then reference your branches on the related bugs or discussions to share your progress with other contributors.
 +
 +
Several services do offer Git repository hosting. If you choose GitHub, you can start by forking the [https://github.com/eclipse?utf8=%E2%9C%93&q=platform&type=&language= GitHub mirror] of your choice and work with branches on your forked repo; '''do NOT use pull-requests against mirrors''' (those are ignored)! If you'd like to already take advantage of the Eclipse Fondation governance offer as you're experimenting, please consider getting in touch with the [https://dev.eclipse.org/mhonarc/lists/e4-dev/ e4 project] which can offer you either a sandbox repo, or a fork of a Platform repo to work with at Eclipse.org.
  
 
=== Creating a Gerrit review or a patch ===
 
=== Creating a Gerrit review or a patch ===
Line 203: Line 198:
 
{{codeblock|/*******************************************************************************
 
{{codeblock|/*******************************************************************************
 
  * Copyright (c) 2015, 2016 [Your Company or your name] and others.
 
  * Copyright (c) 2015, 2016 [Your Company or your name] and others.
  * All rights reserved. This program and the accompanying materials
+
  *  
  * are made available under the terms of the Eclipse Public License v1.0
+
* This program and the accompanying materials
 +
  * are made available under the terms of the Eclipse Public License 2.0
 
  * which accompanies this distribution, and is available at
 
  * which accompanies this distribution, and is available at
  * http://www.eclipse.org/legal/epl-v10.html
+
  * https://www.eclipse.org/legal/epl-2.0/
 +
*
 +
* SPDX-License-Identifier: EPL-2.0
 
  *  
 
  *  
 
  * Contributors:
 
  * Contributors:
Line 229: Line 227:
 
{{codeblock|/*******************************************************************************
 
{{codeblock|/*******************************************************************************
 
  * Copyright (c) 2008, 2016 IBM Corporation and others.
 
  * Copyright (c) 2008, 2016 IBM Corporation and others.
  * All rights reserved. This program and the accompanying materials
+
  *  
  * are made available under the terms of the Eclipse Public License v1.0
+
* This program and the accompanying materials
 +
  * are made available under the terms of the Eclipse Public License 2.0
 
  * which accompanies this distribution, and is available at
 
  * which accompanies this distribution, and is available at
  * http://www.eclipse.org/legal/epl-v10.html
+
  * https://www.eclipse.org/legal/epl-2.0/
 +
*
 +
* SPDX-License-Identifier: EPL-2.0
 
  *  
 
  *  
 
  * Contributors:
 
  * Contributors:
Line 241: Line 242:
 
=== Commit Message Conventions ===
 
=== Commit Message Conventions ===
  
* In general, each commit requires a [https://bugs.eclipse.org/bugs/ bug] entry. Only trivial and non-controversial changes (like typos) can be committed without a bug.
+
* Trivial, clean-ups and non-controversial changes (like typos) can be committed without a bug. Clean-up patches are patches which improve the code structure, remove deprecations, code warnings and the like. If clean-up patches are very invasive or big consider also creating a bug for them, to allow easier tracking.
 +
* Commits with functional changes or bug fixes require a [https://bugs.eclipse.org/bugs/ bug] entry.  
 
* A commit related to an existing bug report has to start with "Bug XXXXXX - " or "Bug XXXXXX: " or "Fixed bug XXXXXX: summary".
 
* A commit related to an existing bug report has to start with "Bug XXXXXX - " or "Bug XXXXXX: " or "Fixed bug XXXXXX: summary".
 
* Don't tie unrelated changes to a bug (number) just because you are working on that bug. Simply use e.g. "Fixed typo in XYZ" or "Removed trailing whitespace in XYZ".  
 
* Don't tie unrelated changes to a bug (number) just because you are working on that bug. Simply use e.g. "Fixed typo in XYZ" or "Removed trailing whitespace in XYZ".  
Line 268: Line 270:
 
=== The Build===
 
=== The Build===
 
The Eclipse build is a bit of a mystery to newcomers.  But rest assured that if you break something everyone will know about it and we will laugh at you (not really but we might tease you, or send you a [http://dev.eclipse.org/mhonarc/lists/platform-releng-dev/msg09764.html clown nose] if it was really bad).  If you do one thing it should be to sign up for the [https://dev.eclipse.org/mailman/listinfo/platform-releng-dev platform-releng-dev mailing list].  You'll receive emails when builds complete and when build and test failures occur.  It's always good to pay extra special attention on the mornings after you make a commit or someone makes a commit on your behalf.  The normal reaction to "breaking the build" is to log a bug, notify the platform-releng-dev list about it so that others can gauge the quality of the build, and then fix the bug.
 
The Eclipse build is a bit of a mystery to newcomers.  But rest assured that if you break something everyone will know about it and we will laugh at you (not really but we might tease you, or send you a [http://dev.eclipse.org/mhonarc/lists/platform-releng-dev/msg09764.html clown nose] if it was really bad).  If you do one thing it should be to sign up for the [https://dev.eclipse.org/mailman/listinfo/platform-releng-dev platform-releng-dev mailing list].  You'll receive emails when builds complete and when build and test failures occur.  It's always good to pay extra special attention on the mornings after you make a commit or someone makes a commit on your behalf.  The normal reaction to "breaking the build" is to log a bug, notify the platform-releng-dev list about it so that others can gauge the quality of the build, and then fix the bug.
 +
 +
===Adding a Note and Noteworthy entry===
 +
 +
To add to the N&N clone the repo listed here: https://git.eclipse.org/r/#/admin/projects/www.eclipse.org/eclipse/news
 +
Check existing entries for how to describe new entries.
 +
 +
The plug-in is "platform news" and it contains instructions.html. Frequently the following rules are missed:
 +
 +
* The image should be no more than 720 pixels wide and in png format
 +
* Use the [http://validator.w3.org/#validate_by_input Markup Validation Service] to check your document's markup submitting.
  
 
== Forum ==
 
== Forum ==

Latest revision as of 12:43, 11 October 2019

This page is a starting point for where to begin when wanting to contribute to the project. The goal is to educate and to be as up front as possible with expectations so that the process can be as efficient as possible.

Bugs

If you find a bug, log it. See the FAQ entry "How to Report a Bug", and a description of how a great bug report looks like. If you find a bug that you think is a duplicate, is not a bug, etc. feel free to comment saying so.

If wanting to track bug changes in Platform UI there are a few ways:

  • Via email. If you want to receive email when a bug is logged you can watch the Platform-UI-Inbox@eclipse.org user. You will receive email anytime a new bug is logged to this user or an update is made while assigned to this user. To set this up see Preferences -> Email Preferences -> User Watching. This will email you for all incoming Platform UI bugs; to follow all changes for Platform UI and IDE for bugs that an individual has not yet taken, watch platform-ui-triaged@eclipse.org as well.
  • Via Atom. You can convert any query in bugzilla to a feed that will update when a matched bug changes. To convert a search to a feed perform a search and select "Feed" at the bottom of the search results.

Bug triage

If you are interested to help with bug solving, the Eclipse platform project has a huge backlog of existing bug reports. It is often not possible for the committer to re-test all old bug reports. A contributor can re-test bug reports and report if they are already solved. If you want to help in this area, please send a message to the platform-dev@eclipse.org mailing list. We can nominate you to give you rights to close bugs via the process described Platform Bug triage process.

Setting up your SDK for code contributions

There are two main ways to prepare your IDE to contribute to the Eclipse Platform.

  • Manual SDK setup: the classic way, most used by committers with custom IDEs.
  • Oomph automated setup: good for occasional contributors, it makes easy to contribute to multiple Platform projects.

If interested in contributing with Oomph, read: How to Contribute to Eclipse Platform using Oomph or Eclipse Platform SDK Provisioning.

The rest of this section explains the manual set-up.

First, you need to set up your environment. You need to:

  1. Get an Eclipse SDK
  2. Install the tools we use during development
  3. Get the code for Platform UI
  4. Use the correct target platform


Active branches

Our currently active branches:

  • master - development towards the next release

[1] Get an Eclipse SDK

To get the required updates from other subprojects it is recommended to use a recent I-Build for the Eclipse SDK for contributions. See from http://download.eclipse.org/eclipse/downloads/ for the latest download.

[2] Install the development tools

The Eclipse SDK development requires that certain plug-ins are installed in your IDE. The Eclipse platform team provides a file from which these plug-ins can be installed. Download the following file onto your computer: http://git.eclipse.org/c/platform/eclipse.platform.ui.git/plain/releng/org.eclipse.ui.releng/platformUiTools.p2f

You can install the plug-ins described by this file by using File>Import...>Install>Install Software Items from File.

[3] Get the code for Platform UI

[3.1] Use Gerrit for clone/push

Pushing a Gerrit commit: Make sure you use the signed-of-by and change-id buttons before you create your commit. If you haven't, just amend your commit and add them. Then you can push a commit for review by switching to the Git Repositories view, right-clicking on the repo, and selecting Push to Gerrit.... You want to enter the branch you are pushing to, for example refs/for/master. That will create a Gerrit review, and the review URL will be in the dialog that contains the status. The git command line equivalent would be:

git push origin HEAD:refs/for/master

Now you can commit and Team->Push to Upstream will push your commits directly to Eclipse Gerrit instance. First time push dialog will ask you for your Gerrit username and password, which you can see if you are logged into Gerrit under Settings->HTTP Password.

[3.2] Use ssh for clone/push

Use http://git.eclipse.org/c/platform/eclipse.platform.ui.git/plain/releng/org.eclipse.ui.releng/platformUiProjects.psf.

Please note that the user id of your host will be used as gerrit user id to connect to eclipse servers. If they are not matching you have three solutions:

When using ssh, you also need to upload your ssh key if not already done. See Gerrit over SSH for more information. When using https with Gerrit, you'll need to set your https password in Gerrit. See Gerrit over HTTPS.

When you are using ssh with a passphrase you probably get USERAUTH fail errors (possible import wizard bug). As workaround start cloning a repository listed in the team project set via the default EGit wizard over ssh. After you entered the passphrase you should see the available branches -- you can now abort the EGit wizard and retry importing the team project set as JGit should have been cached the ssh information.

[4] Prepare API tooling

Eclipse provides rich set of API's. Read about what an API is and how API's are evolving here:

API changes need to be properly reflected in bundle versions. Read about this here:

If we contribute code to Eclipse, we always should make sure that our changes do not break API and do not violate version rules!

If the commit one want to merge contains an API change, before merge one should always load the patch into the IDE and run a clean build on related project.

Before doing so one should also make sure API tooling is properly configured, one uses right API baseline and preferences are properly set:

  • Preferences -> Plug in Development -> [x] Workspace Plug-Ins override target platform plugins...
  • Preferences -> Plug in Development -> [ ] Disable API builder (must be unset!)
  • Preferences -> Plug in Development -> Target Platform is set to "Running Platform" and you are using a recent nightly SDK build.
  • Preferences -> Plug in Development -> API Baselines -> [x] _latest_release_ (must be created manually and point to plain SDK installation of the last official SDK release).

If after that you see API errors in the workspace, please consider to read the proposed solution, compare that with the information you can get at [1], [2] and [3] and apply appropriated fix (or "-1" on the Gerrit patch).

There can be multiple possible API error fixes proposed by PDE, but only one can be the right one - unfortunately we still require the power of human brain to apply the right fix.

Basic rule is: during a development cycle (e.g. 4.12) we only increment one version segment one time according to the rules [1], [2] and [3]. Only in case of human errors we have to bump the same version segment twice (once the wrong version is built and published we can't simply revert it so we must increase again...). Note: We never decrement versions if they were already published via official SDK build.

Decision about which bundle version segment to change should be always based on [1], [2] and [3], not just on PDE "quick fix" proposals. In doubt - ask on the platform-dev mailing list.

[1] https://wiki.eclipse.org/Version_Numbering

[2] https://wiki.eclipse.org/Evolving_Java-based_APIs

[3] https://wiki.eclipse.org/Evolving_Java-based_APIs_2

[5] Tweaks for after your environment is set up

Running the tests: you should be able to run a couple of pre-filled launch configs from Run>Run Configurations.

On Linux: The launch configs often come with DISPLAY=:1.0. You should either run a vnc server or remove that variable from the environment tab. An example of a $HOME/.vnc/xstartup that works for the Platform UI tests is:

#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
#vncconfig -iconic &
xterm -geometry 80x24+10+10 -sb -sl 5000 -ls -title "$VNCDESKTOP Desktop" &
#gnome-session --sm-disable --failsafe --disable-sound &

exec metacity --replace --sm-disable

Contributing Code

Whether you're wanting to fix a typo in javadoc or to implement the next whiz bang feature for Platform UI you'll need to know a few things before you contribute code.

Platform UI is using Git as version control system.

More information about getting the code into your workspace

See Platform-releng/Git_Workflows#Gerrit_workflow_for_a_committer and Gerrit#Doing Code Reviews with Gerrit. Even if you are a contributor, the workflows should give you an idea of how to get set up.


Our code is now contained in the git repo at

git://git.eclipse.org/gitroot/platform/eclipse.platform.ui.git
https://<userid>@git.eclipse.org/r/platform/eclipse.platform.ui
ssh://<userid>@git.eclipse.org:29418/platform/eclipse.platform.ui

The Dependency Injection and runtime Eclipse Context code is in

git://git.eclipse.org/gitroot/platform/eclipse.platform.runtime.git
https://<userid>@git.eclipse.org/r/platform/eclipse.platform.runtime
ssh://<userid>@git.eclipse.org:29418/platform/eclipse.platform.runtime


Note: we also maintain some E4-specific tools, hosted in the e4 incubator at (supports Gerrit):

git://git.eclipse.org/gitroot/e4/org.eclipse.e4.tools.git
https://<userid>@git.eclipse.org/r/e4/org.eclipse.e4.tools
ssh://<userid>@git.eclipse.org:29418/e4/org.eclipse.e4.tools

And we support User Assistance (Help) contributions at:

git://git.eclipse.org/gitroot/platform/eclipse.platform.ua.git
https://<userid>@git.eclipse.org/r/platform/eclipse.platform.ua
ssh://<userid>@git.eclipse.org:29418/platform/eclipse.platform.ua


Experimenting with a fork

While you're still in experimentation phase and your code is not ready to be proposed as a contribution, we recommend you to work with a fork of the Git repository and to work with your branches on this fork. This process will make it easier for you to turn your experiment into a proposal as a Gerrit patch proposal (see below) when ready.

You can then reference your branches on the related bugs or discussions to share your progress with other contributors.

Several services do offer Git repository hosting. If you choose GitHub, you can start by forking the GitHub mirror of your choice and work with branches on your forked repo; do NOT use pull-requests against mirrors (those are ignored)! If you'd like to already take advantage of the Eclipse Fondation governance offer as you're experimenting, please consider getting in touch with the e4 project which can offer you either a sandbox repo, or a fork of a Platform repo to work with at Eclipse.org.

Creating a Gerrit review or a patch

The preferred method of contributing bugfixes or new features is via the Gerrit review system. Once a Gerrit change set is created, the link to the Gerrit change should be posted on the Bugzilla. If you are using the correct commit format, this is done automatically by the Eclipse infrastructure.

See Contributing to Eclipse via Gerrit for a detailed description.

It is totally fine to upload a partial fix so that people can give early feedback, please mark in case the review so, e.g., by using [WIP] in the commit message. WIP stands for Work in Progress.

Unit Testing

Testing is imperative to the health of the project. We have a significant amount of tests. The quantity of tests will keep growing as more functionality is added to Platform UI. If you are contributing a fix or writing an enhancement, it is a requirement that tests are written. If you don't write them a committer will have to and that could slow down the contribution process.

There are a couple of things that you should know about our testing process:

  • The most tests are included in org.eclipse.ui.tests, but you will need the other test plug-ins as well to avoid missing dependencies.
  • If looking for tests for a specific class look for a class named {THECLASS}Test.java (e.g. UpdateStrategy.java -> UpdateStrategyTest.java).
  • To run tests, open the Run Configurations dialog (Ctrl+3, 'run...') and expand the "JUnit Plug-in Test" category to see the launch configurations we use to run the tests.
  • If you create a new TestCase make sure to add it to the correct test suite. The test suite class can be found by looking at the launch configuration on the "Test" tab under "Test class". For example, the test suite for JFace is called org.eclipse.jface.tests.AllTests; the main UI test suite is org.eclipse.ui.tests.UiTestSuite.
  • If you want to make a good impression, write tests. This goes for any project, of course.

Coding Conventions

For instance:

/*******************************************************************************
* Copyright (c) 2015, 2016 [Your Company or your name] and others.
* 
* This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
* https://www.eclipse.org/legal/epl-2.0/
*
* SPDX-License-Identifier: EPL-2.0
* 
* Contributors:
*     [Your Company or your name] - initial API and implementation
*******************************************************************************/
  • UI will need you to use project-specific settings for compiler warnings/errors, code formatting, save actions etc. These settings are typically copied into new projects from an existing one.
  • Avoid formatting the whole files - as this can generate pseudo-changes (white-space related) when committing changes to existing source files.
    • The easiest way, for Java files, is to have "Format edited lines" activated in the Preferences -> Java -> Editor -> Save Actions (this should be already pre-configured in the project settings).
    • One can also format just the needed block by selecting it and using "format" (Ctrl+Shift+F).
  • Use "organize imports" (Ctrl-Shift-O) to clean up the imports (we do not use org.eclipse.* type notation).
  • It is considered good practice to write code that does not have warnings. If possible, fix warnings existing whenever you see them.
  • Non-externalized strings are considered errors, do not ship non-externalized strings or use the NON-NLS tag to indicate that you are not relevant for translation
  • Use unix line delimiters (In Eclipse select Window-> Properties -> Workspace and set the file delimiter to Unix
  • Avoid adding trailing whitespace. You can use the save actions in Eclipse to auto-remove them, via the Preferences -> Java -> Editor -> Save Actions. Activate them and as additional action select Configure and select "Remove trailing whitespace"
  • Write/update Javadoc for all API you introduce/change. See Evolving Java-based APIs by Jim des Rivières to understand what it means to maintain an API.


Optional: Update the copyright header for existing files

For changed files, you can optionally add a contribution comment in the copyright header with your name and affiliation, and a bug id. If the top "Copyright (c)" line does not contain the current year, update it by changing the second year to be the current year or by adding a comma and the current year after the initial year. For instance:

/*******************************************************************************
* Copyright (c) 2008, 2016 IBM Corporation and others.
* 
* This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
* https://www.eclipse.org/legal/epl-2.0/
*
* SPDX-License-Identifier: EPL-2.0
* 
* Contributors:
*     IBM Corporation - initial API and implementation
*     John Doe <John.Doe@eclipse.org> - Bug 429728
*******************************************************************************/

Commit Message Conventions

  • Trivial, clean-ups and non-controversial changes (like typos) can be committed without a bug. Clean-up patches are patches which improve the code structure, remove deprecations, code warnings and the like. If clean-up patches are very invasive or big consider also creating a bug for them, to allow easier tracking.
  • Commits with functional changes or bug fixes require a bug entry.
  • A commit related to an existing bug report has to start with "Bug XXXXXX - " or "Bug XXXXXX: " or "Fixed bug XXXXXX: summary".
  • Don't tie unrelated changes to a bug (number) just because you are working on that bug. Simply use e.g. "Fixed typo in XYZ" or "Removed trailing whitespace in XYZ".
  • Don't include such unrelated changes in the real fix/change.
  • The change summary should be short, clear and concise description about the change.
  • The body of the commit message should be more detailed explanatory text (if necessary), describing the change.
    • Important architectural explanations should go into code comments, not just into the commit message.
  • Use the following format for your commit message. The Change-Id is only required if you use Gerrit.
Bug XXXXXX - Functional change in service XYZ

More detailed explanatory text (if necessary), describing the change, the direction of the fix etc.

Change-Id: I0000000000000000000000000000000000000000
Signed-off-by: Your Name <your.email@with-CLA.org>


  • N&N commits that add an entry should always include the bug number.

Before You Check In

  • Commit comments are required for all code commits, bugs should be logged to track work and the bug number and a description is then used in the commit comment to describe the change. For example when fixing a bug, use exactly: "Fixed bug xxx: <title of bug>". The "bug xxxx" part is really important as this is what is used to relate the bugs to the build submissions, so it must be formatted exactly that way (uppercase or lowercase bug should work).
  • Before committing changes, catch up to all changes made by others, and then run the tests.
  • Don't commit your changes if this will cause compile errors for others.

The Build

The Eclipse build is a bit of a mystery to newcomers. But rest assured that if you break something everyone will know about it and we will laugh at you (not really but we might tease you, or send you a clown nose if it was really bad). If you do one thing it should be to sign up for the platform-releng-dev mailing list. You'll receive emails when builds complete and when build and test failures occur. It's always good to pay extra special attention on the mornings after you make a commit or someone makes a commit on your behalf. The normal reaction to "breaking the build" is to log a bug, notify the platform-releng-dev list about it so that others can gauge the quality of the build, and then fix the bug.

Adding a Note and Noteworthy entry

To add to the N&N clone the repo listed here: https://git.eclipse.org/r/#/admin/projects/www.eclipse.org/eclipse/news Check existing entries for how to describe new entries.

The plug-in is "platform news" and it contains instructions.html. Frequently the following rules are missed:

  • The image should be no more than 720 pixels wide and in png format
  • Use the Markup Validation Service to check your document's markup submitting.

Forum

The Eclipse platform forum (newsgroup) is used to ask and answer questions. If you know the answer to a query it would be great if you would respond to it. Also the Eclipse 4 forum is meant for pure Eclipse 4 (non 3.x) related questions.

Wiki

The wiki is open and can be edited by all. If you find a typo, a broken link, or anything that you view as a small issue feel free to fix it. If wanting to contribute a significant amount of information or create a new article we request that you log a bug so that we're aware of what you're contributing. This is so that we can ensure consistency structurally and in the message conveyed.

IRC

Many Platform UI committers hang out on IRC, on both #eclipse-dev and #eclipse-e4. Feel free to ask questions there, or join into development discussions.

Meetings

There are currently no calls scheduled. They can be arranged upon request. For call in details and minutes see E4/Meeting_Minutes.

Back to the top