Skip to main content
Jump to: navigation, search

Difference between revisions of "Pave/pde install"

(New page: {|border="0" cellspacing="15" valign="top" style="width:100%;" |-valign="top" |style="width:80%;"| __NOTOC__ == How to install Pave from update site. == Short step by step tutorial for...)
 
Line 26: Line 26:
 
|[[Image:pave4.jpg|thumb|800px|right]].
 
|[[Image:pave4.jpg|thumb|800px|right]].
 
|-valign="top"
 
|-valign="top"
| Next you have to open install new software ... dialog. Go to Help > Install new software ...
+
| Next you have to get our team set file: [[http://wiki.eclipse.org/images/0/0b/Pave.psf here]]
 
|[[Image:pave5.png|thumb|800px|right]].
 
|[[Image:pave5.png|thumb|800px|right]].
 
|-valign="top"
 
|-valign="top"
| Now download the latest zip update from the Pave website:
+
| Now in eclipse choose File > Import > Team > Team Project Set
|[[Image:pave6.png|thumb|800px|right]].
+
|[[Image:pavepde1.png|thumb|800px|right]].
 
|-valign="top"
 
|-valign="top"
|Going back to eclipse select add type a name (e.g. Pave) and select archive button.
+
| Select browse and navigate to the downloaded pave.psf file
Navigate to the downloaded file and select it.
+
 
Press ok in the dialog.
 
Press ok in the dialog.
|[[Image:pave9.png|thumb|800px|right]].
+
|[[Image:pavepde2.png|thumb|800px|right]].
|-valign="top"
+
|Next deselect Group items by category checkbox and 3 components should appear. Select all three and click next.
+
And finish the wizard.
+
|[[Image:pave10.png|thumb|800px|right]].
+
|-valign="top"
+
|Next you will need a Java EE 5  compatible server. Go to eclipse preferences:
+
Window > Preferences
+
(Eclipse > Preferences)
+
 
+
Server > Runtime Environments.
+
 
+
|[[Image:pave11.png|thumb|800px|right]].
+
|-valign="top"
+
|Select existing server adapter or download a new one (Download additional server adapters)
+
 
+
Finish the wizard and configure your selected server.
+
|[[Image:pave12.png|thumb|800px|right]].
+
 
|-valign="top"
 
|-valign="top"
 +
| Import of the WTP cvs and all pave project will follow. Your workspace will look similar to the one on the screenshot.
 +
Now you have all the code of Pave and can experiment with it.
 +
|[[Image:pavepde3.png|thumb|800px|right]].
 
|}
 
|}
  
 +
Check our tutorial section for more information on how to create new patterns.
  
You are now ready to apply some patterns.
 
 
|}
 
|}

Revision as of 10:31, 27 October 2009


How to install Pave from update site.

Short step by step tutorial for installing pave framework on Galileo or Helios IDE.


First step is to download an Eclipse IDE for Java EE developers.
alt text
First step is to download an Eclipse IDE for Java EE developers.
.
Select mirror close to your location. And download eclipse archive file.
alt
.
Next you have to unzip the content on your filesystem.
alt
.
Find eclipse binary and start it. (eclipse.exe or eclipse)
Pave4.jpg
.
Next you have to get our team set file: [here]
Pave5.png
.
Now in eclipse choose File > Import > Team > Team Project Set
Pavepde1.png
.
Select browse and navigate to the downloaded pave.psf file

Press ok in the dialog.

Pavepde2.png
.
Import of the WTP cvs and all pave project will follow. Your workspace will look similar to the one on the screenshot.

Now you have all the code of Pave and can experiment with it.

Pavepde3.png
.

Check our tutorial section for more information on how to create new patterns.

Back to the top