Papyrus Required External Plugins

From Eclipsepedia

Jump to: navigation, search

Papyrus requires some external plugins in order to compile.
You usually need the common environment, plus some external plugins required to compile Papyrus. The versions of these laters vary according to the Eclipse and Papyrus release.
These page try to maintain the list of external plugins required to compile Papyrus.

Contents

Required Plugins

The following external plugins are required. Check your Eclipse version and go to the corresponding version to know where to get them.

  • Eclipse Modeling
  • EMF Facet
  • antlr
  • modisco
  • xpand
  • e4.xwt
  • EPF

Eclipse 4.2

Use Juno update site - http://download.eclipse.org/releases/juno - to install modeling projects

  • Eclipse Modeling Package 4.2 - http://www.eclipse.org/downloads/index-developer.php
  • EMF Compare UML2 integration - Juno update site
  • EMF Facet - Juno update site
  • modisco - Juno update site
  • xtext - Juno update site
  • EMF Model Query SDK - Juno update site
  • EMF Model Transaction SDK - Juno update site
  • GEF Zest SDK - Juno update site
  • GMF Notation SDK - Juno update site
  • GMF Tooling - Juno update site
  • Operational QVT SDK - Juno update site
  • Subversive SVN Team provider - Juno update site
  • e4.xwt - http://download.eclipse.org/e4/downloads/
  • EPF - Juno update site

Eclipse 3.8

Use Juno update site - http://download.eclipse.org/releases/juno - to install modeling projects

Eclipse Indigo SR1


Eclipse Indigo M7

Eclipse Indigo M5

Eclipse Indigo M4

You can also use the target platform defined here:

Eclipse Helios

  • Can be used with Papyrus 7.x branch.
  • [3] Eclipse Modeling 3.6. GMF needs to be install on top of this release.
  • [4] ANTLR 3.0.0. Download this plug-in and put it into the dropins folder.


Compilation Troubleshooting