Jump to: navigation, search

Difference between revisions of "Papyrus/Discussion/Architecture refactoring/Papyrus SDK"

m (Francois.le-fevre.cea.fr moved page Papyrus/Photon Work Description/Architecture refactoring/Papyrus SDK to Papyrus/Discussion/Architecture refactoring/Papyrus SDK: not incomming task for Photon, but linked to a discussion)
(Proposition)
 
(4 intermediate revisions by the same user not shown)
Line 1: Line 1:
=Context=
+
=Declaration of intent=
  
In Oxygen Papyrus main feature is released as the following id "org.eclipse.papyrus.sdk.feature" labeled as "Papyrus for UML". There is here two confusion. At first papyrus is not only dedicated to UML and secundly SDK stands for "software development kit" and is dedicated to developers. Additionnaly the developer features are not released under a stable update site as it is done in other Eclipse projects.
+
==Context==
 +
In Oxygen Papyrus main feature is released as the following id "org.eclipse.papyrus.sdk.feature" labeled as "Papyrus for UML". There is here two confusion. At first papyrus is not only dedicated to UML and secundly SDK stands for "software development kit" and is dedicated to developers. Additionnaly the developer features are not released under a stable update site as it is done in other Eclipse projects. This is a proposal for a discussion before integrating it to a given roadmap.
  
 +
==Relevant Discussions==
  
=Proposition=
+
* Bug 526327 - [test][releng] Fork Papyrus JUnit feature into Papyrus-RT https://bugs.eclipse.org/bugs/show_bug.cgi?id=526327
 +
 
 +
==Proposition==
 
* We propose to restore naming convention for the Papyrus feature. It will be important also to hihglight the fact that we could also install Papyrus (core/infra) without Papyrus UML, that wy it could be pertinent to distinguish:
 
* We propose to restore naming convention for the Papyrus feature. It will be important also to hihglight the fact that we could also install Papyrus (core/infra) without Papyrus UML, that wy it could be pertinent to distinguish:
 
** org.eclipse.papyrus (for Papyrus infra and core) previously part of org.eclipse.papyrus.sdk)
 
** org.eclipse.papyrus (for Papyrus infra and core) previously part of org.eclipse.papyrus.sdk)
 
** org.eclipse.papyrus.uml (for Papyrus UML) previously part of org.eclipse.papyrus.sdk)
 
** org.eclipse.papyrus.uml (for Papyrus UML) previously part of org.eclipse.papyrus.sdk)
 
** org.eclipse.papyrus.sdk (previously org.eclipse.papyrus.dev.feature)
 
** org.eclipse.papyrus.sdk (previously org.eclipse.papyrus.dev.feature)
 +
* All features or plugins located in the root repository have to be published. If they do'not need, they have to be migrated to another repository.
  
 
=Actions to tackle=
 
=Actions to tackle=
Line 19: Line 24:
 
* introduce the Papyrus UML feature that requires the Papyrus feature
 
* introduce the Papyrus UML feature that requires the Papyrus feature
  
=Verification=
+
=Vote=
  
* Check when installing Papyrus that we have the 3 main features.
+
*
  
 
=Team=
 
=Team=

Latest revision as of 10:03, 6 December 2017

Declaration of intent

Context

In Oxygen Papyrus main feature is released as the following id "org.eclipse.papyrus.sdk.feature" labeled as "Papyrus for UML". There is here two confusion. At first papyrus is not only dedicated to UML and secundly SDK stands for "software development kit" and is dedicated to developers. Additionnaly the developer features are not released under a stable update site as it is done in other Eclipse projects. This is a proposal for a discussion before integrating it to a given roadmap.

Relevant Discussions

Proposition

  • We propose to restore naming convention for the Papyrus feature. It will be important also to hihglight the fact that we could also install Papyrus (core/infra) without Papyrus UML, that wy it could be pertinent to distinguish:
    • org.eclipse.papyrus (for Papyrus infra and core) previously part of org.eclipse.papyrus.sdk)
    • org.eclipse.papyrus.uml (for Papyrus UML) previously part of org.eclipse.papyrus.sdk)
    • org.eclipse.papyrus.sdk (previously org.eclipse.papyrus.dev.feature)
  • All features or plugins located in the root repository have to be published. If they do'not need, they have to be migrated to another repository.

Actions to tackle

  • deletion of the releng/dev folder, no need to specific target platform, since it includes already the main target platform
  • include the developer plugins directly in the modules of /org.eclipse.papyrus/plugins/pom.xml
  • deletion of the job https://hudson.eclipse.org/papyrus/view/Photon%20(Master)/job/Papyrus-Master-Developer/
  • create a papyrus DSK feature that groups all actual developer plugins
  • rename the previously Papyrus SDK feature into Papyrus feature, with a focus with papyrus core and infra plugins
  • introduce the Papyrus UML feature that requires the Papyrus feature

Vote

Team

  • Benoit Maggi - CEA
  • Francois Le Fevre - CEA
  • Quentin Le Menez - CEA