Skip to main content
Jump to: navigation, search

Difference between revisions of "Papyrus-RT/Developer/Developer Guide/DevEnv Mars"

(Created page with "There are several possible ways to make a development environment to work on PapyrusRT, but it's a good idea to follow the steps provided here as we know these work. ==Instal...")
 
Line 54: Line 54:
 
Note whenever you update either the Papyrus or Papyrus-RT features, you should do a git pull on the relevant git repositories. In the case of Papyrus, a mismatch between the "production" version (the installed feature) and the "development" version (the cloned repository) will result in many runtime errors.
 
Note whenever you update either the Papyrus or Papyrus-RT features, you should do a git pull on the relevant git repositories. In the case of Papyrus, a mismatch between the "production" version (the installed feature) and the "development" version (the cloned repository) will result in many runtime errors.
  
==Configure your git repositories=
+
==Configure your git repositories==
  
 
On each of the repositories you should do a "Gerrit Configuration":
 
On each of the repositories you should do a "Gerrit Configuration":

Revision as of 14:04, 18 August 2015

There are several possible ways to make a development environment to work on PapyrusRT, but it's a good idea to follow the steps provided here as we know these work.

Installing Eclipse

  1. Download the plain Eclipse SDK 4.5 (Mars) from http://download.eclipse.org/eclipse/downloads/, selecting the one specific to your development platform.
  2. Decompress the archive in some target folder. For example: ~/dev/papyrusrt

Installing required features

Install each of the following features by clicking on "Help -> Install New Software..." and selecting the appropriate update site.

  • From the "Mars" releases update site at http://download.eclipse.org/releases/mars
    • Xtext 2.8.0 (found under 'Modeling' or 'General Purpose Tools')
    • EMF Eclipe Modeling Famework SDK 2.11.0 (found under 'Modeling')
    • Ecore Diagram Editor SDK 3.0.0 (found under 'Modeling'; aka EcoreTools; includes Sirius)
    • Mylyn Task List 3.15.0 (under 'Collaboration')
    • Mylyn Task-Focused Interface 3.15.0 (under 'Collaboration')
    • Mylyn Tasks Connector: Bugzilla 3.15.0 (under 'Collaboration')
    • Papyrus UML 1.1.0 (found under 'Modeling')
    • Eclipse XML Editors and Tools 3.6.3 (found under 'Programming Languages' and 'Web, XML, Java EE and OSGi Enterprise Development')
NOTE: It's important to use this version of EGit/JGit, rather than the latest (3.7.0) available from the Mars releases update-site because the current Gerrit repository server uses an older version (3.2) that sometimes causes errors when used with clients that have 3.5 or later.


  • Install the UML RealTime profile (Incubation)
    • This is better done by clicking on "Help -> Install Papyrus Additional Components".

Clone the repositories

Git repositories are cloned from the "Git Perspective" (Window -> Perspective -> Open Perspective -> Other... and select "Git")

In this perspective, under the "Git Repositories" view (on the left of the work area), click the "Clone" button (it has a bluish curved arrow). Enter the appropriate URI and credentials.

Once you've entered those, you'll be asked for a branch to clone. Select "master". Then you'll be asked to chose a destination folder and whether to import the projects. Usually you want to import the projects, but for Papyrus itself you might want to say no, as it is very large. It's better for Papyrus to import only some projects as needed to resolve dependencies.

Note whenever you update either the Papyrus or Papyrus-RT features, you should do a git pull on the relevant git repositories. In the case of Papyrus, a mismatch between the "production" version (the installed feature) and the "development" version (the cloned repository) will result in many runtime errors.

Configure your git repositories

On each of the repositories you should do a "Gerrit Configuration":

  1. Select and unfold the repository
  2. Select and unfold "Remotes"
  3. Right-click on "origin"
  4. Click on "Gerrit Configuration"
  5. Click on "Finish".
  6. Select and unfold "Branches"
  7. Select and unfold "Local"
  8. Right-click "master"
  9. Click on "Configure Branch..."
  10. Set "Rebase" (tick the checkbox)
  11. Click "OK"

Back to the top